import setools-4.2.2-1.el8
This commit is contained in:
parent
bae233a865
commit
8eaad824e8
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
SOURCES/4.2.0.tar.gz
|
SOURCES/4.2.2.tar.gz
|
||||||
|
@ -1 +1 @@
|
|||||||
3de773047e99ed28cba8a86c4a9cf9c509753796 SOURCES/4.2.0.tar.gz
|
96da818e44293bac44d765453036b624ed573512 SOURCES/4.2.2.tar.gz
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
From 617c3ae83c1c72ead627a57e1529724c62df807f Mon Sep 17 00:00:00 2001
|
From 4b3dc6b38abbd32cda557d5ef9ea1383ac5fdcf2 Mon Sep 17 00:00:00 2001
|
||||||
From: rpm-build <rpm-build>
|
From: rpm-build <rpm-build>
|
||||||
Date: Thu, 23 Feb 2017 08:17:07 +0100
|
Date: Thu, 23 Feb 2017 08:17:07 +0100
|
||||||
Subject: [PATCH 1/2] Do not use -Werror during build
|
Subject: [PATCH 2/3] Do not use -Werror during build
|
||||||
MIME-Version: 1.0
|
MIME-Version: 1.0
|
||||||
Content-Type: text/plain; charset=UTF-8
|
Content-Type: text/plain; charset=UTF-8
|
||||||
Content-Transfer-Encoding: 8bit
|
Content-Transfer-Encoding: 8bit
|
||||||
@ -32,7 +32,7 @@ error: command 'gcc' failed with exit status 1
|
|||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/setup.py b/setup.py
|
diff --git a/setup.py b/setup.py
|
||||||
index 2ca44c9..9319bf6 100644
|
index c94daf1..a7442ac 100644
|
||||||
--- a/setup.py
|
--- a/setup.py
|
||||||
+++ b/setup.py
|
+++ b/setup.py
|
||||||
@@ -105,7 +105,7 @@ ext_py_mods = [Extension('setools.policyrep', ['setools/policyrep.pyx'],
|
@@ -105,7 +105,7 @@ ext_py_mods = [Extension('setools.policyrep', ['setools/policyrep.pyx'],
|
||||||
@ -45,5 +45,5 @@ index 2ca44c9..9319bf6 100644
|
|||||||
'-Wfloat-equal',
|
'-Wfloat-equal',
|
||||||
'-Wformat', '-Wformat=2',
|
'-Wformat', '-Wformat=2',
|
||||||
--
|
--
|
||||||
2.9.3
|
2.17.2
|
||||||
|
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
From 2512c3ba608077db3a5e0286b976fadc8a04a5c4 Mon Sep 17 00:00:00 2001
|
From b960869bcbcb58f2ce9af598484f209935c096b0 Mon Sep 17 00:00:00 2001
|
||||||
From: rpm-build <rpm-build>
|
From: Vit Mojzis <vmojzis@redhat.com>
|
||||||
Date: Thu, 23 Feb 2017 08:17:07 +0100
|
Date: Fri, 26 Apr 2019 15:27:25 +0200
|
||||||
Subject: [PATCH 2/2] Do not export/use setools.InfoFlowAnalysis and
|
Subject: [PATCH 3/3] Do not export/use setools.InfoFlowAnalysis and
|
||||||
setools.DomainTransitionAnalysis
|
setools.DomainTransitionAnalysis
|
||||||
|
|
||||||
dta and infoflow modules require networkx which brings lot of dependencies.
|
dta and infoflow modules require networkx which brings lot of dependencies.
|
||||||
@ -14,27 +14,27 @@ sedta and seinfoflow to require python3-networkx
|
|||||||
---
|
---
|
||||||
sedta | 4 ++--
|
sedta | 4 ++--
|
||||||
seinfoflow | 4 ++--
|
seinfoflow | 4 ++--
|
||||||
setools/__init__.py | 4 ++--
|
setools/__init__.py | 4 ----
|
||||||
setoolsgui/apol/dta.py | 2 +-
|
setoolsgui/apol/dta.py | 2 +-
|
||||||
setoolsgui/apol/infoflow.py | 2 +-
|
setoolsgui/apol/infoflow.py | 2 +-
|
||||||
tests/dta.py | 2 +-
|
tests/dta.py | 2 +-
|
||||||
tests/infoflow.py | 2 +-
|
tests/infoflow.py | 2 +-
|
||||||
7 files changed, 10 insertions(+), 10 deletions(-)
|
7 files changed, 8 insertions(+), 12 deletions(-)
|
||||||
|
|
||||||
diff --git a/sedta b/sedta
|
diff --git a/sedta b/sedta
|
||||||
index 10cf43a..b75b4e1 100755
|
index 60861ca..41e38a2 100755
|
||||||
--- a/sedta
|
--- a/sedta
|
||||||
+++ b/sedta
|
+++ b/sedta
|
||||||
@@ -21,7 +21,7 @@ import sys
|
@@ -22,7 +22,7 @@ import argparse
|
||||||
import argparse
|
|
||||||
import logging
|
import logging
|
||||||
|
import signal
|
||||||
|
|
||||||
-import setools
|
-import setools
|
||||||
+import setools.dta
|
+import setools.dta
|
||||||
|
|
||||||
|
|
||||||
def print_transition(trans):
|
def print_transition(trans):
|
||||||
@@ -111,7 +111,7 @@ else:
|
@@ -114,7 +114,7 @@ else:
|
||||||
|
|
||||||
try:
|
try:
|
||||||
p = setools.SELinuxPolicy(args.policy)
|
p = setools.SELinuxPolicy(args.policy)
|
||||||
@ -44,7 +44,7 @@ index 10cf43a..b75b4e1 100755
|
|||||||
if args.shortest_path or args.all_paths:
|
if args.shortest_path or args.all_paths:
|
||||||
if args.shortest_path:
|
if args.shortest_path:
|
||||||
diff --git a/seinfoflow b/seinfoflow
|
diff --git a/seinfoflow b/seinfoflow
|
||||||
index 3ec05ca..32a9a3e 100755
|
index 97b14ba..e7f965d 100755
|
||||||
--- a/seinfoflow
|
--- a/seinfoflow
|
||||||
+++ b/seinfoflow
|
+++ b/seinfoflow
|
||||||
@@ -17,7 +17,7 @@
|
@@ -17,7 +17,7 @@
|
||||||
@ -56,7 +56,7 @@ index 3ec05ca..32a9a3e 100755
|
|||||||
import argparse
|
import argparse
|
||||||
import sys
|
import sys
|
||||||
import logging
|
import logging
|
||||||
@@ -78,7 +78,7 @@ else:
|
@@ -81,7 +81,7 @@ else:
|
||||||
try:
|
try:
|
||||||
p = setools.SELinuxPolicy(args.policy)
|
p = setools.SELinuxPolicy(args.policy)
|
||||||
m = setools.PermissionMap(args.map)
|
m = setools.PermissionMap(args.map)
|
||||||
@ -66,23 +66,22 @@ index 3ec05ca..32a9a3e 100755
|
|||||||
if args.shortest_path or args.all_paths:
|
if args.shortest_path or args.all_paths:
|
||||||
if args.shortest_path:
|
if args.shortest_path:
|
||||||
diff --git a/setools/__init__.py b/setools/__init__.py
|
diff --git a/setools/__init__.py b/setools/__init__.py
|
||||||
index 7b70f5e..020be31 100644
|
index 7b70f5e..5a5f7fe 100644
|
||||||
--- a/setools/__init__.py
|
--- a/setools/__init__.py
|
||||||
+++ b/setools/__init__.py
|
+++ b/setools/__init__.py
|
||||||
@@ -73,11 +73,11 @@ from .pcideviceconquery import PcideviceconQuery
|
@@ -73,12 +73,8 @@ from .pcideviceconquery import PcideviceconQuery
|
||||||
from .devicetreeconquery import DevicetreeconQuery
|
from .devicetreeconquery import DevicetreeconQuery
|
||||||
|
|
||||||
# Information Flow Analysis
|
# Information Flow Analysis
|
||||||
-from .infoflow import InfoFlowAnalysis
|
-from .infoflow import InfoFlowAnalysis
|
||||||
+# from .infoflow import InfoFlowAnalysis
|
|
||||||
from .permmap import PermissionMap
|
from .permmap import PermissionMap
|
||||||
|
|
||||||
# Domain Transition Analysis
|
-# Domain Transition Analysis
|
||||||
-from .dta import DomainTransitionAnalysis
|
-from .dta import DomainTransitionAnalysis
|
||||||
+# from .dta import DomainTransitionAnalysis
|
-
|
||||||
|
|
||||||
# Policy difference
|
# Policy difference
|
||||||
from .diff import PolicyDifference
|
from .diff import PolicyDifference
|
||||||
|
|
||||||
diff --git a/setoolsgui/apol/dta.py b/setoolsgui/apol/dta.py
|
diff --git a/setoolsgui/apol/dta.py b/setoolsgui/apol/dta.py
|
||||||
index 4608b9d..2cde44c 100644
|
index 4608b9d..2cde44c 100644
|
||||||
--- a/setoolsgui/apol/dta.py
|
--- a/setoolsgui/apol/dta.py
|
||||||
@ -136,5 +135,5 @@ index aa0e44a..fca2848 100644
|
|||||||
from setools.exception import InvalidType
|
from setools.exception import InvalidType
|
||||||
from setools.permmap import PermissionMap
|
from setools.permmap import PermissionMap
|
||||||
--
|
--
|
||||||
2.9.3
|
2.17.2
|
||||||
|
|
||||||
|
@ -1,14 +1,14 @@
|
|||||||
# % global setools_pre_ver rc
|
# % global setools_pre_ver rc
|
||||||
# % global gitver f1e5b20
|
# % global gitver f1e5b20
|
||||||
|
|
||||||
%global sepol_ver 2.8-1
|
%global sepol_ver 2.9-1
|
||||||
%global selinux_ver 2.8-1
|
%global selinux_ver 2.9-1
|
||||||
|
|
||||||
%bcond_with networkx
|
%bcond_with networkx
|
||||||
|
|
||||||
Name: setools
|
Name: setools
|
||||||
Version: 4.2.0
|
Version: 4.2.2
|
||||||
Release: 2%{?setools_pre_ver:.%{setools_pre_ver}}%{?dist}
|
Release: 1%{?setools_pre_ver:.%{setools_pre_ver}}%{?dist}
|
||||||
Summary: Policy analysis tools for SELinux
|
Summary: Policy analysis tools for SELinux
|
||||||
|
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
@ -16,7 +16,6 @@ URL: https://github.com/SELinuxProject/setools/wiki
|
|||||||
Source0: https://github.com/SELinuxProject/setools/archive/%{version}%{?setools_pre_ver:-%{setools_pre_ver}}.tar.gz
|
Source0: https://github.com/SELinuxProject/setools/archive/%{version}%{?setools_pre_ver:-%{setools_pre_ver}}.tar.gz
|
||||||
Source1: setools.pam
|
Source1: setools.pam
|
||||||
Source2: apol.desktop
|
Source2: apol.desktop
|
||||||
|
|
||||||
Patch1001: 1001-Do-not-use-Werror-during-build.patch
|
Patch1001: 1001-Do-not-use-Werror-during-build.patch
|
||||||
Patch1002: 1002-Do-not-export-use-setools.InfoFlowAnalysis-and-setoo.patch
|
Patch1002: 1002-Do-not-export-use-setools.InfoFlowAnalysis-and-setoo.patch
|
||||||
|
|
||||||
@ -112,7 +111,8 @@ Python modules designed to facilitate SELinux policy analysis.
|
|||||||
|
|
||||||
%build
|
%build
|
||||||
# Remove CFLAGS=... for noarch packages (unneeded)
|
# Remove CFLAGS=... for noarch packages (unneeded)
|
||||||
CFLAGS="%{optflags}" %{__python3} setup.py build
|
%set_build_flags
|
||||||
|
%{__python3} setup.py build
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -162,6 +162,18 @@ rm -rf %{buildroot}%{_bindir}/apol %{buildroot}%{python3_sitearch}/setoolsgui \
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 08 2019 Vit Mojzis <vmojzis@redhat.com> - 4.2.2-1
|
||||||
|
- SETools 4.2.2 release
|
||||||
|
|
||||||
|
* Mon May 13 2019 Vit Mojzis <vmojzis@redhat.com> - 4.2.1-3
|
||||||
|
- Use %set_build_flags instead of %optflags
|
||||||
|
|
||||||
|
* Mon May 06 2019 Vit Mojzis <vmojzis@redhat.com> - 4.2.1-2
|
||||||
|
- SELinuxPolicy: Create a map of aliases on policy load (#1672631)
|
||||||
|
|
||||||
|
* Tue Mar 26 2019 Petr Lautrbach <plautrba@redhat.com> - 4.2.1-1
|
||||||
|
- SETools 4.2.1 release (#1581761, #1595582)
|
||||||
|
|
||||||
* Fri Nov 16 2018 Lumír Balhar <lbalhar@redhat.com> - 4.2.0-2
|
* Fri Nov 16 2018 Lumír Balhar <lbalhar@redhat.com> - 4.2.0-2
|
||||||
- Require platform-python-setuptools instead of python3-setuptools
|
- Require platform-python-setuptools instead of python3-setuptools
|
||||||
- Resolves: rhbz#1650548
|
- Resolves: rhbz#1650548
|
||||||
|
Loading…
Reference in New Issue
Block a user