- Build on rawhide
This commit is contained in:
parent
35eefc5861
commit
6e3a73eab1
@ -1,84 +1,5 @@
|
||||
--- setools-3.0/Makefile.am.rhat 2006-10-04 12:15:08.000000000 -0400
|
||||
+++ setools-3.0/Makefile.am 2006-10-26 16:20:34.000000000 -0400
|
||||
@@ -9,6 +9,7 @@
|
||||
SUBDIRS = libqpol libapol libpoldiff libsefs libseaudit secmds sechecker sediff man $(MAYBE_GUI) $(MAYBE_BWIDGET)
|
||||
|
||||
EXTRA_DIST = VERSION KNOWN-BUGS
|
||||
+doc_DATA = KNOWN-BUGS README
|
||||
|
||||
libqpol:
|
||||
$(MAKE) -C $(top_srcdir)/libqpol
|
||||
--- setools-3.0/sechecker/Makefile.am.rhat 2006-10-04 12:14:44.000000000 -0400
|
||||
+++ setools-3.0/sechecker/Makefile.am 2006-10-26 16:20:34.000000000 -0400
|
||||
@@ -1,7 +1,7 @@
|
||||
setoolsdir = @setoolsdir@
|
||||
bin_PROGRAMS = sechecker
|
||||
|
||||
-dist_setools_DATA = \
|
||||
+doc_DATA = \
|
||||
sechecker_help.txt
|
||||
|
||||
profilesdir = @profile_install_dir@
|
||||
--- setools-3.0/seaudit/Makefile.am.rhat 2006-10-06 15:14:34.000000000 -0400
|
||||
+++ setools-3.0/seaudit/Makefile.am 2006-10-26 16:20:34.000000000 -0400
|
||||
@@ -10,6 +10,9 @@
|
||||
@GTK_LIBS@ @GLADE_LIBS@ @XML_LIBS@ -rdynamic
|
||||
LDADD = @SELINUX_LIB_FLAG@ $(top_builddir)/libseaudit/libseaudit.a @APOL_LIB_FLAG@ @QPOL_LIB_FLAG@
|
||||
|
||||
+doc_DATA = \
|
||||
+ seaudit_help.txt
|
||||
+
|
||||
dist_setools_DATA = \
|
||||
customize_filter_window.glade \
|
||||
filter_window.glade \
|
||||
@@ -18,7 +21,6 @@
|
||||
query_window.glade \
|
||||
report_window.glade \
|
||||
seaudit.glade \
|
||||
- seaudit_help.txt \
|
||||
seaudit-report.conf \
|
||||
seaudit-report.css
|
||||
|
||||
--- setools-3.0/apol/Makefile.am.rhat 2006-10-13 13:56:21.000000000 -0400
|
||||
+++ setools-3.0/apol/Makefile.am 2006-10-26 16:20:34.000000000 -0400
|
||||
@@ -4,9 +4,10 @@
|
||||
bin_PROGRAMS = apol
|
||||
dist_setools_SCRIPTS = apol.tcl
|
||||
|
||||
-dist_setools_DATA = apol_help.txt domaintrans_help.txt file_relabel_help.txt \
|
||||
- infoflow_help.txt types_relation_help.txt \
|
||||
- perm_maps/apol_perm_mapping_ver12 \
|
||||
+doc_DATA = apol_help.txt domaintrans_help.txt file_relabel_help.txt \
|
||||
+ infoflow_help.txt types_relation_help.txt
|
||||
+
|
||||
+dist_setools_DATA = perm_maps/apol_perm_mapping_ver12 \
|
||||
perm_maps/apol_perm_mapping_ver15 \
|
||||
perm_maps/apol_perm_mapping_ver16 \
|
||||
perm_maps/apol_perm_mapping_ver17 \
|
||||
--- setools-3.0/sediff/Makefile.am.rhat 2006-10-04 12:14:48.000000000 -0400
|
||||
+++ setools-3.0/sediff/Makefile.am 2006-10-26 16:20:34.000000000 -0400
|
||||
@@ -1,6 +1,7 @@
|
||||
setoolsdir = @setoolsdir@
|
||||
|
||||
-dist_setools_DATA = sediff_help.txt sediff.glade
|
||||
+doc_DATA = sediff_help.txt
|
||||
+dist_setools_DATA = sediff.glade
|
||||
|
||||
if BUILD_GUI
|
||||
MAYBE_SEDIFFX = sediffx
|
||||
--- setools-3.0/configure.ac.rhat 2006-10-13 14:59:34.000000000 -0400
|
||||
+++ setools-3.0/configure.ac 2006-10-26 16:42:08.000000000 -0400
|
||||
@@ -3,6 +3,10 @@
|
||||
AC_CONFIG_HEADER(config.h)
|
||||
AM_INIT_AUTOMAKE(setools, 3.0)
|
||||
|
||||
+docdir="\${datadir}/doc/$PACKAGE_NAME-$PACKAGE_VERSION"
|
||||
+AC_SUBST(docdir)
|
||||
+AC_SUBST(YFLAGS)
|
||||
+
|
||||
dnl *** update these variables as versions change; also update AC_INIT ***
|
||||
libqpol_version=1.0.0
|
||||
libqpol_soname=libqpol.so.1
|
||||
@@ -19,7 +23,7 @@
|
||||
|
||||
libseaudit_version=3.0.0
|
||||
|
@ -144,7 +144,6 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_datadir}/applications/sediffx.desktop
|
||||
%config(noreplace) %{_sysconfdir}/pam.d/seaudit
|
||||
%config(noreplace) %{_sysconfdir}/security/console.apps/seaudit
|
||||
/usr/share/doc/setools-%{version}/*.txt
|
||||
|
||||
/usr/share/setools/apol.tcl
|
||||
/usr/share/setools/apol_perm_mapping_ver12
|
||||
@ -209,8 +208,8 @@ Headers, static libraries and API docs for SETools.
|
||||
%{_bindir}/sechecker
|
||||
%{_bindir}/sediff
|
||||
%dir /usr/share/doc/setools-%{version}
|
||||
/usr/share/doc/setools-%{version}/KNOWN-BUGS
|
||||
/usr/share/doc/setools-%{version}/README
|
||||
%doc KNOWN-BUGS
|
||||
%doc README
|
||||
%{_mandir}/man1/sechecker.1.gz
|
||||
%{_mandir}/man1/seinfo.1.gz
|
||||
%{_mandir}/man1/sediff.1.gz
|
||||
@ -218,6 +217,7 @@ Headers, static libraries and API docs for SETools.
|
||||
%attr(755,root,root) %dir /usr/share/setools
|
||||
%attr(755,root,root) %dir /usr/share/setools/sechecker-profiles
|
||||
/usr/share/setools/sechecker-profiles/*
|
||||
/usr/share/setools/*.txt
|
||||
%{_libdir}/libapol.so*
|
||||
%{_libdir}/libqpol.so*
|
||||
%{_libdir}/libpoldiff.so*
|
||||
|
Loading…
Reference in New Issue
Block a user