- Build on rawhide
This commit is contained in:
parent
e3cde34ed8
commit
6c5a986741
@ -1,5 +1,5 @@
|
||||
--- setools-3.0/Makefile.am.rhat 2006-10-04 12:15:08.000000000 -0400
|
||||
+++ setools-3.0/Makefile.am 2006-10-24 13:14:16.000000000 -0400
|
||||
+++ setools-3.0/Makefile.am 2006-10-26 16:08:20.000000000 -0400
|
||||
@@ -9,6 +9,7 @@
|
||||
SUBDIRS = libqpol libapol libpoldiff libsefs libseaudit secmds sechecker sediff man $(MAYBE_GUI) $(MAYBE_BWIDGET)
|
||||
|
||||
@ -9,7 +9,7 @@
|
||||
libqpol:
|
||||
$(MAKE) -C $(top_srcdir)/libqpol
|
||||
--- setools-3.0/sechecker/Makefile.am.rhat 2006-10-04 12:14:44.000000000 -0400
|
||||
+++ setools-3.0/sechecker/Makefile.am 2006-10-24 13:14:16.000000000 -0400
|
||||
+++ setools-3.0/sechecker/Makefile.am 2006-10-26 16:08:20.000000000 -0400
|
||||
@@ -1,7 +1,7 @@
|
||||
setoolsdir = @setoolsdir@
|
||||
bin_PROGRAMS = sechecker
|
||||
@ -20,7 +20,7 @@
|
||||
|
||||
profilesdir = @profile_install_dir@
|
||||
--- setools-3.0/seaudit/Makefile.am.rhat 2006-10-06 15:14:34.000000000 -0400
|
||||
+++ setools-3.0/seaudit/Makefile.am 2006-10-24 13:14:16.000000000 -0400
|
||||
+++ setools-3.0/seaudit/Makefile.am 2006-10-26 16:08:20.000000000 -0400
|
||||
@@ -10,6 +10,9 @@
|
||||
@GTK_LIBS@ @GLADE_LIBS@ @XML_LIBS@ -rdynamic
|
||||
LDADD = @SELINUX_LIB_FLAG@ $(top_builddir)/libseaudit/libseaudit.a @APOL_LIB_FLAG@ @QPOL_LIB_FLAG@
|
||||
@ -40,7 +40,7 @@
|
||||
seaudit-report.css
|
||||
|
||||
--- setools-3.0/apol/Makefile.am.rhat 2006-10-13 13:56:21.000000000 -0400
|
||||
+++ setools-3.0/apol/Makefile.am 2006-10-24 13:14:16.000000000 -0400
|
||||
+++ setools-3.0/apol/Makefile.am 2006-10-26 16:08:20.000000000 -0400
|
||||
@@ -4,9 +4,10 @@
|
||||
bin_PROGRAMS = apol
|
||||
dist_setools_SCRIPTS = apol.tcl
|
||||
@ -55,23 +55,16 @@
|
||||
perm_maps/apol_perm_mapping_ver15 \
|
||||
perm_maps/apol_perm_mapping_ver16 \
|
||||
perm_maps/apol_perm_mapping_ver17 \
|
||||
--- setools-3.0/packages/Makefile.am.rhat 2006-10-11 12:50:16.000000000 -0400
|
||||
+++ setools-3.0/packages/Makefile.am 2006-10-24 13:14:16.000000000 -0400
|
||||
@@ -1,10 +1,8 @@
|
||||
--- setools-3.0/packages/Makefile.am.rhat 2006-10-26 16:15:12.000000000 -0400
|
||||
+++ setools-3.0/packages/Makefile.am 2006-10-26 16:19:41.000000000 -0400
|
||||
@@ -1,4 +1,4 @@
|
||||
-bwidget_destdir = @BWIDGET_DESTDIR@
|
||||
-
|
||||
+bwidget_destdir = $(DESTDIR)/@BWIDGET_DESTDIR@
|
||||
|
||||
dist_noinst_DATA = BWidget-1.8.0.tar.bz2 combobox.tcl mainframe.tcl notebook.tcl Doxyfile
|
||||
|
||||
install-data-local:
|
||||
tar jxf BWidget-1.8.0.tar.bz2
|
||||
- mv BWidget-1.8.0 $(bwidget_destdir)
|
||||
+ mv BWidget-1.8.0 $(BWIDGET_DESTDIR)
|
||||
|
||||
uninstall-local:
|
||||
- -rm -rf $(bwidget_destdir)/BWidget-1.8.0
|
||||
+ -rm -rf $(BWIDGET_DESTDIR)/BWidget-1.8.0
|
||||
--- setools-3.0/sediff/Makefile.am.rhat 2006-10-04 12:14:48.000000000 -0400
|
||||
+++ setools-3.0/sediff/Makefile.am 2006-10-24 13:14:16.000000000 -0400
|
||||
+++ setools-3.0/sediff/Makefile.am 2006-10-26 16:08:20.000000000 -0400
|
||||
@@ -1,6 +1,7 @@
|
||||
setoolsdir = @setoolsdir@
|
||||
|
||||
@ -82,7 +75,7 @@
|
||||
if BUILD_GUI
|
||||
MAYBE_SEDIFFX = sediffx
|
||||
--- setools-3.0/configure.ac.rhat 2006-10-13 14:59:34.000000000 -0400
|
||||
+++ setools-3.0/configure.ac 2006-10-24 13:18:31.000000000 -0400
|
||||
+++ setools-3.0/configure.ac 2006-10-26 16:18:59.000000000 -0400
|
||||
@@ -3,6 +3,10 @@
|
||||
AC_CONFIG_HEADER(config.h)
|
||||
AM_INIT_AUTOMAKE(setools, 3.0)
|
||||
@ -103,7 +96,19 @@
|
||||
|
||||
version_min_sepol_major=1
|
||||
version_min_sepol_minor=12
|
||||
@@ -249,17 +253,21 @@
|
||||
@@ -220,7 +224,10 @@
|
||||
AC_SUBST(BWIDGET_DESTDIR)
|
||||
fi
|
||||
else
|
||||
- copy_bwidget=no
|
||||
+
|
||||
+ BWIDGET_DESTDIR="\${datadir}/tcl8.4/"
|
||||
+ AC_SUBST(BWIDGET_DESTDIR)
|
||||
+ copy_bwidget=yes
|
||||
bwidget_ver=1.8
|
||||
fi
|
||||
|
||||
@@ -249,17 +256,21 @@
|
||||
AC_ARG_WITH(sepol-devel,
|
||||
AC_HELP_STRING([--with-sepol-devel],
|
||||
[prefix where sepol development files are installed]),
|
||||
|
@ -1,7 +1,7 @@
|
||||
Summary: SELinux tools for managing policy
|
||||
Name: setools
|
||||
Version: 3.0
|
||||
Release: 1
|
||||
Release: 2
|
||||
License: GPL
|
||||
Group: System Environment/Base
|
||||
URL: http://www.tresys.com/
|
||||
@ -224,6 +224,9 @@ Headers, static libraries and API docs for SETools.
|
||||
%{_libdir}/libsefs.so*
|
||||
|
||||
%changelog
|
||||
* Thu Oct 26 2006 Dan Walsh <dwalsh@redhat.com> 3.0-2
|
||||
- Build on rawhide
|
||||
|
||||
* Sun Oct 15 2006 Dan Walsh <dwalsh@redhat.com> 3.0-1
|
||||
- Update to upstream
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user