auto-import changelog data from setools-1.4-2.src.rpm
Thu Jun 10 2004 Dan Walsh <dwalsh@redhat.com> 1.4-2 - Fix install locations of policy_src_dir
This commit is contained in:
parent
07c5f9aeca
commit
4db8a2fbe8
@ -1,5 +1,5 @@
|
|||||||
--- setools-1.4/seuser/Makefile.rhat 2004-06-02 13:44:13.000000000 -0400
|
--- setools-1.4/seuser/Makefile.rhat 2004-06-02 13:44:13.000000000 -0400
|
||||||
+++ setools-1.4/seuser/Makefile 2004-06-02 15:57:20.939475608 -0400
|
+++ setools-1.4/seuser/Makefile 2004-06-02 15:57:20.000000000 -0400
|
||||||
@@ -22,10 +22,10 @@
|
@@ -22,10 +22,10 @@
|
||||||
SHELL = /bin/sh
|
SHELL = /bin/sh
|
||||||
|
|
||||||
@ -14,7 +14,7 @@
|
|||||||
se_user.tcl: $(TCL-FILES)
|
se_user.tcl: $(TCL-FILES)
|
||||||
cat $(TCL-FILES) | \
|
cat $(TCL-FILES) | \
|
||||||
--- setools-1.4/awish/Makefile.rhat 2004-06-02 13:44:13.000000000 -0400
|
--- setools-1.4/awish/Makefile.rhat 2004-06-02 13:44:13.000000000 -0400
|
||||||
+++ setools-1.4/awish/Makefile 2004-06-02 15:57:20.940475456 -0400
|
+++ setools-1.4/awish/Makefile 2004-06-02 15:57:20.000000000 -0400
|
||||||
@@ -4,7 +4,7 @@
|
@@ -4,7 +4,7 @@
|
||||||
AWISH_OBJ = awish.o $(LIBSEUSER-TCL) $(LIBAPOL-TCL)
|
AWISH_OBJ = awish.o $(LIBSEUSER-TCL) $(LIBAPOL-TCL)
|
||||||
|
|
||||||
@ -45,7 +45,7 @@
|
|||||||
install -m 755 awish $(BINDIR)
|
install -m 755 awish $(BINDIR)
|
||||||
|
|
||||||
--- setools-1.4/libseuser/seuser_db.c.rhat 2004-06-02 13:44:13.000000000 -0400
|
--- setools-1.4/libseuser/seuser_db.c.rhat 2004-06-02 13:44:13.000000000 -0400
|
||||||
+++ setools-1.4/libseuser/seuser_db.c 2004-06-02 15:57:20.942475152 -0400
|
+++ setools-1.4/libseuser/seuser_db.c 2004-06-02 15:57:20.000000000 -0400
|
||||||
@@ -17,6 +17,7 @@
|
@@ -17,6 +17,7 @@
|
||||||
#include <pwd.h>
|
#include <pwd.h>
|
||||||
#include <sys/types.h>
|
#include <sys/types.h>
|
||||||
@ -100,7 +100,7 @@
|
|||||||
fclose(fp);
|
fclose(fp);
|
||||||
free_conf_info(db);
|
free_conf_info(db);
|
||||||
--- setools-1.4/libseuser/Makefile.rhat 2004-06-02 13:44:12.000000000 -0400
|
--- setools-1.4/libseuser/Makefile.rhat 2004-06-02 13:44:12.000000000 -0400
|
||||||
+++ setools-1.4/libseuser/Makefile 2004-06-02 15:57:20.943475000 -0400
|
+++ setools-1.4/libseuser/Makefile 2004-06-02 15:57:20.000000000 -0400
|
||||||
@@ -11,8 +11,12 @@
|
@@ -11,8 +11,12 @@
|
||||||
|
|
||||||
libseuser-tcl: ../lib/libseuser-tcl.a
|
libseuser-tcl: ../lib/libseuser-tcl.a
|
||||||
@ -125,7 +125,7 @@
|
|||||||
mkdir -p $@
|
mkdir -p $@
|
||||||
|
|
||||||
--- setools-1.4/packages/Makefile.rhat 2004-06-02 13:44:12.000000000 -0400
|
--- setools-1.4/packages/Makefile.rhat 2004-06-02 13:44:12.000000000 -0400
|
||||||
+++ setools-1.4/packages/Makefile 2004-06-02 16:03:28.721564232 -0400
|
+++ setools-1.4/packages/Makefile 2004-06-02 16:03:28.000000000 -0400
|
||||||
@@ -4,9 +4,10 @@
|
@@ -4,9 +4,10 @@
|
||||||
|
|
||||||
# INSTALL_PATH is set based upon your current
|
# INSTALL_PATH is set based upon your current
|
||||||
@ -146,20 +146,20 @@
|
|||||||
\ No newline at end of file
|
\ No newline at end of file
|
||||||
+bare: clean
|
+bare: clean
|
||||||
--- setools-1.4/Makefile.rhat 2004-06-02 13:44:13.000000000 -0400
|
--- setools-1.4/Makefile.rhat 2004-06-02 13:44:13.000000000 -0400
|
||||||
+++ setools-1.4/Makefile 2004-06-02 15:57:20.945474696 -0400
|
+++ setools-1.4/Makefile 2004-06-10 14:56:04.354591984 -0400
|
||||||
@@ -21,9 +21,9 @@
|
@@ -21,8 +21,9 @@
|
||||||
# File location defaults; used in various places in code
|
# File location defaults; used in various places in code
|
||||||
# Change these if you want different defaults
|
# Change these if you want different defaults
|
||||||
SELINUX_DIR = $(DESTDIR)/selinux
|
SELINUX_DIR = $(DESTDIR)/selinux
|
||||||
-POLICY_INSTALL_DIR = $(DESTDIR)/etc/security/selinux
|
-POLICY_INSTALL_DIR = $(DESTDIR)/etc/security/selinux
|
||||||
+POLICY_INSTALL_DIR = $(DESTDIR)/etc/selinux/strict
|
-POLICY_SRC_DIR = $(DESTDIR)$(POLICY_INSTALL_DIR)/src/policy
|
||||||
POLICY_SRC_DIR = $(DESTDIR)$(POLICY_INSTALL_DIR)/src/policy
|
+SELINUX_POLICY_DIR = $(DESTDIR)/etc/selinux/strict/
|
||||||
-POLICY_SRC_FILE = $(POLICY_SRC_DIR)/policy.conf
|
+POLICY_INSTALL_DIR = $(DESTDIR)$(SELINUX_POLICY_DIR)/policy
|
||||||
+POLICY_SRC_FILE = $(POLICY_SRC_DIR)/policy/policy.conf
|
+POLICY_SRC_DIR = $(DESTDIR)$(SELINUX_POLICY_DIR)/src/policy
|
||||||
|
POLICY_SRC_FILE = $(POLICY_SRC_DIR)/policy.conf
|
||||||
DEFAULT_LOG_FILE = /var/log/messages
|
DEFAULT_LOG_FILE = /var/log/messages
|
||||||
|
|
||||||
# Compile options
|
@@ -120,7 +121,7 @@
|
||||||
@@ -120,7 +120,7 @@
|
|
||||||
echo "Could not build awish."; \
|
echo "Could not build awish."; \
|
||||||
echo "Tcl library is not built or not in expected location(s)."; \
|
echo "Tcl library is not built or not in expected location(s)."; \
|
||||||
fi
|
fi
|
||||||
@ -168,7 +168,7 @@
|
|||||||
seuser: selinux_tool
|
seuser: selinux_tool
|
||||||
cd seuser; $(MAKE) seuser
|
cd seuser; $(MAKE) seuser
|
||||||
|
|
||||||
@@ -141,9 +141,9 @@
|
@@ -141,9 +142,9 @@
|
||||||
|
|
||||||
secmds: selinux_tool
|
secmds: selinux_tool
|
||||||
cd secmds; $(MAKE) all
|
cd secmds; $(MAKE) all
|
||||||
@ -180,7 +180,7 @@
|
|||||||
|
|
||||||
libapol-tcl: selinux_tool
|
libapol-tcl: selinux_tool
|
||||||
cd libapol;
|
cd libapol;
|
||||||
@@ -215,17 +215,23 @@
|
@@ -215,17 +216,23 @@
|
||||||
|
|
||||||
install-nogui: $(INSTALL_LIBDIR) install-seuser install-secmds
|
install-nogui: $(INSTALL_LIBDIR) install-seuser install-secmds
|
||||||
|
|
||||||
@ -208,7 +208,7 @@
|
|||||||
|
|
||||||
# Next four targets are to support installation as part of a system
|
# Next four targets are to support installation as part of a system
|
||||||
--- setools-1.4/docs-src/Makefile.rhat 2004-06-02 13:44:13.000000000 -0400
|
--- setools-1.4/docs-src/Makefile.rhat 2004-06-02 13:44:13.000000000 -0400
|
||||||
+++ setools-1.4/docs-src/Makefile 2004-06-02 15:57:20.946474544 -0400
|
+++ setools-1.4/docs-src/Makefile 2004-06-02 15:57:20.000000000 -0400
|
||||||
@@ -55,3 +55,14 @@
|
@@ -55,3 +55,14 @@
|
||||||
for file in $(TOP-DOCS); do \
|
for file in $(TOP-DOCS); do \
|
||||||
rm -f ../$$file; \
|
rm -f ../$$file; \
|
||||||
@ -225,7 +225,7 @@
|
|||||||
+ install -m 644 ../apol/*.txt ${INSTALL_HELPDIR}
|
+ install -m 644 ../apol/*.txt ${INSTALL_HELPDIR}
|
||||||
+
|
+
|
||||||
--- setools-1.4/apol/Makefile.rhat 2004-06-02 13:44:12.000000000 -0400
|
--- setools-1.4/apol/Makefile.rhat 2004-06-02 13:44:12.000000000 -0400
|
||||||
+++ setools-1.4/apol/Makefile 2004-06-02 15:57:20.947474392 -0400
|
+++ setools-1.4/apol/Makefile 2004-06-02 15:57:20.000000000 -0400
|
||||||
@@ -11,14 +11,14 @@
|
@@ -11,14 +11,14 @@
|
||||||
APOL_HELP_FILES = apol_help.txt dta_help.txt iflow_help.txt obj_perms_help.txt
|
APOL_HELP_FILES = apol_help.txt dta_help.txt iflow_help.txt obj_perms_help.txt
|
||||||
APOL_PERM_MAPS = apol_perm_mapping_ver12 apol_perm_mapping_ver15 \
|
APOL_PERM_MAPS = apol_perm_mapping_ver12 apol_perm_mapping_ver15 \
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
Summary: SELinux tools for managing policy
|
Summary: SELinux tools for managing policy
|
||||||
Name: setools
|
Name: setools
|
||||||
Version: 1.4
|
Version: 1.4
|
||||||
Release: 1
|
Release: 2
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Source: http://www.tresys.com/Downloads/selinux-tools/setools-%{version}.tgz
|
Source: http://www.tresys.com/Downloads/selinux-tools/setools-%{version}.tgz
|
||||||
@ -124,6 +124,9 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
|
||||||
|
* Thu Jun 10 2004 Dan Walsh <dwalsh@redhat.com> 1.4-2
|
||||||
|
- Fix install locations of policy_src_dir
|
||||||
|
|
||||||
* Wed Jun 2 2004 Dan Walsh <dwalsh@redhat.com> 1.4-1
|
* Wed Jun 2 2004 Dan Walsh <dwalsh@redhat.com> 1.4-1
|
||||||
- Update to latest from TRESYS.
|
- Update to latest from TRESYS.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user