Apply swig patch to make apol work again.
This commit is contained in:
parent
aa84f5eb45
commit
100f5e541c
@ -1,14 +1,14 @@
|
|||||||
diff -up setools-3.3.7/Makefile.am.noship setools-3.3.7/Makefile.am
|
diff -up setools-3.3.7/Makefile.am.noship setools-3.3.7/Makefile.am
|
||||||
--- setools-3.3.7/Makefile.am.noship 2012-09-28 13:15:50.758642089 -0400
|
--- setools-3.3.7/Makefile.am.noship 2008-02-22 14:06:28.000000000 -0500
|
||||||
+++ setools-3.3.7/Makefile.am 2012-09-28 13:15:50.911643035 -0400
|
+++ setools-3.3.7/Makefile.am 2013-01-30 09:18:59.775157146 -0500
|
||||||
@@ -8,9 +8,8 @@ endif
|
@@ -8,9 +8,8 @@ endif
|
||||||
if BUILD_GUI
|
if BUILD_GUI
|
||||||
MAYBE_GUI = seaudit
|
MAYBE_GUI = seaudit
|
||||||
endif
|
endif
|
||||||
-# sediffx is also built conditionally, from sediffx/Makefile.am
|
-# sediffx is also built conditionally, from sediffx/Makefile.am
|
||||||
|
|
||||||
-SUBDIRS = libqpol libapol libsefs libpoldiff libseaudit secmds sechecker sediff man packages debian $(MAYBE_APOL) $(MAYBE_GUI) python
|
-SUBDIRS = libqpol libapol libsefs libpoldiff libseaudit secmds sechecker sediff man packages debian $(MAYBE_APOL) $(MAYBE_GUI)
|
||||||
+SUBDIRS = libqpol libapol libsefs libpoldiff libseaudit secmds sediff man packages debian $(MAYBE_APOL) $(MAYBE_GUI) python
|
+SUBDIRS = libqpol libapol libsefs libpoldiff libseaudit secmds sediff man packages debian $(MAYBE_APOL) $(MAYBE_GUI)
|
||||||
|
|
||||||
#old indent opts
|
#old indent opts
|
||||||
#INDENT_OPTS = -npro -nbad -bap -sob -ss -l132 -di1 -nbc -br -nbbb -c40 -cd40 -ncdb -ce -cli0 -cp40 -ncs -d0 -nfc1 -nfca -i8 -ts8 -ci8 -lp -ip0 -npcs -npsl -sc
|
#INDENT_OPTS = -npro -nbad -bap -sob -ss -l132 -di1 -nbc -br -nbbb -c40 -cd40 -ncdb -ce -cli0 -cp40 -ncs -d0 -nfc1 -nfca -i8 -ts8 -ci8 -lp -ip0 -npcs -npsl -sc
|
||||||
@ -67,7 +67,7 @@ diff -up setools-3.3.7/Makefile.am.noship setools-3.3.7/Makefile.am
|
|||||||
|
|
||||||
diff -up setools-3.3.7/man/Makefile.am.noship setools-3.3.7/man/Makefile.am
|
diff -up setools-3.3.7/man/Makefile.am.noship setools-3.3.7/man/Makefile.am
|
||||||
--- setools-3.3.7/man/Makefile.am.noship 2007-08-02 17:16:33.000000000 -0400
|
--- setools-3.3.7/man/Makefile.am.noship 2007-08-02 17:16:33.000000000 -0400
|
||||||
+++ setools-3.3.7/man/Makefile.am 2012-09-28 13:15:50.912643041 -0400
|
+++ setools-3.3.7/man/Makefile.am 2013-01-30 09:16:13.696871566 -0500
|
||||||
@@ -1,19 +1,10 @@
|
@@ -1,19 +1,10 @@
|
||||||
if BUILD_GUI
|
if BUILD_GUI
|
||||||
MAYBEMANS = apol.1 \
|
MAYBEMANS = apol.1 \
|
||||||
@ -93,7 +93,7 @@ diff -up setools-3.3.7/man/Makefile.am.noship setools-3.3.7/man/Makefile.am
|
|||||||
-CLEANFILES = seaudit-report.8
|
-CLEANFILES = seaudit-report.8
|
||||||
diff -up setools-3.3.7/seaudit/Makefile.am.noship setools-3.3.7/seaudit/Makefile.am
|
diff -up setools-3.3.7/seaudit/Makefile.am.noship setools-3.3.7/seaudit/Makefile.am
|
||||||
--- setools-3.3.7/seaudit/Makefile.am.noship 2008-02-22 14:06:28.000000000 -0500
|
--- setools-3.3.7/seaudit/Makefile.am.noship 2008-02-22 14:06:28.000000000 -0500
|
||||||
+++ setools-3.3.7/seaudit/Makefile.am 2012-09-28 13:16:47.983863211 -0400
|
+++ setools-3.3.7/seaudit/Makefile.am 2013-01-30 09:16:13.697871568 -0500
|
||||||
@@ -1,5 +1,4 @@
|
@@ -1,5 +1,4 @@
|
||||||
setoolsdir = @setoolsdir@
|
setoolsdir = @setoolsdir@
|
||||||
-bin_PROGRAMS = seaudit-report
|
-bin_PROGRAMS = seaudit-report
|
||||||
@ -158,7 +158,7 @@ diff -up setools-3.3.7/seaudit/Makefile.am.noship setools-3.3.7/seaudit/Makefile
|
|||||||
+CLEANFILES = dot_seaudit
|
+CLEANFILES = dot_seaudit
|
||||||
diff -up setools-3.3.7/secmds/Makefile.am.noship setools-3.3.7/secmds/Makefile.am
|
diff -up setools-3.3.7/secmds/Makefile.am.noship setools-3.3.7/secmds/Makefile.am
|
||||||
--- setools-3.3.7/secmds/Makefile.am.noship 2007-08-02 17:16:33.000000000 -0400
|
--- setools-3.3.7/secmds/Makefile.am.noship 2007-08-02 17:16:33.000000000 -0400
|
||||||
+++ setools-3.3.7/secmds/Makefile.am 2012-09-28 13:15:50.913643048 -0400
|
+++ setools-3.3.7/secmds/Makefile.am 2013-01-30 09:16:13.698871569 -0500
|
||||||
@@ -1,6 +1,6 @@
|
@@ -1,6 +1,6 @@
|
||||||
# various setools command line tools
|
# various setools command line tools
|
||||||
|
|
||||||
@ -188,7 +188,7 @@ diff -up setools-3.3.7/secmds/Makefile.am.noship setools-3.3.7/secmds/Makefile.a
|
|||||||
|
|
||||||
diff -up setools-3.3.7/sediff/Makefile.am.noship setools-3.3.7/sediff/Makefile.am
|
diff -up setools-3.3.7/sediff/Makefile.am.noship setools-3.3.7/sediff/Makefile.am
|
||||||
--- setools-3.3.7/sediff/Makefile.am.noship 2007-04-25 15:20:20.000000000 -0400
|
--- setools-3.3.7/sediff/Makefile.am.noship 2007-04-25 15:20:20.000000000 -0400
|
||||||
+++ setools-3.3.7/sediff/Makefile.am 2012-09-28 13:15:50.913643048 -0400
|
+++ setools-3.3.7/sediff/Makefile.am 2013-01-30 09:16:13.698871569 -0500
|
||||||
@@ -1,13 +1,6 @@
|
@@ -1,13 +1,6 @@
|
||||||
setoolsdir = @setoolsdir@
|
setoolsdir = @setoolsdir@
|
||||||
|
|
||||||
@ -241,3 +241,15 @@ diff -up setools-3.3.7/sediff/Makefile.am.noship setools-3.3.7/sediff/Makefile.a
|
|||||||
$(top_builddir)/libpoldiff/src/libpoldiff.so:
|
$(top_builddir)/libpoldiff/src/libpoldiff.so:
|
||||||
$(MAKE) -C $(top_builddir)/libpoldiff/src $(notdir $@)
|
$(MAKE) -C $(top_builddir)/libpoldiff/src $(notdir $@)
|
||||||
|
|
||||||
|
diff -up setools-3.3.7/configure.ac~ setools-3.3.7/configure.ac
|
||||||
|
--- setools-3.3.7/configure.ac~ 2013-01-30 09:52:05.689136955 -0500
|
||||||
|
+++ setools-3.3.7/configure.ac 2013-01-30 09:56:26.853722063 -0500
|
||||||
|
@@ -63,7 +63,7 @@ if test ${ac_cv_prog_cc_c99} = "no"; the
|
||||||
|
fi
|
||||||
|
AC_PROG_CXX
|
||||||
|
AC_LANG([C])
|
||||||
|
-AC_PROG_LIBTOOL
|
||||||
|
+AC_PROG_RANLIB
|
||||||
|
AC_PROG_LN_S
|
||||||
|
AC_PROG_LEX
|
||||||
|
AC_PROG_YACC
|
||||||
|
@ -13,7 +13,7 @@ Source: http://oss.tresys.com/projects/setools/chrome/site/dists/setools-%{versi
|
|||||||
Source1: setools.pam
|
Source1: setools.pam
|
||||||
Source2: apol.desktop
|
Source2: apol.desktop
|
||||||
Source3: seaudit.desktop
|
Source3: seaudit.desktop
|
||||||
Patch1: 0001-add-setools-seinfo-and-sesearch-python-bindings.patch
|
#Patch1: 0001-add-setools-seinfo-and-sesearch-python-bindings.patch
|
||||||
Patch2: 0002-setools-should-exit-with-an-error-status-if-it-gets-.patch
|
Patch2: 0002-setools-should-exit-with-an-error-status-if-it-gets-.patch
|
||||||
Patch3: 0003-Since-we-do-not-ship-neverallow-rules-all-always-fai.patch
|
Patch3: 0003-Since-we-do-not-ship-neverallow-rules-all-always-fai.patch
|
||||||
Patch4: 0004-Fix-man-pages-and-getoptions.patch
|
Patch4: 0004-Fix-man-pages-and-getoptions.patch
|
||||||
@ -174,7 +174,7 @@ This package includes the following graphical tools:
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p 1 -b .python
|
#%patch1 -p 1 -b .python
|
||||||
%patch2 -p 1 -b .exitstatus
|
%patch2 -p 1 -b .exitstatus
|
||||||
%patch3 -p 1 -b .neverallow
|
%patch3 -p 1 -b .neverallow
|
||||||
%patch4 -p 1 -b .manpage
|
%patch4 -p 1 -b .manpage
|
||||||
@ -195,7 +195,9 @@ This package includes the following graphical tools:
|
|||||||
# Fixup expected version of SWIG:
|
# Fixup expected version of SWIG:
|
||||||
sed -i -e "s|AC_PROG_SWIG(1.3.28)|AC_PROG_SWIG(2.0.0)|g" configure.ac
|
sed -i -e "s|AC_PROG_SWIG(1.3.28)|AC_PROG_SWIG(2.0.0)|g" configure.ac
|
||||||
# and rebuild the autotooled files:
|
# and rebuild the autotooled files:
|
||||||
autoreconf
|
aclocal
|
||||||
|
automake --add-missing
|
||||||
|
autoconf
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -249,7 +251,6 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%ifarch x86_64 ppc64 sparc64 s390x
|
%ifarch x86_64 ppc64 sparc64 s390x
|
||||||
%{pkg_py_arch}/
|
%{pkg_py_arch}/
|
||||||
%endif
|
%endif
|
||||||
%{python_sitearch}/setools*.egg-info
|
|
||||||
|
|
||||||
%files libs-tcl
|
%files libs-tcl
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
|
Loading…
Reference in New Issue
Block a user