- Upgrade to upstream version
This commit is contained in:
parent
247fbd4a5d
commit
08641530c8
@ -6,3 +6,4 @@ setools-2.1.0.tar.bz2
|
|||||||
setools-2.1.1.tar.bz2
|
setools-2.1.1.tar.bz2
|
||||||
setools-2.1.2.tar.bz2
|
setools-2.1.2.tar.bz2
|
||||||
setools-2.1.3.tar.bz2
|
setools-2.1.3.tar.bz2
|
||||||
|
setools-2.2.tar.bz2
|
||||||
|
@ -1,98 +1,6 @@
|
|||||||
--- setools-2.1.0/sepct/Makefile.rhat 2005-04-18 10:51:59.000000000 -0400
|
--- setools-2.2/seaudit/Makefile.rhat 2005-10-28 18:12:32.000000000 -0400
|
||||||
+++ setools-2.1.0/sepct/Makefile 2005-05-12 12:30:44.000000000 -0400
|
+++ setools-2.2/seaudit/Makefile 2005-11-03 16:46:34.000000000 -0500
|
||||||
@@ -23,7 +23,7 @@
|
@@ -60,8 +60,8 @@
|
||||||
# do nothing
|
|
||||||
|
|
||||||
install: sepcut
|
|
||||||
- install -m 755 sepcut $(BINDIR)
|
|
||||||
+ install -m 755 sepcut $(SBINDIR)
|
|
||||||
install -m 644 $(SEPCUT_HELP_FILE) $(INSTALL_LIBDIR)
|
|
||||||
|
|
||||||
clean:
|
|
||||||
--- setools-2.1.0/sediff/Makefile.rhat 2005-04-18 10:52:02.000000000 -0400
|
|
||||||
+++ setools-2.1.0/sediff/Makefile 2005-05-06 08:19:47.000000000 -0400
|
|
||||||
@@ -23,7 +23,8 @@
|
|
||||||
install -m 755 sediff $(BINDIR);
|
|
||||||
|
|
||||||
install: all
|
|
||||||
- install -m 755 sediff sediffx $(BINDIR);
|
|
||||||
+ install -m 755 sediff $(BINDIR);
|
|
||||||
+ install -m 755 sediffx $(SBINDIR);
|
|
||||||
install -m 644 $(GLADE_FILES) $(INSTALL_LIBDIR)
|
|
||||||
install -m 644 sediff_help.txt $(INSTALL_LIBDIR)
|
|
||||||
|
|
||||||
--- setools-2.1.0/seuser/Makefile.rhat 2005-04-18 10:52:00.000000000 -0400
|
|
||||||
+++ setools-2.1.0/seuser/Makefile 2005-05-06 08:19:47.000000000 -0400
|
|
||||||
@@ -166,7 +166,7 @@
|
|
||||||
install: seuser seuserx se_user.tcl
|
|
||||||
install -d $(BINDIR)
|
|
||||||
install -m 755 seuser $(BINDIR)
|
|
||||||
- install -m 755 seuserx $(BINDIR);
|
|
||||||
+ install -m 755 seuserx $(SBINDIR);
|
|
||||||
install -m 755 $(SE_SHELL_SCRIPTS) $(BINDIR)
|
|
||||||
install -m 644 se_user.tcl $(SEUSER_HELP_FILE) $(INSTALL_LIBDIR)
|
|
||||||
install -m 644 $(SEUSER_CONF_FILE) $(INSTALL_LIBDIR);
|
|
||||||
--- setools-2.1.0/packages/Makefile.rhat 2005-04-18 10:52:01.000000000 -0400
|
|
||||||
+++ setools-2.1.0/packages/Makefile 2005-05-06 08:19:47.000000000 -0400
|
|
||||||
@@ -16,4 +16,4 @@
|
|
||||||
clean:
|
|
||||||
rm -Rf BWidget-1.4.1
|
|
||||||
|
|
||||||
-bare: clean
|
|
||||||
\ No newline at end of file
|
|
||||||
+bare: clean
|
|
||||||
--- setools-2.1.0/Makefile.rhat 2005-04-18 10:51:59.000000000 -0400
|
|
||||||
+++ setools-2.1.0/Makefile 2005-05-06 08:19:47.000000000 -0400
|
|
||||||
@@ -42,8 +42,8 @@
|
|
||||||
# File location defaults; used in various places in code
|
|
||||||
# Change these if you want different defaults
|
|
||||||
SELINUX_DIR = $(DESTDIR)/selinux
|
|
||||||
-SELINUX_POLICY_DIR = $(DESTDIR)/etc/security/selinux
|
|
||||||
-POLICY_INSTALL_DIR = $(DESTDIR)$(SELINUX_POLICY_DIR)
|
|
||||||
+SELINUX_POLICY_DIR = $(DESTDIR)/etc/selinux/strict/
|
|
||||||
+POLICY_INSTALL_DIR = $(DESTDIR)$(SELINUX_POLICY_DIR)/policy
|
|
||||||
POLICY_SRC_DIR = $(DESTDIR)$(SELINUX_POLICY_DIR)/src/policy
|
|
||||||
POLICY_SRC_FILE = $(POLICY_SRC_DIR)/policy.conf
|
|
||||||
DEFAULT_LOG_FILE = /var/log/messages
|
|
||||||
@@ -59,6 +59,7 @@
|
|
||||||
# Install directories
|
|
||||||
# Binaries go here
|
|
||||||
BINDIR = $(DESTDIR)/usr/bin
|
|
||||||
+SBINDIR = $(DESTDIR)/usr/sbin
|
|
||||||
|
|
||||||
# The code uses the specified path below. If you change this, DO NOT add
|
|
||||||
# a trailing path seperator ("/"). For example, use "/usr/share/setools"
|
|
||||||
@@ -102,7 +103,7 @@
|
|
||||||
SRC_POLICY_DIR = ../../
|
|
||||||
|
|
||||||
# exports
|
|
||||||
-export CFLAGS CC YACC LEX LINKFLAGS BINDIR INSTALL_LIBDIR INSTALL_HELPDIR LIBS TCL_LIBINC TCL_LIBS MAKE
|
|
||||||
+export CFLAGS CC YACC LEX LINKFLAGS BINDIR SBINDIR INSTALL_LIBDIR INSTALL_HELPDIR LIBS TCL_LIBINC TCL_LIBS MAKE
|
|
||||||
export SELINUX_DIR POLICY_INSTALL_DIR POLICY_SRC_DIR SRC_POLICY_DIR POLICY_SRC_FILE DEFAULT_LOG_FILE
|
|
||||||
export TOPDIR SHARED_LIB_INSTALL_DIR STATIC_LIB_INSTALL_DIR SETOOLS_INCLUDE DYNAMIC LIBSELINUX USE_LIBSEFS
|
|
||||||
|
|
||||||
--- setools-2.1.0/apol/Makefile.rhat 2005-04-18 10:52:00.000000000 -0400
|
|
||||||
+++ setools-2.1.0/apol/Makefile 2005-05-06 08:19:47.000000000 -0400
|
|
||||||
@@ -70,7 +70,7 @@
|
|
||||||
cd ../ ; $(MAKE) libsefs
|
|
||||||
|
|
||||||
install: apol apol.tcl
|
|
||||||
- install -m 755 apol $(BINDIR)
|
|
||||||
+ install -m 755 apol $(SBINDIR)
|
|
||||||
@if [ -n $(INSTALL_LIBDIR) ]; then \
|
|
||||||
for file in $(TCL-FILES); do \
|
|
||||||
if [ -f $(INSTALL_LIBDIR)/$$file ]; then \
|
|
||||||
@@ -79,6 +79,7 @@
|
|
||||||
done \
|
|
||||||
fi
|
|
||||||
install -m 644 apol.tcl $(APOL_HELP_FILES) $(APOL_PERM_MAPS) $(INSTALL_LIBDIR)
|
|
||||||
+ install -m 644 $(APOL_HELP_FILES) $(APOL_PERM_MAPS) ${INSTALL_HELPDIR}
|
|
||||||
cd $(INSTALL_LIBDIR); ln -sf $(APOL_DFLT_PMAP) apol_perm_mapping
|
|
||||||
|
|
||||||
clean:
|
|
||||||
--- setools-2.1.0/seaudit/Makefile.rhat 2005-04-18 10:52:00.000000000 -0400
|
|
||||||
+++ setools-2.1.0/seaudit/Makefile 2005-05-06 08:19:47.000000000 -0400
|
|
||||||
@@ -54,8 +54,8 @@
|
|
||||||
$(CC) $(CFLAGS) $(GTK_CFLAGS) $(LIBXML_FLAGS) $(INCLUDE) -c $<
|
$(CC) $(CFLAGS) $(GTK_CFLAGS) $(LIBXML_FLAGS) $(INCLUDE) -c $<
|
||||||
|
|
||||||
install: seaudit seaudit-report
|
install: seaudit seaudit-report
|
||||||
@ -103,23 +11,45 @@
|
|||||||
install -m 644 $(GLADE_FILES) $(INSTALL_LIBDIR)
|
install -m 644 $(GLADE_FILES) $(INSTALL_LIBDIR)
|
||||||
install -m 644 seaudit_help.txt $(INSTALL_LIBDIR)
|
install -m 644 seaudit_help.txt $(INSTALL_LIBDIR)
|
||||||
install -m 444 dot_seaudit $(INSTALL_LIBDIR)
|
install -m 444 dot_seaudit $(INSTALL_LIBDIR)
|
||||||
--- setools-2.1.0/Makefile.foo 2005-05-23 14:53:49.000000000 -0400
|
--- setools-2.2/apol/Makefile.rhat 2005-10-28 18:12:32.000000000 -0400
|
||||||
+++ setools-2.1.0/Makefile 2005-05-23 14:54:17.000000000 -0400
|
+++ setools-2.2/apol/Makefile 2005-11-03 16:46:34.000000000 -0500
|
||||||
@@ -26,7 +26,7 @@
|
@@ -80,7 +80,7 @@
|
||||||
TCLVER = $(shell env tclsh tcl_vars)
|
$(MAKE) -C .. libsefs
|
||||||
#TCLVER = 8.3
|
|
||||||
#TCL_INCLUDE = -I/usr/include
|
install: apol apol.tcl
|
||||||
-#TCL_LIBINC = -L/usr/lib
|
- install -m 755 apol $(BINDIR)
|
||||||
+#TCL_LIBINC = -L$(LIBDIR)
|
+ install -m 755 apol $(SBINDIR)
|
||||||
TCL_LIBS = -ltk$(TCLVER) -ltcl$(TCLVER) -ldl $(LIBS)
|
@if [ -n $(INSTALL_LIBDIR) ]; then \
|
||||||
|
for file in $(TCL-FILES); do \
|
||||||
|
if [ -f $(INSTALL_LIBDIR)/$$file ]; then \
|
||||||
|
@@ -89,6 +89,7 @@
|
||||||
|
done \
|
||||||
|
fi
|
||||||
|
install -m 644 apol.tcl $(APOL_HELP_FILES) $(APOL_PERM_MAPS) $(INSTALL_LIBDIR)
|
||||||
|
+ install -m 644 $(APOL_HELP_FILES) $(APOL_PERM_MAPS) ${INSTALL_HELPDIR}
|
||||||
|
cd $(INSTALL_LIBDIR); ln -sf $(APOL_DFLT_PMAP) apol_perm_mapping
|
||||||
|
|
||||||
|
clean:
|
||||||
|
--- setools-2.2/Makefile.rhat 2005-11-03 16:46:34.000000000 -0500
|
||||||
|
+++ setools-2.2/Makefile 2005-11-03 16:48:03.000000000 -0500
|
||||||
|
@@ -10,7 +10,7 @@
|
||||||
|
LIBS = -lfl -lm
|
||||||
|
|
||||||
INCLUDE_DIR = $(DESTDIR)/usr/include
|
INCLUDE_DIR = $(DESTDIR)/usr/include
|
||||||
|
|
||||||
@@ -35,7 +35,7 @@
|
|
||||||
YACC = bison -y
|
|
||||||
LEX = flex -olex.yy.c
|
|
||||||
|
|
||||||
-SHARED_LIB_INSTALL_DIR = $(DESTDIR)/usr/lib
|
-SHARED_LIB_INSTALL_DIR = $(DESTDIR)/usr/lib
|
||||||
+SHARED_LIB_INSTALL_DIR = $(DESTDIR)$(LIBDIR)
|
+SHARED_LIB_INSTALL_DIR = $(DESTDIR)$(LIBDIR)
|
||||||
STATIC_LIB_INSTALL_DIR = $(SHARED_LIB_INSTALL_DIR)
|
STATIC_LIB_INSTALL_DIR = $(SHARED_LIB_INSTALL_DIR)
|
||||||
SETOOLS_INCLUDE = $(INCLUDE_DIR)/setools
|
SETOOLS_INCLUDE = $(INCLUDE_DIR)/setools
|
||||||
|
TCLVER = $(shell env tclsh tcl_vars)
|
||||||
|
--- setools-2.2/sediff/Makefile.rhat 2005-10-28 18:12:32.000000000 -0400
|
||||||
|
+++ setools-2.2/sediff/Makefile 2005-11-03 16:46:34.000000000 -0500
|
||||||
|
@@ -24,7 +24,8 @@
|
||||||
|
install -m 755 sediff $(BINDIR);
|
||||||
|
|
||||||
|
install: all
|
||||||
|
- install -m 755 sediff sediffx $(BINDIR);
|
||||||
|
+ install -m 755 sediff $(BINDIR);
|
||||||
|
+ install -m 755 sediffx $(SBINDIR);
|
||||||
|
install -m 644 $(GLADE_FILES) $(INSTALL_LIBDIR)
|
||||||
|
install -m 644 sediff_help.txt $(INSTALL_LIBDIR)
|
||||||
|
|
||||||
|
24
setools.spec
24
setools.spec
@ -41,7 +41,7 @@ The tools and libraries in this release include:
|
|||||||
1. libapol: The main policy.conf analysis library, which is the core
|
1. libapol: The main policy.conf analysis library, which is the core
|
||||||
library for all our tools.
|
library for all our tools.
|
||||||
|
|
||||||
See the help files for apol and sepcutfor help on using the
|
See the help files for apol for help on using the
|
||||||
tools.
|
tools.
|
||||||
|
|
||||||
%package gui
|
%package gui
|
||||||
@ -64,18 +64,12 @@ The tools and libraries in this release include:
|
|||||||
|
|
||||||
1. apol: The GUI-based policy analysis tool.
|
1. apol: The GUI-based policy analysis tool.
|
||||||
|
|
||||||
2. sepcut: A basic GUI-based policy configuration, browsing,
|
2. awish: A version of the TCL/TK wish interpreter that includes the
|
||||||
editing, and testing tool. This tool is intended to provide a
|
setools libraries. We use this to test our GUIs (apol have the
|
||||||
complete, single user interface for viewing the source files of a
|
|
||||||
policy, configuring policy program modules, editing policy files, and
|
|
||||||
making and testing the policy.
|
|
||||||
|
|
||||||
3. awish: A version of the TCL/TK wish interpreter that includes the
|
|
||||||
setools libraries. We use this to test our GUIs (apol and seuser have the
|
|
||||||
interpreter compiled within them). One could conceivably write one's own
|
interpreter compiled within them). One could conceivably write one's own
|
||||||
GUI tools using TCL/TK as extended via awish.
|
GUI tools using TCL/TK as extended via awish.
|
||||||
|
|
||||||
See the help files for apol and sepcut for help on using the
|
See the help files for apol for help on using the
|
||||||
tools.
|
tools.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
@ -101,21 +95,16 @@ rm -f ${RPM_BUILD_ROOT}/usr/bin/indexcon
|
|||||||
install -D %{SOURCE1} ${RPM_BUILD_ROOT}%{_sysconfdir}/pam.d/apol
|
install -D %{SOURCE1} ${RPM_BUILD_ROOT}%{_sysconfdir}/pam.d/apol
|
||||||
install -D %{SOURCE1} ${RPM_BUILD_ROOT}%{_sysconfdir}/pam.d/seaudit
|
install -D %{SOURCE1} ${RPM_BUILD_ROOT}%{_sysconfdir}/pam.d/seaudit
|
||||||
install -D %{SOURCE1} ${RPM_BUILD_ROOT}%{_sysconfdir}/pam.d/sediffx
|
install -D %{SOURCE1} ${RPM_BUILD_ROOT}%{_sysconfdir}/pam.d/sediffx
|
||||||
install -D %{SOURCE1} ${RPM_BUILD_ROOT}%{_sysconfdir}/pam.d/sepcut
|
|
||||||
install -D %{SOURCE2} ${RPM_BUILD_ROOT}%{_sysconfdir}/security/console.apps/apol
|
install -D %{SOURCE2} ${RPM_BUILD_ROOT}%{_sysconfdir}/security/console.apps/apol
|
||||||
install -D %{SOURCE4} ${RPM_BUILD_ROOT}%{_sysconfdir}/security/console.apps/seaudit
|
install -D %{SOURCE4} ${RPM_BUILD_ROOT}%{_sysconfdir}/security/console.apps/seaudit
|
||||||
install -D %{SOURCE8} ${RPM_BUILD_ROOT}%{_sysconfdir}/security/console.apps/sediffx
|
install -D %{SOURCE8} ${RPM_BUILD_ROOT}%{_sysconfdir}/security/console.apps/sediffx
|
||||||
install -D %{SOURCE10} ${RPM_BUILD_ROOT}%{_sysconfdir}/security/console.apps/sepcut
|
|
||||||
install -D %{SOURCE5} ${RPM_BUILD_ROOT}%{_datadir}/applications/apol.desktop
|
install -D %{SOURCE5} ${RPM_BUILD_ROOT}%{_datadir}/applications/apol.desktop
|
||||||
install -D %{SOURCE7} ${RPM_BUILD_ROOT}%{_datadir}/applications/seaudit.desktop
|
install -D %{SOURCE7} ${RPM_BUILD_ROOT}%{_datadir}/applications/seaudit.desktop
|
||||||
install -D %{SOURCE9} ${RPM_BUILD_ROOT}%{_datadir}/applications/sediffx.desktop
|
install -D %{SOURCE9} ${RPM_BUILD_ROOT}%{_datadir}/applications/sediffx.desktop
|
||||||
install -D %{SOURCE11} ${RPM_BUILD_ROOT}%{_datadir}/applications/sepcut.desktop
|
|
||||||
cd $RPM_BUILD_ROOT/%{_bindir}/
|
cd $RPM_BUILD_ROOT/%{_bindir}/
|
||||||
ln -sf consolehelper apol
|
ln -sf consolehelper apol
|
||||||
ln -sf consolehelper seaudit
|
ln -sf consolehelper seaudit
|
||||||
ln -sf consolehelper sepcut
|
|
||||||
ln -sf consolehelper sediffx
|
ln -sf consolehelper sediffx
|
||||||
ln -sf consolehelper sepcut
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf ${RPM_BUILD_ROOT}
|
rm -rf ${RPM_BUILD_ROOT}
|
||||||
@ -133,20 +122,15 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%{_bindir}/seaudit
|
%{_bindir}/seaudit
|
||||||
%{_sbindir}/seaudit
|
%{_sbindir}/seaudit
|
||||||
%{_sbindir}/seaudit-report
|
%{_sbindir}/seaudit-report
|
||||||
%{_bindir}/sepcut
|
|
||||||
%{_sbindir}/sepcut
|
|
||||||
%{_datadir}/applications/apol.desktop
|
%{_datadir}/applications/apol.desktop
|
||||||
%{_datadir}/applications/seaudit.desktop
|
%{_datadir}/applications/seaudit.desktop
|
||||||
%{_datadir}/applications/sediffx.desktop
|
%{_datadir}/applications/sediffx.desktop
|
||||||
%{_datadir}/applications/sepcut.desktop
|
|
||||||
%config %{_sysconfdir}/pam.d/apol
|
%config %{_sysconfdir}/pam.d/apol
|
||||||
%config %{_sysconfdir}/pam.d/seaudit
|
%config %{_sysconfdir}/pam.d/seaudit
|
||||||
%config %{_sysconfdir}/pam.d/sediffx
|
%config %{_sysconfdir}/pam.d/sediffx
|
||||||
%config %{_sysconfdir}/pam.d/sepcut
|
|
||||||
%config %{_sysconfdir}/security/console.apps/apol
|
%config %{_sysconfdir}/security/console.apps/apol
|
||||||
%config %{_sysconfdir}/security/console.apps/seaudit
|
%config %{_sysconfdir}/security/console.apps/seaudit
|
||||||
%config %{_sysconfdir}/security/console.apps/sediffx
|
%config %{_sysconfdir}/security/console.apps/sediffx
|
||||||
%config %{_sysconfdir}/security/console.apps/sepcut
|
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Summary: Development environment for SETools
|
Summary: Development environment for SETools
|
||||||
|
Loading…
Reference in New Issue
Block a user