auto-import changelog data from setools-1.4-1.src.rpm
Wed Jun 02 2004 Dan Walsh <dwalsh@redhat.com> 1.4-1 - Update to latest from TRESYS. Tue Jun 01 2004 Dan Walsh <dwalsh@redhat.com> 1.3-3 - Make changes to work with targeted/strict policy
This commit is contained in:
parent
36c6b02ebb
commit
07c5f9aeca
@ -1 +1 @@
|
||||
setools-1.3.1.tgz
|
||||
setools-1.4.tgz
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- setools-1.3.1/seuser/Makefile.rhat 2004-05-05 16:14:59.000000000 -0400
|
||||
+++ setools-1.3.1/seuser/Makefile 2004-05-28 15:21:50.390091152 -0400
|
||||
--- setools-1.4/seuser/Makefile.rhat 2004-06-02 13:44:13.000000000 -0400
|
||||
+++ setools-1.4/seuser/Makefile 2004-06-02 15:57:20.939475608 -0400
|
||||
@@ -22,10 +22,10 @@
|
||||
SHELL = /bin/sh
|
||||
|
||||
@ -13,31 +13,8 @@
|
||||
|
||||
se_user.tcl: $(TCL-FILES)
|
||||
cat $(TCL-FILES) | \
|
||||
@@ -86,7 +86,7 @@
|
||||
cat ../policy/seuser_template.fc | \
|
||||
sed -e 's|SEUSER_BINDIR|$(BINDIR)|g' | \
|
||||
sed -e 's|SEUSER_INSTALL_LIBDIR|$(INSTALL_LIBDIR)|g' > ../policy/seuser.fc
|
||||
-
|
||||
+
|
||||
-@if [ -e $(POLICY_SRC_DIR)/policy/Makefile -a -e ../policy/seuser.fc ]; then \
|
||||
install -d $(TE_PROGS_DIR); \
|
||||
install -d $(FC_PROGS_DIR); \
|
||||
@@ -102,11 +102,11 @@
|
||||
echo " not found. type 'make install-src' from your policy directory, or"; \
|
||||
echo " consult your SELinux documentation."; \
|
||||
fi
|
||||
-
|
||||
+
|
||||
-@if [ -e ../policy/seuser.fc ]; then \
|
||||
rm -f ../policy/seuser.fc; \
|
||||
fi
|
||||
-
|
||||
+
|
||||
|
||||
policy-install: seuser-policy
|
||||
-@if [ -e $(POLICY_SRC_DIR)/policy/Makefile ]; then \
|
||||
--- setools-1.3.1/awish/Makefile.rhat 2004-05-05 16:14:59.000000000 -0400
|
||||
+++ setools-1.3.1/awish/Makefile 2004-05-28 15:21:16.296274200 -0400
|
||||
--- setools-1.4/awish/Makefile.rhat 2004-06-02 13:44:13.000000000 -0400
|
||||
+++ setools-1.4/awish/Makefile 2004-06-02 15:57:20.940475456 -0400
|
||||
@@ -4,7 +4,7 @@
|
||||
AWISH_OBJ = awish.o $(LIBSEUSER-TCL) $(LIBAPOL-TCL)
|
||||
|
||||
@ -67,19 +44,8 @@
|
||||
install: awish
|
||||
install -m 755 awish $(BINDIR)
|
||||
|
||||
--- setools-1.3.1/secmds/Makefile.rhat 2004-05-05 16:14:59.000000000 -0400
|
||||
+++ setools-1.3.1/secmds/Makefile 2004-05-28 14:59:44.269692096 -0400
|
||||
@@ -42,7 +42,7 @@
|
||||
|
||||
install: $(SE_CMDS)
|
||||
install -m 755 $(SE_CMDS) $(BINDIR);
|
||||
- chcon system_u:object_r:setfiles_exec_t $(BINDIR)/replcon
|
||||
+# chcon system_u:object_r:setfiles_exec_t $(BINDIR)/replcon
|
||||
|
||||
%.o: %.c
|
||||
$(CC) $(CFLAGS) $(INCLUDE) -c $<
|
||||
--- setools-1.3.1/libseuser/seuser_db.c.rhat 2004-05-05 16:14:59.000000000 -0400
|
||||
+++ setools-1.3.1/libseuser/seuser_db.c 2004-05-28 15:07:45.945466248 -0400
|
||||
--- setools-1.4/libseuser/seuser_db.c.rhat 2004-06-02 13:44:13.000000000 -0400
|
||||
+++ setools-1.4/libseuser/seuser_db.c 2004-06-02 15:57:20.942475152 -0400
|
||||
@@ -17,6 +17,7 @@
|
||||
#include <pwd.h>
|
||||
#include <sys/types.h>
|
||||
@ -88,7 +54,7 @@
|
||||
#include "seuser_db.h"
|
||||
|
||||
/* apol lib */
|
||||
@@ -751,8 +752,10 @@
|
||||
@@ -788,8 +789,10 @@
|
||||
}
|
||||
free(full_config);
|
||||
|
||||
@ -101,7 +67,7 @@
|
||||
if(db->policy_conf == NULL) {
|
||||
fclose(fp);
|
||||
free_conf_info(db);
|
||||
@@ -767,7 +770,9 @@
|
||||
@@ -804,7 +807,9 @@
|
||||
return 4;
|
||||
}
|
||||
|
||||
@ -112,7 +78,7 @@
|
||||
if(db->policy_dir == NULL) {
|
||||
fclose(fp);
|
||||
free_conf_info(db);
|
||||
@@ -782,7 +787,9 @@
|
||||
@@ -819,7 +824,9 @@
|
||||
return 6;
|
||||
}
|
||||
|
||||
@ -123,7 +89,7 @@
|
||||
if(db->user_file == NULL) {
|
||||
fclose(fp);
|
||||
free_conf_info(db);
|
||||
@@ -791,7 +798,8 @@
|
||||
@@ -828,7 +835,8 @@
|
||||
}
|
||||
/* users file may not exist which is ok, so we won't check read access. */
|
||||
|
||||
@ -133,8 +99,8 @@
|
||||
if(db->file_contexts_file == NULL) {
|
||||
fclose(fp);
|
||||
free_conf_info(db);
|
||||
--- setools-1.3.1/libseuser/Makefile.rhat 2004-05-05 16:14:59.000000000 -0400
|
||||
+++ setools-1.3.1/libseuser/Makefile 2004-05-28 15:11:27.571773928 -0400
|
||||
--- setools-1.4/libseuser/Makefile.rhat 2004-06-02 13:44:12.000000000 -0400
|
||||
+++ setools-1.4/libseuser/Makefile 2004-06-02 15:57:20.943475000 -0400
|
||||
@@ -11,8 +11,12 @@
|
||||
|
||||
libseuser-tcl: ../lib/libseuser-tcl.a
|
||||
@ -158,54 +124,42 @@
|
||||
../lib:
|
||||
mkdir -p $@
|
||||
|
||||
--- setools-1.3.1/packages/Makefile.rhat 2004-05-05 16:14:59.000000000 -0400
|
||||
+++ setools-1.3.1/packages/Makefile 2004-05-28 14:59:44.273691488 -0400
|
||||
@@ -3,11 +3,13 @@
|
||||
# by Kevin Carr kcarr@tresys.com
|
||||
|
||||
# Make sure INSTALL_PATH is set properly for your system!
|
||||
-INSTALL_PATH=/usr/share/tcl8.3/
|
||||
+TCLVER = $(shell env tclsh ../tcl_vars version)
|
||||
+INSTALL_PATH=$(DESTDIR)/usr/share/tcl$(TCLVER)/
|
||||
--- setools-1.4/packages/Makefile.rhat 2004-06-02 13:44:12.000000000 -0400
|
||||
+++ setools-1.4/packages/Makefile 2004-06-02 16:03:28.721564232 -0400
|
||||
@@ -4,9 +4,10 @@
|
||||
|
||||
# INSTALL_PATH is set based upon your current
|
||||
# version of tcl using the tcl_vars script.
|
||||
-INSTALL_PATH=$(shell env tclsh ../tcl_vars tcl_library)
|
||||
+INSTALL_PATH=$(DESTDIR)/$(shell env tclsh ../tcl_vars tcl_library)
|
||||
|
||||
install:
|
||||
- tar -zxvf BWidget-1.4.1.tar.gz
|
||||
+ mkdir -p $(INSTALL_PATH)
|
||||
+ tar -zxf BWidget-1.4.1.tar.gz
|
||||
+ mkdir -p $(INSTALL_PATH)
|
||||
tar -zxvf BWidget-1.4.1.tar.gz
|
||||
mv BWidget-1.4.1 $(INSTALL_PATH)
|
||||
|
||||
remove:
|
||||
@@ -20,4 +22,4 @@
|
||||
@@ -19,4 +20,4 @@
|
||||
clean:
|
||||
rm -rf BWidget-1.4.1/
|
||||
|
||||
bare:
|
||||
- clean
|
||||
-bare: clean
|
||||
\ No newline at end of file
|
||||
+ clean
|
||||
--- setools-1.3.1/Makefile.rhat 2004-05-05 16:14:59.000000000 -0400
|
||||
+++ setools-1.3.1/Makefile 2004-05-28 15:03:16.395444080 -0400
|
||||
@@ -20,8 +20,8 @@
|
||||
|
||||
+bare: clean
|
||||
--- setools-1.4/Makefile.rhat 2004-06-02 13:44:13.000000000 -0400
|
||||
+++ setools-1.4/Makefile 2004-06-02 15:57:20.945474696 -0400
|
||||
@@ -21,9 +21,9 @@
|
||||
# File location defaults; used in various places in code
|
||||
# Change these if you want different defaults
|
||||
-POLICY_SRC_DIR = $(DESTDIR)/etc/security/selinux/src
|
||||
SELINUX_DIR = $(DESTDIR)/selinux
|
||||
-POLICY_INSTALL_DIR = $(DESTDIR)/etc/security/selinux
|
||||
+POLICY_INSTALL_DIR = $(DESTDIR)/etc/selinux/strict
|
||||
POLICY_SRC_DIR = $(DESTDIR)$(POLICY_INSTALL_DIR)/src/policy
|
||||
-POLICY_SRC_FILE = $(POLICY_SRC_DIR)/policy.conf
|
||||
+POLICY_SRC_DIR = $(DESTDIR)/etc/selinux/strict/src
|
||||
+POLICY_SRC_FILE = $(POLICY_SRC_DIR)/policy/policy.conf
|
||||
DEFAULT_LOG_FILE = /var/log/messages
|
||||
|
||||
# Compile options
|
||||
@@ -83,6 +83,8 @@
|
||||
@echo " install-seuserx: build and install seuser and seuserx (selinux required)"
|
||||
@echo " install-secmds: build and install command line tools (selinux not required)"
|
||||
@echo " install-seaudit: build and install seaudit (selinux not required)"
|
||||
+ @echo " install-bwidget: build and install BWidget (selinux not required)"
|
||||
+ @echo " install-libraries: build and install libraries"
|
||||
@echo " "
|
||||
@echo " all: build everything, but don't install"
|
||||
@echo " all-nogui: only build non-GUI tools and libraries"
|
||||
@@ -116,7 +118,7 @@
|
||||
@@ -120,7 +120,7 @@
|
||||
echo "Could not build awish."; \
|
||||
echo "Tcl library is not built or not in expected location(s)."; \
|
||||
fi
|
||||
@ -214,7 +168,7 @@
|
||||
seuser: selinux_tool
|
||||
cd seuser; $(MAKE) seuser
|
||||
|
||||
@@ -137,9 +139,9 @@
|
||||
@@ -141,9 +141,9 @@
|
||||
|
||||
secmds: selinux_tool
|
||||
cd secmds; $(MAKE) all
|
||||
@ -226,23 +180,7 @@
|
||||
|
||||
libapol-tcl: selinux_tool
|
||||
cd libapol;
|
||||
@@ -186,6 +188,15 @@
|
||||
echo "Tcl library is not built or not in expected location(s)."; \
|
||||
fi
|
||||
|
||||
+install-libseuser:
|
||||
+ cd libseuser; $(MAKE) install
|
||||
+
|
||||
+install-libapol:
|
||||
+ cd libapol; $(MAKE) install INSTALL_HELPDIR=$(INSTALL_HELPDIR)
|
||||
+
|
||||
+install-libraries: install-libseuser install-libapol
|
||||
+ cd libseuser; $(MAKE) install
|
||||
+
|
||||
# installs both GUI and non-GUI versions
|
||||
install-seuserx: $(INSTALL_LIBDIR)
|
||||
cd seuser;
|
||||
@@ -211,8 +222,14 @@
|
||||
@@ -215,17 +215,23 @@
|
||||
|
||||
install-nogui: $(INSTALL_LIBDIR) install-seuser install-secmds
|
||||
|
||||
@ -256,10 +194,21 @@
|
||||
-install: install-apol install-seuserx install-sepcut install-awish install-secmds install-seaudit
|
||||
+install: install-apol install-seuserx install-sepcut install-awish install-secmds install-seaudit install-bwidget install-docs
|
||||
|
||||
# Install the policy - this is a separate step to better support systems with
|
||||
# non-standard policies.
|
||||
install-seuser-policy: $(INSTALL_LIBDIR)
|
||||
cd seuser; $(MAKE) install-policy
|
||||
-
|
||||
+
|
||||
install-secmds-policy: $(INSTALL_LIBDIR)
|
||||
cd secmds; $(MAKE) install-policy
|
||||
-
|
||||
+
|
||||
install-policy: install-seuser-policy install-secmds-policy
|
||||
|
||||
# Next four targets are to support installation as part of a system
|
||||
# install. These targets are deprecated.
|
||||
--- setools-1.3.1/docs-src/Makefile.rhat 2004-05-05 16:14:59.000000000 -0400
|
||||
+++ setools-1.3.1/docs-src/Makefile 2004-05-28 14:59:44.276691032 -0400
|
||||
--- setools-1.4/docs-src/Makefile.rhat 2004-06-02 13:44:13.000000000 -0400
|
||||
+++ setools-1.4/docs-src/Makefile 2004-06-02 15:57:20.946474544 -0400
|
||||
@@ -55,3 +55,14 @@
|
||||
for file in $(TOP-DOCS); do \
|
||||
rm -f ../$$file; \
|
||||
@ -275,8 +224,8 @@
|
||||
+ install -m 644 ../sepct/sepcut_help.txt ${INSTALL_HELPDIR}
|
||||
+ install -m 644 ../apol/*.txt ${INSTALL_HELPDIR}
|
||||
+
|
||||
--- setools-1.3.1/apol/Makefile.rhat 2004-05-05 16:14:59.000000000 -0400
|
||||
+++ setools-1.3.1/apol/Makefile 2004-05-28 15:15:29.505994336 -0400
|
||||
--- setools-1.4/apol/Makefile.rhat 2004-06-02 13:44:12.000000000 -0400
|
||||
+++ setools-1.4/apol/Makefile 2004-06-02 15:57:20.947474392 -0400
|
||||
@@ -11,14 +11,14 @@
|
||||
APOL_HELP_FILES = apol_help.txt dta_help.txt iflow_help.txt obj_perms_help.txt
|
||||
APOL_PERM_MAPS = apol_perm_mapping_ver12 apol_perm_mapping_ver15 \
|
||||
|
10
setools.spec
10
setools.spec
@ -1,7 +1,7 @@
|
||||
Summary: SELinux tools for managing policy
|
||||
Name: setools
|
||||
Version: 1.3.1
|
||||
Release: 3
|
||||
Version: 1.4
|
||||
Release: 1
|
||||
License: GPL
|
||||
Group: System Environment/Base
|
||||
Source: http://www.tresys.com/Downloads/selinux-tools/setools-%{version}.tgz
|
||||
@ -123,7 +123,11 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
/usr/share/doc/setools-%{version}/*
|
||||
|
||||
%changelog
|
||||
* Fri Apr 16 2004 Dan Walsh <dwalsh@redhat.com> 1.3-3
|
||||
|
||||
* Wed Jun 2 2004 Dan Walsh <dwalsh@redhat.com> 1.4-1
|
||||
- Update to latest from TRESYS.
|
||||
|
||||
* Tue Jun 1 2004 Dan Walsh <dwalsh@redhat.com> 1.3-3
|
||||
- Make changes to work with targeted/strict policy
|
||||
* Fri Apr 16 2004 Dan Walsh <dwalsh@redhat.com> 1.3-2
|
||||
- Take out requirement for policy file
|
||||
|
Loading…
Reference in New Issue
Block a user