[tw]
- using new syntax for access database (#177566) - fixed failure message while shutting down sm-client (#119429) resolution: stop sm-client before sendmail - fixed method to specify persistent queue runners (#126760) - removed patch backup files from sendmail-cf tree (#152955) - fixed missing dnl on SMART_HOST define (#166680) - fixed wrong location of aliases and aliases.db file in aliases man page (#166744) - enabled CipherList config option for sendmail (#172352) - added user chowns for /etc/mail/authinfo.db and move check for cf files (#184341) - fixed Makefile of vacation (#191396) vacation is not included in this sendmail package - /var/log/mail now belongs to sendmail (#192850)
This commit is contained in:
parent
a0b70ea720
commit
a849b7d235
20
sendmail-8.13.7-aliases_dir.patch
Normal file
20
sendmail-8.13.7-aliases_dir.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- sendmail-8.13.7/sendmail/aliases.5.aliases_dir 2006-07-14 15:41:59.000000000 +0200
|
||||
+++ sendmail-8.13.7/sendmail/aliases.5 2006-07-14 15:42:38.000000000 +0200
|
||||
@@ -23,7 +23,7 @@
|
||||
aliases used by
|
||||
sendmail.
|
||||
The file resides in
|
||||
-/etc/mail
|
||||
+/etc
|
||||
and
|
||||
is formatted as a series of lines of the form
|
||||
.IP
|
||||
@@ -96,7 +96,7 @@
|
||||
.PP
|
||||
This is only the raw data file; the actual aliasing information is
|
||||
placed into a binary format in the file
|
||||
-/etc/mail/aliases.db
|
||||
+/etc/aliases.db
|
||||
using the program
|
||||
newaliases(1).
|
||||
A
|
11
sendmail-8.13.7-vacation.patch
Normal file
11
sendmail-8.13.7-vacation.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- sendmail-8.13.7/vacation/Makefile.vacation 1999-09-24 00:36:45.000000000 +0200
|
||||
+++ sendmail-8.13.7/vacation/Makefile 2006-07-18 15:12:42.000000000 +0200
|
||||
@@ -1,7 +1,7 @@
|
||||
# $Id: Makefile,v 8.5 1999/09/23 22:36:45 ca Exp $
|
||||
|
||||
SHELL= /bin/sh
|
||||
-BUILD= ./Build
|
||||
+BUILD= ./Build -f ../redhat.config.m4
|
||||
OPTIONS= $(CONFIG) $(FLAGS)
|
||||
|
||||
all: FRC
|
@ -19,7 +19,7 @@ dnl #
|
||||
dnl # Uncomment and edit the following line if your outgoing mail needs to
|
||||
dnl # be sent out through an external mail server:
|
||||
dnl #
|
||||
dnl define(`SMART_HOST',`smtp.your.provider')
|
||||
dnl define(`SMART_HOST',`smtp.your.provider')dnl
|
||||
dnl #
|
||||
define(`confDEF_USER_ID',``8:12'')dnl
|
||||
dnl define(`confAUTO_REBUILD')dnl
|
||||
|
@ -11,6 +11,9 @@ CFFILES = sendmail.cf submit.cf
|
||||
|
||||
|
||||
all: ${CFFILES} ${POSSIBLE} virtusertable.db access.db domaintable.db mailertable.db
|
||||
@if test -f /etc/mail/authinfo.db; then \
|
||||
/bin/chown smmsp:smmsp /etc/mail/authinfo.db; \
|
||||
fi
|
||||
|
||||
userdb.db: userdb
|
||||
@makemap btree $@ < $<
|
||||
@ -21,7 +24,7 @@ userdb.db: userdb
|
||||
%.cf: %.mc
|
||||
@if test -f /usr/share/sendmail-cf/m4/cf.m4; then \
|
||||
umask 022; \
|
||||
mv -f $@ $@.bak; \
|
||||
[ -e $@ ] && mv -f $@ $@.bak; \
|
||||
m4 $< > $@; \
|
||||
else \
|
||||
echo -e "WARNING: '$<' is modified. Please install package sendmail-cf to update your configuration."; \
|
||||
|
@ -62,7 +62,7 @@ start() {
|
||||
/sbin/restorecon /var/run/sm-client.pid
|
||||
fi
|
||||
daemon --check sm-client /usr/sbin/sendmail -L sm-msp-queue -Ac \
|
||||
-q $SMQUEUE $SENDMAIL_OPTARG
|
||||
-q$SMQUEUE $SENDMAIL_OPTARG
|
||||
RETVAL=$?
|
||||
echo
|
||||
[ $RETVAL -eq 0 ] && touch /var/lock/subsys/sm-client
|
||||
@ -101,11 +101,6 @@ reload() {
|
||||
|
||||
stop() {
|
||||
# Stop daemons.
|
||||
echo -n $"Shutting down $prog: "
|
||||
killproc sendmail
|
||||
RETVAL=$?
|
||||
echo
|
||||
[ $RETVAL -eq 0 ] && rm -f /var/lock/subsys/sendmail
|
||||
if test -f /var/run/sm-client.pid ; then
|
||||
echo -n $"Shutting down sm-client: "
|
||||
killproc sm-client
|
||||
@ -114,6 +109,11 @@ stop() {
|
||||
[ $RETVAL -eq 0 ] && rm -f /var/run/sm-client.pid
|
||||
[ $RETVAL -eq 0 ] && rm -f /var/lock/subsys/sm-client
|
||||
fi
|
||||
echo -n $"Shutting down $prog: "
|
||||
killproc sendmail
|
||||
RETVAL=$?
|
||||
echo
|
||||
[ $RETVAL -eq 0 ] && rm -f /var/lock/subsys/sendmail
|
||||
return $RETVAL
|
||||
}
|
||||
|
||||
|
@ -18,7 +18,7 @@
|
||||
Summary: A widely used Mail Transport Agent (MTA).
|
||||
Name: sendmail
|
||||
Version: 8.13.7
|
||||
Release: 2.1
|
||||
Release: 3
|
||||
License: Sendmail
|
||||
Group: System Environment/Daemons
|
||||
Provides: smtpdaemon
|
||||
@ -42,6 +42,8 @@ Patch9: sendmail-8.12.7-hesiod.patch
|
||||
Patch10: sendmail-8.12.7-manpage.patch
|
||||
Patch11: sendmail-8.13.6-dynamic.patch
|
||||
Patch12: sendmail-8.13.0-cyrus.patch
|
||||
Patch13: sendmail-8.13.7-aliases_dir.patch
|
||||
Patch14: sendmail-8.13.7-vacation.patch
|
||||
Buildroot: %{_tmppath}/%{name}-root
|
||||
BuildRequires: tcp_wrappers
|
||||
BuildRequires: db4-devel
|
||||
@ -137,13 +139,15 @@ your sendmail.cf file.
|
||||
%patch10 -p1 -b .manpage
|
||||
%patch11 -p1 -b .dynamic
|
||||
%patch12 -p1 -b .cyrus
|
||||
%patch13 -p1 -b .aliases_dir
|
||||
%patch14 -p1 -b .vacation
|
||||
|
||||
%build
|
||||
# generate redhat config file
|
||||
cat > redhat.config.m4 << EOF
|
||||
define(\`confMAPDEF', \`-DNEWDB -DNIS -DHESIOD -DMAP_REGEX -DSOCKETMAP -DNAMED_BIND=1')
|
||||
define(\`confOPTIMIZE', \`\`\`${RPM_OPT_FLAGS}''')
|
||||
define(\`confENVDEF', \`-I/usr/include/db4 -I/usr/kerberos/include -Wall -DXDEBUG=0 -DTCPWRAPPERS -DNETINET6 -DHES_GETMAILHOST -DUSE_VENDOR_CF_PATH=1 -D_FFR_WORKAROUND_BROKEN_NAMESERVERS -D_FFR_SMTP_SSL')
|
||||
define(\`confENVDEF', \`-I/usr/include/db4 -I/usr/kerberos/include -Wall -DXDEBUG=0 -DTCPWRAPPERS -DNETINET6 -DHES_GETMAILHOST -DUSE_VENDOR_CF_PATH=1 -D_FFR_WORKAROUND_BROKEN_NAMESERVERS -D_FFR_SMTP_SSL -D_FFR_TLS_1')
|
||||
define(\`confLIBDIRS', \`-L/usr/kerberos/%{_lib}')
|
||||
define(\`confLIBS', \`-lnsl -lwrap -lhesiod -lcrypt -ldb')
|
||||
define(\`confMANOWN', \`root')
|
||||
@ -293,6 +297,10 @@ cp %{SOURCE9} $DOC/README.redhat
|
||||
|
||||
# Install the cf files for the sendmail-cf package.
|
||||
cp -ar cf/* $RPM_BUILD_ROOT%{sendmailcf}
|
||||
# remove patch backup files
|
||||
rm -rf $RPM_BUILD_ROOT%{sendmailcf}/cf/Build.*
|
||||
rm -rf $RPM_BUILD_ROOT%{sendmailcf}/*/*.mc.*
|
||||
rm -rf $RPM_BUILD_ROOT%{sendmailcf}/*/*.m4.*
|
||||
|
||||
install -d -m755 $RPM_BUILD_ROOT/etc/mail
|
||||
|
||||
@ -333,9 +341,9 @@ cat <<EOF > $RPM_BUILD_ROOT/etc/mail/access
|
||||
# package.
|
||||
#
|
||||
# by default we allow relaying from localhost...
|
||||
localhost.localdomain RELAY
|
||||
localhost RELAY
|
||||
127.0.0.1 RELAY
|
||||
Connect:localhost.localdomain RELAY
|
||||
Connect:localhost RELAY
|
||||
Connect:127.0.0.1 RELAY
|
||||
|
||||
EOF
|
||||
for map in virtusertable access domaintable mailertable ; do
|
||||
@ -523,6 +531,7 @@ exit 0
|
||||
%{_mandir}/man1/newaliases.sendmail.1*
|
||||
%{_mandir}/man1/mailq.sendmail.1*
|
||||
|
||||
%dir %{stdir}
|
||||
%config(noreplace) %{stdir}/statistics
|
||||
%config(noreplace) /etc/mail/sendmail.cf
|
||||
%config(noreplace) /etc/mail/submit.cf
|
||||
@ -578,6 +587,22 @@ exit 0
|
||||
%{_docdir}/sendmail
|
||||
|
||||
%changelog
|
||||
* Tue Jul 18 2006 Thomas Woerner <twoerner@redhat.com> 8.13.7-3
|
||||
- using new syntax for access database (#177566)
|
||||
- fixed failure message while shutting down sm-client (#119429)
|
||||
resolution: stop sm-client before sendmail
|
||||
- fixed method to specify persistent queue runners (#126760)
|
||||
- removed patch backup files from sendmail-cf tree (#152955)
|
||||
- fixed missing dnl on SMART_HOST define (#166680)
|
||||
- fixed wrong location of aliases and aliases.db file in aliases man page
|
||||
(#166744)
|
||||
- enabled CipherList config option for sendmail (#172352)
|
||||
- added user chowns for /etc/mail/authinfo.db and move check for cf files
|
||||
(#184341)
|
||||
- fixed Makefile of vacation (#191396)
|
||||
vacation is not included in this sendmail package
|
||||
- /var/log/mail now belongs to sendmail (#192850)
|
||||
|
||||
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 8.13.7-2.1
|
||||
- rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user