- new version 8.14.4 (#552078)
- RPM attributes S, 5, T not recorded for statistics file - adapted patches: makemapman, dynamic, switchfile (#552078) - movefiles patch incorporated into aliases_dir patch - drop exitpanic patch (fixed upstream)
This commit is contained in:
parent
b9b6cf93b6
commit
647e3b9587
13
.cvsignore
13
.cvsignore
@ -1,12 +1 @@
|
||||
sendmail.8.13.1.tar.gz
|
||||
sendmail.8.13.2.tar.gz
|
||||
sendmail.8.13.3.tar.gz
|
||||
sendmail.8.13.4.tar.gz
|
||||
sendmail.8.13.5.tar.gz
|
||||
sendmail.8.13.6.tar.gz
|
||||
sendmail.8.13.7.tar.gz
|
||||
sendmail.8.13.8.tar.gz
|
||||
sendmail.8.14.0.tar.gz
|
||||
sendmail.8.14.1.tar.gz
|
||||
sendmail.8.14.2.tar.gz
|
||||
sendmail.8.14.3.tar.gz
|
||||
sendmail.8.14.4.tar.gz
|
||||
|
@ -1,20 +0,0 @@
|
||||
--- sendmail-8.13.7/sendmail/aliases.5.aliases_dir 2006-07-14 15:41:59.000000000 +0200
|
||||
+++ sendmail-8.13.7/sendmail/aliases.5 2006-07-14 15:42:38.000000000 +0200
|
||||
@@ -23,7 +23,7 @@
|
||||
aliases used by
|
||||
sendmail.
|
||||
The file resides in
|
||||
-/etc/mail
|
||||
+/etc
|
||||
and
|
||||
is formatted as a series of lines of the form
|
||||
.IP
|
||||
@@ -96,7 +96,7 @@
|
||||
.PP
|
||||
This is only the raw data file; the actual aliasing information is
|
||||
placed into a binary format in the file
|
||||
-/etc/mail/aliases.db
|
||||
+/etc/aliases.db
|
||||
using the program
|
||||
newaliases(1).
|
||||
A
|
@ -1,64 +0,0 @@
|
||||
diff -up sendmail-8.14.3/sendmail/envelope.c.exitpanic sendmail-8.14.3/sendmail/envelope.c
|
||||
--- sendmail-8.14.3/sendmail/envelope.c.exitpanic 2008-03-31 18:32:13.000000000 +0200
|
||||
+++ sendmail-8.14.3/sendmail/envelope.c 2009-12-15 13:55:52.000000000 +0100
|
||||
@@ -163,14 +163,14 @@ newenvelope(e, parent, rpool)
|
||||
** split -- if true, split by recipient if message is queued up
|
||||
**
|
||||
** Returns:
|
||||
-** none.
|
||||
+** true if savemail panic'ed.
|
||||
**
|
||||
** Side Effects:
|
||||
** housekeeping necessary to dispose of an envelope.
|
||||
** Unlocks this queue file.
|
||||
*/
|
||||
|
||||
-void
|
||||
+bool
|
||||
dropenvelope(e, fulldrop, split)
|
||||
register ENVELOPE *e;
|
||||
bool fulldrop;
|
||||
@@ -209,7 +209,7 @@ dropenvelope(e, fulldrop, split)
|
||||
|
||||
/* we must have an id to remove disk files */
|
||||
if (id == NULL)
|
||||
- return;
|
||||
+ return panic;
|
||||
|
||||
/* if verify-only mode, we can skip most of this */
|
||||
if (OpMode == MD_VERIFY)
|
||||
@@ -618,6 +618,8 @@ simpledrop:
|
||||
}
|
||||
e->e_id = NULL;
|
||||
e->e_flags &= ~EF_HAS_DF;
|
||||
+
|
||||
+ return panic;
|
||||
}
|
||||
/*
|
||||
** CLEARENVELOPE -- clear an envelope without unlocking
|
||||
diff -up sendmail-8.14.3/sendmail/main.c.exitpanic sendmail-8.14.3/sendmail/main.c
|
||||
--- sendmail-8.14.3/sendmail/main.c.exitpanic 2008-03-31 18:32:13.000000000 +0200
|
||||
+++ sendmail-8.14.3/sendmail/main.c 2009-12-15 13:55:52.000000000 +0100
|
||||
@@ -2952,7 +2952,9 @@ finis(drop, cleanup, exitstat)
|
||||
{
|
||||
if (CurEnv->e_id != NULL)
|
||||
{
|
||||
- dropenvelope(CurEnv, true, false);
|
||||
+ if (dropenvelope(CurEnv, true, false))
|
||||
+ /* exit with OS error if savemail panic'ed */
|
||||
+ exitstat = EX_OSERR;
|
||||
sm_rpool_free(CurEnv->e_rpool);
|
||||
CurEnv->e_rpool = NULL;
|
||||
|
||||
diff -up sendmail-8.14.3/sendmail/sendmail.h.exitpanic sendmail-8.14.3/sendmail/sendmail.h
|
||||
--- sendmail-8.14.3/sendmail/sendmail.h.exitpanic 2008-02-16 00:19:58.000000000 +0100
|
||||
+++ sendmail-8.14.3/sendmail/sendmail.h 2009-12-15 13:55:52.000000000 +0100
|
||||
@@ -982,7 +982,7 @@ extern ENVELOPE BlankEnvelope;
|
||||
|
||||
/* functions */
|
||||
extern void clearenvelope __P((ENVELOPE *, bool, SM_RPOOL_T *));
|
||||
-extern void dropenvelope __P((ENVELOPE *, bool, bool));
|
||||
+extern bool dropenvelope __P((ENVELOPE *, bool, bool));
|
||||
extern ENVELOPE *newenvelope __P((ENVELOPE *, ENVELOPE *, SM_RPOOL_T *));
|
||||
extern void clrsessenvelope __P((ENVELOPE *));
|
||||
extern void printenvflags __P((ENVELOPE *));
|
@ -1,82 +0,0 @@
|
||||
diff -up sendmail-8.14.3/cf/m4/cfhead.m4.movefiles sendmail-8.14.3/cf/m4/cfhead.m4
|
||||
--- sendmail-8.14.3/cf/m4/cfhead.m4.movefiles 2004-01-28 23:02:22.000000000 +0100
|
||||
+++ sendmail-8.14.3/cf/m4/cfhead.m4 2008-12-02 18:07:06.000000000 +0100
|
||||
@@ -259,7 +259,7 @@ ifdef(`MAIL_SETTINGS_DIR', , `define(`MA
|
||||
define(`DATABASE_MAP_TYPE', `hash')
|
||||
|
||||
# set up default values for options
|
||||
-define(`ALIAS_FILE', `MAIL_SETTINGS_DIR`'aliases')
|
||||
+define(`ALIAS_FILE', `/etc/aliases')
|
||||
define(`confMAILER_NAME', ``MAILER-DAEMON'')
|
||||
define(`confFROM_LINE', `From $g $d')
|
||||
define(`confOPERATORS', `.:%@!^/[]+')
|
||||
diff -up sendmail-8.14.3/sendmail/newaliases.0.movefiles sendmail-8.14.3/sendmail/newaliases.0
|
||||
--- sendmail-8.14.3/sendmail/newaliases.0.movefiles 2008-05-03 05:38:22.000000000 +0200
|
||||
+++ sendmail-8.14.3/sendmail/newaliases.0 2008-12-02 18:07:06.000000000 +0100
|
||||
@@ -10,7 +10,7 @@ SSYYNNOOPPSSIISS
|
||||
|
||||
DDEESSCCRRIIPPTTIIOONN
|
||||
NNeewwaalliiaasseess rebuilds the random access data base for the mail aliases
|
||||
- file /etc/mail/aliases. It must be run each time this file is changed
|
||||
+ file /etc/aliases. It must be run each time this file is changed
|
||||
in order for the change to take effect.
|
||||
|
||||
NNeewwaalliiaasseess is identical to ``sendmail -bi''.
|
||||
@@ -22,7 +22,7 @@ DDEESSCCRRIIPPTTIIOONN
|
||||
sseennddmmaaiill..
|
||||
|
||||
FFIILLEESS
|
||||
- /etc/mail/aliases The mail aliases file
|
||||
+ /etc/aliases The mail aliases file
|
||||
|
||||
SSEEEE AALLSSOO
|
||||
aliases(5), sendmail(8)
|
||||
diff -up sendmail-8.14.3/sendmail/newaliases.1.movefiles sendmail-8.14.3/sendmail/newaliases.1
|
||||
--- sendmail-8.14.3/sendmail/newaliases.1.movefiles 2001-10-10 05:23:17.000000000 +0200
|
||||
+++ sendmail-8.14.3/sendmail/newaliases.1 2008-12-02 18:07:06.000000000 +0100
|
||||
@@ -20,7 +20,7 @@ newaliases
|
||||
.SH DESCRIPTION
|
||||
.B Newaliases
|
||||
rebuilds the random access data base for the mail aliases file
|
||||
-/etc/mail/aliases. It must be run each time this file is changed
|
||||
+/etc/aliases. It must be run each time this file is changed
|
||||
in order for the change to take effect.
|
||||
.PP
|
||||
.B Newaliases
|
||||
@@ -40,7 +40,7 @@ puts a special token into the data base
|
||||
.B sendmail.
|
||||
.SH FILES
|
||||
.TP 2i
|
||||
-/etc/mail/aliases
|
||||
+/etc/aliases
|
||||
The mail aliases file
|
||||
.SH SEE ALSO
|
||||
aliases(5), sendmail(8)
|
||||
diff -up sendmail-8.14.3/sendmail/sendmail.0.movefiles sendmail-8.14.3/sendmail/sendmail.0
|
||||
--- sendmail-8.14.3/sendmail/sendmail.0.movefiles 2008-05-03 05:38:22.000000000 +0200
|
||||
+++ sendmail-8.14.3/sendmail/sendmail.0 2008-12-02 18:09:10.000000000 +0100
|
||||
@@ -430,10 +430,10 @@ FFIILLEESS
|
||||
are only approximations.
|
||||
|
||||
|
||||
- /etc/mail/aliases
|
||||
+ /etc/aliases
|
||||
raw data for alias names
|
||||
|
||||
- /etc/mail/aliases.db
|
||||
+ /etc/aliases.db
|
||||
data base of alias names
|
||||
|
||||
/etc/mail/sendmail.cf
|
||||
diff -up sendmail-8.14.3/sendmail/sendmail.8.movefiles sendmail-8.14.3/sendmail/sendmail.8
|
||||
--- sendmail-8.14.3/sendmail/sendmail.8.movefiles 2007-08-02 07:42:33.000000000 +0200
|
||||
+++ sendmail-8.14.3/sendmail/sendmail.8 2008-12-02 18:07:06.000000000 +0100
|
||||
@@ -706,7 +706,7 @@ Thus,
|
||||
these values are only approximations.
|
||||
.PP
|
||||
.TP
|
||||
- /etc/mail/aliases
|
||||
+ /etc/aliases
|
||||
raw data for alias names
|
||||
.TP
|
||||
/etc/mail/aliases.db
|
@ -1,12 +0,0 @@
|
||||
diff -up sendmail-8.14.3/sendmail/conf.c.switchfile sendmail-8.14.3/sendmail/conf.c
|
||||
--- sendmail-8.14.3/sendmail/conf.c.switchfile 2008-04-14 04:09:35.000000000 +0200
|
||||
+++ sendmail-8.14.3/sendmail/conf.c 2009-12-15 13:32:55.000000000 +0100
|
||||
@@ -968,7 +968,7 @@ switch_map_find(service, maptype, mapret
|
||||
p = strpbrk(buf, "#\n");
|
||||
if (p != NULL)
|
||||
*p = '\0';
|
||||
- p = strpbrk(buf, " \t");
|
||||
+ p = strpbrk(buf, " \t:");
|
||||
if (p != NULL)
|
||||
*p++ = '\0';
|
||||
if (buf[0] == '\0')
|
119
sendmail-8.14.4-aliases_dir.patch
Normal file
119
sendmail-8.14.4-aliases_dir.patch
Normal file
@ -0,0 +1,119 @@
|
||||
diff -up sendmail-8.14.3/cf/m4/cfhead.m4.movefiles sendmail-8.14.3/cf/m4/cfhead.m4
|
||||
--- sendmail-8.14.3/cf/m4/cfhead.m4.movefiles<->2004-01-28 23:02:22.000000000 +0100
|
||||
+++ sendmail-8.14.3/cf/m4/cfhead.m4<--->2008-12-02 18:07:06.000000000 +0100
|
||||
@@ -259,7 +259,7 @@ ifdef(`MAIL_SETTINGS_DIR', , `define(`MA
|
||||
define(`DATABASE_MAP_TYPE', `hash')
|
||||
.
|
||||
# set up default values for options
|
||||
-define(`ALIAS_FILE', `MAIL_SETTINGS_DIR`'aliases')
|
||||
+define(`ALIAS_FILE', `/etc/aliases')
|
||||
define(`confMAILER_NAME', ``MAILER-DAEMON'')
|
||||
define(`confFROM_LINE', `From $g $d')
|
||||
define(`confOPERATORS', `.:%@!^/[]+')
|
||||
diff -up ./sendmail/aliases.0.orig ./sendmail/aliases.0
|
||||
--- ./sendmail/aliases.0.orig 2009-12-23 05:48:32.000000000 +0100
|
||||
+++ ./sendmail/aliases.0 2010-02-01 10:49:56.093920068 +0100
|
||||
@@ -63,7 +63,7 @@ DDEESSCCRRIIPPTTIIOONN
|
||||
the list of users defined in that file.
|
||||
|
||||
This is only the raw data file; the actual aliasing information is
|
||||
- placed into a binary format in the file /etc/mail/aliases.db using the
|
||||
+ placed into a binary format in the file /etc/aliases.db using the
|
||||
program newaliases(1). A newaliases command should be executed each
|
||||
time the aliases file is changed for the change to take effect.
|
||||
|
||||
diff -up ./sendmail/aliases.5.orig ./sendmail/aliases.5
|
||||
--- ./sendmail/aliases.5.orig 2004-07-12 07:39:21.000000000 +0200
|
||||
+++ ./sendmail/aliases.5 2010-02-01 10:45:46.407921946 +0100
|
||||
@@ -23,7 +23,7 @@ ID
|
||||
aliases used by
|
||||
sendmail.
|
||||
The file resides in
|
||||
-/etc/mail
|
||||
+/etc
|
||||
and
|
||||
is formatted as a series of lines of the form
|
||||
.IP
|
||||
@@ -96,7 +96,7 @@ list of users defined in that file.
|
||||
.PP
|
||||
This is only the raw data file; the actual aliasing information is
|
||||
placed into a binary format in the file
|
||||
-/etc/mail/aliases.db
|
||||
+/etc/aliases.db
|
||||
using the program
|
||||
newaliases(1).
|
||||
A
|
||||
diff -up ./sendmail/newaliases.0.orig ./sendmail/newaliases.0
|
||||
--- ./sendmail/newaliases.0.orig 2009-12-23 05:48:32.000000000 +0100
|
||||
+++ ./sendmail/newaliases.0 2010-02-01 10:49:46.527918883 +0100
|
||||
@@ -10,7 +10,7 @@ SSYYNNOOPPSSIISS
|
||||
|
||||
DDEESSCCRRIIPPTTIIOONN
|
||||
NNeewwaalliiaasseess rebuilds the random access data base for the mail aliases
|
||||
- file /etc/mail/aliases. It must be run each time this file is changed
|
||||
+ file /etc/aliases. It must be run each time this file is changed
|
||||
in order for the change to take effect.
|
||||
|
||||
NNeewwaalliiaasseess is identical to ``sendmail -bi''.
|
||||
@@ -22,7 +22,7 @@ DDEESSCCRRIIPPTTIIOONN
|
||||
sseennddmmaaiill..
|
||||
|
||||
FFIILLEESS
|
||||
- /etc/mail/aliases The mail aliases file
|
||||
+ /etc/aliases The mail aliases file
|
||||
|
||||
SSEEEE AALLSSOO
|
||||
aliases(5), sendmail(8)
|
||||
diff -up ./sendmail/newaliases.1.orig ./sendmail/newaliases.1
|
||||
--- ./sendmail/newaliases.1.orig 2001-10-10 05:23:17.000000000 +0200
|
||||
+++ ./sendmail/newaliases.1 2010-02-01 10:49:36.194921433 +0100
|
||||
@@ -20,7 +20,7 @@ newaliases
|
||||
.SH DESCRIPTION
|
||||
.B Newaliases
|
||||
rebuilds the random access data base for the mail aliases file
|
||||
-/etc/mail/aliases. It must be run each time this file is changed
|
||||
+/etc/aliases. It must be run each time this file is changed
|
||||
in order for the change to take effect.
|
||||
.PP
|
||||
.B Newaliases
|
||||
@@ -40,7 +40,7 @@ puts a special token into the data base
|
||||
.B sendmail.
|
||||
.SH FILES
|
||||
.TP 2i
|
||||
-/etc/mail/aliases
|
||||
+/etc/aliases
|
||||
The mail aliases file
|
||||
.SH SEE ALSO
|
||||
aliases(5), sendmail(8)
|
||||
diff -up ./sendmail/sendmail.0.orig ./sendmail/sendmail.0
|
||||
--- ./sendmail/sendmail.0.orig 2009-12-23 05:48:32.000000000 +0100
|
||||
+++ ./sendmail/sendmail.0 2010-02-01 10:49:04.494920283 +0100
|
||||
@@ -430,10 +430,10 @@ FFIILLEESS
|
||||
are only approximations.
|
||||
|
||||
|
||||
- /etc/mail/aliases
|
||||
+ /etc/aliases
|
||||
raw data for alias names
|
||||
|
||||
- /etc/mail/aliases.db
|
||||
+ /etc/aliases.db
|
||||
data base of alias names
|
||||
|
||||
/etc/mail/sendmail.cf
|
||||
diff -up ./sendmail/sendmail.8.orig ./sendmail/sendmail.8
|
||||
--- ./sendmail/sendmail.8.orig 2009-04-10 19:49:19.000000000 +0200
|
||||
+++ ./sendmail/sendmail.8 2010-02-01 10:50:04.993920355 +0100
|
||||
@@ -706,10 +706,10 @@ Thus,
|
||||
these values are only approximations.
|
||||
.PP
|
||||
.TP
|
||||
- /etc/mail/aliases
|
||||
+ /etc/aliases
|
||||
raw data for alias names
|
||||
.TP
|
||||
- /etc/mail/aliases.db
|
||||
+ /etc/aliases.db
|
||||
data base of alias names
|
||||
.TP
|
||||
/etc/mail/sendmail.cf
|
@ -1,7 +1,7 @@
|
||||
--- sendmail-8.14.0/devtools/OS/Linux.dynamic 2007-02-06 17:05:00.000000000 +0100
|
||||
+++ sendmail-8.14.0/devtools/OS/Linux 2007-02-06 17:05:00.000000000 +0100
|
||||
@@ -6,7 +6,7 @@
|
||||
define(`confDEPEND_TYPE', `CC-M')
|
||||
--- sendmail-8.14.4/devtools/OS/Linux 2010-01-03 22:55:35.000000000 +0100
|
||||
+++ sendmail-8.14.4/devtools/OS/Linux.dynamic 2010-01-03 22:59:03.000000000 +0100
|
||||
@@ -7,7 +7,7 @@
|
||||
define(`confCCOPTS_SO', `-fPIC')
|
||||
define(`confSM_OS_HEADER', `sm_os_linux')
|
||||
define(`confMANROOT', `/usr/share/man/man')
|
||||
-define(`confLIBS', `-ldl')
|
||||
@ -9,7 +9,7 @@
|
||||
define(`confEBINDIR', `/usr/sbin')
|
||||
APPENDDEF(`confLIBSEARCH', `crypt nsl')
|
||||
|
||||
@@ -21,19 +21,19 @@
|
||||
@@ -22,19 +22,19 @@
|
||||
ifelse(confBLDVARIANT, `DEBUG',
|
||||
dnl Debug build
|
||||
`
|
||||
@ -33,8 +33,8 @@
|
||||
- define(`confOPTIMIZE',`-O2')
|
||||
+ define(`confOPTIMIZE',`-O2 -fpie')
|
||||
')
|
||||
--- sendmail-8.14.0/libsm/Makefile.m4.dynamic 2006-08-16 23:06:31.000000000 +0200
|
||||
+++ sendmail-8.14.0/libsm/Makefile.m4 2007-02-06 17:06:06.000000000 +0100
|
||||
--- sendmail-8.14.4/libsm/Makefile.m4 2006-08-16 23:06:31.000000000 +0200
|
||||
+++ sendmail-8.14.4/libsm/Makefile.m4.dynamic 2010-01-03 23:01:36.000000000 +0100
|
||||
@@ -6,7 +6,7 @@
|
||||
define(`confREQUIRE_SM_OS_H', `true')
|
||||
PREPENDDEF(`confENVDEF', `confMAPDEF')
|
@ -1,6 +1,5 @@
|
||||
diff -up sendmail-8.14.3/cf/cf/Build.makemapman sendmail-8.14.3/cf/cf/Build
|
||||
--- sendmail-8.14.3/cf/cf/Build.makemapman 1999-03-02 03:37:12.000000000 +0100
|
||||
+++ sendmail-8.14.3/cf/cf/Build 2008-12-02 18:04:37.000000000 +0100
|
||||
--- sendmail-8.14.4/cf/cf/Build 1999-03-02 03:37:12.000000000 +0100
|
||||
+++ sendmail-8.14.4/cf/cf/Build.makemapman 2010-01-03 22:49:38.000000000 +0100
|
||||
@@ -18,7 +18,7 @@
|
||||
SMROOT=${SMROOT-../..}
|
||||
BUILDTOOLS=${BUILDTOOLS-$SMROOT/devtools}
|
||||
@ -10,19 +9,18 @@ diff -up sendmail-8.14.3/cf/cf/Build.makemapman sendmail-8.14.3/cf/cf/Build
|
||||
ret=$?
|
||||
if [ $ret -ne 0 ]
|
||||
then
|
||||
diff -up sendmail-8.14.3/devtools/OS/Linux.makemapman sendmail-8.14.3/devtools/OS/Linux
|
||||
--- sendmail-8.14.3/devtools/OS/Linux.makemapman 2002-03-22 00:59:25.000000000 +0100
|
||||
+++ sendmail-8.14.3/devtools/OS/Linux 2008-12-02 18:06:18.000000000 +0100
|
||||
@@ -5,7 +5,7 @@ dnl Place personal settings in devtools/
|
||||
|
||||
--- sendmail-8.14.4/devtools/OS/Linux 2009-01-22 03:15:42.000000000 +0100
|
||||
+++ sendmail-8.14.4/devtools/OS/Linux.makemapman 2010-01-03 22:50:27.000000000 +0100
|
||||
@@ -6,7 +6,7 @@
|
||||
define(`confDEPEND_TYPE', `CC-M')
|
||||
define(`confCCOPTS_SO', `-fPIC')
|
||||
define(`confSM_OS_HEADER', `sm_os_linux')
|
||||
-define(`confMANROOT', `/usr/man/man')
|
||||
+define(`confMANROOT', `/usr/share/man/man')
|
||||
define(`confLIBS', `-ldl')
|
||||
define(`confEBINDIR', `/usr/sbin')
|
||||
APPENDDEF(`confLIBSEARCH', `crypt nsl')
|
||||
@@ -15,6 +15,8 @@ define(`confMTCCOPTS', `-D_REENTRANT')
|
||||
@@ -16,6 +16,8 @@
|
||||
define(`confMTLDOPTS', `-lpthread')
|
||||
define(`confLDOPTS_SO', `-shared')
|
||||
define(`confSONAME',`-soname')
|
||||
@ -31,10 +29,9 @@ diff -up sendmail-8.14.3/devtools/OS/Linux.makemapman sendmail-8.14.3/devtools/O
|
||||
|
||||
ifelse(confBLDVARIANT, `DEBUG',
|
||||
dnl Debug build
|
||||
diff -up sendmail-8.14.3/makemap/makemap.8.makemapman sendmail-8.14.3/makemap/makemap.8
|
||||
--- sendmail-8.14.3/makemap/makemap.8.makemapman 2008-05-03 01:07:48.000000000 +0200
|
||||
+++ sendmail-8.14.3/makemap/makemap.8 2008-12-02 18:04:37.000000000 +0100
|
||||
@@ -52,12 +52,6 @@ selected using the
|
||||
--- sendmail-8.14.4/makemap/makemap.8 2008-05-03 01:07:48.000000000 +0200
|
||||
+++ sendmail-8.14.4/makemap/makemap.8.makemapman 2010-01-03 22:51:04.000000000 +0100
|
||||
@@ -52,12 +52,6 @@
|
||||
parameter.
|
||||
They may be
|
||||
.TP
|
||||
@ -47,10 +44,9 @@ diff -up sendmail-8.14.3/makemap/makemap.8.makemapman sendmail-8.14.3/makemap/ma
|
||||
btree
|
||||
B-Tree format maps.
|
||||
This requires the new Berkeley DB
|
||||
diff -up sendmail-8.14.3/rmail/rmail.c.makemapman sendmail-8.14.3/rmail/rmail.c
|
||||
--- sendmail-8.14.3/rmail/rmail.c.makemapman 2001-09-18 23:45:29.000000000 +0200
|
||||
+++ sendmail-8.14.3/rmail/rmail.c 2008-12-02 18:04:37.000000000 +0100
|
||||
@@ -276,7 +276,6 @@ main(argc, argv)
|
||||
--- sendmail-8.14.4/rmail/rmail.c 2001-09-18 23:45:29.000000000 +0200
|
||||
+++ sendmail-8.14.4/rmail/rmail.c.makemapman 2010-01-03 22:51:36.000000000 +0100
|
||||
@@ -276,7 +276,6 @@
|
||||
args[i++] = _PATH_SENDMAIL; /* Build sendmail's argument list. */
|
||||
args[i++] = "-G"; /* relay submission */
|
||||
args[i++] = "-oee"; /* No errors, just status. */
|
11
sendmail-8.14.4-switchfile.patch
Normal file
11
sendmail-8.14.4-switchfile.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- sendmail-8.14.4/sendmail/conf.c 2009-12-18 18:25:12.000000000 +0100
|
||||
+++ sendmail-8.14.4/sendmail/conf.c.switchfile 2010-01-03 23:08:27.000000000 +0100
|
||||
@@ -972,7 +972,7 @@
|
||||
if (p != NULL)
|
||||
*p = '\0';
|
||||
#ifndef SM_NSSWITCH_DELIMS
|
||||
-# define SM_NSSWITCH_DELIMS " \t"
|
||||
+# define SM_NSSWITCH_DELIMS " \t:"
|
||||
#endif /* SM_NSSWITCH_DELIMS */
|
||||
p = strpbrk(buf, SM_NSSWITCH_DELIMS);
|
||||
if (p != NULL)
|
@ -13,8 +13,8 @@
|
||||
|
||||
Summary: A widely used Mail Transport Agent (MTA)
|
||||
Name: sendmail
|
||||
Version: 8.14.3
|
||||
Release: 10%{?dist}
|
||||
Version: 8.14.4
|
||||
Release: 1%{?dist}
|
||||
License: Sendmail
|
||||
Group: System Environment/Daemons
|
||||
URL: http://www.sendmail.org/
|
||||
@ -34,21 +34,19 @@ Source14: sendmail-etc-mail-local-host-names
|
||||
Source15: sendmail-etc-mail-mailertable
|
||||
Source16: sendmail-etc-mail-trusted-users
|
||||
Source17: sendmail-etc-mail-virtusertable
|
||||
Patch3: sendmail-8.14.3-makemapman.patch
|
||||
Patch3: sendmail-8.14.4-makemapman.patch
|
||||
Patch4: sendmail-8.14.3-smrsh_paths.patch
|
||||
Patch5: sendmail-8.14.3-movefiles.patch
|
||||
Patch7: sendmail-8.13.7-pid.patch
|
||||
Patch9: sendmail-8.12.7-hesiod.patch
|
||||
Patch10: sendmail-8.12.7-manpage.patch
|
||||
Patch11: sendmail-8.14.0-dynamic.patch
|
||||
Patch12: sendmail-8.13.0-cyrus.patch
|
||||
Patch13: sendmail-8.13.7-aliases_dir.patch
|
||||
Patch13: sendmail-8.14.4-aliases_dir.patch
|
||||
Patch14: sendmail-8.13.7-vacation.patch
|
||||
Patch15: sendmail-8.14.1-noversion.patch
|
||||
Patch16: sendmail-8.13.1-localdomain.patch
|
||||
Patch17: sendmail-8.14.3-sharedmilter.patch
|
||||
Patch18: sendmail-8.14.3-switchfile.patch
|
||||
Patch19: sendmail-8.14.3-exitpanic.patch
|
||||
Patch18: sendmail-8.14.4-switchfile.patch
|
||||
Patch20: sendmail-8.14.3-milterfdleaks.patch
|
||||
Patch21: sendmail-8.14.3-ipv6-bad-helo.patch
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -147,7 +145,6 @@ This package includes the milter shared library.
|
||||
|
||||
%patch3 -p1 -b .makemapman
|
||||
%patch4 -p1 -b .smrsh_paths
|
||||
%patch5 -p1 -b .movefiles
|
||||
%patch7 -p1 -b .pid
|
||||
%patch9 -p1 -b .hesiod
|
||||
%patch10 -p1 -b .manpage
|
||||
@ -162,7 +159,6 @@ cp devtools/M4/UNIX/{,shared}library.m4
|
||||
%patch17 -p1 -b .sharedmilter
|
||||
|
||||
%patch18 -p1 -b .switchfile
|
||||
%patch19 -p1 -b .exitpanic
|
||||
%patch20 -p1 -b .milterfdleaks
|
||||
%patch21 -p1 -b .ipv6-bad-helo
|
||||
|
||||
@ -497,7 +493,7 @@ exit 0
|
||||
%attr(0770,smmsp,smmsp) %dir %{spooldir}/clientmqueue
|
||||
%attr(0700,root,mail) %dir %{spooldir}/mqueue
|
||||
|
||||
%config(noreplace) %{stdir}/statistics
|
||||
%config(noreplace) %verify(not size mtime md5) %{stdir}/statistics
|
||||
%config(noreplace) %{maildir}/Makefile
|
||||
%config(noreplace) %{maildir}/make
|
||||
%config(noreplace) %{maildir}/sendmail.cf
|
||||
@ -566,6 +562,13 @@ exit 0
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Feb 02 2010 Jaroslav Škarvada <jskarvad@redhat.com> - 8.14.4-1
|
||||
- new version 8.14.4 (#552078)
|
||||
- RPM attributes S, 5, T not recorded for statistics file
|
||||
- adapted patches: makemapman, dynamic, switchfile (#552078)
|
||||
- movefiles patch incorporated into aliases_dir patch
|
||||
- drop exitpanic patch (fixed upstream)
|
||||
|
||||
* Sun Jan 03 2010 Robert Scheck <robert@fedoraproject.org> 8.14.3-10
|
||||
- handle IPv6:::1 in block_bad_helo.m4 like 127.0.0.1 (#549217)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user