[tw]
- new version 8.14.0 - adapted patches: makemapman, dynamic
This commit is contained in:
parent
dc6dc81683
commit
33f964f233
@ -6,3 +6,4 @@ sendmail.8.13.5.tar.gz
|
||||
sendmail.8.13.6.tar.gz
|
||||
sendmail.8.13.7.tar.gz
|
||||
sendmail.8.13.8.tar.gz
|
||||
sendmail.8.14.0.tar.gz
|
||||
|
46
sendmail-8.14.0-dynamic.patch
Normal file
46
sendmail-8.14.0-dynamic.patch
Normal file
@ -0,0 +1,46 @@
|
||||
--- sendmail-8.14.0/devtools/OS/Linux.dynamic 2007-02-06 17:05:00.000000000 +0100
|
||||
+++ sendmail-8.14.0/devtools/OS/Linux 2007-02-06 17:05:00.000000000 +0100
|
||||
@@ -6,7 +6,7 @@
|
||||
define(`confDEPEND_TYPE', `CC-M')
|
||||
define(`confSM_OS_HEADER', `sm_os_linux')
|
||||
define(`confMANROOT', `/usr/share/man/man')
|
||||
-define(`confLIBS', `-ldl')
|
||||
+define(`confLIBS', `-pie -ldl')
|
||||
define(`confEBINDIR', `/usr/sbin')
|
||||
APPENDDEF(`confLIBSEARCH', `crypt nsl')
|
||||
|
||||
@@ -21,19 +21,19 @@
|
||||
ifelse(confBLDVARIANT, `DEBUG',
|
||||
dnl Debug build
|
||||
`
|
||||
- define(`confOPTIMIZE',`-g -Wall')
|
||||
+ define(`confOPTIMIZE',`-g -Wall -fpie')
|
||||
',
|
||||
dnl Optimized build
|
||||
confBLDVARIANT, `OPTIMIZED',
|
||||
`
|
||||
- define(`confOPTIMIZE',`-O2')
|
||||
+ define(`confOPTIMIZE',`-O2 -fpie')
|
||||
',
|
||||
dnl Purify build
|
||||
confBLDVARIANT, `PURIFY',
|
||||
`
|
||||
- define(`confOPTIMIZE',`-g')
|
||||
+ define(`confOPTIMIZE',`-g -fpie')
|
||||
',
|
||||
dnl default
|
||||
`
|
||||
- define(`confOPTIMIZE',`-O2')
|
||||
+ define(`confOPTIMIZE',`-O2 -fpie')
|
||||
')
|
||||
--- sendmail-8.14.0/libsm/Makefile.m4.dynamic 2006-08-16 23:06:31.000000000 +0200
|
||||
+++ sendmail-8.14.0/libsm/Makefile.m4 2007-02-06 17:06:06.000000000 +0100
|
||||
@@ -6,7 +6,7 @@
|
||||
define(`confREQUIRE_SM_OS_H', `true')
|
||||
PREPENDDEF(`confENVDEF', `confMAPDEF')
|
||||
bldPRODUCT_START(`library', `libsm')
|
||||
-define(`bldSOURCES', ` assert.c debug.c errstring.c exc.c heap.c match.c rpool.c strdup.c strerror.c strl.c clrerr.c fclose.c feof.c ferror.c fflush.c fget.c fpos.c findfp.c flags.c fopen.c fprintf.c fpurge.c fput.c fread.c fscanf.c fseek.c fvwrite.c fwalk.c fwrite.c get.c makebuf.c put.c refill.c rewind.c setvbuf.c smstdio.c snprintf.c sscanf.c stdio.c strio.c ungetc.c vasprintf.c vfprintf.c vfscanf.c vprintf.c vsnprintf.c wbuf.c wsetup.c string.c stringf.c xtrap.c strto.c test.c path.c strcasecmp.c strrevcmp.c signal.c clock.c config.c shm.c sem.c mbdb.c strexit.c cf.c ldap.c niprop.c mpeix.c memstat.c util.c ')
|
||||
+define(`bldSOURCES', ` assert.c debug.c errstring.c exc.c heap.c match.c rpool.c strdup.c strl.c clrerr.c fclose.c feof.c ferror.c fflush.c fget.c fpos.c findfp.c flags.c fopen.c fprintf.c fpurge.c fput.c fread.c fscanf.c fseek.c fvwrite.c fwalk.c fwrite.c get.c makebuf.c put.c refill.c rewind.c setvbuf.c smstdio.c snprintf.c sscanf.c stdio.c strio.c ungetc.c vasprintf.c vfprintf.c vfscanf.c vprintf.c vsnprintf.c wbuf.c wsetup.c string.c stringf.c xtrap.c strto.c test.c path.c strcasecmp.c strrevcmp.c signal.c clock.c config.c shm.c sem.c mbdb.c strexit.c cf.c ldap.c niprop.c mpeix.c memstat.c util.c ')
|
||||
bldPRODUCT_END
|
||||
dnl msg.c
|
||||
dnl syslogio.c
|
56
sendmail-8.14.0-makemapman.patch
Normal file
56
sendmail-8.14.0-makemapman.patch
Normal file
@ -0,0 +1,56 @@
|
||||
--- sendmail-8.12.2/devtools/OS/Linux Tue Feb 19 15:23:34 2002
|
||||
+++ sendmail-8.12.2/devtools/OS/Linux Tue Feb 19 15:24:05 2002
|
||||
@@ -1,7 +1,7 @@
|
||||
# $Id: Linux,v 8.29 2001/08/15 08:55:54 guenther Exp $
|
||||
define(`confDEPEND_TYPE', `CC-M')
|
||||
define(`confSM_OS_HEADER', `sm_os_linux')
|
||||
-define(`confMANROOT', `/usr/man/man')
|
||||
+define(`confMANROOT', `/usr/share/man/man')
|
||||
define(`confLIBS', `-ldl')
|
||||
define(`confEBINDIR', `/usr/sbin')
|
||||
APPENDDEF(`confLIBSEARCH', `crypt nsl')
|
||||
@@ -11,6 +11,8 @@
|
||||
define(`confMTLDOPTS', `-lpthread')
|
||||
define(`confLDOPTS_SO', `-shared')
|
||||
define(`confSONAME',`-soname')
|
||||
+define('confSBINGRP', 'mail')
|
||||
+define('confSBINMODE', '6755')
|
||||
|
||||
ifelse(confBLDVARIANT, `DEBUG',
|
||||
dnl Debug build
|
||||
--- sendmail-8.12.2/makemap/makemap.8 Tue Oct 9 23:23:02 2001
|
||||
+++ sendmail-8.12.2/makemap/makemap.8 Tue Feb 19 15:23:34 2002
|
||||
@@ -50,12 +50,6 @@
|
||||
parameter.
|
||||
They may be
|
||||
.TP
|
||||
-dbm
|
||||
-DBM format maps.
|
||||
-This requires the
|
||||
-ndbm(3)
|
||||
-library.
|
||||
-.TP
|
||||
btree
|
||||
B-Tree format maps.
|
||||
This requires the new Berkeley DB
|
||||
--- sendmail-8.12.2/cf/cf/Build Mon Mar 1 21:37:12 1999
|
||||
+++ sendmail-8.12.2/cf/cf/Build Tue Feb 19 15:23:34 2002
|
||||
@@ -18,7 +18,7 @@
|
||||
SMROOT=${SMROOT-../..}
|
||||
BUILDTOOLS=${BUILDTOOLS-$SMROOT/devtools}
|
||||
|
||||
-M4=`sh $BUILDTOOLS/bin/find_m4.sh`
|
||||
+M4=/usr/bin/m4
|
||||
ret=$?
|
||||
if [ $ret -ne 0 ]
|
||||
then
|
||||
--- sendmail-8.12.2/rmail/rmail.c Tue Sep 18 17:45:29 2001
|
||||
+++ sendmail-8.12.2/rmail/rmail.c Tue Feb 19 15:23:34 2002
|
||||
@@ -276,7 +276,6 @@
|
||||
args[i++] = _PATH_SENDMAIL; /* Build sendmail's argument list. */
|
||||
args[i++] = "-G"; /* relay submission */
|
||||
args[i++] = "-oee"; /* No errors, just status. */
|
||||
- args[i++] = "-odq"; /* Queue it, don't try to deliver. */
|
||||
args[i++] = "-oi"; /* Ignore '.' on a line by itself. */
|
||||
|
||||
/* set from system and protocol used */
|
@ -17,8 +17,8 @@
|
||||
|
||||
Summary: A widely used Mail Transport Agent (MTA).
|
||||
Name: sendmail
|
||||
Version: 8.13.8
|
||||
Release: 4
|
||||
Version: 8.14.0
|
||||
Release: 1
|
||||
License: Sendmail
|
||||
Group: System Environment/Daemons
|
||||
Provides: smtpdaemon
|
||||
@ -34,13 +34,13 @@ Source7: Sendmail-sasl1.conf
|
||||
Source8: sendmail.pam
|
||||
Source9: sendmail-8.12.5-newconfig.readme
|
||||
Source11: Sendmail-sasl2.conf
|
||||
Patch3: sendmail-8.12.2-makemapman.patch
|
||||
Patch3: sendmail-8.14.0-makemapman.patch
|
||||
Patch4: sendmail-8.13.2-smrsh-paths.patch
|
||||
Patch5: sendmail-8.12.2-movefiles.patch
|
||||
Patch7: sendmail-8.13.7-pid.patch
|
||||
Patch9: sendmail-8.12.7-hesiod.patch
|
||||
Patch10: sendmail-8.12.7-manpage.patch
|
||||
Patch11: sendmail-8.13.6-dynamic.patch
|
||||
Patch11: sendmail-8.14.0-dynamic.patch
|
||||
Patch12: sendmail-8.13.0-cyrus.patch
|
||||
Patch13: sendmail-8.13.7-aliases_dir.patch
|
||||
Patch14: sendmail-8.13.7-vacation.patch
|
||||
@ -589,6 +589,10 @@ exit 0
|
||||
%{_docdir}/sendmail
|
||||
|
||||
%changelog
|
||||
* Tue Feb 6 2007 Thomas Woerner <twoerner@redhat.com> 8.14.0-1
|
||||
- new version 8.14.0
|
||||
- adapted patches: makemapman, dynamic
|
||||
|
||||
* Tue Jan 23 2007 Florian La Roche <laroche@redhat.com>
|
||||
- #205803 add sparc/sparc64 to -fPIE list
|
||||
- change sendmail.cf reference into sendmail-cf package name
|
||||
|
Loading…
Reference in New Issue
Block a user