diff --git a/make-rhat-patches.sh b/make-rhat-patches.sh
index ae3b3649..8afbbfc0 100755
--- a/make-rhat-patches.sh
+++ b/make-rhat-patches.sh
@@ -2,8 +2,8 @@
 
 DISTGIT_PATH=$(pwd)
 
-RHEL_VERSION="rhel-9.0.0-beta"
-DISTGIT_BRANCH="rhel-9.0.0-beta"
+RHEL_VERSION="rhel-9.0.0"
+DISTGIT_BRANCH="rhel-9.0.0"
 REPO_SELINUX_POLICY=${REPO_SELINUX_POLICY:-git@gitlab.cee.redhat.com:SELinux/selinux-policy.git}
 REPO_SELINUX_POLICY_BRANCH=${REPO_SELINUX_POLICY_BRANCH:-$RHEL_VERSION}
 REPO_CONTAINER_SELINUX=${REPO_CONTAINER_SELINUX:-git@github.com:projectatomic/container-selinux.git}
diff --git a/selinux-policy.spec b/selinux-policy.spec
index 70412788..163982f2 100644
--- a/selinux-policy.spec
+++ b/selinux-policy.spec
@@ -1,6 +1,6 @@
 # github repo with selinux-policy sources
 %global giturl https://github.com/fedora-selinux/selinux-policy
-%global commit 2ec72a07f432737e21bbc78d6ef1cbf6ed360224
+%global commit 9ecb03063e9f99c8ce4afb273e65b098c6cd5be7
 %global shortcommit %(c=%{commit}; echo ${c:0:7})
 
 %define distro redhat
@@ -23,7 +23,7 @@
 %define CHECKPOLICYVER 3.2
 Summary: SELinux policy configuration
 Name: selinux-policy
-Version: 34.1.15
+Version: 34.1.16
 Release: 1%{?dist}
 License: GPLv2+
 Source: %{giturl}/archive/%{commit}/%{name}-%{shortcommit}.tar.gz
@@ -792,6 +792,26 @@ exit 0
 %endif
 
 %changelog
+* Thu Sep 23 2021 Zdenek Pytela <zpytela@redhat.com> - 34.1.16-1
+- Allow fprintd install a sleep delay inhibitor
+Resolves: rhbz#1999537
+- Update mount_manage_pid_files() to use manage_files_pattern
+Resolves: rhbz#1999997
+- Allow gnome at-spi processes create and use stream sockets
+Resolves: rhbz#2004885
+- Allow haproxy list the sysfs directories content
+Resolves: rhbz#1986823
+- Allow virtlogd_t read process state of user domains
+Resolves: rhbz#1994592
+- Support hitless reloads feature in haproxy
+Resolves: rhbz#1997182
+- Allow firewalld load kernel modules
+Resolves: rhbz#1999152
+- Allow communication between at-spi and gdm processes
+Resolves: rhbz#2003037
+- Remove "ipa = module" from modules-targeted-contrib.conf
+Resolves: rhbz#2006039
+
 * Mon Aug 30 2021 Zdenek Pytela <zpytela@redhat.com> - 34.1.15-1
 - Update ica_filetrans_named_content() with create_file_perms
 Resolves: rhbz#1976180
diff --git a/sources b/sources
index 6df6fe4a..66f19eb6 100644
--- a/sources
+++ b/sources
@@ -1,3 +1,3 @@
-SHA512 (selinux-policy-2ec72a0.tar.gz) = c77e80ddcb0de9bef01e875f9695aac0f9fdb88b9d68eb554fc30c5470b9b87c8bbf35dd6244014bbffd684da3d452c4e69e4500bb1477114c18c42bbea0c827
-SHA512 (container-selinux.tgz) = 91caaa8f5fbaa14875bbaa5bc959df86d1eeb9d6ab82c5829ac6e954b2a86676546d0a6034b16503efcce1b64679f433fd7e35dea12d282001b279ea7a340fc9
+SHA512 (selinux-policy-9ecb030.tar.gz) = c30233c65578c370b7a0e7a4a0b781cf03281ddd8ad2de755c99d7fca8d333af6aca35f6924e85a7d0cdb0e062e3a43bedbd1d95c119ea2d4de5a604a7d1f304
 SHA512 (macro-expander) = 243ee49f1185b78ac47e56ca9a3f3592f8975fab1a2401c0fcc7f88217be614fe31805bacec602b728e7fcfc21dcc17d90e9a54ce87f3a0c97624d9ad885aea4
+SHA512 (container-selinux.tgz) = 92f1dce3772b5e4a4924f3d260cefc617939dc967c689d090279a6bf24b369d2d2dc1f816d43f063315b9e0d0c05f1b3dac82681b49b2860a106157b5bab7339