diff --git a/www/html/switch.html b/www/html/switch.html index 55d5ee05..633d0c17 100644 --- a/www/html/switch.html +++ b/www/html/switch.html @@ -15,7 +15,7 @@

-# tar -jxvf refpolicy-20050802.tar.bz2 -C /tmp
+# tar -jxvf refpolicy-20050922.tar.bz2 -C /tmp
 # cd /tmp/refpolicy
 # make install-src
 
@@ -26,19 +26,17 @@

The policy source is found in the /etc/selinux/refpolicy/src/policy/ directory. - Use the example targeted modules configuration.

 # cd /etc/selinux/refpolicy/src/policy
-# cp policy/modules.conf.targeted_example policy/modules.conf
 

Edit the policy Makefile (/etc/selinux/refpolicy/src/policy/Makefile). Near the top of the file, the policy has a few build options. - The TYPE needs to be set to targeted, and the DISTRO option needs to be - uncommented and set to redhat. + The TYPE needs to be set to targeted, the DISTRO option needs to be + uncommented and set to redhat, and DIRECT_INITRC should be set to y.

@@ -54,7 +52,9 @@
 #OUTPUT_POLICY = 18
 
 # Policy Type
-# strict, targeted, strict-mls, targeted-mls
+# strict, targeted,
+# strict-mls, targeted-mls,
+# strict-mcs, targeted-mcs
 TYPE = targeted
 
 # Policy Name
@@ -72,6 +72,13 @@ NAME = refpolicy
 # Fedora users should enable redhat.
 DISTRO = redhat
 
+# Direct admin init
+# Setting this will allow sysadm to directly
+# run init scripts, instead of requring run_init.
+# This is a build option, as role transitions do
+# not work in conditional policy.
+DIRECT_INITRC=y
+
 # Build monolithic policy.  Putting n here
 # will build a loadable module policy.
 # Only monolithic policies are currently supported.