Update to 3.15.90
This commit is contained in:
parent
6172fb85e2
commit
8f9fba88c5
1
.gitignore
vendored
1
.gitignore
vendored
@ -49,3 +49,4 @@ seahorse-2.30.0.tar.bz2
|
||||
/seahorse-3.12.0.tar.xz
|
||||
/seahorse-3.12.2.tar.xz
|
||||
/seahorse-3.14.0.tar.xz
|
||||
/seahorse-3.15.90.tar.xz
|
||||
|
@ -1,42 +0,0 @@
|
||||
From d51b3db2211e806891384798c0c028502bb2b50b Mon Sep 17 00:00:00 2001
|
||||
From: Matthias Clasen <mclasen@redhat.com>
|
||||
Date: Fri, 14 Nov 2014 04:37:10 -0500
|
||||
Subject: [PATCH 1/4] Don't hide GtkBuilder errors
|
||||
|
||||
This makes it unnecessarily hard to track down invalid
|
||||
ui files.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=740138
|
||||
---
|
||||
libseahorse/seahorse-widget.c | 8 +++++++-
|
||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/libseahorse/seahorse-widget.c b/libseahorse/seahorse-widget.c
|
||||
index 963dfd2..49284e4 100644
|
||||
--- a/libseahorse/seahorse-widget.c
|
||||
+++ b/libseahorse/seahorse-widget.c
|
||||
@@ -259,6 +259,7 @@ object_set_property (GObject *object, guint prop_id, const GValue *value, GParam
|
||||
SeahorseWidget *swidget;
|
||||
GtkWidget *w;
|
||||
char *path;
|
||||
+ GError *error = NULL;
|
||||
|
||||
swidget = SEAHORSE_WIDGET (object);
|
||||
|
||||
@@ -270,7 +271,12 @@ object_set_property (GObject *object, guint prop_id, const GValue *value, GParam
|
||||
path = g_strdup_printf ("%sseahorse-%s.xml",
|
||||
SEAHORSE_UIDIR, swidget->name);
|
||||
swidget->gtkbuilder = gtk_builder_new ();
|
||||
- gtk_builder_add_from_file (swidget->gtkbuilder, path, NULL);
|
||||
+ gtk_builder_add_from_file (swidget->gtkbuilder, path, &error);
|
||||
+ if (error)
|
||||
+ {
|
||||
+ g_warning ("Error parsing %s: %s\n", path, error->message);
|
||||
+ g_error_free (error);
|
||||
+ }
|
||||
g_free (path);
|
||||
g_return_if_fail (swidget->gtkbuilder != NULL);
|
||||
|
||||
--
|
||||
2.1.0
|
||||
|
@ -1,28 +0,0 @@
|
||||
From 20536a1282bb506bb4a3f11a83ddb6d46669e552 Mon Sep 17 00:00:00 2001
|
||||
From: Matthias Clasen <mclasen@redhat.com>
|
||||
Date: Fri, 14 Nov 2014 04:38:00 -0500
|
||||
Subject: [PATCH 2/4] ssh generation: Fix invalid ui file
|
||||
|
||||
GtkGrid does not have :n-rows or :n-columns properties.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=740138
|
||||
---
|
||||
ssh/seahorse-ssh-generate.xml | 2 --
|
||||
1 file changed, 2 deletions(-)
|
||||
|
||||
diff --git a/ssh/seahorse-ssh-generate.xml b/ssh/seahorse-ssh-generate.xml
|
||||
index 03defd9..9cb9e04 100644
|
||||
--- a/ssh/seahorse-ssh-generate.xml
|
||||
+++ b/ssh/seahorse-ssh-generate.xml
|
||||
@@ -196,8 +196,6 @@
|
||||
<property name="can_focus">False</property>
|
||||
<property name="row_spacing">6</property>
|
||||
<property name="column_spacing">12</property>
|
||||
- <property name="n_rows">2</property>
|
||||
- <property name="n_columns">2</property>
|
||||
<child>
|
||||
<object class="GtkLabel" id="label46">
|
||||
<property name="visible">True</property>
|
||||
--
|
||||
2.1.0
|
||||
|
@ -1,26 +0,0 @@
|
||||
From e9917a0a81fd58e1555c71a29c9f5fea80e327b2 Mon Sep 17 00:00:00 2001
|
||||
From: Matthias Clasen <mclasen@redhat.com>
|
||||
Date: Sat, 15 Nov 2014 12:05:14 -0500
|
||||
Subject: [PATCH 4/4] Remove more invalid properties
|
||||
|
||||
This was overlooked in the previous commit.
|
||||
---
|
||||
ssh/seahorse-ssh-generate.xml | 2 --
|
||||
1 file changed, 2 deletions(-)
|
||||
|
||||
diff --git a/ssh/seahorse-ssh-generate.xml b/ssh/seahorse-ssh-generate.xml
|
||||
index 9cb9e04..d918617 100644
|
||||
--- a/ssh/seahorse-ssh-generate.xml
|
||||
+++ b/ssh/seahorse-ssh-generate.xml
|
||||
@@ -279,8 +279,6 @@
|
||||
<property name="margin_left">20</property>
|
||||
<property name="row_spacing">6</property>
|
||||
<property name="column_spacing">12</property>
|
||||
- <property name="n_rows">2</property>
|
||||
- <property name="n_columns">2</property>
|
||||
<child>
|
||||
<object class="GtkLabel" id="label49">
|
||||
<property name="visible">True</property>
|
||||
--
|
||||
2.1.0
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: seahorse
|
||||
Version: 3.14.0
|
||||
Release: 4%{?dist}
|
||||
Version: 3.15.90
|
||||
Release: 1%{?dist}
|
||||
Summary: A GNOME application for managing encryption keys
|
||||
Group: User Interface/Desktops
|
||||
# seahorse is GPLv2+
|
||||
@ -8,15 +8,7 @@ Group: User Interface/Desktops
|
||||
License: GPLv2+ and LGPLv2+
|
||||
URL: http://projects.gnome.org/seahorse/
|
||||
#VCS: git:git://git.gnome.org/seahorse
|
||||
Source: http://download.gnome.org/sources/seahorse/3.14/%{name}-%{version}.tar.xz
|
||||
|
||||
# Use GnuPG 1.4.x instead of 2.0.x
|
||||
Patch0: set-gnupg-engine.patch
|
||||
|
||||
# Backported upstream patches
|
||||
Patch1: 0001-Don-t-hide-GtkBuilder-errors.patch
|
||||
Patch2: 0002-ssh-generation-Fix-invalid-ui-file.patch
|
||||
Patch3: 0003-Remove-more-invalid-properties.patch
|
||||
Source: https://download.gnome.org/sources/%{name}/3.15/%{name}-%{version}.tar.xz
|
||||
|
||||
BuildRequires: glib2-devel
|
||||
BuildRequires: gtk3-devel
|
||||
@ -59,10 +51,6 @@ operations. It is a keyring manager.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
%build
|
||||
GNUPG=/usr/bin/gpg ; export GNUPG ; %configure
|
||||
@ -133,6 +121,9 @@ update-mime-database -n %{_datadir}/mime &> /dev/null || :
|
||||
%{_datadir}/gnome-shell/search-providers/seahorse-search-provider.ini
|
||||
|
||||
%changelog
|
||||
* Thu Feb 26 2015 David King <amigadave@amigadave.com> - 3.15.90-1
|
||||
- Update to 3.15.90
|
||||
|
||||
* Sat Feb 21 2015 Till Maas <opensource@till.name> - 3.14.0-4
|
||||
- Rebuilt for Fedora 23 Change
|
||||
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
|
||||
|
@ -1,28 +0,0 @@
|
||||
From cad4d259805840d912d3f20f76bc3f4cd57e9502 Mon Sep 17 00:00:00 2001
|
||||
From: Stef Walter <stefw@redhat.com>
|
||||
Date: Sat, 25 Oct 2014 08:44:33 +0200
|
||||
Subject: [PATCH] pgp: Force use of the first gnupg found by configure.ac
|
||||
|
||||
Some people are having problems using recent versions of gpg2.
|
||||
This allows configure.ac to identify a version during building
|
||||
and then stick to using that one.
|
||||
---
|
||||
pgp/seahorse-pgp-backend.c | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/pgp/seahorse-pgp-backend.c b/pgp/seahorse-pgp-backend.c
|
||||
index ab9b8fb..4b267c3 100644
|
||||
--- a/pgp/seahorse-pgp-backend.c
|
||||
+++ b/pgp/seahorse-pgp-backend.c
|
||||
@@ -310,6 +310,8 @@ seahorse_pgp_backend_initialize (void)
|
||||
g_object_unref (self);
|
||||
|
||||
g_return_if_fail (pgp_backend != NULL);
|
||||
+
|
||||
+ gpgme_set_engine_info (GPGME_PROTOCOL_OpenPGP, GNUPG, NULL);
|
||||
}
|
||||
|
||||
SeahorseGpgmeKeyring *
|
||||
--
|
||||
2.1.0
|
||||
|
Loading…
Reference in New Issue
Block a user