* Fri Dec 17 2021 Miroslav Rezanina <mrezanin@redhat.com> - 1.15.0-1
- Rebase to seabios to 1.15.0 [bz#2018393] - 0003-pci-let-firmware-reserve-IO-for-pcie-pci-bridge.patch [bz#2001732] - 0004-pci-reserve-resources-for-pcie-pci-bridge-to-fix-reg.patch [bz#2001732] - Resolves: bz#2018393 ([rebase] update seabios to nov '21 release) - Resolves: bz#2001732 ([virtual network][qemu-6.1.0-1] Fail to hotplug nic with rtl8139 driver)
This commit is contained in:
parent
1ab775559f
commit
e8c19e4ea7
1
.gitignore
vendored
1
.gitignore
vendored
@ -28,3 +28,4 @@ seabios-0.6.0.tar.gz
|
||||
/seabios-1.12.1.tar.xz
|
||||
/seabios-1.13.0.tar.gz
|
||||
/seabios-1.14.0.tar.gz
|
||||
/seabios-1.15.0.tar.gz
|
||||
|
@ -1,4 +1,4 @@
|
||||
From d320b19cacb31ca9154682d623dd004eb0681843 Mon Sep 17 00:00:00 2001
|
||||
From 10883a49e78ba83e3667e4386b8f11b4aa18ddb2 Mon Sep 17 00:00:00 2001
|
||||
From: Radim Krcmar <rkrcmar@redhat.com>
|
||||
Date: Mon, 10 Mar 2014 15:14:27 +0100
|
||||
Subject: Workaround for a win8.1-32 S4 resume bug
|
||||
@ -41,7 +41,7 @@ Signed-off-by: Radim Krčmář <rkrcmar@redhat.com>
|
||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/clock.c b/src/clock.c
|
||||
index e44e112..298a722 100644
|
||||
index e44e1120..298a7229 100644
|
||||
--- a/src/clock.c
|
||||
+++ b/src/clock.c
|
||||
@@ -309,7 +309,13 @@ handle_08(void)
|
||||
@ -60,5 +60,5 @@ index e44e112..298a722 100644
|
||||
pic_eoi1();
|
||||
}
|
||||
--
|
||||
2.18.4
|
||||
2.27.0
|
||||
|
||||
|
90
0003-pci-let-firmware-reserve-IO-for-pcie-pci-bridge.patch
Normal file
90
0003-pci-let-firmware-reserve-IO-for-pcie-pci-bridge.patch
Normal file
@ -0,0 +1,90 @@
|
||||
From 87689162d5203522a8e089bb0e46302a07c77301 Mon Sep 17 00:00:00 2001
|
||||
From: Igor Mammedov <imammedo@redhat.com>
|
||||
Date: Mon, 29 Nov 2021 06:48:12 -0500
|
||||
Subject: pci: let firmware reserve IO for pcie-pci-bridge
|
||||
|
||||
RH-Bugzilla: 2001732
|
||||
|
||||
With [1] patch hotplug of rtl8139 succeeds, with caveat that it
|
||||
fails to initialize IO bar, which is caused by [2] that makes
|
||||
firmware skip IO reservation for any PCIe device, which isn't
|
||||
correct in case of pcie-pci-bridge.
|
||||
Fix it by exposing hotplug type and making IO resource optional
|
||||
only if PCIe hotplug is in use.
|
||||
|
||||
[1]
|
||||
"pci: reserve resources for pcie-pci-bridge to fix regressed hotplug on q35"
|
||||
[2]
|
||||
|
||||
Fixes: 76327b9f32a ("fw/pci: do not automatically allocate IO region for PCIe bridges")
|
||||
Signed-off-by: Igor Mammedov imammedo@redhat.com
|
||||
CC: mapfelba@redhat.com
|
||||
CC: kraxel@redhat.com
|
||||
CC: mst@redhat.com
|
||||
CC: lvivier@redhat.com
|
||||
CC: jusual@redhat.com
|
||||
Tested-by: Laurent Vivier <lvivier@redhat.com>
|
||||
Acked-by: Michael S. Tsirkin <mst@redhat.com>
|
||||
Message-Id: <20211129114812.231849-3-imammedo@redhat.com>
|
||||
Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
|
||||
---
|
||||
src/fw/pciinit.c | 19 ++++++++++++++-----
|
||||
1 file changed, 14 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/src/fw/pciinit.c b/src/fw/pciinit.c
|
||||
index d25931bb..3c99d514 100644
|
||||
--- a/src/fw/pciinit.c
|
||||
+++ b/src/fw/pciinit.c
|
||||
@@ -793,7 +793,13 @@ pci_region_create_entry(struct pci_bus *bus, struct pci_device *dev,
|
||||
return entry;
|
||||
}
|
||||
|
||||
-static int pci_bus_hotplug_support(struct pci_bus *bus, u8 pcie_cap)
|
||||
+typedef enum hotplug_type_t {
|
||||
+ HOTPLUG_NO_SUPPORTED = 0,
|
||||
+ HOTPLUG_PCIE,
|
||||
+ HOTPLUG_SHPC
|
||||
+} hotplug_type_t;
|
||||
+
|
||||
+static hotplug_type_t pci_bus_hotplug_support(struct pci_bus *bus, u8 pcie_cap)
|
||||
{
|
||||
u8 shpc_cap;
|
||||
|
||||
@@ -815,11 +821,12 @@ static int pci_bus_hotplug_support(struct pci_bus *bus, u8 pcie_cap)
|
||||
*/
|
||||
u16 slot_implemented = pcie_flags & PCI_EXP_FLAGS_SLOT;
|
||||
|
||||
- return downstream_port && slot_implemented;
|
||||
+ return downstream_port && slot_implemented ?
|
||||
+ HOTPLUG_PCIE : HOTPLUG_NO_SUPPORTED;
|
||||
}
|
||||
|
||||
shpc_cap = pci_find_capability(bus->bus_dev->bdf, PCI_CAP_ID_SHPC, 0);
|
||||
- return !!shpc_cap;
|
||||
+ return !!shpc_cap ? HOTPLUG_SHPC : HOTPLUG_NO_SUPPORTED;
|
||||
}
|
||||
|
||||
/* Test whether bridge support forwarding of transactions
|
||||
@@ -904,7 +911,7 @@ static int pci_bios_check_devices(struct pci_bus *busses)
|
||||
u8 pcie_cap = pci_find_capability(bdf, PCI_CAP_ID_EXP, 0);
|
||||
u8 qemu_cap = pci_find_resource_reserve_capability(bdf);
|
||||
|
||||
- int hotplug_support = pci_bus_hotplug_support(s, pcie_cap);
|
||||
+ hotplug_type_t hotplug_support = pci_bus_hotplug_support(s, pcie_cap);
|
||||
for (type = 0; type < PCI_REGION_TYPE_COUNT; type++) {
|
||||
u64 align = (type == PCI_REGION_TYPE_IO) ?
|
||||
PCI_BRIDGE_IO_MIN : PCI_BRIDGE_MEM_MIN;
|
||||
@@ -948,7 +955,9 @@ static int pci_bios_check_devices(struct pci_bus *busses)
|
||||
if (pci_region_align(&s->r[type]) > align)
|
||||
align = pci_region_align(&s->r[type]);
|
||||
u64 sum = pci_region_sum(&s->r[type]);
|
||||
- int resource_optional = pcie_cap && (type == PCI_REGION_TYPE_IO);
|
||||
+ int resource_optional = 0;
|
||||
+ if (hotplug_support == HOTPLUG_PCIE)
|
||||
+ resource_optional = pcie_cap && (type == PCI_REGION_TYPE_IO);
|
||||
if (!sum && hotplug_support && !resource_optional)
|
||||
sum = align; /* reserve min size for hot-plug */
|
||||
if (size > sum) {
|
||||
--
|
||||
2.27.0
|
||||
|
@ -1,44 +0,0 @@
|
||||
From 45b10c18abf43fb87ce1f39c8894be498e3ca1ad Mon Sep 17 00:00:00 2001
|
||||
From: Gerd Hoffmann <kraxel@redhat.com>
|
||||
Date: Tue, 19 Apr 2016 11:27:50 +0200
|
||||
Subject: redhat: reserve more memory on fseg
|
||||
|
||||
RH-Author: Gerd Hoffmann <kraxel@redhat.com>
|
||||
Message-id: <1461065271-22039-2-git-send-email-kraxel@redhat.com>
|
||||
Patchwork-id: 70213
|
||||
O-Subject: [RHEL-7.1 seabios PATCH 1/2] redhat: reserve more memory on fseg
|
||||
Bugzilla: 1327060
|
||||
RH-Acked-by: Miroslav Rezanina <mrezanin@redhat.com>
|
||||
RH-Acked-by: Marcel Apfelbaum <marcel@redhat.com>
|
||||
RH-Acked-by: Laszlo Ersek <lersek@redhat.com>
|
||||
|
||||
seabios 1.7.5 has about 8k free space in fseg.
|
||||
|
||||
configure 1.9.1 to keep the same amout space in fseg, so the amout of
|
||||
disks we are able to handle stays roughly the same. ahci + scsi are
|
||||
slightly below the 1.7.5 numbers but stay above the documented limits.
|
||||
virtio-block numbers are higher than the 1.7.5 numbers.
|
||||
|
||||
Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
|
||||
Signed-off-by: Miroslav Rezanina <mrezanin@redhat.com>
|
||||
(cherry picked from commit 0561b82b0470679505d62f49eec83adb01eec0ab)
|
||||
---
|
||||
scripts/layoutrom.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/scripts/layoutrom.py b/scripts/layoutrom.py
|
||||
index 6616721..71841aa 100755
|
||||
--- a/scripts/layoutrom.py
|
||||
+++ b/scripts/layoutrom.py
|
||||
@@ -66,7 +66,7 @@ BUILD_BIOS_SIZE = 0x10000
|
||||
BUILD_ROM_START = 0xc0000
|
||||
BUILD_LOWRAM_END = 0xa0000
|
||||
# Space to reserve in f-segment for dynamic allocations
|
||||
-BUILD_MIN_BIOSTABLE = 2048
|
||||
+BUILD_MIN_BIOSTABLE = 8192
|
||||
|
||||
# Layout the 16bit code. This ensures sections with fixed offset
|
||||
# requirements are placed in the correct location. It also places the
|
||||
--
|
||||
2.18.4
|
||||
|
@ -0,0 +1,83 @@
|
||||
From ded76fad62293d5dbe4eebf30d3b19c9eb8330de Mon Sep 17 00:00:00 2001
|
||||
From: Igor Mammedov <imammedo@redhat.com>
|
||||
Date: Mon, 29 Nov 2021 06:48:11 -0500
|
||||
Subject: pci: reserve resources for pcie-pci-bridge to fix regressed hotplug
|
||||
on q35
|
||||
|
||||
RH-Bugzilla: 2001732
|
||||
|
||||
If QEMU is started with unpopulated pcie-pci-bridge with ACPI PCI
|
||||
hotplug enabled (default since QEMU-6.1), hotplugging a PCI device
|
||||
into one of the bridge slots fails due to lack of resources.
|
||||
|
||||
once linux guest is booted (test used Fedora 34), hotplug NIC from
|
||||
QEMU monitor:
|
||||
(qemu) device_add rtl8139,bus=pcie-pci-bridge-0,addr=0x2
|
||||
|
||||
guest fails hotplug with:
|
||||
pci 0000:01:02.0: [10ec:8139] type 00 class 0x020000
|
||||
pci 0000:01:02.0: reg 0x10: [io 0x0000-0x00ff]
|
||||
pci 0000:01:02.0: reg 0x14: [mem 0x00000000-0x000000ff]
|
||||
pci 0000:01:02.0: reg 0x30: [mem 0x00000000-0x0003ffff pref]
|
||||
pci 0000:01:02.0: BAR 6: no space for [mem size 0x00040000 pref]
|
||||
pci 0000:01:02.0: BAR 6: failed to assign [mem size 0x00040000 pref]
|
||||
pci 0000:01:02.0: BAR 0: no space for [io size 0x0100]
|
||||
pci 0000:01:02.0: BAR 0: failed to assign [io size 0x0100]
|
||||
pci 0000:01:02.0: BAR 1: no space for [mem size 0x00000100]
|
||||
pci 0000:01:02.0: BAR 1: failed to assign [mem size 0x00000100]
|
||||
8139cp: 8139cp: 10/100 PCI Ethernet driver v1.3 (Mar 22, 2004)
|
||||
PCI Interrupt Link [GSIG] enabled at IRQ 22
|
||||
8139cp 0000:01:02.0: no MMIO resource
|
||||
8139cp: probe of 0000:01:02.0 failed with error -5
|
||||
|
||||
Reason for this is that commit [1] didn't take into account
|
||||
pcie-pci-bridge, marking bridge as non hotpluggable instead of
|
||||
handling it as possibly SHPC capable bridge.
|
||||
Fix issue by checking if pcie-pci-bridge is SHPC capable and
|
||||
if it is mark it as hotpluggable.
|
||||
|
||||
Fixes regression in QEMU-6.1 and later, since it was switched
|
||||
to ACPI based PCI hotplug on Q35 by default at that time.
|
||||
|
||||
[1]
|
||||
Fixes: 3aa31d7d637 ("hw/pci: reserve IO and mem for pci express downstream ports with no devices attached")
|
||||
Signed-off-by: Igor Mammedov imammedo@redhat.com
|
||||
CC: mapfelba@redhat.com
|
||||
CC: kraxel@redhat.com
|
||||
CC: mst@redhat.com
|
||||
CC: lvivier@redhat.com
|
||||
CC: jusual@redhat.com
|
||||
Tested-by: Laurent Vivier <lvivier@redhat.com>
|
||||
Acked-by: Michael S. Tsirkin <mst@redhat.com>
|
||||
Message-Id: <20211129114812.231849-2-imammedo@redhat.com>
|
||||
Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
|
||||
---
|
||||
src/fw/pciinit.c | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/src/fw/pciinit.c b/src/fw/pciinit.c
|
||||
index 3c99d514..badf13d3 100644
|
||||
--- a/src/fw/pciinit.c
|
||||
+++ b/src/fw/pciinit.c
|
||||
@@ -808,6 +808,10 @@ static hotplug_type_t pci_bus_hotplug_support(struct pci_bus *bus, u8 pcie_cap)
|
||||
pcie_cap + PCI_EXP_FLAGS);
|
||||
u8 port_type = ((pcie_flags & PCI_EXP_FLAGS_TYPE) >>
|
||||
(__builtin_ffs(PCI_EXP_FLAGS_TYPE) - 1));
|
||||
+
|
||||
+ if (port_type == PCI_EXP_TYPE_PCI_BRIDGE)
|
||||
+ goto check_shpc;
|
||||
+
|
||||
u8 downstream_port = (port_type == PCI_EXP_TYPE_DOWNSTREAM) ||
|
||||
(port_type == PCI_EXP_TYPE_ROOT_PORT);
|
||||
/*
|
||||
@@ -825,6 +829,7 @@ static hotplug_type_t pci_bus_hotplug_support(struct pci_bus *bus, u8 pcie_cap)
|
||||
HOTPLUG_PCIE : HOTPLUG_NO_SUPPORTED;
|
||||
}
|
||||
|
||||
+check_shpc:
|
||||
shpc_cap = pci_find_capability(bus->bus_dev->bdf, PCI_CAP_ID_SHPC, 0);
|
||||
return !!shpc_cap ? HOTPLUG_SHPC : HOTPLUG_NO_SUPPORTED;
|
||||
}
|
||||
--
|
||||
2.27.0
|
||||
|
@ -1,123 +0,0 @@
|
||||
From 1454a162d2bb3e38a4f567ebfd64c75624cb9c19 Mon Sep 17 00:00:00 2001
|
||||
From: Ladi Prosek <lprosek@redhat.com>
|
||||
Date: Mon, 31 Oct 2016 19:33:05 +0100
|
||||
Subject: vgabios: Reorder video modes to work around a Windows bug
|
||||
|
||||
RH-Author: Ladi Prosek <lprosek@redhat.com>
|
||||
Message-id: <1477924385-6169-1-git-send-email-lprosek@redhat.com>
|
||||
Patchwork-id: 72677
|
||||
O-Subject: [RHEL-7.4/7.3.z seabios PATCH] vgabios: Reorder video modes to work around a Windows bug
|
||||
Bugzilla: 1392028
|
||||
RH-Acked-by: Laszlo Ersek <lersek@redhat.com>
|
||||
RH-Acked-by: Gerd Hoffmann <kraxel@redhat.com>
|
||||
RH-Acked-by: vrozenfe <vrozenfe@redhat.com>
|
||||
|
||||
Windows Server 2016 and Windows 10 RS1 come with a bug in its blue screen
|
||||
of death rendering logic which prevents it from generating crash dumps.
|
||||
|
||||
The bug does not manifest if Windows sees a suitable 32 bpp video mode
|
||||
before a suitable 24 bpp video mode in the list of modes returned from
|
||||
vgabios. This commit moves all 32 bpp modes to the front of the list to
|
||||
make sure that this is always the case.
|
||||
|
||||
Upstream patch:
|
||||
https://www.coreboot.org/pipermail/seabios/2016-October/010963.html
|
||||
|
||||
There are valid concerns upstream about the breaking nature of the fix
|
||||
but for the limited set of operating systems supported by RHEL/RHEV we
|
||||
can easily verify that they are unaffected. So as things stand now, this
|
||||
is a downstream-only patch which will be reverted in the near future;
|
||||
the exact time will depend on Windows 10 RS2 schedule and other factors.
|
||||
The goal is to make sure that our customers running Windows 10 VMs can
|
||||
generate crash dumps.
|
||||
|
||||
Signed-off-by: Ladi Prosek <lprosek@redhat.com>
|
||||
Signed-off-by: Miroslav Rezanina <mrezanin@redhat.com>
|
||||
---
|
||||
vgasrc/svgamodes.c | 38 ++++++++++++++++++++------------------
|
||||
1 file changed, 20 insertions(+), 18 deletions(-)
|
||||
|
||||
diff --git a/vgasrc/svgamodes.c b/vgasrc/svgamodes.c
|
||||
index 6e494c7..008f1b9 100644
|
||||
--- a/vgasrc/svgamodes.c
|
||||
+++ b/vgasrc/svgamodes.c
|
||||
@@ -12,6 +12,25 @@
|
||||
#include "svgamodes.h"
|
||||
|
||||
struct generic_svga_mode svga_modes[] VAR16 = {
|
||||
+ /* 32 bpp BOCHS modes */
|
||||
+ { 0x140, { MM_DIRECT, 320, 200, 32, 8, 16, SEG_GRAPH } },
|
||||
+ { 0x141, { MM_DIRECT, 640, 400, 32, 8, 16, SEG_GRAPH } },
|
||||
+ { 0x142, { MM_DIRECT, 640, 480, 32, 8, 16, SEG_GRAPH } },
|
||||
+ { 0x143, { MM_DIRECT, 800, 600, 32, 8, 16, SEG_GRAPH } },
|
||||
+ { 0x144, { MM_DIRECT, 1024, 768, 32, 8, 16, SEG_GRAPH } },
|
||||
+ { 0x145, { MM_DIRECT, 1280, 1024, 32, 8, 16, SEG_GRAPH } },
|
||||
+ { 0x147, { MM_DIRECT, 1600, 1200, 32, 8, 16, SEG_GRAPH } },
|
||||
+ { 0x14c, { MM_DIRECT, 1152, 864, 32, 8, 16, SEG_GRAPH } },
|
||||
+ { 0x177, { MM_DIRECT, 1280, 768, 32, 8, 16, SEG_GRAPH } },
|
||||
+ { 0x17a, { MM_DIRECT, 1280, 800, 32, 8, 16, SEG_GRAPH } },
|
||||
+ { 0x17d, { MM_DIRECT, 1280, 960, 32, 8, 16, SEG_GRAPH } },
|
||||
+ { 0x180, { MM_DIRECT, 1440, 900, 32, 8, 16, SEG_GRAPH } },
|
||||
+ { 0x183, { MM_DIRECT, 1400, 1050, 32, 8, 16, SEG_GRAPH } },
|
||||
+ { 0x186, { MM_DIRECT, 1680, 1050, 32, 8, 16, SEG_GRAPH } },
|
||||
+ { 0x189, { MM_DIRECT, 1920, 1200, 32, 8, 16, SEG_GRAPH } },
|
||||
+ { 0x18c, { MM_DIRECT, 2560, 1600, 32, 8, 16, SEG_GRAPH } },
|
||||
+ { 0x18f, { MM_DIRECT, 1280, 720, 32, 8, 16, SEG_GRAPH } },
|
||||
+ { 0x192, { MM_DIRECT, 1920, 1080, 32, 8, 16, SEG_GRAPH } },
|
||||
/* standard modes */
|
||||
{ 0x100, { MM_PACKED, 640, 400, 8, 8, 16, SEG_GRAPH } },
|
||||
{ 0x101, { MM_PACKED, 640, 480, 8, 8, 16, SEG_GRAPH } },
|
||||
@@ -41,49 +60,32 @@ struct generic_svga_mode svga_modes[] VAR16 = {
|
||||
{ 0x11E, { MM_DIRECT, 1600, 1200, 16, 8, 16, SEG_GRAPH } },
|
||||
{ 0x11F, { MM_DIRECT, 1600, 1200, 24, 8, 16, SEG_GRAPH } },
|
||||
/* other modes */
|
||||
- { 0x140, { MM_DIRECT, 320, 200, 32, 8, 16, SEG_GRAPH } },
|
||||
- { 0x141, { MM_DIRECT, 640, 400, 32, 8, 16, SEG_GRAPH } },
|
||||
- { 0x142, { MM_DIRECT, 640, 480, 32, 8, 16, SEG_GRAPH } },
|
||||
- { 0x143, { MM_DIRECT, 800, 600, 32, 8, 16, SEG_GRAPH } },
|
||||
- { 0x144, { MM_DIRECT, 1024, 768, 32, 8, 16, SEG_GRAPH } },
|
||||
- { 0x145, { MM_DIRECT, 1280, 1024, 32, 8, 16, SEG_GRAPH } },
|
||||
+ /* 8, 15, 16, and 24 bpp BOCHS modes */
|
||||
{ 0x146, { MM_PACKED, 320, 200, 8, 8, 16, SEG_GRAPH } },
|
||||
- { 0x147, { MM_DIRECT, 1600, 1200, 32, 8, 16, SEG_GRAPH } },
|
||||
{ 0x148, { MM_PACKED, 1152, 864, 8, 8, 16, SEG_GRAPH } },
|
||||
{ 0x149, { MM_DIRECT, 1152, 864, 15, 8, 16, SEG_GRAPH } },
|
||||
{ 0x14a, { MM_DIRECT, 1152, 864, 16, 8, 16, SEG_GRAPH } },
|
||||
{ 0x14b, { MM_DIRECT, 1152, 864, 24, 8, 16, SEG_GRAPH } },
|
||||
- { 0x14c, { MM_DIRECT, 1152, 864, 32, 8, 16, SEG_GRAPH } },
|
||||
{ 0x175, { MM_DIRECT, 1280, 768, 16, 8, 16, SEG_GRAPH } },
|
||||
{ 0x176, { MM_DIRECT, 1280, 768, 24, 8, 16, SEG_GRAPH } },
|
||||
- { 0x177, { MM_DIRECT, 1280, 768, 32, 8, 16, SEG_GRAPH } },
|
||||
{ 0x178, { MM_DIRECT, 1280, 800, 16, 8, 16, SEG_GRAPH } },
|
||||
{ 0x179, { MM_DIRECT, 1280, 800, 24, 8, 16, SEG_GRAPH } },
|
||||
- { 0x17a, { MM_DIRECT, 1280, 800, 32, 8, 16, SEG_GRAPH } },
|
||||
{ 0x17b, { MM_DIRECT, 1280, 960, 16, 8, 16, SEG_GRAPH } },
|
||||
{ 0x17c, { MM_DIRECT, 1280, 960, 24, 8, 16, SEG_GRAPH } },
|
||||
- { 0x17d, { MM_DIRECT, 1280, 960, 32, 8, 16, SEG_GRAPH } },
|
||||
{ 0x17e, { MM_DIRECT, 1440, 900, 16, 8, 16, SEG_GRAPH } },
|
||||
{ 0x17f, { MM_DIRECT, 1440, 900, 24, 8, 16, SEG_GRAPH } },
|
||||
- { 0x180, { MM_DIRECT, 1440, 900, 32, 8, 16, SEG_GRAPH } },
|
||||
{ 0x181, { MM_DIRECT, 1400, 1050, 16, 8, 16, SEG_GRAPH } },
|
||||
{ 0x182, { MM_DIRECT, 1400, 1050, 24, 8, 16, SEG_GRAPH } },
|
||||
- { 0x183, { MM_DIRECT, 1400, 1050, 32, 8, 16, SEG_GRAPH } },
|
||||
{ 0x184, { MM_DIRECT, 1680, 1050, 16, 8, 16, SEG_GRAPH } },
|
||||
{ 0x185, { MM_DIRECT, 1680, 1050, 24, 8, 16, SEG_GRAPH } },
|
||||
- { 0x186, { MM_DIRECT, 1680, 1050, 32, 8, 16, SEG_GRAPH } },
|
||||
{ 0x187, { MM_DIRECT, 1920, 1200, 16, 8, 16, SEG_GRAPH } },
|
||||
{ 0x188, { MM_DIRECT, 1920, 1200, 24, 8, 16, SEG_GRAPH } },
|
||||
- { 0x189, { MM_DIRECT, 1920, 1200, 32, 8, 16, SEG_GRAPH } },
|
||||
{ 0x18a, { MM_DIRECT, 2560, 1600, 16, 8, 16, SEG_GRAPH } },
|
||||
{ 0x18b, { MM_DIRECT, 2560, 1600, 24, 8, 16, SEG_GRAPH } },
|
||||
- { 0x18c, { MM_DIRECT, 2560, 1600, 32, 8, 16, SEG_GRAPH } },
|
||||
{ 0x18d, { MM_DIRECT, 1280, 720, 16, 8, 16, SEG_GRAPH } },
|
||||
{ 0x18e, { MM_DIRECT, 1280, 720, 24, 8, 16, SEG_GRAPH } },
|
||||
- { 0x18f, { MM_DIRECT, 1280, 720, 32, 8, 16, SEG_GRAPH } },
|
||||
{ 0x190, { MM_DIRECT, 1920, 1080, 16, 8, 16, SEG_GRAPH } },
|
||||
{ 0x191, { MM_DIRECT, 1920, 1080, 24, 8, 16, SEG_GRAPH } },
|
||||
- { 0x192, { MM_DIRECT, 1920, 1080, 32, 8, 16, SEG_GRAPH } },
|
||||
|
||||
/* custom resolutions for 16:9 displays */
|
||||
{ 0x193, { MM_DIRECT, 1600, 900, 16, 8, 16, SEG_GRAPH } },
|
||||
--
|
||||
2.18.4
|
||||
|
@ -1,22 +0,0 @@
|
||||
# for qemu machine types 1.7 + older
|
||||
# need to turn off features (xhci,uas) to make it fit into 128k
|
||||
CONFIG_QEMU=y
|
||||
CONFIG_ROM_SIZE=128
|
||||
CONFIG_ATA_DMA=n
|
||||
CONFIG_BOOTSPLASH=n
|
||||
CONFIG_XEN=n
|
||||
CONFIG_USB_OHCI=n
|
||||
CONFIG_USB_XHCI=n
|
||||
CONFIG_USB_UAS=n
|
||||
CONFIG_SDCARD=n
|
||||
CONFIG_TCGBIOS=n
|
||||
CONFIG_MPT_SCSI=n
|
||||
CONFIG_ESP_SCSI=n
|
||||
CONFIG_MEGASAS=n
|
||||
CONFIG_PVSCSI=n
|
||||
CONFIG_NVME=n
|
||||
CONFIG_USE_SMM=n
|
||||
CONFIG_VGAHOOKS=n
|
||||
CONFIG_HOST_BIOS_GEOMETRY=n
|
||||
CONFIG_ACPI_PARSE=n
|
||||
CONFIG_SERCON=n
|
25
seabios.spec
25
seabios.spec
@ -1,23 +1,20 @@
|
||||
Name: seabios
|
||||
Version: 1.14.0
|
||||
Release: 7%{?dist}
|
||||
Version: 1.15.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Open-source legacy BIOS implementation
|
||||
|
||||
License: LGPLv3
|
||||
URL: https://www.coreboot.org/SeaBIOS
|
||||
|
||||
Source0: https://code.coreboot.org/p/seabios/downloads/get/seabios-1.14.0.tar.gz
|
||||
Source0: https://code.coreboot.org/p/seabios/downloads/get/seabios-1.15.0.tar.gz
|
||||
|
||||
Patch0002: 0002-Workaround-for-a-win8.1-32-S4-resume-bug.patch
|
||||
Patch0003: 0003-redhat-reserve-more-memory-on-fseg.patch
|
||||
Patch0004: 0004-vgabios-Reorder-video-modes-to-work-around-a-Windows.patch
|
||||
|
||||
# Source-git patches
|
||||
Patch0003: 0003-pci-let-firmware-reserve-IO-for-pcie-pci-bridge.patch
|
||||
Patch0004: 0004-pci-reserve-resources-for-pcie-pci-bridge-to-fix-reg.patch
|
||||
|
||||
Source10: config.vga-cirrus
|
||||
Source12: config.vga-qxl
|
||||
Source13: config.vga-stdvga
|
||||
Source17: config.seabios-128k
|
||||
Source18: config.seabios-256k
|
||||
Source19: config.vga-virtio
|
||||
Source20: config.vga-ramfb
|
||||
@ -107,7 +104,6 @@ build_bios() {
|
||||
}
|
||||
|
||||
# seabios
|
||||
build_bios %{_sourcedir}/config.seabios-128k bios.bin bios.bin
|
||||
build_bios %{_sourcedir}/config.seabios-256k bios.bin bios-256k.bin
|
||||
|
||||
|
||||
@ -122,7 +118,6 @@ done
|
||||
%install
|
||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/seabios
|
||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/seavgabios
|
||||
install -m 0644 binaries/bios.bin $RPM_BUILD_ROOT%{_datadir}/seabios/bios.bin
|
||||
install -m 0644 binaries/bios-256k.bin $RPM_BUILD_ROOT%{_datadir}/seabios/bios-256k.bin
|
||||
install -m 0644 binaries/vgabios*.bin $RPM_BUILD_ROOT%{_datadir}/seavgabios
|
||||
|
||||
@ -140,6 +135,16 @@ install -m 0644 binaries/vgabios*.bin $RPM_BUILD_ROOT%{_datadir}/seavgabios
|
||||
%{_datadir}/seavgabios/vgabios*.bin
|
||||
|
||||
%changelog
|
||||
* Fri Dec 17 2021 Miroslav Rezanina <mrezanin@redhat.com> - 1.15.0-1
|
||||
- Rebase to seabios to 1.15.0 [bz#2018393]
|
||||
- 0003-pci-let-firmware-reserve-IO-for-pcie-pci-bridge.patch [bz#2001732]
|
||||
- 0004-pci-reserve-resources-for-pcie-pci-bridge-to-fix-reg.patch [bz#2001732]
|
||||
- Resolves: bz#2018393
|
||||
([rebase] update seabios to nov '21 release)
|
||||
- Resolves: bz#2001732
|
||||
([virtual network][qemu-6.1.0-1] Fail to hotplug nic with rtl8139 driver)
|
||||
|
||||
|
||||
* Wed Sep 15 2021 Miroslav Rezanina <mrezanin@redhat.com> - 1.14.0-7
|
||||
- seabios-Drop-fedora-bits-they-are-not-tested-and-currently-f.patch [bz#2004169]
|
||||
- seabios-Disable-TPM-support.patch [bz#2004169]
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (seabios-1.14.0.tar.gz) = 215c42f59425f8abd062be7b11fc0e39c977cee5001a2381551b0f851ac337d0dd53c065267e6dee0e710ffd700fa635f9007b89da8dfce0f47122c984ee8146
|
||||
SHA512 (seabios-1.15.0.tar.gz) = f894025043aab7d9b0f513216f7abc99904405838632c48b2f0e9c0c09533022cfdef9216082814a941ab0d513d1b02d3b103133ab3aba0fd0f82e96138125fc
|
||||
|
Loading…
Reference in New Issue
Block a user