Update to 1.13.0
Signed-off-by: Cole Robinson <crobinso@redhat.com>
This commit is contained in:
parent
1256a6f0de
commit
a9b600b0a0
1
.gitignore
vendored
1
.gitignore
vendored
@ -26,3 +26,4 @@ seabios-0.6.0.tar.gz
|
||||
/seabios-1.11.2.tar.gz
|
||||
/seabios-1.12.0.tar.gz
|
||||
/seabios-1.12.1.tar.xz
|
||||
/seabios-1.13.0.tar.gz
|
||||
|
@ -33,18 +33,15 @@ generate crash dumps.
|
||||
|
||||
Signed-off-by: Ladi Prosek <lprosek@redhat.com>
|
||||
Signed-off-by: Miroslav Rezanina <mrezanin@redhat.com>
|
||||
---
|
||||
vgasrc/bochsvga.c | 39 ++++++++++++++++++++-------------------
|
||||
1 file changed, 20 insertions(+), 19 deletions(-)
|
||||
|
||||
diff --git a/vgasrc/bochsvga.c b/vgasrc/bochsvga.c
|
||||
index ec5d101..c5d1511 100644
|
||||
--- a/vgasrc/bochsvga.c
|
||||
+++ b/vgasrc/bochsvga.c
|
||||
@@ -28,6 +28,25 @@ static struct bochsvga_mode
|
||||
u16 mode;
|
||||
struct vgamode_s info;
|
||||
} bochsvga_modes[] VAR16 = {
|
||||
diff --git a/vgasrc/svgamodes.c b/vgasrc/svgamodes.c
|
||||
index 6e494c7..008f1b9 100644
|
||||
--- a/vgasrc/svgamodes.c
|
||||
+++ b/vgasrc/svgamodes.c
|
||||
@@ -12,6 +12,25 @@
|
||||
#include "svgamodes.h"
|
||||
|
||||
struct generic_svga_mode svga_modes[] VAR16 = {
|
||||
+ /* 32 bpp BOCHS modes */
|
||||
+ { 0x140, { MM_DIRECT, 320, 200, 32, 8, 16, SEG_GRAPH } },
|
||||
+ { 0x141, { MM_DIRECT, 640, 400, 32, 8, 16, SEG_GRAPH } },
|
||||
@ -67,11 +64,10 @@ index ec5d101..c5d1511 100644
|
||||
/* standard modes */
|
||||
{ 0x100, { MM_PACKED, 640, 400, 8, 8, 16, SEG_GRAPH } },
|
||||
{ 0x101, { MM_PACKED, 640, 480, 8, 8, 16, SEG_GRAPH } },
|
||||
@@ -56,50 +75,32 @@ static struct bochsvga_mode
|
||||
{ 0x11D, { MM_DIRECT, 1600, 1200, 15, 8, 16, SEG_GRAPH } },
|
||||
@@ -41,49 +60,32 @@ struct generic_svga_mode svga_modes[] VAR16 = {
|
||||
{ 0x11E, { MM_DIRECT, 1600, 1200, 16, 8, 16, SEG_GRAPH } },
|
||||
{ 0x11F, { MM_DIRECT, 1600, 1200, 24, 8, 16, SEG_GRAPH } },
|
||||
- /* BOCHS modes */
|
||||
/* other modes */
|
||||
- { 0x140, { MM_DIRECT, 320, 200, 32, 8, 16, SEG_GRAPH } },
|
||||
- { 0x141, { MM_DIRECT, 640, 400, 32, 8, 16, SEG_GRAPH } },
|
||||
- { 0x142, { MM_DIRECT, 640, 480, 32, 8, 16, SEG_GRAPH } },
|
||||
@ -116,9 +112,6 @@ index ec5d101..c5d1511 100644
|
||||
{ 0x190, { MM_DIRECT, 1920, 1080, 16, 8, 16, SEG_GRAPH } },
|
||||
{ 0x191, { MM_DIRECT, 1920, 1080, 24, 8, 16, SEG_GRAPH } },
|
||||
- { 0x192, { MM_DIRECT, 1920, 1080, 32, 8, 16, SEG_GRAPH } },
|
||||
};
|
||||
|
||||
static int dispi_found VAR16 = 0;
|
||||
--
|
||||
1.8.3.1
|
||||
|
||||
/* custom resolutions for 16:9 displays */
|
||||
{ 0x193, { MM_DIRECT, 1600, 900, 16, 8, 16, SEG_GRAPH } },
|
||||
|
11
seabios.spec
11
seabios.spec
@ -3,15 +3,15 @@
|
||||
%endif
|
||||
|
||||
Name: seabios
|
||||
Version: 1.12.1
|
||||
Release: 3%{?dist}
|
||||
Version: 1.13.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Open-source legacy BIOS implementation
|
||||
|
||||
License: LGPLv3
|
||||
URL: http://www.coreboot.org/SeaBIOS
|
||||
|
||||
#Source0: http://code.coreboot.org/p/seabios/downloads/get/{name}-{version}.tar.gz
|
||||
Source0: %{name}-%{version}.tar.xz
|
||||
Source0: http://code.coreboot.org/p/seabios/downloads/get/%{name}-%{version}.tar.gz
|
||||
#Source0: %%{name}-%%{version}.tar.xz
|
||||
|
||||
Patch0001: 0001-Workaround-for-a-win8.1-32-S4-resume-bug.patch
|
||||
Patch0002: 0002-reserve-more-memory-on-fseg.patch
|
||||
@ -158,6 +158,9 @@ install -m 0644 binaries/vgabios*.bin $RPM_BUILD_ROOT%{_datadir}/seavgabios
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Dec 09 2019 Cole Robinson <aintdiscole@gmail.com> - 1.13.0-1
|
||||
- Update to 1.13.0
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.12.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (seabios-1.12.1.tar.xz) = 9cff995868b338a668e0cd78a382828c80a11dd36193502a45cbef6b2c8c207c198c76ffb9d7a299306f5cb1c981bd5b6d5456900e67b8622324da0763917a21
|
||||
SHA512 (seabios-1.13.0.tar.gz) = 167ae289b140486b99e27444718096c3359ce4dc55ca9d6ffccdac85053e7f0af2d02e0af0b313c0a8814a313a3c7c5b47a428aa2c30b1c63b2eea90f8b4f368
|
||||
|
Loading…
Reference in New Issue
Block a user