Stop advertising S3 and S4 in DSDT (bz#704467)

Conflicts:

	seabios.spec
This commit is contained in:
Paolo Bonzini 2012-03-21 23:27:31 +01:00
parent 9c63fd69eb
commit 8c17f83f51
2 changed files with 75 additions and 2 deletions

View File

@ -0,0 +1,65 @@
From 526d703a74752b66fd54ac4a9133a3de31c90549 Mon Sep 17 00:00:00 2001
From: Gleb Natapov <gleb@redhat.com>
Date: Sun, 11 Sep 2011 09:05:50 +0200
Subject: [PATCH] do not advertise S4/S3 in DSDT
RH-Author: Gleb Natapov <gleb@redhat.com>
Message-id: <20110911090550.GF21417@redhat.com>
Patchwork-id: 32631
O-Subject: [PATCHv2 RHEL6.2 SEABIOS] do not advertise S4/S3 in DSDT
Bugzilla: 736522
RH-Acked-by: Gerd Hoffmann <kraxel@redhat.com>
RH-Acked-by: Marcelo Tosatti <mtosatti@redhat.com>
RH-Acked-by: Markus Armbruster <armbru@redhat.com>
To compile Seabios with PM support run make "DSDT_CPP_FLAGS=-DDSDT_PM"
BZ: 736522
Upstream: local patch
Signed-off-by: Gleb Natapov <gleb@redhat.com>
--
Gleb.
Signed-off-by: Michal Novotny <minovotn@redhat.com>
---
Makefile | 2 +-
src/acpi-dsdt.dsl | 2 ++
2 files changed, 3 insertions(+), 1 deletions(-)
diff --git a/Makefile b/Makefile
index b185ac8..f5c7104 100644
--- a/Makefile
+++ b/Makefile
@@ -186,7 +186,7 @@ $(OUT)vgabios.bin: $(OUT)vgabios.bin.raw tools/buildrom.py
####### dsdt build rules
src/%.hex: src/%.dsl
@echo "Compiling DSDT"
- $(Q)cpp -P $< > $(OUT)$*.dsl.i
+ $(Q)cpp $(DSDT_CPP_FLAGS) -P $< > $(OUT)$*.dsl.i
$(Q)iasl -tc -p $(OUT)$* $(OUT)$*.dsl.i
$(Q)cp $(OUT)$*.hex $@
diff --git a/src/acpi-dsdt.dsl b/src/acpi-dsdt.dsl
index b54c558..1db5ae9 100644
--- a/src/acpi-dsdt.dsl
+++ b/src/acpi-dsdt.dsl
@@ -722,6 +722,7 @@ DefinitionBlock (
}
}
+#ifdef DSDT_PM
/*
* S3 (suspend-to-ram), S4 (suspend-to-disk) and S5 (power-off) type codes:
* must match piix4 emulation.
@@ -740,6 +741,7 @@ DefinitionBlock (
Zero, /* reserved */
Zero /* reserved */
})
+#endif
Name (\_S5, Package (0x04)
{
Zero, /* PM1a_CNT.SLP_TYP */
--
1.7.4.4

View File

@ -1,6 +1,6 @@
Name: seabios
Version: 0.6.1
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Open-source legacy BIOS implementation
Group: Applications/Emulators
@ -8,9 +8,11 @@ License: LGPLv3
URL: http://www.coreboot.org/SeaBIOS
Source0: http://www.linuxtogo.org/~kevin/SeaBIOS/%{name}-%{version}.tar.gz
Patch00: seabios-do-not-advertise-S4-S3-in-DSDT.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: python
BuildRequires: python iasl
ExclusiveArch: %{ix86} x86_64
Requires: %{name}-bin = %{version}-%{release}
@ -38,6 +40,8 @@ that a typical x86 proprietary BIOS implements.
%prep
%setup -q
%patch00 -p1
# Makefile changes version to include date and buildhost
sed -i 's,VERSION=%{version}.*,VERSION=%{version},g' Makefile
@ -74,6 +78,10 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Wed Mar 21 2012 Paolo Bonzini <pbonzini@redhat.com> - 0.6.1-2
- Stop advertising S3 and S4 in DSDT (bz#704467)
- incdule iasl buildreq
* Mon Feb 14 2011 Justin M. forbes <jforbes@redhat.com> - 0.6.1-1
- Update to 0.6.1 upstream for a number of bugfixes