update to 1.6.3 upstream

This commit is contained in:
Justin M. Forbes 2012-02-08 14:06:34 -06:00
parent 51ef0b6e51
commit 6960463bf1
7 changed files with 1595 additions and 72 deletions

1
.gitignore vendored
View File

@ -1,3 +1,4 @@
seabios-0.5.1.tar.gz
seabios-0.6.0.tar.gz
/seabios-0.6.2.tar.gz
/seabios-1.6.3.tar.gz

View File

@ -1,49 +0,0 @@
diff -ruNp seabios-0.6.2.orig/Makefile seabios-0.6.2/Makefile
--- seabios-0.6.2.orig/Makefile 2011-07-13 10:52:50.000000000 -0500
+++ seabios-0.6.2/Makefile 2011-07-13 11:14:14.000000000 -0500
@@ -5,7 +5,7 @@
# This file may be distributed under the terms of the GNU LGPLv3 license.
# Program version
-VERSION=0.6.2-$(shell date +"%Y%m%d_%H%M%S")-$(shell hostname)
+VERSION=0.6.2
# Output directory
OUT=out/
diff -ruNp seabios-0.6.2.orig/src/ahci.c seabios-0.6.2/src/ahci.c
--- seabios-0.6.2.orig/src/ahci.c 2011-07-13 10:52:50.000000000 -0500
+++ seabios-0.6.2/src/ahci.c 2011-07-13 11:14:14.000000000 -0500
@@ -408,7 +408,6 @@ static void
ahci_detect(void *data)
{
struct ahci_ctrl_s *ctrl = data;
- struct ahci_port_s *port;
u32 pnr, max;
int rc;
@@ -422,7 +421,7 @@ ahci_detect(void *data)
dprintf(1, "AHCI/%d: link %s\n", pnr, rc == 0 ? "up" : "down");
if (rc != 0)
continue;
- port = ahci_port_init(ctrl, pnr);
+ ahci_port_init(ctrl, pnr);
}
}
diff -ruNp seabios-0.6.2.orig/src/bregs.h seabios-0.6.2/src/bregs.h
--- seabios-0.6.2.orig/src/bregs.h 2011-07-13 10:52:50.000000000 -0500
+++ seabios-0.6.2/src/bregs.h 2011-07-13 11:16:04.000000000 -0500
@@ -37,9 +37,9 @@
struct bregs {
u16 ds;
u16 es;
- UREG(edi, di, di_hi, di_lo);
- UREG(esi, si, si_hi, si_lo);
- UREG(ebp, bp, bp_hi, bp_lo);
+ UREG(edi, di, di8u, di8l);
+ UREG(esi, si, si8u, si8l);
+ UREG(ebp, bp, bp8u, bp8l);
UREG(ebx, bx, bh, bl);
UREG(edx, dx, dh, dl);
UREG(ecx, cx, ch, cl);
Binary files seabios-0.6.2.orig/tools/layoutrom.pyc and seabios-0.6.2/tools/layoutrom.pyc differ

View File

@ -1,17 +0,0 @@
Beware that seabios 0.6.2 is broken for QXL. You need to apply this
patch
diff --git a/src/config.h b/src/config.h
index e6e07c9..cd71c3a 100644
--- a/src/config.h
+++ b/src/config.h
@@ -51,7 +51,7 @@
#define BUILD_PCIPREFMEM_END 0
#else
#define BUILD_PCIMEM_START 0xf0000000
-#define BUILD_PCIMEM_SIZE 0x08000000 /* half- of pci window */
+#define BUILD_PCIMEM_SIZE 0x09000000 /* half- of pci window */
#define BUILD_PCIMEM_END (BUILD_PCIMEM_START + BUILD_PCIMEM_SIZE)
#define BUILD_PCIPREFMEM_START BUILD_PCIMEM_END
#define BUILD_PCIPREFMEM_SIZE (BUILD_PCIPREFMEM_END - BUILD_PCIPREFMEM_START)

View File

@ -0,0 +1,27 @@
commit a3fea015398d7c41db5b5d348fe3f6d76236b6be
Author: Paolo Bonzini <pbonzini@redhat.com>
Date: Fri Nov 18 15:59:24 2011 +0100
usb: fix boot paths
The fw paths for USB devices that SeaBIOS computes are off-by-one,
because QEMU builds those paths with a numbering that starts from one
(see usb_fill_port and usb_hub_initfn in QEMU). Fix that so that
the numbering agrees.
diff --git a/src/boot.c b/src/boot.c
index 119f290..93928d3 100644
--- a/src/boot.c
+++ b/src/boot.c
@@ -191,9 +191,9 @@ int bootprio_find_usb(struct pci_device *pci, u64 path)
for (i=56; i>0; i-=8) {
int port = (path >> i) & 0xff;
if (port != 0xff)
- p += snprintf(p, desc+sizeof(desc)-p, "/hub@%x", port);
+ p += snprintf(p, desc+sizeof(desc)-p, "/hub@%x", port+1);
}
- snprintf(p, desc+sizeof(desc)-p, "/*@%x", (u32)(path & 0xff));
+ snprintf(p, desc+sizeof(desc)-p, "/*@%x", (u32)(path & 0xff)+1);
return find_prio(desc);
}

1557
seabios-virtio-scsi.patch Normal file

File diff suppressed because it is too large Load Diff

View File

@ -1,6 +1,6 @@
Name: seabios
Version: 0.6.2
Release: 4%{?dist}
Version: 1.6.3
Release: 1%{?dist}
Summary: Open-source legacy BIOS implementation
Group: Applications/Emulators
@ -8,9 +8,9 @@ License: LGPLv3
URL: http://www.coreboot.org/SeaBIOS
Source0: http://www.linuxtogo.org/~kevin/SeaBIOS/%{name}-%{version}.tar.gz
Patch00: seabios-0.6.2-build.patch
Patch01: seabios-0.6.2-fix-QXL.patch
Patch02: seabios-do-not-advertise-S4-S3-in-DSDT.patch
Patch00: seabios-usb_fix_boot_paths.patch
Patch01: seabios-do-not-advertise-S4-S3-in-DSDT.patch
Patch02: seabios-virtio-scsi.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -82,6 +82,10 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Wed Feb 08 2012 Justin M. Forbes <jforbes@redhat.com> - 1.6.3-1
- Update to 1.6.3 upstream
- Add virtio-scsi
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.2-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild

View File

@ -1 +1 @@
ec58d93b93fa29550164693f714c9320 seabios-0.6.2.tar.gz
d7cd612ff34f9b910a63c2d73b25eef3 seabios-1.6.3.tar.gz