Stop advertising S3 and S4 in DSDT (bz#741375)

This commit is contained in:
Justin M. Forbes 2011-10-05 21:16:30 -05:00
parent f2a4e67030
commit 66f7090d85
2 changed files with 73 additions and 2 deletions

View File

@ -0,0 +1,65 @@
From 526d703a74752b66fd54ac4a9133a3de31c90549 Mon Sep 17 00:00:00 2001
From: Gleb Natapov <gleb@redhat.com>
Date: Sun, 11 Sep 2011 09:05:50 +0200
Subject: [PATCH] do not advertise S4/S3 in DSDT
RH-Author: Gleb Natapov <gleb@redhat.com>
Message-id: <20110911090550.GF21417@redhat.com>
Patchwork-id: 32631
O-Subject: [PATCHv2 RHEL6.2 SEABIOS] do not advertise S4/S3 in DSDT
Bugzilla: 736522
RH-Acked-by: Gerd Hoffmann <kraxel@redhat.com>
RH-Acked-by: Marcelo Tosatti <mtosatti@redhat.com>
RH-Acked-by: Markus Armbruster <armbru@redhat.com>
To compile Seabios with PM support run make "DSDT_CPP_FLAGS=-DDSDT_PM"
BZ: 736522
Upstream: local patch
Signed-off-by: Gleb Natapov <gleb@redhat.com>
--
Gleb.
Signed-off-by: Michal Novotny <minovotn@redhat.com>
---
Makefile | 2 +-
src/acpi-dsdt.dsl | 2 ++
2 files changed, 3 insertions(+), 1 deletions(-)
diff --git a/Makefile b/Makefile
index b185ac8..f5c7104 100644
--- a/Makefile
+++ b/Makefile
@@ -186,7 +186,7 @@ $(OUT)vgabios.bin: $(OUT)vgabios.bin.raw tools/buildrom.py
####### dsdt build rules
src/%.hex: src/%.dsl
@echo "Compiling DSDT"
- $(Q)cpp -P $< > $(OUT)$*.dsl.i
+ $(Q)cpp $(DSDT_CPP_FLAGS) -P $< > $(OUT)$*.dsl.i
$(Q)iasl -tc -p $(OUT)$* $(OUT)$*.dsl.i
$(Q)cp $(OUT)$*.hex $@
diff --git a/src/acpi-dsdt.dsl b/src/acpi-dsdt.dsl
index b54c558..1db5ae9 100644
--- a/src/acpi-dsdt.dsl
+++ b/src/acpi-dsdt.dsl
@@ -722,6 +722,7 @@ DefinitionBlock (
}
}
+#ifdef DSDT_PM
/*
* S3 (suspend-to-ram), S4 (suspend-to-disk) and S5 (power-off) type codes:
* must match piix4 emulation.
@@ -740,6 +741,7 @@ DefinitionBlock (
Zero, /* reserved */
Zero /* reserved */
})
+#endif
Name (\_S5, Package (0x04)
{
Zero, /* PM1a_CNT.SLP_TYP */
--
1.7.4.4

View File

@ -1,6 +1,6 @@
Name: seabios Name: seabios
Version: 0.6.2 Version: 0.6.2
Release: 2%{?dist} Release: 3%{?dist}
Summary: Open-source legacy BIOS implementation Summary: Open-source legacy BIOS implementation
Group: Applications/Emulators Group: Applications/Emulators
@ -10,10 +10,11 @@ Source0: http://www.linuxtogo.org/~kevin/SeaBIOS/%{name}-%{version}.tar.g
Patch00: seabios-0.6.2-build.patch Patch00: seabios-0.6.2-build.patch
Patch01: seabios-0.6.2-fix-QXL.patch Patch01: seabios-0.6.2-fix-QXL.patch
Patch02: seabios-do-not-advertise-S4-S3-in-DSDT.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: python BuildRequires: python iasl
ExclusiveArch: %{ix86} x86_64 ExclusiveArch: %{ix86} x86_64
Requires: %{name}-bin = %{version}-%{release} Requires: %{name}-bin = %{version}-%{release}
@ -43,6 +44,7 @@ that a typical x86 proprietary BIOS implements.
%patch00 -p1 %patch00 -p1
%patch01 -p1 %patch01 -p1
%patch02 -p1
# Makefile changes version to include date and buildhost # Makefile changes version to include date and buildhost
sed -i 's,VERSION=%{version}.*,VERSION=%{version},g' Makefile sed -i 's,VERSION=%{version}.*,VERSION=%{version},g' Makefile
@ -80,6 +82,10 @@ rm -rf $RPM_BUILD_ROOT
%changelog %changelog
* Wed Oct 05 2011 Justin M. Forbes <jforbes@redhat.com> - 0.6.2-3
- Stop advertising S3 and S4 in DSDT (bz#741375)
- incdule iasl buildreq
* Wed Jul 13 2011 Justin M. Forbes <jforbes@redhat.com> - 0.6.2-2 * Wed Jul 13 2011 Justin M. Forbes <jforbes@redhat.com> - 0.6.2-2
- Fix QXL bug in 0.6.2 - Fix QXL bug in 0.6.2