import seabios-1.15.0-1.el9
This commit is contained in:
commit
50e7c39c1b
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/seabios-1.15.0.tar.gz
|
1
.seabios.metadata
Normal file
1
.seabios.metadata
Normal file
@ -0,0 +1 @@
|
||||
1ab1ca5971e59d8d6b5c579b242d586e54a86873 SOURCES/seabios-1.15.0.tar.gz
|
64
SOURCES/0002-Workaround-for-a-win8.1-32-S4-resume-bug.patch
Normal file
64
SOURCES/0002-Workaround-for-a-win8.1-32-S4-resume-bug.patch
Normal file
@ -0,0 +1,64 @@
|
||||
From 10883a49e78ba83e3667e4386b8f11b4aa18ddb2 Mon Sep 17 00:00:00 2001
|
||||
From: Radim Krcmar <rkrcmar@redhat.com>
|
||||
Date: Mon, 10 Mar 2014 15:14:27 +0100
|
||||
Subject: Workaround for a win8.1-32 S4 resume bug
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
RH-Author: Radim Krcmar <rkrcmar@redhat.com>
|
||||
Message-id: <1394464467-23560-1-git-send-email-rkrcmar@redhat.com>
|
||||
Patchwork-id: 58069
|
||||
O-Subject: [RHEL7.0 seabios PATCH] Workaround for a win8.1-32 S4 resume bug
|
||||
Bugzilla: 1050775
|
||||
RH-Acked-by: Paolo Bonzini <pbonzini@redhat.com>
|
||||
RH-Acked-by: Gerd Hoffmann <kraxel@redhat.com>
|
||||
RH-Acked-by: Laszlo Ersek <lersek@redhat.com>
|
||||
|
||||
bug: https://bugzilla.redhat.com/show_bug.cgi?id=1050775
|
||||
brew: http://brewweb.devel.redhat.com/brew/taskinfo?taskID=7176174
|
||||
This patch has no upstream equivalent.
|
||||
|
||||
When a 32 bit version of windows 8.1 resumes from suspend, it writes 1
|
||||
into 0x72 in the early boot because it didn't expect a NULL pointer.
|
||||
0x72 is lower offset byte of 0x1c interrupt entry, so we jump into a
|
||||
middle of other function if this interrupt is triggered.
|
||||
|
||||
Because 0x1c is only triggered from our handle_08, we detect if our
|
||||
default value (function that does only iret) has its lower offset byte
|
||||
overwritten and skip it in that case.
|
||||
(Windows never sets own callback there, so we always detect this bug
|
||||
correctly, as seabios doesn't use it either
|
||||
Other sources shouldn't incorrectly overwrite it or use seabios code,
|
||||
but it is quite ok even if the guest did this on purpose.)
|
||||
|
||||
The reason Windows uses NULL pointer is still unknown, but this bug is
|
||||
blocking WHQL certification, so we have to work around it in 7.0.
|
||||
|
||||
Signed-off-by: Radim Krčmář <rkrcmar@redhat.com>
|
||||
---
|
||||
src/clock.c | 8 +++++++-
|
||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/clock.c b/src/clock.c
|
||||
index e44e1120..298a7229 100644
|
||||
--- a/src/clock.c
|
||||
+++ b/src/clock.c
|
||||
@@ -309,7 +309,13 @@ handle_08(void)
|
||||
struct bregs br;
|
||||
memset(&br, 0, sizeof(br));
|
||||
br.flags = F_IF;
|
||||
- call16_int(0x1c, &br);
|
||||
+ struct segoff_s isr1c = GET_IVT(0x1c);
|
||||
+ // hardcoded address of entry_iret_official with lower segment byte
|
||||
+ // overwritten by 1
|
||||
+ if (isr1c.seg == ((SEG_BIOS & ~0xff) | 0x1) && isr1c.offset == 0xff53)
|
||||
+ dprintf(1, "Worked around win8.1-32 S4 resume bug\n");
|
||||
+ else
|
||||
+ call16_int(0x1c, &br);
|
||||
|
||||
pic_eoi1();
|
||||
}
|
||||
--
|
||||
2.27.0
|
||||
|
@ -0,0 +1,90 @@
|
||||
From 87689162d5203522a8e089bb0e46302a07c77301 Mon Sep 17 00:00:00 2001
|
||||
From: Igor Mammedov <imammedo@redhat.com>
|
||||
Date: Mon, 29 Nov 2021 06:48:12 -0500
|
||||
Subject: pci: let firmware reserve IO for pcie-pci-bridge
|
||||
|
||||
RH-Bugzilla: 2001732
|
||||
|
||||
With [1] patch hotplug of rtl8139 succeeds, with caveat that it
|
||||
fails to initialize IO bar, which is caused by [2] that makes
|
||||
firmware skip IO reservation for any PCIe device, which isn't
|
||||
correct in case of pcie-pci-bridge.
|
||||
Fix it by exposing hotplug type and making IO resource optional
|
||||
only if PCIe hotplug is in use.
|
||||
|
||||
[1]
|
||||
"pci: reserve resources for pcie-pci-bridge to fix regressed hotplug on q35"
|
||||
[2]
|
||||
|
||||
Fixes: 76327b9f32a ("fw/pci: do not automatically allocate IO region for PCIe bridges")
|
||||
Signed-off-by: Igor Mammedov imammedo@redhat.com
|
||||
CC: mapfelba@redhat.com
|
||||
CC: kraxel@redhat.com
|
||||
CC: mst@redhat.com
|
||||
CC: lvivier@redhat.com
|
||||
CC: jusual@redhat.com
|
||||
Tested-by: Laurent Vivier <lvivier@redhat.com>
|
||||
Acked-by: Michael S. Tsirkin <mst@redhat.com>
|
||||
Message-Id: <20211129114812.231849-3-imammedo@redhat.com>
|
||||
Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
|
||||
---
|
||||
src/fw/pciinit.c | 19 ++++++++++++++-----
|
||||
1 file changed, 14 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/src/fw/pciinit.c b/src/fw/pciinit.c
|
||||
index d25931bb..3c99d514 100644
|
||||
--- a/src/fw/pciinit.c
|
||||
+++ b/src/fw/pciinit.c
|
||||
@@ -793,7 +793,13 @@ pci_region_create_entry(struct pci_bus *bus, struct pci_device *dev,
|
||||
return entry;
|
||||
}
|
||||
|
||||
-static int pci_bus_hotplug_support(struct pci_bus *bus, u8 pcie_cap)
|
||||
+typedef enum hotplug_type_t {
|
||||
+ HOTPLUG_NO_SUPPORTED = 0,
|
||||
+ HOTPLUG_PCIE,
|
||||
+ HOTPLUG_SHPC
|
||||
+} hotplug_type_t;
|
||||
+
|
||||
+static hotplug_type_t pci_bus_hotplug_support(struct pci_bus *bus, u8 pcie_cap)
|
||||
{
|
||||
u8 shpc_cap;
|
||||
|
||||
@@ -815,11 +821,12 @@ static int pci_bus_hotplug_support(struct pci_bus *bus, u8 pcie_cap)
|
||||
*/
|
||||
u16 slot_implemented = pcie_flags & PCI_EXP_FLAGS_SLOT;
|
||||
|
||||
- return downstream_port && slot_implemented;
|
||||
+ return downstream_port && slot_implemented ?
|
||||
+ HOTPLUG_PCIE : HOTPLUG_NO_SUPPORTED;
|
||||
}
|
||||
|
||||
shpc_cap = pci_find_capability(bus->bus_dev->bdf, PCI_CAP_ID_SHPC, 0);
|
||||
- return !!shpc_cap;
|
||||
+ return !!shpc_cap ? HOTPLUG_SHPC : HOTPLUG_NO_SUPPORTED;
|
||||
}
|
||||
|
||||
/* Test whether bridge support forwarding of transactions
|
||||
@@ -904,7 +911,7 @@ static int pci_bios_check_devices(struct pci_bus *busses)
|
||||
u8 pcie_cap = pci_find_capability(bdf, PCI_CAP_ID_EXP, 0);
|
||||
u8 qemu_cap = pci_find_resource_reserve_capability(bdf);
|
||||
|
||||
- int hotplug_support = pci_bus_hotplug_support(s, pcie_cap);
|
||||
+ hotplug_type_t hotplug_support = pci_bus_hotplug_support(s, pcie_cap);
|
||||
for (type = 0; type < PCI_REGION_TYPE_COUNT; type++) {
|
||||
u64 align = (type == PCI_REGION_TYPE_IO) ?
|
||||
PCI_BRIDGE_IO_MIN : PCI_BRIDGE_MEM_MIN;
|
||||
@@ -948,7 +955,9 @@ static int pci_bios_check_devices(struct pci_bus *busses)
|
||||
if (pci_region_align(&s->r[type]) > align)
|
||||
align = pci_region_align(&s->r[type]);
|
||||
u64 sum = pci_region_sum(&s->r[type]);
|
||||
- int resource_optional = pcie_cap && (type == PCI_REGION_TYPE_IO);
|
||||
+ int resource_optional = 0;
|
||||
+ if (hotplug_support == HOTPLUG_PCIE)
|
||||
+ resource_optional = pcie_cap && (type == PCI_REGION_TYPE_IO);
|
||||
if (!sum && hotplug_support && !resource_optional)
|
||||
sum = align; /* reserve min size for hot-plug */
|
||||
if (size > sum) {
|
||||
--
|
||||
2.27.0
|
||||
|
@ -0,0 +1,83 @@
|
||||
From ded76fad62293d5dbe4eebf30d3b19c9eb8330de Mon Sep 17 00:00:00 2001
|
||||
From: Igor Mammedov <imammedo@redhat.com>
|
||||
Date: Mon, 29 Nov 2021 06:48:11 -0500
|
||||
Subject: pci: reserve resources for pcie-pci-bridge to fix regressed hotplug
|
||||
on q35
|
||||
|
||||
RH-Bugzilla: 2001732
|
||||
|
||||
If QEMU is started with unpopulated pcie-pci-bridge with ACPI PCI
|
||||
hotplug enabled (default since QEMU-6.1), hotplugging a PCI device
|
||||
into one of the bridge slots fails due to lack of resources.
|
||||
|
||||
once linux guest is booted (test used Fedora 34), hotplug NIC from
|
||||
QEMU monitor:
|
||||
(qemu) device_add rtl8139,bus=pcie-pci-bridge-0,addr=0x2
|
||||
|
||||
guest fails hotplug with:
|
||||
pci 0000:01:02.0: [10ec:8139] type 00 class 0x020000
|
||||
pci 0000:01:02.0: reg 0x10: [io 0x0000-0x00ff]
|
||||
pci 0000:01:02.0: reg 0x14: [mem 0x00000000-0x000000ff]
|
||||
pci 0000:01:02.0: reg 0x30: [mem 0x00000000-0x0003ffff pref]
|
||||
pci 0000:01:02.0: BAR 6: no space for [mem size 0x00040000 pref]
|
||||
pci 0000:01:02.0: BAR 6: failed to assign [mem size 0x00040000 pref]
|
||||
pci 0000:01:02.0: BAR 0: no space for [io size 0x0100]
|
||||
pci 0000:01:02.0: BAR 0: failed to assign [io size 0x0100]
|
||||
pci 0000:01:02.0: BAR 1: no space for [mem size 0x00000100]
|
||||
pci 0000:01:02.0: BAR 1: failed to assign [mem size 0x00000100]
|
||||
8139cp: 8139cp: 10/100 PCI Ethernet driver v1.3 (Mar 22, 2004)
|
||||
PCI Interrupt Link [GSIG] enabled at IRQ 22
|
||||
8139cp 0000:01:02.0: no MMIO resource
|
||||
8139cp: probe of 0000:01:02.0 failed with error -5
|
||||
|
||||
Reason for this is that commit [1] didn't take into account
|
||||
pcie-pci-bridge, marking bridge as non hotpluggable instead of
|
||||
handling it as possibly SHPC capable bridge.
|
||||
Fix issue by checking if pcie-pci-bridge is SHPC capable and
|
||||
if it is mark it as hotpluggable.
|
||||
|
||||
Fixes regression in QEMU-6.1 and later, since it was switched
|
||||
to ACPI based PCI hotplug on Q35 by default at that time.
|
||||
|
||||
[1]
|
||||
Fixes: 3aa31d7d637 ("hw/pci: reserve IO and mem for pci express downstream ports with no devices attached")
|
||||
Signed-off-by: Igor Mammedov imammedo@redhat.com
|
||||
CC: mapfelba@redhat.com
|
||||
CC: kraxel@redhat.com
|
||||
CC: mst@redhat.com
|
||||
CC: lvivier@redhat.com
|
||||
CC: jusual@redhat.com
|
||||
Tested-by: Laurent Vivier <lvivier@redhat.com>
|
||||
Acked-by: Michael S. Tsirkin <mst@redhat.com>
|
||||
Message-Id: <20211129114812.231849-2-imammedo@redhat.com>
|
||||
Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
|
||||
---
|
||||
src/fw/pciinit.c | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/src/fw/pciinit.c b/src/fw/pciinit.c
|
||||
index 3c99d514..badf13d3 100644
|
||||
--- a/src/fw/pciinit.c
|
||||
+++ b/src/fw/pciinit.c
|
||||
@@ -808,6 +808,10 @@ static hotplug_type_t pci_bus_hotplug_support(struct pci_bus *bus, u8 pcie_cap)
|
||||
pcie_cap + PCI_EXP_FLAGS);
|
||||
u8 port_type = ((pcie_flags & PCI_EXP_FLAGS_TYPE) >>
|
||||
(__builtin_ffs(PCI_EXP_FLAGS_TYPE) - 1));
|
||||
+
|
||||
+ if (port_type == PCI_EXP_TYPE_PCI_BRIDGE)
|
||||
+ goto check_shpc;
|
||||
+
|
||||
u8 downstream_port = (port_type == PCI_EXP_TYPE_DOWNSTREAM) ||
|
||||
(port_type == PCI_EXP_TYPE_ROOT_PORT);
|
||||
/*
|
||||
@@ -825,6 +829,7 @@ static hotplug_type_t pci_bus_hotplug_support(struct pci_bus *bus, u8 pcie_cap)
|
||||
HOTPLUG_PCIE : HOTPLUG_NO_SUPPORTED;
|
||||
}
|
||||
|
||||
+check_shpc:
|
||||
shpc_cap = pci_find_capability(bus->bus_dev->bdf, PCI_CAP_ID_SHPC, 0);
|
||||
return !!shpc_cap ? HOTPLUG_SHPC : HOTPLUG_NO_SUPPORTED;
|
||||
}
|
||||
--
|
||||
2.27.0
|
||||
|
4
SOURCES/config.seabios-256k
Normal file
4
SOURCES/config.seabios-256k
Normal file
@ -0,0 +1,4 @@
|
||||
# for qemu machine types 2.0 + newer
|
||||
CONFIG_QEMU=y
|
||||
CONFIG_ROM_SIZE=256
|
||||
CONFIG_ATA_DMA=n
|
3
SOURCES/config.vga-bochs-display
Normal file
3
SOURCES/config.vga-bochs-display
Normal file
@ -0,0 +1,3 @@
|
||||
CONFIG_BUILD_VGABIOS=y
|
||||
CONFIG_DISPLAY_BOCHS=y
|
||||
CONFIG_VGA_PCI=y
|
3
SOURCES/config.vga-cirrus
Normal file
3
SOURCES/config.vga-cirrus
Normal file
@ -0,0 +1,3 @@
|
||||
CONFIG_BUILD_VGABIOS=y
|
||||
CONFIG_VGA_CIRRUS=y
|
||||
CONFIG_VGA_PCI=y
|
6
SOURCES/config.vga-qxl
Normal file
6
SOURCES/config.vga-qxl
Normal file
@ -0,0 +1,6 @@
|
||||
CONFIG_BUILD_VGABIOS=y
|
||||
CONFIG_VGA_BOCHS=y
|
||||
CONFIG_VGA_PCI=y
|
||||
CONFIG_OVERRIDE_PCI_ID=y
|
||||
CONFIG_VGA_VID=0x1b36
|
||||
CONFIG_VGA_DID=0x0100
|
3
SOURCES/config.vga-ramfb
Normal file
3
SOURCES/config.vga-ramfb
Normal file
@ -0,0 +1,3 @@
|
||||
CONFIG_BUILD_VGABIOS=y
|
||||
CONFIG_VGA_RAMFB=y
|
||||
CONFIG_VGA_PCI=n
|
3
SOURCES/config.vga-stdvga
Normal file
3
SOURCES/config.vga-stdvga
Normal file
@ -0,0 +1,3 @@
|
||||
CONFIG_BUILD_VGABIOS=y
|
||||
CONFIG_VGA_BOCHS=y
|
||||
CONFIG_VGA_PCI=y
|
6
SOURCES/config.vga-virtio
Normal file
6
SOURCES/config.vga-virtio
Normal file
@ -0,0 +1,6 @@
|
||||
CONFIG_BUILD_VGABIOS=y
|
||||
CONFIG_VGA_BOCHS=y
|
||||
CONFIG_VGA_PCI=y
|
||||
CONFIG_OVERRIDE_PCI_ID=y
|
||||
CONFIG_VGA_VID=0x1af4
|
||||
CONFIG_VGA_DID=0x1050
|
418
SPECS/seabios.spec
Normal file
418
SPECS/seabios.spec
Normal file
@ -0,0 +1,418 @@
|
||||
Name: seabios
|
||||
Version: 1.15.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Open-source legacy BIOS implementation
|
||||
|
||||
License: LGPLv3
|
||||
URL: https://www.coreboot.org/SeaBIOS
|
||||
|
||||
Source0: https://code.coreboot.org/p/seabios/downloads/get/seabios-1.15.0.tar.gz
|
||||
|
||||
Patch0002: 0002-Workaround-for-a-win8.1-32-S4-resume-bug.patch
|
||||
Patch0003: 0003-pci-let-firmware-reserve-IO-for-pcie-pci-bridge.patch
|
||||
Patch0004: 0004-pci-reserve-resources-for-pcie-pci-bridge-to-fix-reg.patch
|
||||
|
||||
Source10: config.vga-cirrus
|
||||
Source12: config.vga-qxl
|
||||
Source13: config.vga-stdvga
|
||||
Source18: config.seabios-256k
|
||||
Source19: config.vga-virtio
|
||||
Source20: config.vga-ramfb
|
||||
Source21: config.vga-bochs-display
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: gcc
|
||||
BuildRequires: python3 iasl
|
||||
|
||||
ExclusiveArch: x86_64
|
||||
|
||||
Requires: %{name}-bin = %{version}-%{release}
|
||||
Requires: seavgabios-bin = %{version}-%{release}
|
||||
|
||||
# Seabios is noarch, but required on architectures which cannot build it.
|
||||
# Disable debuginfo because it is of no use to us.
|
||||
%global debug_package %{nil}
|
||||
|
||||
# Similarly, tell RPM to not complain about x86 roms being shipped noarch
|
||||
%global _binaries_in_noarch_packages_terminate_build 0
|
||||
|
||||
# You can build a debugging version of the BIOS by setting this to a
|
||||
# value > 1. See src/config.h for possible values, but setting it to
|
||||
# a number like 99 will enable all possible debugging. Note that
|
||||
# debugging goes to a special qemu port that you have to enable. See
|
||||
# the SeaBIOS top-level README file for the magic qemu invocation to
|
||||
# enable this.
|
||||
%global debug_level 1
|
||||
|
||||
|
||||
%description
|
||||
SeaBIOS is an open-source legacy BIOS implementation which can be used as
|
||||
a coreboot payload. It implements the standard BIOS calling interfaces
|
||||
that a typical x86 proprietary BIOS implements.
|
||||
|
||||
|
||||
%package bin
|
||||
Summary: Seabios for x86
|
||||
Buildarch: noarch
|
||||
|
||||
|
||||
%description bin
|
||||
SeaBIOS is an open-source legacy BIOS implementation which can be used as
|
||||
a coreboot payload. It implements the standard BIOS calling interfaces
|
||||
that a typical x86 proprietary BIOS implements.
|
||||
|
||||
|
||||
%package -n seavgabios-bin
|
||||
Summary: Seavgabios for x86
|
||||
Buildarch: noarch
|
||||
|
||||
%description -n seavgabios-bin
|
||||
SeaVGABIOS is an open-source VGABIOS implementation.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%autopatch -p1
|
||||
|
||||
%build
|
||||
%define _lto_cflags %{nil}
|
||||
export CFLAGS="$RPM_OPT_FLAGS"
|
||||
mkdir binaries
|
||||
|
||||
build_bios() {
|
||||
make PYTHON=%{__python3} clean distclean
|
||||
cp $1 .config
|
||||
echo "CONFIG_TCGBIOS=n" >> .config
|
||||
echo "CONFIG_DEBUG_LEVEL=%{debug_level}" >> .config
|
||||
make PYTHON=%{__python3} oldnoconfig V=1 EXTRAVERSION="-%release"
|
||||
|
||||
make V=1 \
|
||||
EXTRAVERSION="-%{release}" \
|
||||
PYTHON=%{__python3} \
|
||||
%if 0%{?cross:1}
|
||||
HOSTCC=gcc \
|
||||
CC=x86_64-linux-gnu-gcc \
|
||||
AS=x86_64-linux-gnu-as \
|
||||
LD=x86_64-linux-gnu-ld \
|
||||
OBJCOPY=x86_64-linux-gnu-objcopy \
|
||||
OBJDUMP=x86_64-linux-gnu-objdump \
|
||||
STRIP=x86_64-linux-gnu-strip \
|
||||
%endif
|
||||
$4
|
||||
|
||||
cp out/$2 binaries/$3
|
||||
}
|
||||
|
||||
# seabios
|
||||
build_bios %{_sourcedir}/config.seabios-256k bios.bin bios-256k.bin
|
||||
|
||||
|
||||
# seavgabios
|
||||
%global vgaconfigs cirrus qxl stdvga virtio ramfb bochs-display
|
||||
for config in %{vgaconfigs}; do
|
||||
build_bios %{_sourcedir}/config.vga-${config} \
|
||||
vgabios.bin vgabios-${config}.bin out/vgabios.bin
|
||||
done
|
||||
|
||||
|
||||
%install
|
||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/seabios
|
||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/seavgabios
|
||||
install -m 0644 binaries/bios-256k.bin $RPM_BUILD_ROOT%{_datadir}/seabios/bios-256k.bin
|
||||
install -m 0644 binaries/vgabios*.bin $RPM_BUILD_ROOT%{_datadir}/seavgabios
|
||||
|
||||
|
||||
%files
|
||||
%doc COPYING COPYING.LESSER README
|
||||
|
||||
|
||||
%files bin
|
||||
%dir %{_datadir}/seabios/
|
||||
%{_datadir}/seabios/bios*.bin
|
||||
|
||||
%files -n seavgabios-bin
|
||||
%dir %{_datadir}/seavgabios/
|
||||
%{_datadir}/seavgabios/vgabios*.bin
|
||||
|
||||
%changelog
|
||||
* Fri Dec 17 2021 Miroslav Rezanina <mrezanin@redhat.com> - 1.15.0-1
|
||||
- Rebase to seabios to 1.15.0 [bz#2018393]
|
||||
- 0003-pci-let-firmware-reserve-IO-for-pcie-pci-bridge.patch [bz#2001732]
|
||||
- 0004-pci-reserve-resources-for-pcie-pci-bridge-to-fix-reg.patch [bz#2001732]
|
||||
- Resolves: bz#2018393
|
||||
([rebase] update seabios to nov '21 release)
|
||||
- Resolves: bz#2001732
|
||||
([virtual network][qemu-6.1.0-1] Fail to hotplug nic with rtl8139 driver)
|
||||
|
||||
|
||||
* Wed Sep 15 2021 Miroslav Rezanina <mrezanin@redhat.com> - 1.14.0-7
|
||||
- seabios-Drop-fedora-bits-they-are-not-tested-and-currently-f.patch [bz#2004169]
|
||||
- seabios-Disable-TPM-support.patch [bz#2004169]
|
||||
- Resolves: bz#2004169
|
||||
(seabios implements and/or uses the deprecated SHA-1 algorithm by default)
|
||||
|
||||
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 1.14.0-6
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Mon Jun 28 2021 Miroslav Rezanina <mrezanin@redhat.com> - 1.14.0-5
|
||||
- seabios-Disable-power-support.patch [bz#1951027]
|
||||
- Resolves: bz#1951027
|
||||
(SeaBios no longer needed for ppc64)
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 1.14.0-4
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Wed Feb 10 2021 Miroslav Rezanina <mrezanin@redhat.com> - 1.14.0-3
|
||||
- Update to include in RHEL 9 compose
|
||||
- Resolves: rhbz#1926095
|
||||
(qemu-kvm not available for ppc64le)
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.14.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Tue Nov 24 2020 Cole Robinson <aintdiscole@gmail.com> - 1.14.0-1
|
||||
- Update to 1.14.0
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.13.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.13.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Mon Dec 09 2019 Cole Robinson <aintdiscole@gmail.com> - 1.13.0-1
|
||||
- Update to 1.13.0
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.12.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Thu Jul 11 2019 Cole Robinson <aintdiscole@gmail.com> - 1.12.1-2
|
||||
- Add config.vga-ati from qemu 4.1
|
||||
|
||||
* Wed Mar 27 2019 Cole Robinson <aintdiscole@gmail.com> - 1.12.1-1
|
||||
- Update to 1.12.1 for qemu 4.0
|
||||
|
||||
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.12.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Sat Nov 17 2018 Cole Robinson <crobinso@redhat.com> - 1.12.0-1
|
||||
- Rebase to version 1.12.0 for qemu-3.1.0
|
||||
|
||||
* Tue Jul 24 2018 Cole Robinson <crobinso@redhat.com> - 1.11.2-1
|
||||
- Rebased to version 1.11.2
|
||||
- Add BuildRequires: gcc (bz #1606326)
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.11.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Thu Mar 22 2018 Cole Robinson <crobinso@redhat.com> - 1.11.1-1
|
||||
- Rebased to version 1.11.1
|
||||
|
||||
* Mon Mar 19 2018 Paolo Bonzini <pbonzini@redhat.com> - 1.11.0-2
|
||||
- Build with Python 3
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.11.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Fri Nov 17 2017 Paolo Bonzini <pbonzini@redhat.com> - 1.11.0-1
|
||||
- Rebased to version 1.11.0
|
||||
- Add three patches from RHEL
|
||||
|
||||
* Fri Nov 17 2017 Paolo Bonzini <pbonzini@redhat.com> - 1.10.2-3
|
||||
- Disable cross-compilation on RHEL
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Wed Mar 15 2017 Cole Robinson <crobinso@redhat.com> - 1.10.2-1
|
||||
- Rebased to version 1.10.2
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Sun Dec 04 2016 Cole Robinson <crobinso@redhat.com> - 1.10.1-1
|
||||
- Rebased to version 1.10.1
|
||||
|
||||
* Wed Aug 03 2016 Cole Robinson <crobinso@redhat.com> - 1.9.3-1
|
||||
- Rebased to version 1.9.3
|
||||
|
||||
* Thu Mar 24 2016 Paolo Bonzini <pbonzini@redhat.com> - 1.9.1-3
|
||||
- Include MPT Fusion driver, in preparation for QEMU 2.6
|
||||
- Include XHCI and SD in 128k ROM, sacrifice bootsplash instead
|
||||
|
||||
* Thu Mar 17 2016 Cole Robinson <crobinso@redhat.com> - 1.9.1-1
|
||||
- Rebased to version 1.9.1
|
||||
- Fix incorrect UUID format in boot output (bz #1284259)
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.9.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Tue Nov 17 2015 Cole Robinson <crobinso@redhat.com> 1.9.0-1
|
||||
- Rebased to version 1.9.0
|
||||
|
||||
* Tue Jul 14 2015 Cole Robinson <crobinso@redhat.com> 1.8.2-1
|
||||
- Rebased to version 1.8.2
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Wed Mar 18 2015 Cole Robinson <crobinso@redhat.com> - 1.8.1-1
|
||||
- Rebased to version 1.8.1
|
||||
|
||||
* Sat Feb 21 2015 Cole Robinson <crobinso@redhat.com> - 1.8.0-1
|
||||
- Rebased to version 1.8.0
|
||||
- Initial support for USB3 hubs
|
||||
- Initial support for SD cards (on QEMU only)
|
||||
- Initial support for transitioning to 32bit mode using SMIs (on QEMU TCG
|
||||
only)
|
||||
- SeaVGABIOS improvements
|
||||
|
||||
* Sat Nov 15 2014 Cole Robinson <crobinso@redhat.com> - 1.7.5.1-1
|
||||
- Update to seabios-1.7.5.1
|
||||
|
||||
* Wed Jul 09 2014 Cole Robinson <crobinso@redhat.com> - 1.7.5-3
|
||||
- Fix PCI-e hotplug (bz #1115598)
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Sat May 31 2014 Cole Robinson <crobinso@redhat.com> - 1.7.5-1
|
||||
- Rebased to version 1.7.5
|
||||
- Support for obtaining SMBIOS tables directly from QEMU.
|
||||
- XHCI USB controller fixes for real hardware
|
||||
- seavgabios: New driver for "coreboot native vga" support
|
||||
- seavgabios: Improved detection of x86emu versions with incorrect
|
||||
emulation.
|
||||
- Several bug fixes and code cleanups
|
||||
|
||||
* Wed Mar 26 2014 Matthias Clasen <mclasen@redhat.com> 1.7.4-5
|
||||
- Fix booting FreeBSD VMs in virt-manager
|
||||
|
||||
* Mon Mar 17 2014 Cole Robinson <crobinso@redhat.com> 1.7.4-3
|
||||
- Build 256k bios images for qemu 2.0
|
||||
|
||||
* Thu Mar 13 2014 Cole Robinson <crobinso@redhat.com> - 1.7.4-2
|
||||
- Fix kvm migration with empty virtio-scsi controller (bz #1032208)
|
||||
|
||||
* Mon Jan 06 2014 Cole Robinson <crobinso@redhat.com> - 1.7.4-1
|
||||
- Rebased to version 1.7.4
|
||||
- Support for obtaining ACPI tables directly from QEMU.
|
||||
- Initial support for XHCI USB controllers (initially for QEMU only).
|
||||
- Support for booting from "pvscsi" devices on QEMU.
|
||||
- Enhanced floppy driver - improved support for real hardware.
|
||||
- coreboot cbmem console support.
|
||||
|
||||
* Tue Nov 19 2013 Cole Robinson <crobinso@redhat.com> - 1.7.3.2-1
|
||||
- Update to 1.7.3.2 for qemu 1.7
|
||||
|
||||
* Thu Nov 14 2013 Paolo Bonzini <pbonzini@redhat.com> - 1.7.3.1-3
|
||||
- Fix pasto in CONFIG_DEBUG_LEVEL.
|
||||
|
||||
* Thu Nov 14 2013 Paolo Bonzini <pbonzini@redhat.com> - 1.7.3.1-2
|
||||
- Compile as all three of BIOS, CSM and CoreBoot payload.
|
||||
|
||||
* Wed Aug 14 2013 Cole Robinson <crobinso@redhat.com> - 1.7.3.1-1
|
||||
- Rebased to version 1.7.3.1
|
||||
- Fix USB EHCI detection that was broken in hlist conversion of
|
||||
PCIDevices.
|
||||
- Fix bug in CBFS file walking with compressed files.
|
||||
- acpi: sync FADT flags from PIIX4 to Q35
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Tue Jul 09 2013 Cole Robinson <crobinso@redhat.com> - 1.7.3-2
|
||||
- Install aml files for use by qemu
|
||||
|
||||
* Mon Jul 08 2013 Cole Robinson <crobinso@redhat.com> - 1.7.3-1
|
||||
- Rebased to version 1.7.3
|
||||
- Initial support for using SeaBIOS as a UEFI CSM
|
||||
- Support for detecting and using ACPI reboot ports.
|
||||
- Non-standard floppy sizes now work again with recent QEMU versions.
|
||||
- Several bug fixes and code cleanups
|
||||
- Again fix vgabios obsoletes (bz #981147)
|
||||
|
||||
* Mon May 27 2013 Cole Robinson <crobinso@redhat.com> - 1.7.2.2-1
|
||||
- Update to seabios stable 1.7.2.2
|
||||
- Obsolete vgabios (bz #967315)
|
||||
|
||||
* Thu Jan 24 2013 Cole Robinson <crobinso@redhat.com> - 1.7.2-1
|
||||
- Rebased to version 1.7.2
|
||||
- Support for ICH9 host chipset ("q35") on emulators
|
||||
- Support for booting from LSI MegaRAID SAS controllers
|
||||
- Support for using the ACPI PM timer on emulators
|
||||
- Improved Geode VGA BIOS support.
|
||||
- Several bug fixes
|
||||
|
||||
* Thu Dec 6 2012 Peter Robinson <pbrobinson@fedoraproject.org> 1.7.1-4
|
||||
- Root seabios package is noarch too because it only contains docs
|
||||
|
||||
* Fri Oct 19 2012 Cole Robinson <crobinso@redhat.com> - 1.7.1-3
|
||||
- Add seavgabios subpackage
|
||||
|
||||
* Wed Oct 17 2012 Paolo Bonzini <pbonzini@redhat.com> - 1.7.1-2
|
||||
- Build with cross compiler. Resolves: #866664.
|
||||
|
||||
* Wed Sep 05 2012 Cole Robinson <crobinso@redhat.com> - 1.7.1-1
|
||||
- Rebased to version 1.7.1
|
||||
- Initial support for booting from USB attached scsi (USB UAS) drives
|
||||
- USB EHCI 64bit controller support
|
||||
- USB MSC multi-LUN device support
|
||||
- Support for booting from LSI SCSI controllers on emulators
|
||||
- Support for booting from AMD PCscsi controllers on emulators
|
||||
|
||||
* Mon Aug 13 2012 Richard W.M. Jones <rjones@redhat.com> - 1.7.0-4
|
||||
- Modernise and tidy up the RPM.
|
||||
- Allow debug versions of SeaBIOS to be built easily.
|
||||
|
||||
* Mon Aug 06 2012 Cole Robinson <crobinso@redhat.com> - 1.7.0-3
|
||||
- Enable S3/S4 support for guests (it's an F18 feature after all)
|
||||
|
||||
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Mon May 28 2012 Cole Robinson <crobinso@redhat.com> - 1.7.0-1
|
||||
- Rebased to version 1.7.0
|
||||
- Support for virtio-scsi
|
||||
- Improved USB drive support
|
||||
- Several USB controller bug fixes and improvements
|
||||
|
||||
* Wed Mar 28 2012 Paolo Bonzini <pbonzini@redhat.com> - 1.6.3-2
|
||||
- Fix bugs in booting from host (or redirected) USB pen drives
|
||||
|
||||
* Wed Feb 08 2012 Justin M. Forbes <jforbes@redhat.com> - 1.6.3-1
|
||||
- Update to 1.6.3 upstream
|
||||
- Add virtio-scsi
|
||||
|
||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.2-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Wed Oct 05 2011 Justin M. Forbes <jforbes@redhat.com> - 0.6.2-3
|
||||
- Stop advertising S3 and S4 in DSDT (bz#741375)
|
||||
- incdule iasl buildreq
|
||||
|
||||
* Wed Jul 13 2011 Justin M. Forbes <jforbes@redhat.com> - 0.6.2-2
|
||||
- Fix QXL bug in 0.6.2
|
||||
|
||||
* Wed Jul 13 2011 Justin M. forbes <jforbes@redhat.com> - 0.6.2-1
|
||||
- Update to 0.6.2 upstream for a number of bugfixes
|
||||
|
||||
* Mon Feb 14 2011 Justin M. forbes <jforbes@redhat.com> - 0.6.1-1
|
||||
- Update to 0.6.1 upstream for a number of bugfixes
|
||||
|
||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Tue Aug 10 2010 Justin M. Forbes <jforbes@redhat.com> 0.6.0-1
|
||||
- Update seabios to latest stable so we can drop patches.
|
||||
|
||||
* Tue Apr 20 2010 Justin M. Forbes <jforbes@redhat.com> 0.5.1-2
|
||||
- Ugly hacks to make package noarch and available for arch that cannot build it.
|
||||
- Disable useless debuginfo
|
||||
|
||||
* Wed Mar 03 2010 Justin M. Forbes <jforbes@redhat.com> 0.5.1-1
|
||||
- Update to 0.5.1 stable release
|
||||
- Pick up patches required for current qemu
|
||||
|
||||
* Thu Jan 07 2010 Justin M. Forbes <jforbes@redhat.com> 0.5.1-0.1.20100108git669c991
|
||||
- Created initial package
|
Loading…
Reference in New Issue
Block a user