Enable S3/S4 support for guests (it's an F18 feature after all)

This commit is contained in:
Cole Robinson 2012-08-06 19:25:59 -04:00
parent 5be931076d
commit 209d0d8266
2 changed files with 4 additions and 36 deletions

View File

@ -1,31 +0,0 @@
diff -rup seabios-1.7.0/Makefile mysea/Makefile
--- seabios-1.7.0/Makefile 2012-05-28 16:53:27.898842738 -0400
+++ mysea/Makefile 2012-05-28 16:50:37.307644939 -0400
@@ -221,7 +221,7 @@ $(OUT)vgabios.bin: $(OUT)vgabios.bin.raw
src/%.hex: src/%.dsl ./tools/acpi_extract_preprocess.py ./tools/acpi_extract.py
@echo "Compiling DSDT"
- $(Q)cpp -P $< > $(OUT)$*.dsl.i.orig
+ $(Q)cpp $(DSDT_CPP_FLAGS) -P $< > $(OUT)$*.dsl.i.orig
$(Q)$(PYTHON) ./tools/acpi_extract_preprocess.py $(OUT)$*.dsl.i.orig > $(OUT)$*.dsl.i
$(Q)iasl -l -tc -p $(OUT)$* $(OUT)$*.dsl.i
$(Q)$(PYTHON) ./tools/acpi_extract.py $(OUT)$*.lst > $(OUT)$*.off
diff -rup seabios-1.7.0/src/acpi-dsdt.dsl mysea/src/acpi-dsdt.dsl
--- seabios-1.7.0/src/acpi-dsdt.dsl 2012-04-14 22:27:40.000000000 -0400
+++ mysea/src/acpi-dsdt.dsl 2012-05-28 16:52:11.745575415 -0400
@@ -609,6 +609,7 @@ DefinitionBlock (
* Suspend
****************************************************************/
+#ifdef DSDT_PM
/*
* S3 (suspend-to-ram), S4 (suspend-to-disk) and S5 (power-off) type codes:
* must match piix4 emulation.
@@ -627,6 +628,7 @@ DefinitionBlock (
Zero, /* reserved */
Zero /* reserved */
})
+#endif
Name (\_S5, Package (0x04)
{
Zero, /* PM1a_CNT.SLP_TYP */

View File

@ -1,15 +1,12 @@
Name: seabios
Version: 1.7.0
Release: 2%{?dist}
Release: 3%{?dist}
Summary: Open-source legacy BIOS implementation
Group: Applications/Emulators
License: LGPLv3
URL: http://www.coreboot.org/SeaBIOS
Source0: http://www.linuxtogo.org/~kevin/SeaBIOS/%{name}-%{version}.tar.gz
# Don't advertise guest support for S3/S4 (bz 741375)
# keep: Non upstream, carry it until someone needs s3/s4
Patch1: %{name}-do-not-advertise-S4-S3-in-DSDT.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -41,7 +38,6 @@ that a typical x86 proprietary BIOS implements.
%prep
%setup -q
%patch1 -p1
# Makefile changes version to include date and buildhost
@ -80,6 +76,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Mon Aug 06 2012 Cole Robinson <crobinso@redhat.com> - 1.7.0-3
- Enable S3/S4 support for guests (it's an F18 feature after all)
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild