Import rpm: 686d41d5a67cdeb65c77fbe0d2f1f4764d051f6a
This commit is contained in:
parent
60278f3e20
commit
172b127caa
@ -1,17 +1,19 @@
|
||||
From d1e13b6d631a45882471efcbe367c690e1698b42 Mon Sep 17 00:00:00 2001
|
||||
From a35645ca4985b8fdd4f4d8c4d87ae05001061c53 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Volker=20R=C3=BCmelin?= <vr_qemu@t-online.de>
|
||||
Date: Sat, 2 Apr 2022 20:28:38 +0200
|
||||
Subject: [PATCH 1/2] pci: refactor the pci_config_*() functions
|
||||
Subject: [PATCH 2/3] pci: refactor the pci_config_*() functions
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
RH-Author: Gerd Hoffmann <kraxel@redhat.com>
|
||||
RH-MergeRequest: 4: reset: force standard PCI configuration access
|
||||
RH-Commit: [1/2] 49093312e6cdddd301766fcfb91cf80260be3f05 (kraxel/centos-seabios)
|
||||
RH-Bugzilla: 2086407
|
||||
RH-Acked-by: Miroslav Rezanina <mrezanin@redhat.com>
|
||||
RH-MergeRequest: 7: pci: fix reset for q35 and tcg
|
||||
RH-Commit: [1/2] 7607f8f3296435a2884902f650ce060c6be07bd1
|
||||
RH-Bugzilla: 2083884
|
||||
RH-Acked-by: Pawel Polawski <ppolawsk@redhat.com>
|
||||
RH-Acked-by: Oliver Steffen <osteffen@redhat.com>
|
||||
RH-Acked-by: Igor Mammedov <imammedo@redhat.com>
|
||||
RH-Acked-by: Laszlo Ersek <lersek@redhat.com>
|
||||
|
||||
Split out the Standard PCI Configuration Access Mechanism
|
||||
pci_ioconfig_*() functions from the pci_config_*() functions.
|
||||
@ -168,5 +170,5 @@ index 01c51f70..ee6acafc 100644
|
||||
void pci_reboot(void);
|
||||
|
||||
--
|
||||
2.31.1
|
||||
2.35.3
|
||||
|
||||
|
@ -1,17 +1,19 @@
|
||||
From dbca6bf0626072c3b90ffe4f4c6e5db92814bd5d Mon Sep 17 00:00:00 2001
|
||||
From a7e5f1d8f1f874434f8b3e6d6eac784d5e3e3971 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Volker=20R=C3=BCmelin?= <vr_qemu@t-online.de>
|
||||
Date: Sat, 2 Apr 2022 20:28:39 +0200
|
||||
Subject: [PATCH 2/2] reset: force standard PCI configuration access
|
||||
Subject: [PATCH 3/3] reset: force standard PCI configuration access
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
RH-Author: Gerd Hoffmann <kraxel@redhat.com>
|
||||
RH-MergeRequest: 4: reset: force standard PCI configuration access
|
||||
RH-Commit: [2/2] 70fa6dd1d546a03a3b44e438f84682325f5ee029 (kraxel/centos-seabios)
|
||||
RH-Bugzilla: 2086407
|
||||
RH-Acked-by: Miroslav Rezanina <mrezanin@redhat.com>
|
||||
RH-MergeRequest: 7: pci: fix reset for q35 and tcg
|
||||
RH-Commit: [2/2] 693fbb9148c81f344dc9f64e7a36e51b42ee1a95
|
||||
RH-Bugzilla: 2083884
|
||||
RH-Acked-by: Pawel Polawski <ppolawsk@redhat.com>
|
||||
RH-Acked-by: Oliver Steffen <osteffen@redhat.com>
|
||||
RH-Acked-by: Igor Mammedov <imammedo@redhat.com>
|
||||
RH-Acked-by: Laszlo Ersek <lersek@redhat.com>
|
||||
|
||||
After a reset of a QEMU -machine q35 guest, the PCI Express
|
||||
Enhanced Configuration Mechanism is disabled and the variable
|
||||
@ -153,5 +155,5 @@ index ee6acafc..b2f5baf4 100644
|
||||
// PCI configuration access using either PCI CAM or PCIe ECAM
|
||||
void pci_config_writel(u16 bdf, u32 addr, u32 val);
|
||||
--
|
||||
2.31.1
|
||||
2.35.3
|
||||
|
||||
|
40
seabios-shortcut-skip-unbootable-disks-optimitation.patch
Normal file
40
seabios-shortcut-skip-unbootable-disks-optimitation.patch
Normal file
@ -0,0 +1,40 @@
|
||||
From 27b924ad88b53c1bff736d144b90ce655087d1a5 Mon Sep 17 00:00:00 2001
|
||||
From: Gerd Hoffmann <kraxel@redhat.com>
|
||||
Date: Fri, 29 Oct 2021 11:19:10 +0200
|
||||
Subject: [PATCH 1/3] shortcut skip-unbootable-disks optimitation
|
||||
|
||||
RH-Author: Gerd Hoffmann <kraxel@redhat.com>
|
||||
RH-MergeRequest: 6: shortcut skip-unbootable-disks optimitation
|
||||
RH-Commit: [1/1] 95008c119b45b4a360caa4a7733420d72aec99cb
|
||||
RH-Bugzilla: 2073012
|
||||
RH-Acked-by: Laszlo Ersek <lersek@redhat.com>
|
||||
RH-Acked-by: Oliver Steffen <osteffen@redhat.com>
|
||||
RH-Acked-by: Pawel Polawski <ppolawsk@redhat.com>
|
||||
---
|
||||
src/boot.c | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/src/boot.c b/src/boot.c
|
||||
index 1effd802..b18e7788 100644
|
||||
--- a/src/boot.c
|
||||
+++ b/src/boot.c
|
||||
@@ -297,11 +297,16 @@ find_prio(const char *glob)
|
||||
|
||||
u8 is_bootprio_strict(void)
|
||||
{
|
||||
+#if 0
|
||||
static int prio_halt = -2;
|
||||
|
||||
if (prio_halt == -2)
|
||||
prio_halt = find_prio("HALT");
|
||||
return prio_halt >= 0;
|
||||
+#else
|
||||
+ // force initializing all disks
|
||||
+ return 0;
|
||||
+#endif
|
||||
}
|
||||
|
||||
int bootprio_find_pci_device(struct pci_device *pci)
|
||||
--
|
||||
2.35.3
|
||||
|
@ -1,12 +1,12 @@
|
||||
From 7ef00c50cafaf356b9aef5f7c7865b405de6b2f5 Mon Sep 17 00:00:00 2001
|
||||
From 88e527d9fbbbe8d05e45f6db8a151d22e7f973d3 Mon Sep 17 00:00:00 2001
|
||||
From: Gerd Hoffmann <kraxel@redhat.com>
|
||||
Date: Thu, 30 Jun 2022 17:28:40 +0200
|
||||
Subject: [PATCH] virtio-blk: use larger default request size
|
||||
|
||||
RH-Author: Gerd Hoffmann <kraxel@redhat.com>
|
||||
RH-MergeRequest: 5: virtio-blk: use larger default request size
|
||||
RH-Commit: [1/1] 5b2833de23fdab9fc3c170e448e9ed07d9fb82dd (kraxel/centos-seabios)
|
||||
RH-Bugzilla: 2108555
|
||||
RH-MergeRequest: 8: virtio-blk: use larger default request size
|
||||
RH-Commit: [1/1] df68a35a0d02fb91f61eca9e9342ae5f13f99803
|
||||
RH-Bugzilla: 2101787
|
||||
RH-Acked-by: Oliver Steffen <osteffen@redhat.com>
|
||||
RH-Acked-by: Pawel Polawski <ppolawsk@redhat.com>
|
||||
RH-Acked-by: Miroslav Rezanina <mrezanin@redhat.com>
|
||||
|
28
seabios.spec
28
seabios.spec
@ -1,6 +1,6 @@
|
||||
Name: seabios
|
||||
Version: 1.16.0
|
||||
Release: 1%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: Open-source legacy BIOS implementation
|
||||
|
||||
Group: Applications/Emulators
|
||||
@ -22,6 +22,14 @@ Source21: config.seabios-256k
|
||||
Patch0002: 0002-allow-1TB-of-RAM.patch
|
||||
Patch0003: 0003-smbios-set-bios-vendor-version-fields-to-Seabios-0.5.patch
|
||||
Patch0004: 0004-Workaround-for-a-win8.1-32-S4-resume-bug.patch
|
||||
# For bz#2073012 - Guest whose os is installed multiple disks but boot partition is installed on single disk can't boot into OS on RHEL 8 [rhel-8.7.0]
|
||||
Patch5: seabios-shortcut-skip-unbootable-disks-optimitation.patch
|
||||
# For bz#2083884 - qemu reboot problem with seabios 1.16.0
|
||||
Patch6: seabios-pci-refactor-the-pci_config_-functions.patch
|
||||
# For bz#2083884 - qemu reboot problem with seabios 1.16.0
|
||||
Patch7: seabios-reset-force-standard-PCI-configuration-access.patch
|
||||
# For bz#2101787 - [rhel.8.7] Loading a kernel/initrd is sometimes very slow
|
||||
Patch8: seabios-virtio-blk-use-larger-default-request-size.patch
|
||||
|
||||
BuildRequires: python3 iasl
|
||||
ExclusiveArch: x86_64 %{power64}
|
||||
@ -76,6 +84,10 @@ SeaVGABIOS is an open-source VGABIOS implementation.
|
||||
%patch0002 -p1
|
||||
%patch0003 -p1
|
||||
%patch0004 -p1
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch8 -p1
|
||||
|
||||
%build
|
||||
%ifarch x86_64
|
||||
@ -134,6 +146,20 @@ install -m 0644 binaries/vgabios*.bin $RPM_BUILD_ROOT%{_datadir}/seavgabios
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jul 27 2022 Miroslav Rezanina <mrezanin@redhat.com> - 1.16.0-3
|
||||
- seabios-virtio-blk-use-larger-default-request-size.patch [bz#2101787]
|
||||
- Resolves: bz#2101787
|
||||
([rhel.8.7] Loading a kernel/initrd is sometimes very slow)
|
||||
|
||||
* Mon May 30 2022 Jon Maloy <jmaloy@redhat.com> - 1.16.0-2
|
||||
- seabios-shortcut-skip-unbootable-disks-optimitation.patch [bz#2073012]
|
||||
- seabios-pci-refactor-the-pci_config_-functions.patch [bz#2083884]
|
||||
- seabios-reset-force-standard-PCI-configuration-access.patch [bz#2083884]
|
||||
- Resolves: bz#2073012
|
||||
(Guest whose os is installed multiple disks but boot partition is installed on single disk can't boot into OS on RHEL 8 [rhel-8.7.0])
|
||||
- Resolves: bz#2083884
|
||||
(qemu reboot problem with seabios 1.16.0)
|
||||
|
||||
* Tue Apr 26 2022 Paweł Poławski <ppolawsk@redhat.com> - 1.16.0-1
|
||||
- Rebase to upstream 1.16 tag [bz#2066828]
|
||||
- Resolves: bz#2066828
|
||||
|
Loading…
Reference in New Issue
Block a user