d046e745cb
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/scotch#003eab6126457924871d59c9170816d983c85bf7
69 lines
2.8 KiB
Diff
69 lines
2.8 KiB
Diff
diff -rupN --no-dereference scotch_6.1.0/src/esmumps/Makefile scotch_6.1.0-new/src/esmumps/Makefile
|
|
--- scotch_6.1.0/src/esmumps/Makefile 2020-09-03 14:04:40.000000000 +0200
|
|
+++ scotch_6.1.0-new/src/esmumps/Makefile 2020-09-08 11:33:53.230226763 +0200
|
|
@@ -184,7 +184,7 @@ esmumps_strats$(OBJ) : esmumps_strats.c
|
|
esmumps.h
|
|
|
|
libesmumps$(LIB) : $(LIBESMUMPSDEPS)
|
|
- $(AR) $(ARFLAGS) $(@) $(?)
|
|
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS)
|
|
-$(RANLIB) $(@)
|
|
|
|
main_esmumps$(EXE) : main_esmumps.c \
|
|
diff -rupN --no-dereference scotch_6.1.0/src/libscotch/Makefile scotch_6.1.0-new/src/libscotch/Makefile
|
|
--- scotch_6.1.0/src/libscotch/Makefile 2020-09-03 13:48:31.000000000 +0200
|
|
+++ scotch_6.1.0-new/src/libscotch/Makefile 2020-09-08 11:33:53.231226835 +0200
|
|
@@ -3121,26 +3121,26 @@ ptscotchf.h : ptdummysizes$(EXE) \
|
|
library_pt_f.h
|
|
./ptdummysizes$(EXE) "-s$(SCOTCH_NAME_SUFFIX)" library_pt_f.h ptscotchf.h
|
|
|
|
-libscotch$(LIB) : $(LIBSCOTCHDEPS)
|
|
- $(AR) $(ARFLAGS) $(@) $(?)
|
|
+libscotch$(LIB) : $(LIBSCOTCHDEPS) libscotcherr$(LIB)
|
|
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS) -L . -lscotcherr
|
|
-$(RANLIB) $(@)
|
|
|
|
libscotcherr$(LIB) : library_error$(OBJ)
|
|
- $(AR) $(ARFLAGS) $(@) $(?)
|
|
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS)
|
|
-$(RANLIB) $(@)
|
|
|
|
libscotcherrexit$(LIB) : library_error_exit$(OBJ)
|
|
- $(AR) $(ARFLAGS) $(@) $(?)
|
|
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS)
|
|
-$(RANLIB) $(@)
|
|
|
|
-libptscotch$(LIB) : $(LIBPTSCOTCHDEPS)
|
|
- $(AR) $(ARFLAGS) $(@) $(?)
|
|
+libptscotch$(LIB) : $(LIBPTSCOTCHDEPS) libscotch$(LIB)
|
|
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS) -L . -lscotch
|
|
-$(RANLIB) $(@)
|
|
|
|
libptscotcherr$(LIB) : library_error_pt$(OBJ)
|
|
- $(AR) $(ARFLAGS) $(@) $(?)
|
|
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS)
|
|
-$(RANLIB) $(@)
|
|
|
|
libptscotcherrexit$(LIB) : library_error_exit_pt$(OBJ)
|
|
- $(AR) $(ARFLAGS) $(@) $(?)
|
|
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS)
|
|
-$(RANLIB) $(@)
|
|
diff -rupN --no-dereference scotch_6.1.0/src/libscotchmetis/Makefile scotch_6.1.0-new/src/libscotchmetis/Makefile
|
|
--- scotch_6.1.0/src/libscotchmetis/Makefile 2020-09-03 14:04:30.000000000 +0200
|
|
+++ scotch_6.1.0-new/src/libscotchmetis/Makefile 2020-09-08 11:33:53.231226835 +0200
|
|
@@ -142,12 +142,12 @@ libptscotchparmetis$(LIB) : parmetis_dgr
|
|
parmetis_dgraph_order_f$(OBJ) \
|
|
parmetis_dgraph_part$(OBJ) \
|
|
parmetis_dgraph_part_f$(OBJ)
|
|
- $(AR) $(ARFLAGS) $(@) $(^)
|
|
+ $(AR) $(ARFLAGS) $(@) $(^) $(LDFLAGS) -L ../libscotch -lptscotch
|
|
-$(RANLIB) $(@)
|
|
|
|
libscotchmetis$(LIB) : metis_graph_order$(OBJ) \
|
|
metis_graph_order_f$(OBJ) \
|
|
metis_graph_part$(OBJ) \
|
|
metis_graph_part_f$(OBJ)
|
|
- $(AR) $(ARFLAGS) $(@) $(^)
|
|
+ $(AR) $(ARFLAGS) $(@) $(^) $(LDFLAGS) -L ../libscotch -lscotch
|
|
-$(RANLIB) $(@)
|