54 lines
2.0 KiB
Diff
54 lines
2.0 KiB
Diff
diff -up scotch_6.0.6/src/libscotch/Makefile.ldflags scotch_6.0.6/src/libscotch/Makefile
|
|
--- scotch_6.0.6/src/libscotch/Makefile.ldflags 2018-07-14 09:24:49.000000000 -0600
|
|
+++ scotch_6.0.6/src/libscotch/Makefile 2018-12-16 11:51:17.539309609 -0700
|
|
@@ -3065,25 +3065,25 @@ ptscotchf.h : ptdummysizes$(EXE) \
|
|
./ptdummysizes$(EXE) "-s$(SCOTCH_NAME_SUFFIX)" library_pt_f.h ptscotchf.h
|
|
|
|
libscotch$(LIB) : $(LIBSCOTCHDEPS)
|
|
- $(AR) $(ARFLAGS) $(@) $(?)
|
|
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS)
|
|
-$(RANLIB) $(@)
|
|
|
|
libscotcherr$(LIB) : library_error$(OBJ)
|
|
- $(AR) $(ARFLAGS) $(@) $(?)
|
|
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS)
|
|
-$(RANLIB) $(@)
|
|
|
|
libscotcherrexit$(LIB) : library_error_exit$(OBJ)
|
|
- $(AR) $(ARFLAGS) $(@) $(?)
|
|
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS)
|
|
-$(RANLIB) $(@)
|
|
|
|
libptscotch$(LIB) : $(LIBPTSCOTCHDEPS)
|
|
- $(AR) $(ARFLAGS) $(@) $(?)
|
|
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS)
|
|
-$(RANLIB) $(@)
|
|
|
|
libptscotcherr$(LIB) : library_error_pt$(OBJ)
|
|
- $(AR) $(ARFLAGS) $(@) $(?)
|
|
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS)
|
|
-$(RANLIB) $(@)
|
|
|
|
libptscotcherrexit$(LIB) : library_error_exit_pt$(OBJ)
|
|
- $(AR) $(ARFLAGS) $(@) $(?)
|
|
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS)
|
|
-$(RANLIB) $(@)
|
|
diff -up scotch_6.0.6/src/libscotchmetis/Makefile.ldflags scotch_6.0.6/src/libscotchmetis/Makefile
|
|
--- scotch_6.0.6/src/libscotchmetis/Makefile.ldflags 2018-07-14 09:24:49.000000000 -0600
|
|
+++ scotch_6.0.6/src/libscotchmetis/Makefile 2018-12-16 11:50:54.513988475 -0700
|
|
@@ -139,12 +139,12 @@ libptscotchparmetis$(LIB) : parmetis_dgr
|
|
parmetis_dgraph_order_f$(OBJ) \
|
|
parmetis_dgraph_part$(OBJ) \
|
|
parmetis_dgraph_part_f$(OBJ)
|
|
- $(AR) $(ARFLAGS) $(@) $(^)
|
|
+ $(AR) $(ARFLAGS) $(@) $(^) $(LDFLAGS)
|
|
-$(RANLIB) $(@)
|
|
|
|
libscotchmetis$(LIB) : metis_graph_order$(OBJ) \
|
|
metis_graph_order_f$(OBJ) \
|
|
metis_graph_part$(OBJ) \
|
|
metis_graph_part_f$(OBJ)
|
|
- $(AR) $(ARFLAGS) $(@) $(^)
|
|
+ $(AR) $(ARFLAGS) $(@) $(^) $(LDFLAGS)
|
|
-$(RANLIB) $(@)
|