Fix underlinked libraries (#1680315)
This commit is contained in:
parent
8e446ef7c0
commit
80a3be3bcc
@ -1,12 +1,26 @@
|
||||
diff -up scotch_6.0.6/src/esmumps/Makefile.ldflags scotch_6.0.6/src/esmumps/Makefile
|
||||
--- scotch_6.0.6/src/esmumps/Makefile.ldflags 2018-07-14 09:24:49.000000000 -0600
|
||||
+++ scotch_6.0.6/src/esmumps/Makefile 2019-04-12 12:29:40.901976055 -0600
|
||||
@@ -148,7 +148,7 @@ libesmumps$(LIB) : graph_graph$(OBJ)
|
||||
esmumps$(OBJ) \
|
||||
esmumps_f$(OBJ) \
|
||||
esmumps_strats$(OBJ)
|
||||
- $(AR) $(ARFLAGS) $(@) $(?)
|
||||
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS) -L ../libscotch -lscotch
|
||||
-$(RANLIB) $(@)
|
||||
|
||||
main_esmumps$(EXE) : main_esmumps.c \
|
||||
diff -up scotch_6.0.6/src/libscotch/Makefile.ldflags scotch_6.0.6/src/libscotch/Makefile
|
||||
--- scotch_6.0.6/src/libscotch/Makefile.ldflags 2018-07-14 09:24:49.000000000 -0600
|
||||
+++ scotch_6.0.6/src/libscotch/Makefile 2018-12-16 11:51:17.539309609 -0700
|
||||
@@ -3065,25 +3065,25 @@ ptscotchf.h : ptdummysizes$(EXE) \
|
||||
+++ scotch_6.0.6/src/libscotch/Makefile 2019-04-12 12:29:31.310136618 -0600
|
||||
@@ -3064,26 +3064,26 @@
|
||||
library_pt_f.h
|
||||
./ptdummysizes$(EXE) "-s$(SCOTCH_NAME_SUFFIX)" library_pt_f.h ptscotchf.h
|
||||
|
||||
libscotch$(LIB) : $(LIBSCOTCHDEPS)
|
||||
-libscotch$(LIB) : $(LIBSCOTCHDEPS)
|
||||
- $(AR) $(ARFLAGS) $(@) $(?)
|
||||
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS)
|
||||
+libscotch$(LIB) : $(LIBSCOTCHDEPS) libscotcherr$(LIB)
|
||||
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS) -L . -lscotcherr
|
||||
-$(RANLIB) $(@)
|
||||
|
||||
libscotcherr$(LIB) : library_error$(OBJ)
|
||||
@ -19,9 +33,10 @@ diff -up scotch_6.0.6/src/libscotch/Makefile.ldflags scotch_6.0.6/src/libscotch/
|
||||
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS)
|
||||
-$(RANLIB) $(@)
|
||||
|
||||
libptscotch$(LIB) : $(LIBPTSCOTCHDEPS)
|
||||
-libptscotch$(LIB) : $(LIBPTSCOTCHDEPS)
|
||||
- $(AR) $(ARFLAGS) $(@) $(?)
|
||||
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS)
|
||||
+libptscotch$(LIB) : $(LIBPTSCOTCHDEPS) libscotch$(LIB)
|
||||
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS) -L . -lscotch
|
||||
-$(RANLIB) $(@)
|
||||
|
||||
libptscotcherr$(LIB) : library_error_pt$(OBJ)
|
||||
@ -35,13 +50,13 @@ diff -up scotch_6.0.6/src/libscotch/Makefile.ldflags scotch_6.0.6/src/libscotch/
|
||||
-$(RANLIB) $(@)
|
||||
diff -up scotch_6.0.6/src/libscotchmetis/Makefile.ldflags scotch_6.0.6/src/libscotchmetis/Makefile
|
||||
--- scotch_6.0.6/src/libscotchmetis/Makefile.ldflags 2018-07-14 09:24:49.000000000 -0600
|
||||
+++ scotch_6.0.6/src/libscotchmetis/Makefile 2018-12-16 11:50:54.513988475 -0700
|
||||
+++ scotch_6.0.6/src/libscotchmetis/Makefile 2019-04-12 12:31:07.100533120 -0600
|
||||
@@ -139,12 +139,12 @@ libptscotchparmetis$(LIB) : parmetis_dgr
|
||||
parmetis_dgraph_order_f$(OBJ) \
|
||||
parmetis_dgraph_part$(OBJ) \
|
||||
parmetis_dgraph_part_f$(OBJ)
|
||||
- $(AR) $(ARFLAGS) $(@) $(^)
|
||||
+ $(AR) $(ARFLAGS) $(@) $(^) $(LDFLAGS)
|
||||
+ $(AR) $(ARFLAGS) $(@) $(^) $(LDFLAGS) -L ../libscotch -lptscotch
|
||||
-$(RANLIB) $(@)
|
||||
|
||||
libscotchmetis$(LIB) : metis_graph_order$(OBJ) \
|
||||
@ -49,5 +64,5 @@ diff -up scotch_6.0.6/src/libscotchmetis/Makefile.ldflags scotch_6.0.6/src/libsc
|
||||
metis_graph_part$(OBJ) \
|
||||
metis_graph_part_f$(OBJ)
|
||||
- $(AR) $(ARFLAGS) $(@) $(^)
|
||||
+ $(AR) $(ARFLAGS) $(@) $(^) $(LDFLAGS)
|
||||
+ $(AR) $(ARFLAGS) $(@) $(^) $(LDFLAGS) -L ../libscotch -lscotch
|
||||
-$(RANLIB) $(@)
|
||||
|
25
scotch.spec
25
scotch.spec
@ -10,7 +10,7 @@
|
||||
Name: scotch
|
||||
Summary: Graph, mesh and hypergraph partitioning library
|
||||
Version: 6.0.6
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
|
||||
License: CeCILL-C
|
||||
URL: https://gforge.inria.fr/projects/scotch/
|
||||
@ -21,6 +21,8 @@ Source1: scotch-Makefile.shared.inc.in
|
||||
Patch0: scotch_esmumps.patch
|
||||
# Make shared libraries link properly with -Wl,--as-needed
|
||||
Patch1: scotch-ldflags.patch
|
||||
# Fix undefined man page macros
|
||||
Patch2: scotch-man.patch
|
||||
|
||||
BuildRequires: flex
|
||||
BuildRequires: bison
|
||||
@ -36,7 +38,6 @@ ptscotch sub-packages.
|
||||
%package devel
|
||||
Summary: Development libraries for scotch
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Obsoletes: %{name}-static < 6.0.0-8
|
||||
|
||||
%description devel
|
||||
This package contains development libraries for scotch.
|
||||
@ -64,7 +65,6 @@ compiled with mpich.
|
||||
%package -n ptscotch-mpich-devel
|
||||
Summary: Development libraries for PT-Scotch (mpich)
|
||||
Requires: pt%{name}-mpich%{?_isa} = %{version}-%{release}
|
||||
Obsoletes: ptscotch-mpich-static < 6.0.0-8
|
||||
|
||||
%description -n ptscotch-mpich-devel
|
||||
This package contains development libraries for PT-Scotch, compiled against
|
||||
@ -93,10 +93,10 @@ compiled with openmpi.
|
||||
%package -n ptscotch-openmpi-devel
|
||||
Summary: Development libraries for PT-Scotch (openmpi)
|
||||
Requires: pt%{name}-openmpi%{?_isa} = %{version}-%{release}
|
||||
Obsoletes: ptscotch-openmpi-static < 6.0.0-8
|
||||
|
||||
%description -n ptscotch-openmpi-devel
|
||||
This package contains development libraries for PT-Scotch, compiled against openmpi.
|
||||
This package contains development libraries for PT-Scotch, compiled against
|
||||
openmpi.
|
||||
|
||||
|
||||
%package -n ptscotch-openmpi-devel-parmetis
|
||||
@ -129,13 +129,13 @@ popd
|
||||
|
||||
%{_mpich_load}
|
||||
pushd %{mpichdir}/src/
|
||||
make ptscotch ptesmumps CFLAGS="%{optflags}" LDFLAGS="%{?__global_ldflags}" SOMAJ="%{so_maj}"
|
||||
make ptscotch ptesmumps CFLAGS="%{optflags}" LDFLAGS="%{?__global_ldflags} -L%{_libdir}/mpich/lib -lmpi" SOMAJ="%{so_maj}"
|
||||
popd
|
||||
%{_mpich_unload}
|
||||
|
||||
%{_openmpi_load}
|
||||
pushd %{openmpidir}/src/
|
||||
make ptscotch ptesmumps CFLAGS="%{optflags}" LDFLAGS="%{?__global_ldflags}" SOMAJ="%{so_maj}"
|
||||
make ptscotch ptesmumps CFLAGS="%{optflags}" LDFLAGS="%{?__global_ldflags} -L%{_libdir}/openmpi/lib -lmpi" SOMAJ="%{so_maj}"
|
||||
popd
|
||||
%{_openmpi_unload}
|
||||
|
||||
@ -206,6 +206,10 @@ popd
|
||||
###############################################################################
|
||||
|
||||
|
||||
%check
|
||||
LD_LIBRARY_PATH=%{buildroot}%{_libdir} make -C src/check
|
||||
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
%ldconfig_scriptlets -n ptscotch-mpich
|
||||
@ -265,6 +269,13 @@ popd
|
||||
%doc doc/scotch_example.f
|
||||
|
||||
%changelog
|
||||
* Fri Apr 12 2019 Jerry James <loganjerry@gmail.com> - 6.0.6-6
|
||||
- Fix underlinked libraries (bz 1680315)
|
||||
- Fix too-long description line
|
||||
- Drop ancient obsoletes
|
||||
- Add check script
|
||||
- Fix undefined macros in man pages
|
||||
|
||||
* Thu Feb 14 2019 Orion Poplawski <orion@nwra.com> - 6.0.6-5
|
||||
- Rebuild for openmpi 3.1.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user