scotch package is retired on c9s for CS-704
This commit is contained in:
parent
ccea696b77
commit
510c5b25db
15
.gitignore
vendored
15
.gitignore
vendored
@ -1,15 +0,0 @@
|
|||||||
scotch_5.1.8.tar.gz
|
|
||||||
/scotch_5.1.10b.tar.gz
|
|
||||||
/scotch_5.1.11.tar.gz
|
|
||||||
/scotch_5.1.12b.tar.gz
|
|
||||||
/scotch_6.0.0.tar.gz
|
|
||||||
/scotch_6.0.1.tar.gz
|
|
||||||
/scotch_6.0.3.tar.gz
|
|
||||||
/scotch_6.0.4.tar.gz
|
|
||||||
/scotch_6.0.5.tar.gz
|
|
||||||
/scotch_6.0.6.tar.gz
|
|
||||||
/scotch_6.0.7.tar.gz
|
|
||||||
/scotch_6.0.8.tar.gz
|
|
||||||
/scotch_6.0.9.tar.gz
|
|
||||||
/scotch_6.0.10.tar.gz
|
|
||||||
/scotch_6.1.0.tar.gz
|
|
1
dead.package
Normal file
1
dead.package
Normal file
@ -0,0 +1 @@
|
|||||||
|
scotch package is retired on c9s for CS-704
|
@ -1,6 +0,0 @@
|
|||||||
--- !Policy
|
|
||||||
product_versions:
|
|
||||||
- rhel-9
|
|
||||||
decision_context: osci_compose_gate
|
|
||||||
rules:
|
|
||||||
- !PassingTestCaseRule {test_case_name: baseos-ci.brew-build.tier1.functional}
|
|
@ -1,24 +0,0 @@
|
|||||||
EXE =
|
|
||||||
LIB = .so
|
|
||||||
OBJ = .o
|
|
||||||
|
|
||||||
MAKE = make
|
|
||||||
AR = gcc
|
|
||||||
CAT = cat
|
|
||||||
CCS = gcc
|
|
||||||
CCP = mpicc
|
|
||||||
CCD = mpicc
|
|
||||||
override CFLAGS += -DCOMMON_FILE_COMPRESS_GZ -DCOMMON_FILE_COMPRESS_BZ2 -DCOMMON_FILE_COMPRESS_LZMA \
|
|
||||||
-DCOMMON_PTHREAD -DCOMMON_RANDOM_FIXED_SEED -DSCOTCH_RENAME \
|
|
||||||
-Drestrict=__restrict -DIDXSIZE64
|
|
||||||
CLIBFLAGS = -shared -fPIC
|
|
||||||
override LDFLAGS += -lz -lbz2 -llzma -lm -lrt -lpthread
|
|
||||||
# LDFLAGS added to AR rule in Makefiles to come after objects to work with -Wl,--as-needed
|
|
||||||
ARFLAGS = -shared -Wl,-soname=$@.$(SOMAJ) -o
|
|
||||||
CP = cp -av
|
|
||||||
LEX = flex
|
|
||||||
LN = ln
|
|
||||||
MKDIR = mkdir -p
|
|
||||||
MV = mv
|
|
||||||
RANLIB = echo
|
|
||||||
YACC = bison -y
|
|
@ -1,68 +0,0 @@
|
|||||||
diff -rupN --no-dereference scotch_6.1.0/src/esmumps/Makefile scotch_6.1.0-new/src/esmumps/Makefile
|
|
||||||
--- scotch_6.1.0/src/esmumps/Makefile 2020-09-03 14:04:40.000000000 +0200
|
|
||||||
+++ scotch_6.1.0-new/src/esmumps/Makefile 2020-09-08 11:33:53.230226763 +0200
|
|
||||||
@@ -184,7 +184,7 @@ esmumps_strats$(OBJ) : esmumps_strats.c
|
|
||||||
esmumps.h
|
|
||||||
|
|
||||||
libesmumps$(LIB) : $(LIBESMUMPSDEPS)
|
|
||||||
- $(AR) $(ARFLAGS) $(@) $(?)
|
|
||||||
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS)
|
|
||||||
-$(RANLIB) $(@)
|
|
||||||
|
|
||||||
main_esmumps$(EXE) : main_esmumps.c \
|
|
||||||
diff -rupN --no-dereference scotch_6.1.0/src/libscotch/Makefile scotch_6.1.0-new/src/libscotch/Makefile
|
|
||||||
--- scotch_6.1.0/src/libscotch/Makefile 2020-09-03 13:48:31.000000000 +0200
|
|
||||||
+++ scotch_6.1.0-new/src/libscotch/Makefile 2020-09-08 11:33:53.231226835 +0200
|
|
||||||
@@ -3121,26 +3121,26 @@ ptscotchf.h : ptdummysizes$(EXE) \
|
|
||||||
library_pt_f.h
|
|
||||||
./ptdummysizes$(EXE) "-s$(SCOTCH_NAME_SUFFIX)" library_pt_f.h ptscotchf.h
|
|
||||||
|
|
||||||
-libscotch$(LIB) : $(LIBSCOTCHDEPS)
|
|
||||||
- $(AR) $(ARFLAGS) $(@) $(?)
|
|
||||||
+libscotch$(LIB) : $(LIBSCOTCHDEPS) libscotcherr$(LIB)
|
|
||||||
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS) -L . -lscotcherr
|
|
||||||
-$(RANLIB) $(@)
|
|
||||||
|
|
||||||
libscotcherr$(LIB) : library_error$(OBJ)
|
|
||||||
- $(AR) $(ARFLAGS) $(@) $(?)
|
|
||||||
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS)
|
|
||||||
-$(RANLIB) $(@)
|
|
||||||
|
|
||||||
libscotcherrexit$(LIB) : library_error_exit$(OBJ)
|
|
||||||
- $(AR) $(ARFLAGS) $(@) $(?)
|
|
||||||
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS)
|
|
||||||
-$(RANLIB) $(@)
|
|
||||||
|
|
||||||
-libptscotch$(LIB) : $(LIBPTSCOTCHDEPS)
|
|
||||||
- $(AR) $(ARFLAGS) $(@) $(?)
|
|
||||||
+libptscotch$(LIB) : $(LIBPTSCOTCHDEPS) libscotch$(LIB)
|
|
||||||
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS) -L . -lscotch
|
|
||||||
-$(RANLIB) $(@)
|
|
||||||
|
|
||||||
libptscotcherr$(LIB) : library_error_pt$(OBJ)
|
|
||||||
- $(AR) $(ARFLAGS) $(@) $(?)
|
|
||||||
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS)
|
|
||||||
-$(RANLIB) $(@)
|
|
||||||
|
|
||||||
libptscotcherrexit$(LIB) : library_error_exit_pt$(OBJ)
|
|
||||||
- $(AR) $(ARFLAGS) $(@) $(?)
|
|
||||||
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS)
|
|
||||||
-$(RANLIB) $(@)
|
|
||||||
diff -rupN --no-dereference scotch_6.1.0/src/libscotchmetis/Makefile scotch_6.1.0-new/src/libscotchmetis/Makefile
|
|
||||||
--- scotch_6.1.0/src/libscotchmetis/Makefile 2020-09-03 14:04:30.000000000 +0200
|
|
||||||
+++ scotch_6.1.0-new/src/libscotchmetis/Makefile 2020-09-08 11:33:53.231226835 +0200
|
|
||||||
@@ -142,12 +142,12 @@ libptscotchparmetis$(LIB) : parmetis_dgr
|
|
||||||
parmetis_dgraph_order_f$(OBJ) \
|
|
||||||
parmetis_dgraph_part$(OBJ) \
|
|
||||||
parmetis_dgraph_part_f$(OBJ)
|
|
||||||
- $(AR) $(ARFLAGS) $(@) $(^)
|
|
||||||
+ $(AR) $(ARFLAGS) $(@) $(^) $(LDFLAGS) -L ../libscotch -lptscotch
|
|
||||||
-$(RANLIB) $(@)
|
|
||||||
|
|
||||||
libscotchmetis$(LIB) : metis_graph_order$(OBJ) \
|
|
||||||
metis_graph_order_f$(OBJ) \
|
|
||||||
metis_graph_part$(OBJ) \
|
|
||||||
metis_graph_part_f$(OBJ)
|
|
||||||
- $(AR) $(ARFLAGS) $(@) $(^)
|
|
||||||
+ $(AR) $(ARFLAGS) $(@) $(^) $(LDFLAGS) -L ../libscotch -lscotch
|
|
||||||
-$(RANLIB) $(@)
|
|
479
scotch.spec
479
scotch.spec
@ -1,479 +0,0 @@
|
|||||||
%global openmpidir %{_builddir}/ptscotch-openmpi-%{version}-%{release}
|
|
||||||
%global mpichdir %{_builddir}/ptscotch-mpich-%{version}-%{release}
|
|
||||||
|
|
||||||
# Shared library versioning:
|
|
||||||
# Increment if interface is changed in an incompatible way
|
|
||||||
%global so_maj 1
|
|
||||||
# Increment if interface is extended
|
|
||||||
%global so_min 3
|
|
||||||
|
|
||||||
Name: scotch
|
|
||||||
Summary: Graph, mesh and hypergraph partitioning library
|
|
||||||
Version: 6.1.0
|
|
||||||
Release: 3%{?dist}
|
|
||||||
|
|
||||||
License: CeCILL-C
|
|
||||||
URL: https://gforge.inria.fr/projects/scotch/
|
|
||||||
# Note: this URL needs to be adjusted for every release, as the file ID changes every time
|
|
||||||
Source0: https://gforge.inria.fr/frs/download.php/file/38352/scotch_6.1.0.tar.gz
|
|
||||||
Source1: scotch-Makefile.shared.inc.in
|
|
||||||
|
|
||||||
# Make shared libraries link properly with -Wl,--as-needed
|
|
||||||
Patch0: scotch-ldflags.patch
|
|
||||||
|
|
||||||
BuildRequires: make
|
|
||||||
BuildRequires: flex
|
|
||||||
BuildRequires: bison
|
|
||||||
BuildRequires: zlib-devel
|
|
||||||
BuildRequires: bzip2-devel
|
|
||||||
BuildRequires: xz-devel
|
|
||||||
|
|
||||||
%description
|
|
||||||
Scotch is a software package for graph and mesh/hypergraph partitioning and
|
|
||||||
sparse matrix ordering. The parallel scotch libraries are packaged in the
|
|
||||||
ptscotch sub-packages.
|
|
||||||
|
|
||||||
%package devel
|
|
||||||
Summary: Development libraries for scotch
|
|
||||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
|
||||||
|
|
||||||
%description devel
|
|
||||||
This package contains development libraries for scotch.
|
|
||||||
|
|
||||||
|
|
||||||
%package doc
|
|
||||||
Summary: Documentations and example for scotch and ptscotch
|
|
||||||
BuildArch: noarch
|
|
||||||
|
|
||||||
%description doc
|
|
||||||
Contains documentations and example for scotch and ptscotch
|
|
||||||
|
|
||||||
###############################################################################
|
|
||||||
|
|
||||||
%package -n ptscotch-mpich
|
|
||||||
Summary: PT-Scotch libraries compiled against mpich
|
|
||||||
BuildRequires: mpich-devel
|
|
||||||
|
|
||||||
%description -n ptscotch-mpich
|
|
||||||
Scotch is a software package for graph and mesh/hypergraph partitioning and
|
|
||||||
sparse matrix ordering. This sub-package provides parallelized scotch libraries
|
|
||||||
compiled with mpich.
|
|
||||||
|
|
||||||
|
|
||||||
%package -n ptscotch-mpich-devel
|
|
||||||
Summary: Development libraries for PT-Scotch (mpich)
|
|
||||||
Requires: pt%{name}-mpich%{?_isa} = %{version}-%{release}
|
|
||||||
|
|
||||||
%description -n ptscotch-mpich-devel
|
|
||||||
This package contains development libraries for PT-Scotch, compiled against
|
|
||||||
mpich.
|
|
||||||
|
|
||||||
%package -n ptscotch-mpich-devel-parmetis
|
|
||||||
Summary: Parmetis compatibility header for scotch
|
|
||||||
Requires: pt%{name}-mpich-devel%{?_isa} = %{version}-%{release}
|
|
||||||
|
|
||||||
%description -n ptscotch-mpich-devel-parmetis
|
|
||||||
This package contains the parmetis compatibility header for scotch.
|
|
||||||
|
|
||||||
|
|
||||||
###############################################################################
|
|
||||||
|
|
||||||
%package -n ptscotch-openmpi
|
|
||||||
Summary: PT-Scotch libraries compiled against openmpi
|
|
||||||
BuildRequires: openmpi-devel
|
|
||||||
|
|
||||||
%description -n ptscotch-openmpi
|
|
||||||
Scotch is a software package for graph and mesh/hypergraph partitioning and
|
|
||||||
sparse matrix ordering. This sub-package provides parallelized scotch libraries
|
|
||||||
compiled with openmpi.
|
|
||||||
|
|
||||||
|
|
||||||
%package -n ptscotch-openmpi-devel
|
|
||||||
Summary: Development libraries for PT-Scotch (openmpi)
|
|
||||||
Requires: pt%{name}-openmpi%{?_isa} = %{version}-%{release}
|
|
||||||
|
|
||||||
%description -n ptscotch-openmpi-devel
|
|
||||||
This package contains development libraries for PT-Scotch, compiled against
|
|
||||||
openmpi.
|
|
||||||
|
|
||||||
|
|
||||||
%package -n ptscotch-openmpi-devel-parmetis
|
|
||||||
Summary: Parmetis compatibility header for scotch
|
|
||||||
Requires: pt%{name}-openmpi-devel%{?_isa} = %{version}-%{release}
|
|
||||||
|
|
||||||
%description -n ptscotch-openmpi-devel-parmetis
|
|
||||||
This package contains the parmetis compatibility header for scotch.
|
|
||||||
|
|
||||||
###############################################################################
|
|
||||||
|
|
||||||
%prep
|
|
||||||
# NOTE: If the archive prefix folder does not match %%{name}_%%{version}, then the file ID in the Source URL is likely wrong!
|
|
||||||
%autosetup -p1 -n %{name}_%{version}
|
|
||||||
|
|
||||||
cp -a %{SOURCE1} src/Makefile.inc
|
|
||||||
|
|
||||||
# Convert the license files to utf8
|
|
||||||
for file in doc/CeCILL-C_V1-en.txt doc/CeCILL-C_V1-fr.txt; do
|
|
||||||
iconv -f iso8859-1 -t utf-8 $file > $file.conv && mv -f $file.conv $file
|
|
||||||
done
|
|
||||||
|
|
||||||
cp -a . %{openmpidir}
|
|
||||||
cp -a . %{mpichdir}
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
|
||||||
pushd src/
|
|
||||||
make scotch esmumps CFLAGS="%{optflags}" LDFLAGS="%{?__global_ldflags}" SOMAJ="%{so_maj}"
|
|
||||||
popd
|
|
||||||
|
|
||||||
%{_mpich_load}
|
|
||||||
pushd %{mpichdir}/src/
|
|
||||||
make ptscotch ptesmumps CFLAGS="%{optflags}" LDFLAGS="%{?__global_ldflags} -L%{_libdir}/mpich/lib -lmpi" SOMAJ="%{so_maj}"
|
|
||||||
popd
|
|
||||||
%{_mpich_unload}
|
|
||||||
|
|
||||||
%{_openmpi_load}
|
|
||||||
pushd %{openmpidir}/src/
|
|
||||||
make ptscotch ptesmumps CFLAGS="%{optflags}" LDFLAGS="%{?__global_ldflags} -L%{_libdir}/openmpi/lib -lmpi" SOMAJ="%{so_maj}"
|
|
||||||
popd
|
|
||||||
%{_openmpi_unload}
|
|
||||||
|
|
||||||
|
|
||||||
%install
|
|
||||||
%define doinstall() \
|
|
||||||
make install prefix=%{buildroot}${MPI_HOME} libdir=%{buildroot}${MPI_LIB} includedir=%{buildroot}${MPI_INCLUDE} mandir=%{buildroot}${MPI_MAN} bindir=%{buildroot}${MPI_BIN} \
|
|
||||||
# Fix debuginfo packages not finding sources (See libscotch/Makefile) \
|
|
||||||
ln -s parser_ll.c libscotch/lex.yy.c \
|
|
||||||
ln -s parser_yy.c libscotch/y.tab.c \
|
|
||||||
ln -s parser_ly.h libscotch/y.tab.h \
|
|
||||||
\
|
|
||||||
pushd %{buildroot}${MPI_LIB}; \
|
|
||||||
for lib in *.so; do \
|
|
||||||
chmod 755 $lib \
|
|
||||||
mv $lib $lib.%{so_maj}.%{so_min} && ln -s $lib.%{so_maj}.%{so_min} $lib && ln -s $lib.%{so_maj}.%{so_min} $lib.%{so_maj} \
|
|
||||||
done \
|
|
||||||
popd \
|
|
||||||
\
|
|
||||||
pushd %{buildroot}${MPI_BIN} \
|
|
||||||
for prog in *; do \
|
|
||||||
mv $prog scotch_${prog} \
|
|
||||||
chmod 755 scotch_$prog \
|
|
||||||
done \
|
|
||||||
popd \
|
|
||||||
\
|
|
||||||
pushd %{buildroot}${MPI_MAN}/man1/ \
|
|
||||||
for man in *; do \
|
|
||||||
mv ${man} scotch_${man} \
|
|
||||||
done \
|
|
||||||
# Cleanup man pages (some pages are only relevant for ptscotch packages, and vice versa) \
|
|
||||||
for man in *; do \
|
|
||||||
if [ ! -f %{buildroot}${MPI_BIN}/${man/.1/} ]; then \
|
|
||||||
rm -f $man \
|
|
||||||
fi \
|
|
||||||
done \
|
|
||||||
popd
|
|
||||||
|
|
||||||
###############################################################################
|
|
||||||
|
|
||||||
export MPI_HOME=%{_prefix}
|
|
||||||
export MPI_LIB=%{_libdir}
|
|
||||||
export MPI_INCLUDE=%{_includedir}
|
|
||||||
export MPI_MAN=%{_mandir}
|
|
||||||
export MPI_BIN=%{_bindir}
|
|
||||||
pushd src
|
|
||||||
%doinstall
|
|
||||||
popd
|
|
||||||
|
|
||||||
###############################################################################
|
|
||||||
|
|
||||||
%{_mpich_load}
|
|
||||||
pushd %{mpichdir}/src
|
|
||||||
%doinstall
|
|
||||||
install -m644 libscotchmetis/parmetis.h %{buildroot}${MPI_INCLUDE}
|
|
||||||
popd
|
|
||||||
%{_mpich_unload}
|
|
||||||
|
|
||||||
###############################################################################
|
|
||||||
|
|
||||||
%{_openmpi_load}
|
|
||||||
pushd %{openmpidir}/src
|
|
||||||
%doinstall
|
|
||||||
install -m644 libscotchmetis/parmetis.h %{buildroot}${MPI_INCLUDE}
|
|
||||||
popd
|
|
||||||
%{_openmpi_unload}
|
|
||||||
|
|
||||||
###############################################################################
|
|
||||||
|
|
||||||
|
|
||||||
%check
|
|
||||||
LD_LIBRARY_PATH=%{buildroot}%{_libdir} make -C src/check
|
|
||||||
|
|
||||||
|
|
||||||
%ldconfig_scriptlets
|
|
||||||
|
|
||||||
%ldconfig_scriptlets -n ptscotch-mpich
|
|
||||||
|
|
||||||
%ldconfig_scriptlets -n ptscotch-openmpi
|
|
||||||
|
|
||||||
|
|
||||||
%{!?_licensedir:%global license %%doc}
|
|
||||||
%files
|
|
||||||
%license doc/CeCILL-C_V1-en.txt
|
|
||||||
%{_bindir}/*
|
|
||||||
%{_libdir}/libscotch*.so.1*
|
|
||||||
%{_libdir}/libesmumps*.so.1*
|
|
||||||
%{_mandir}/man1/*
|
|
||||||
|
|
||||||
%files devel
|
|
||||||
%{_libdir}/libscotch*.so
|
|
||||||
%{_libdir}/libesmumps*.so
|
|
||||||
%{_includedir}/*scotch*.h
|
|
||||||
%{_includedir}/*esmumps*.h
|
|
||||||
|
|
||||||
%files -n ptscotch-mpich
|
|
||||||
%license doc/CeCILL-C_V1-en.txt
|
|
||||||
%{_libdir}/mpich/lib/lib*scotch*.so.1*
|
|
||||||
%{_libdir}/mpich/lib/lib*esmumps*.so.1*
|
|
||||||
%{_libdir}/mpich/bin/*
|
|
||||||
%{_mandir}/mpich*/*
|
|
||||||
|
|
||||||
%files -n ptscotch-mpich-devel
|
|
||||||
%{_includedir}/mpich*/*scotch*.h
|
|
||||||
%{_includedir}/mpich*/*esmumps*.h
|
|
||||||
%{_libdir}/mpich/lib/lib*scotch*.so
|
|
||||||
%{_libdir}/mpich/lib/lib*esmumps*.so
|
|
||||||
|
|
||||||
%files -n ptscotch-mpich-devel-parmetis
|
|
||||||
%{_includedir}/mpich*/parmetis.h
|
|
||||||
|
|
||||||
%files -n ptscotch-openmpi
|
|
||||||
%license doc/CeCILL-C_V1-en.txt
|
|
||||||
%{_libdir}/openmpi/lib/lib*scotch*.so.1*
|
|
||||||
%{_libdir}/openmpi/lib/lib*esmumps*.so.1*
|
|
||||||
%{_libdir}/openmpi/bin/*
|
|
||||||
%{_mandir}/openmpi*/*
|
|
||||||
|
|
||||||
%files -n ptscotch-openmpi-devel
|
|
||||||
%{_includedir}/openmpi*/*scotch*.h
|
|
||||||
%{_includedir}/openmpi*/*esmumps*.h
|
|
||||||
%{_libdir}/openmpi/lib/lib*scotch*.so
|
|
||||||
%{_libdir}/openmpi/lib/lib*esmumps*.so
|
|
||||||
|
|
||||||
%files -n ptscotch-openmpi-devel-parmetis
|
|
||||||
%{_includedir}/openmpi*/parmetis.h
|
|
||||||
|
|
||||||
%files doc
|
|
||||||
%license doc/CeCILL-C_V1-en.txt
|
|
||||||
%doc doc/*.pdf
|
|
||||||
%doc doc/scotch_example.f
|
|
||||||
|
|
||||||
%changelog
|
|
||||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 6.1.0-3
|
|
||||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
|
||||||
|
|
||||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 6.1.0-2
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
|
||||||
|
|
||||||
* Tue Sep 08 2020 Sandro Mani <manisandro@gmail.coM> - 6.1.0-1
|
|
||||||
- Update to 6.1.0
|
|
||||||
|
|
||||||
* Wed Sep 02 2020 Sandro Mani <manisandro@gmail.com> - 6.0.10-1
|
|
||||||
- Update to 6.0.10
|
|
||||||
|
|
||||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 6.0.9-3
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
|
||||||
|
|
||||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 6.0.9-2
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
|
||||||
|
|
||||||
* Tue Nov 05 2019 Sandro Mani <manisandro@gmail.com> - 6.0.9-1
|
|
||||||
- Update to 6.0.9
|
|
||||||
|
|
||||||
* Tue Aug 27 2019 Sandro Mani <manisandro@gmail.com> - 6.0.8-1
|
|
||||||
- Update to 6.0.8
|
|
||||||
|
|
||||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 6.0.7-2
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
|
||||||
|
|
||||||
* Mon May 20 2019 Sandro Mani <manisandro@gmail.com> - 6.0.7-1
|
|
||||||
- Update to 6.0.7
|
|
||||||
|
|
||||||
* Fri Apr 12 2019 Jerry James <loganjerry@gmail.com> - 6.0.6-6
|
|
||||||
- Fix underlinked libraries (bz 1680315)
|
|
||||||
- Fix too-long description line
|
|
||||||
- Drop ancient obsoletes
|
|
||||||
- Add check script
|
|
||||||
- Fix undefined macros in man pages
|
|
||||||
|
|
||||||
* Thu Feb 14 2019 Orion Poplawski <orion@nwra.com> - 6.0.6-5
|
|
||||||
- Rebuild for openmpi 3.1.3
|
|
||||||
|
|
||||||
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 6.0.6-4
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
|
||||||
|
|
||||||
* Sun Dec 16 2018 Orion Poplawski <orion@cnwra.com> - 6.0.6-3
|
|
||||||
- Make shared libraries link properly with -Wl,--as-needed
|
|
||||||
|
|
||||||
* Sat Dec 1 2018 Orion Poplawski <orion@cnwra.com> - 6.0.6-2
|
|
||||||
- Drop BR lzma, use xz for lzma support
|
|
||||||
|
|
||||||
* Mon Jul 16 2018 Sandro Mani <manisandro@gmail.com> - 6.0.6-1
|
|
||||||
- Update to 6.0.6
|
|
||||||
|
|
||||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 6.0.5-2
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
|
||||||
|
|
||||||
* Mon Feb 12 2018 Sandro Mani <manisandro@gmail.com> - 6.0.5-1
|
|
||||||
- Update to 6.0.5
|
|
||||||
|
|
||||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 6.0.4-17
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
|
||||||
|
|
||||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 6.0.4-16
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
|
||||||
|
|
||||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 6.0.4-15
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
|
||||||
|
|
||||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 6.0.4-14
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
|
||||||
|
|
||||||
* Thu Oct 27 2016 Sandro Mani <manisandro@gmail.com> - 6.0.4-13
|
|
||||||
- Drop -DSCOTCH_PTHREAD (#1386707)
|
|
||||||
|
|
||||||
* Mon Oct 24 2016 Dan Horák <dan[at]danny.cz> - 6.0.4-12
|
|
||||||
- drop ExcludeArch
|
|
||||||
|
|
||||||
* Fri Oct 21 2016 Orion Poplawski <orion@cora.nwra.com> - 6.0.4-11
|
|
||||||
- Rebuild for openmpi 2.0
|
|
||||||
|
|
||||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 6.0.4-10
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
|
||||||
|
|
||||||
* Fri Jan 22 2016 Sandro Mani <manisandro@gmail.com> - 6.0.4-9
|
|
||||||
- Install parmetis.h in separate package
|
|
||||||
|
|
||||||
* Tue Dec 01 2015 Than Ngo <than@redhat.com> - 6.0.4-8
|
|
||||||
- ExcludeArch: s390 s390x
|
|
||||||
|
|
||||||
* Thu Nov 26 2015 Dave Love <loveshack@fedoraproject.org> - 6.0.4-7
|
|
||||||
- Install parmetis.h
|
|
||||||
- Conditionalize %%license and %%__global_ldflags
|
|
||||||
|
|
||||||
* Tue Sep 15 2015 Orion Poplawski <orion@cora.nwra.com> - 6.0.4-6
|
|
||||||
- Rebuild for openmpi 1.10.0
|
|
||||||
|
|
||||||
* Sat Aug 15 2015 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 6.0.4-5
|
|
||||||
- Rebuild for MPI provides
|
|
||||||
|
|
||||||
* Sun Jul 26 2015 Sandro Mani <manisandro@gmail.com> - 6.0.4-4
|
|
||||||
- Rebuild for RPM MPI Requires Provides Change
|
|
||||||
|
|
||||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.0.4-3
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
|
||||||
|
|
||||||
* Sun May 3 2015 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 6.0.4-2
|
|
||||||
- Rebuild for changed mpich
|
|
||||||
|
|
||||||
* Sat Mar 14 2015 Sandro Mani <manisandro@gmail.com> - 6.0.4-1
|
|
||||||
- Update to 6.0.4
|
|
||||||
|
|
||||||
* Thu Mar 12 2015 Sandro Mani <manisandro@gmail.com> - 6.0.3-4
|
|
||||||
- Rebuild (mpich)
|
|
||||||
|
|
||||||
* Mon Dec 01 2014 Sandro Mani <manisandro@gmail.com> - 6.0.3-2
|
|
||||||
- Build esmumps
|
|
||||||
|
|
||||||
* Wed Nov 05 2014 Sandro Mani <manisandro@gmail.com> - 6.0.3-1
|
|
||||||
- Update to 6.0.3
|
|
||||||
|
|
||||||
* Mon Sep 22 2014 Sandro Mani <manisandro@gmail.com> - 6.0.1-1
|
|
||||||
- Update to 6.0.1
|
|
||||||
|
|
||||||
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.0.0-9
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
|
||||||
|
|
||||||
* Fri Aug 08 2014 Sandro Mani <manisandro@gmail.com> - 6.0.0-8
|
|
||||||
- Rework specfile
|
|
||||||
|
|
||||||
* Sat Jul 05 2014 Sandro Mani <manisandro@gmail.com> - 6.0.0-7
|
|
||||||
- Fix under-linked libraries (#1098680)
|
|
||||||
|
|
||||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.0.0-6
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
|
||||||
|
|
||||||
* Thu Feb 27 2014 Deji Akingunola <dakingun@gmail.com> - 6.0.0-5
|
|
||||||
- Slightly modified Erik Zeek spec re-write (See 2012-10-08 below)
|
|
||||||
- Rename mpich and openmpi subpackages as ptscotch-(mpich/openmpi) (Laurence Mcglashan)
|
|
||||||
|
|
||||||
* Mon Feb 24 2014 Deji Akingunola <dakingun@gmail.com> - 6.0.0-4
|
|
||||||
- Rebuild for mpich-3.1
|
|
||||||
|
|
||||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.0.0-3
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
|
||||||
|
|
||||||
* Sun Jul 21 2013 Deji Akingunola <dakingun@gmail.com> - 6.0.0-2
|
|
||||||
- Rename mpich2 sub-packages to mpich and rebuild for mpich-3.0
|
|
||||||
|
|
||||||
* Thu Jun 13 2013 Deji Akingunola <dakingun@gmail.com> - 6.0.0-1
|
|
||||||
- Update to 6.0.0
|
|
||||||
- Configured to run with 2 threads (for now)
|
|
||||||
- Install the headers in arch-dependent sub-directories
|
|
||||||
|
|
||||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.12-2.b
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
|
||||||
|
|
||||||
* Sat Nov 17 2012 Deji Akingunola <dakingun@gmail.com> - 5.1.12-1.b
|
|
||||||
- Update to 5.1.12b
|
|
||||||
|
|
||||||
* Mon Oct 08 2012 Erik Zeek <eczeek@sandia.gov> - 5.1.11-4
|
|
||||||
- Use internal build machinery to build shared libraries.
|
|
||||||
- A bunch of MPI love.
|
|
||||||
- Install Mpich2 libraries in the proper path.
|
|
||||||
- Provide Mpich2 and OpenMPI libraries.
|
|
||||||
|
|
||||||
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.11-3
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
|
||||||
|
|
||||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.11-2
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
|
||||||
|
|
||||||
* Tue Mar 29 2011 Deji Akingunola <dakingun@gmail.com> - 5.1.11-1
|
|
||||||
- Update to 5.1.11
|
|
||||||
|
|
||||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.10b-2
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
|
||||||
|
|
||||||
* Tue Oct 19 2010 Deji Akingunola <dakingun@gmail.com> - 5.1.10b-1
|
|
||||||
- Update to 5.1.10b
|
|
||||||
|
|
||||||
* Thu Aug 12 2010 Deji Akingunola <dakingun@gmail.com> - 5.1.9-1
|
|
||||||
- Update to 5.1.9
|
|
||||||
- No more static builds
|
|
||||||
|
|
||||||
* Tue Apr 27 2010 Deji Akingunola <dakingun@gmail.com> - 5.1.8-1
|
|
||||||
- Update to 5.1.8
|
|
||||||
|
|
||||||
* Wed Nov 04 2009 Deji Akingunola <dakingun@gmail.com> - 5.1.7-2
|
|
||||||
- Fix the Source url
|
|
||||||
|
|
||||||
* Sun Sep 20 2009 Deji Akingunola <dakingun@gmail.com> - 5.1.7-1
|
|
||||||
- Update to 5.1.7
|
|
||||||
- Put the library under libdir
|
|
||||||
|
|
||||||
* Thu Jun 11 2009 Deji Akingunola <dakingun@gmail.com> - 5.1.6-3
|
|
||||||
- Further spec fixes from package review (convert license files to utf8)
|
|
||||||
- Prefix binaries and their corresponding manpages with scotch_ .
|
|
||||||
- Link in appropriates libraries when creating shared libs
|
|
||||||
|
|
||||||
* Thu Jun 04 2009 Deji Akingunola <dakingun@gmail.com> - 5.1.6-2
|
|
||||||
- Add zlib-devel as BR
|
|
||||||
|
|
||||||
* Wed May 13 2009 Deji Akingunola <dakingun@gmail.com> - 5.1.6-1
|
|
||||||
- Update to 5.1.6
|
|
||||||
|
|
||||||
* Fri Nov 21 2008 Deji Akingunola <dakingun@gmail.com> - 5.1.2-1
|
|
||||||
- Update to 5.1.2
|
|
||||||
|
|
||||||
* Fri Sep 19 2008 Deji Akingunola <dakingun@gmail.com> - 5.1.1-1
|
|
||||||
- initial package creation
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -rupN --no-dereference scotch_6.0.9/src/Makefile scotch_6.0.9-new/src/Makefile
|
|
||||||
--- scotch_6.0.9/src/Makefile 2019-11-04 12:24:11.000000000 +0100
|
|
||||||
+++ scotch_6.0.9-new/src/Makefile 2020-09-02 10:20:56.047045017 +0200
|
|
||||||
@@ -125,6 +125,8 @@ install : required $(bindir) $(includ
|
|
||||||
-$(CP) -f ../include/*scotch*.h $(includedir)
|
|
||||||
-$(CP) -f ../lib/*esmumps*$(LIB) $(libdir)
|
|
||||||
-$(CP) -f ../lib/*scotch*$(LIB) $(libdir)
|
|
||||||
+ -$(CP) -f ../include/*esmumps*.h $(includedir)
|
|
||||||
+ -$(CP) -f ../lib/*esmumps*$(LIB) $(libdir)
|
|
||||||
-$(CP) -Rf ../man/* $(mandir)
|
|
||||||
|
|
||||||
installstub : required $(includedir)
|
|
Loading…
Reference in New Issue
Block a user