Update to 6.1.1

This commit is contained in:
Sandro Mani 2021-06-24 14:45:25 +02:00
parent 7a6e20cca7
commit 177af3db74
6 changed files with 41 additions and 32 deletions

1
.gitignore vendored
View File

@ -13,3 +13,4 @@ scotch_5.1.8.tar.gz
/scotch_6.0.9.tar.gz
/scotch_6.0.10.tar.gz
/scotch_6.1.0.tar.gz
/scotch_6.1.1.tar.gz

12
scotch-gfortran.patch Normal file
View File

@ -0,0 +1,12 @@
diff -rupN scotch_6.1.1/src/check/Makefile scotch_6.1.1-new/src/check/Makefile
--- scotch_6.1.1/src/check/Makefile 2021-06-23 00:09:27.000000000 +0200
+++ scotch_6.1.1-new/src/check/Makefile 2021-06-24 14:19:39.161110960 +0200
@@ -68,7 +68,7 @@ include ../Makefile.inc
$(CC) $(CFLAGS) -I$(SCOTCHINCDIR) -L$(SCOTCHLIBDIR) $(<) -o $(@) $(SCOTCHLIBS) $(LDFLAGS)
%$(EXE) : %.f90
- $(FC) $(FFLAGS) -I$(SCOTCHINCDIR) -L$(SCOTCHLIBDIR) $(<) -o $(@) $(SCOTCHLIBS) $(LDFLAGS)
+ gfortran $(FFLAGS) -I$(SCOTCHINCDIR) -L$(SCOTCHLIBDIR) $(<) -o $(@) $(SCOTCHLIBS) $(LDFLAGS)
##
## Project rules.

View File

@ -1,8 +1,8 @@
diff -rupN --no-dereference scotch_6.1.0/src/esmumps/Makefile scotch_6.1.0-new/src/esmumps/Makefile
--- scotch_6.1.0/src/esmumps/Makefile 2020-09-03 14:04:40.000000000 +0200
+++ scotch_6.1.0-new/src/esmumps/Makefile 2020-09-08 11:33:53.230226763 +0200
@@ -184,7 +184,7 @@ esmumps_strats$(OBJ) : esmumps_strats.c
esmumps.h
diff -rupN --no-dereference scotch_6.1.1/src/esmumps/Makefile scotch_6.1.1-new/src/esmumps/Makefile
--- scotch_6.1.1/src/esmumps/Makefile 2021-06-21 00:22:12.000000000 +0200
+++ scotch_6.1.1-new/src/esmumps/Makefile 2021-06-24 12:35:37.191679393 +0200
@@ -196,7 +196,7 @@ symbol_fax_graph$(OBJ) : symbol_fax_gra
fax.h
libesmumps$(LIB) : $(LIBESMUMPSDEPS)
- $(AR) $(ARFLAGS) $(@) $(?)
@ -10,9 +10,9 @@ diff -rupN --no-dereference scotch_6.1.0/src/esmumps/Makefile scotch_6.1.0-new/s
-$(RANLIB) $(@)
main_esmumps$(EXE) : main_esmumps.c \
diff -rupN --no-dereference scotch_6.1.0/src/libscotch/Makefile scotch_6.1.0-new/src/libscotch/Makefile
--- scotch_6.1.0/src/libscotch/Makefile 2020-09-03 13:48:31.000000000 +0200
+++ scotch_6.1.0-new/src/libscotch/Makefile 2020-09-08 11:33:53.231226835 +0200
diff -rupN --no-dereference scotch_6.1.1/src/libscotch/Makefile scotch_6.1.1-new/src/libscotch/Makefile
--- scotch_6.1.1/src/libscotch/Makefile 2021-06-22 13:55:57.000000000 +0200
+++ scotch_6.1.1-new/src/libscotch/Makefile 2021-06-24 12:35:37.191679393 +0200
@@ -3121,26 +3121,26 @@ ptscotchf.h : ptdummysizes$(EXE) \
library_pt_f.h
./ptdummysizes$(EXE) "-s$(SCOTCH_NAME_SUFFIX)" library_pt_f.h ptscotchf.h
@ -48,10 +48,10 @@ diff -rupN --no-dereference scotch_6.1.0/src/libscotch/Makefile scotch_6.1.0-new
- $(AR) $(ARFLAGS) $(@) $(?)
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS)
-$(RANLIB) $(@)
diff -rupN --no-dereference scotch_6.1.0/src/libscotchmetis/Makefile scotch_6.1.0-new/src/libscotchmetis/Makefile
--- scotch_6.1.0/src/libscotchmetis/Makefile 2020-09-03 14:04:30.000000000 +0200
+++ scotch_6.1.0-new/src/libscotchmetis/Makefile 2020-09-08 11:33:53.231226835 +0200
@@ -142,12 +142,12 @@ libptscotchparmetis$(LIB) : parmetis_dgr
diff -rupN --no-dereference scotch_6.1.1/src/libscotchmetis/Makefile scotch_6.1.1-new/src/libscotchmetis/Makefile
--- scotch_6.1.1/src/libscotchmetis/Makefile 2021-06-23 00:09:27.000000000 +0200
+++ scotch_6.1.1-new/src/libscotchmetis/Makefile 2021-06-24 12:35:37.191679393 +0200
@@ -187,7 +187,7 @@ libptscotchparmetis$(LIB) : parmetis_dgr
parmetis_dgraph_order_f$(OBJ) \
parmetis_dgraph_part$(OBJ) \
parmetis_dgraph_part_f$(OBJ)
@ -59,10 +59,11 @@ diff -rupN --no-dereference scotch_6.1.0/src/libscotchmetis/Makefile scotch_6.1.
+ $(AR) $(ARFLAGS) $(@) $(^) $(LDFLAGS) -L ../libscotch -lptscotch
-$(RANLIB) $(@)
libscotchmetis$(LIB) : metis_graph_order$(OBJ) \
metis_graph_order_f$(OBJ) \
metis_graph_part$(OBJ) \
metis_graph_part_f$(OBJ)
libscotchmetis$(LIB) : metis_graph_dual$(OBJ) \
@@ -200,5 +200,5 @@ libscotchmetis$(LIB) : metis_graph_dual
metis_graph_part_dual_f$(OBJ) \
metis_options$(OBJ) \
metis_options_f$(OBJ)
- $(AR) $(ARFLAGS) $(@) $(^)
+ $(AR) $(ARFLAGS) $(@) $(^) $(LDFLAGS) -L ../libscotch -lscotch
-$(RANLIB) $(@)

View File

@ -9,18 +9,22 @@
Name: scotch
Summary: Graph, mesh and hypergraph partitioning library
Version: 6.1.0
Release: 2%{?dist}
Version: 6.1.1
Release: 1%{?dist}
License: CeCILL-C
URL: https://gforge.inria.fr/projects/scotch/
# Note: this URL needs to be adjusted for every release, as the file ID changes every time
Source0: https://gforge.inria.fr/frs/download.php/file/38352/scotch_6.1.0.tar.gz
Source0: https://gforge.inria.fr/frs/download.php/file/38443/scotch_6.1.1.tar.gz
Source1: scotch-Makefile.shared.inc.in
# Make shared libraries link properly with -Wl,--as-needed
Patch0: scotch-ldflags.patch
# Ensure gfortran is used as fortran compiler
Patch1: scotch-gfortran.patch
BuildRequires: gcc
BuildRequires: gcc-gfortran
BuildRequires: make
BuildRequires: flex
BuildRequires: bison
@ -268,6 +272,9 @@ LD_LIBRARY_PATH=%{buildroot}%{_libdir} make -C src/check
%doc doc/scotch_example.f
%changelog
* Thu Jun 24 2021 Sandro Mani <manisandro@gmail.com> - 6.1.1-1
- Update to 6.1.1
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 6.1.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild

View File

@ -1,12 +0,0 @@
diff -rupN --no-dereference scotch_6.0.9/src/Makefile scotch_6.0.9-new/src/Makefile
--- scotch_6.0.9/src/Makefile 2019-11-04 12:24:11.000000000 +0100
+++ scotch_6.0.9-new/src/Makefile 2020-09-02 10:20:56.047045017 +0200
@@ -125,6 +125,8 @@ install : required $(bindir) $(includ
-$(CP) -f ../include/*scotch*.h $(includedir)
-$(CP) -f ../lib/*esmumps*$(LIB) $(libdir)
-$(CP) -f ../lib/*scotch*$(LIB) $(libdir)
+ -$(CP) -f ../include/*esmumps*.h $(includedir)
+ -$(CP) -f ../lib/*esmumps*$(LIB) $(libdir)
-$(CP) -Rf ../man/* $(mandir)
installstub : required $(includedir)

View File

@ -1 +1 @@
SHA512 (scotch_6.1.0.tar.gz) = a7991f53f254fcaebb6ef2dc2d5fd210fe7b34b9f475fb5ff6caea13634f1b05f5038683312c66bb372b9c7548a689060a884a397dc589fd3bde637d042410e3
SHA512 (scotch_6.1.1.tar.gz) = 1fc77443ac1e4dad37bc51128bb04463606d96e73f57fe3dce80231f2b80a48ee2c2f129a1df29cd1ba1198f332ac70bef6d540703bf01451a4594a566406c3c