Update to 6.0.6
This commit is contained in:
parent
8a43ce268c
commit
0520e20510
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@ scotch_5.1.8.tar.gz
|
|||||||
/scotch_6.0.3.tar.gz
|
/scotch_6.0.3.tar.gz
|
||||||
/scotch_6.0.4.tar.gz
|
/scotch_6.0.4.tar.gz
|
||||||
/scotch_6.0.5.tar.gz
|
/scotch_6.0.5.tar.gz
|
||||||
|
/scotch_6.0.6.tar.gz
|
||||||
|
@ -12,7 +12,7 @@ override CFLAGS += -DCOMMON_FILE_COMPRESS_GZ -DCOMMON_FILE_COMPRESS_BZ2 -DCOMMO
|
|||||||
-DCOMMON_PTHREAD -DCOMMON_RANDOM_FIXED_SEED -DSCOTCH_RENAME \
|
-DCOMMON_PTHREAD -DCOMMON_RANDOM_FIXED_SEED -DSCOTCH_RENAME \
|
||||||
-Drestrict=__restrict -DIDXSIZE64
|
-Drestrict=__restrict -DIDXSIZE64
|
||||||
CLIBFLAGS = -shared -fPIC
|
CLIBFLAGS = -shared -fPIC
|
||||||
override LDFLAGS += -lz -lbz2 -llzmadec -lm -lrt -lpthread
|
override LDFLAGS += -lz -lbz2 -llzma -llzmadec -lm -lrt -lpthread
|
||||||
ARFLAGS = -shared -Wl,-soname=$@.$(SOMAJ) $(LDFLAGS) -o
|
ARFLAGS = -shared -Wl,-soname=$@.$(SOMAJ) $(LDFLAGS) -o
|
||||||
CP = cp -av
|
CP = cp -av
|
||||||
LEX = flex
|
LEX = flex
|
||||||
|
40
scotch.spec
40
scotch.spec
@ -3,21 +3,21 @@
|
|||||||
|
|
||||||
# Shared library versioning:
|
# Shared library versioning:
|
||||||
# Increment if interface is changed in an incompatible way
|
# Increment if interface is changed in an incompatible way
|
||||||
%global so_maj 0
|
%global so_maj 1
|
||||||
# Increment if interface is extended
|
# Increment if interface is extended
|
||||||
%global so_min 2
|
%global so_min 3
|
||||||
|
|
||||||
Name: scotch
|
Name: scotch
|
||||||
Summary: Graph, mesh and hypergraph partitioning library
|
Summary: Graph, mesh and hypergraph partitioning library
|
||||||
Version: 6.0.5
|
Version: 6.0.6
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
License: CeCILL-C
|
License: CeCILL-C
|
||||||
URL: https://gforge.inria.fr/projects/scotch/
|
URL: https://gforge.inria.fr/projects/scotch/
|
||||||
Source0: https://gforge.inria.fr/frs/download.php/file/34618/%{name}_%{version}.tar.gz
|
Source0: https://gforge.inria.fr/frs/download.php/file/37622/%{name}_%{version}.tar.gz
|
||||||
Source1: scotch-Makefile.shared.inc.in
|
Source1: scotch-Makefile.shared.inc.in
|
||||||
|
|
||||||
# Makefile fixes for building esmumps
|
# Makefile fix for installing esmumps
|
||||||
Patch0: scotch_esmumps.patch
|
Patch0: scotch_esmumps.patch
|
||||||
|
|
||||||
BuildRequires: flex
|
BuildRequires: flex
|
||||||
@ -25,7 +25,8 @@ BuildRequires: bison
|
|||||||
BuildRequires: zlib-devel
|
BuildRequires: zlib-devel
|
||||||
BuildRequires: bzip2-devel
|
BuildRequires: bzip2-devel
|
||||||
%if 0%{?fedora}
|
%if 0%{?fedora}
|
||||||
BuildRequires: lzma-devel
|
BuildRequires: xz-devel
|
||||||
|
BuildRequires: lzma-devel
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -109,9 +110,7 @@ This package contains the parmetis compatibility header for scotch.
|
|||||||
###############################################################################
|
###############################################################################
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
# Sigh, they forgot to update the version in the folder name
|
%autosetup -p1 -n %{name}_%{version}
|
||||||
%setup -q -n scotch_6.0.4
|
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
cp -a %{SOURCE1} src/Makefile.inc
|
cp -a %{SOURCE1} src/Makefile.inc
|
||||||
|
|
||||||
@ -131,18 +130,18 @@ cp -a . %{mpichdir}
|
|||||||
|
|
||||||
%build
|
%build
|
||||||
pushd src/
|
pushd src/
|
||||||
%make_build scotch esmumps CFLAGS="%{optflags}" LDFLAGS="%{?__global_ldflags}" SOMAJ="%{so_maj}"
|
make scotch esmumps CFLAGS="%{optflags}" LDFLAGS="%{?__global_ldflags}" SOMAJ="%{so_maj}"
|
||||||
popd
|
popd
|
||||||
|
|
||||||
%{_mpich_load}
|
%{_mpich_load}
|
||||||
pushd %{mpichdir}/src/
|
pushd %{mpichdir}/src/
|
||||||
%make_build ptscotch ptesmumps CFLAGS="%{optflags}" LDFLAGS="%{?__global_ldflags}" SOMAJ="%{so_maj}"
|
make ptscotch ptesmumps CFLAGS="%{optflags}" LDFLAGS="%{?__global_ldflags}" SOMAJ="%{so_maj}"
|
||||||
popd
|
popd
|
||||||
%{_mpich_unload}
|
%{_mpich_unload}
|
||||||
|
|
||||||
%{_openmpi_load}
|
%{_openmpi_load}
|
||||||
pushd %{openmpidir}/src/
|
pushd %{openmpidir}/src/
|
||||||
%make_build ptscotch ptesmumps CFLAGS="%{optflags}" LDFLAGS="%{?__global_ldflags}" SOMAJ="%{so_maj}"
|
make ptscotch ptesmumps CFLAGS="%{optflags}" LDFLAGS="%{?__global_ldflags}" SOMAJ="%{so_maj}"
|
||||||
popd
|
popd
|
||||||
%{_openmpi_unload}
|
%{_openmpi_unload}
|
||||||
|
|
||||||
@ -230,8 +229,8 @@ popd
|
|||||||
%files
|
%files
|
||||||
%license doc/CeCILL-C_V1-en.txt
|
%license doc/CeCILL-C_V1-en.txt
|
||||||
%{_bindir}/*
|
%{_bindir}/*
|
||||||
%{_libdir}/libscotch*.so.0*
|
%{_libdir}/libscotch*.so.1*
|
||||||
%{_libdir}/libesmumps*.so.0*
|
%{_libdir}/libesmumps*.so.1*
|
||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
@ -242,8 +241,8 @@ popd
|
|||||||
|
|
||||||
%files -n ptscotch-mpich
|
%files -n ptscotch-mpich
|
||||||
%license doc/CeCILL-C_V1-en.txt
|
%license doc/CeCILL-C_V1-en.txt
|
||||||
%{_libdir}/mpich/lib/lib*scotch*.so.0*
|
%{_libdir}/mpich/lib/lib*scotch*.so.1*
|
||||||
%{_libdir}/mpich/lib/lib*esmumps*.so.0*
|
%{_libdir}/mpich/lib/lib*esmumps*.so.1*
|
||||||
%{_libdir}/mpich/bin/*
|
%{_libdir}/mpich/bin/*
|
||||||
%{_mandir}/mpich*/*
|
%{_mandir}/mpich*/*
|
||||||
|
|
||||||
@ -258,8 +257,8 @@ popd
|
|||||||
|
|
||||||
%files -n ptscotch-openmpi
|
%files -n ptscotch-openmpi
|
||||||
%license doc/CeCILL-C_V1-en.txt
|
%license doc/CeCILL-C_V1-en.txt
|
||||||
%{_libdir}/openmpi/lib/lib*scotch*.so.0*
|
%{_libdir}/openmpi/lib/lib*scotch*.so.1*
|
||||||
%{_libdir}/openmpi/lib/lib*esmumps*.so.0*
|
%{_libdir}/openmpi/lib/lib*esmumps*.so.1*
|
||||||
%{_libdir}/openmpi/bin/*
|
%{_libdir}/openmpi/bin/*
|
||||||
%{_mandir}/openmpi*/*
|
%{_mandir}/openmpi*/*
|
||||||
|
|
||||||
@ -278,6 +277,9 @@ popd
|
|||||||
%doc doc/scotch_example.f
|
%doc doc/scotch_example.f
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 16 2018 Sandro Mani <manisandro@gmail.com> - 6.0.6-1
|
||||||
|
- Update to 6.0.6
|
||||||
|
|
||||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 6.0.5-2
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 6.0.5-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
@ -1,30 +1,9 @@
|
|||||||
diff -rupN scotch_6.0.4/src/esmumps/Makefile scotch_6.0.4-new/src/esmumps/Makefile
|
diff -rupN scotch_6.0.6/src/Makefile scotch_6.0.6-new/src/Makefile
|
||||||
--- scotch_6.0.4/src/esmumps/Makefile 2015-03-14 00:32:06.000000000 +0100
|
--- scotch_6.0.6/src/Makefile 2018-07-14 17:24:49.000000000 +0200
|
||||||
+++ scotch_6.0.4-new/src/esmumps/Makefile 2015-03-14 20:53:15.577908208 +0100
|
+++ scotch_6.0.6-new/src/Makefile 2018-07-16 15:43:50.833428459 +0200
|
||||||
@@ -59,7 +59,7 @@ scotch : clean
|
@@ -122,6 +122,8 @@ install : required $(bindir) $(includ
|
||||||
|
|
||||||
ptscotch : clean
|
|
||||||
$(MAKE) CFLAGS="$(CFLAGS) -DSCOTCH_PTSCOTCH" CC="$(CCP)" SCOTCHLIB=ptscotch ESMUMPSLIB=ptesmumps \
|
|
||||||
- libesmumps$(LIB) \
|
|
||||||
+ libptesmumps$(LIB) \
|
|
||||||
main_esmumps$(EXE)
|
|
||||||
|
|
||||||
install :
|
|
||||||
@@ -142,7 +142,7 @@ esmumps_strats$(OBJ) : esmumps_strats.c
|
|
||||||
common.h \
|
|
||||||
esmumps.h
|
|
||||||
|
|
||||||
-libesmumps$(LIB) : graph_graph$(OBJ) \
|
|
||||||
+lib$(ESMUMPSLIB)$(LIB) : graph_graph$(OBJ) \
|
|
||||||
order$(OBJ) \
|
|
||||||
order_scotch_graph$(OBJ) \
|
|
||||||
dof$(OBJ) \
|
|
||||||
diff -rupN scotch_6.0.4/src/Makefile scotch_6.0.4-new/src/Makefile
|
|
||||||
--- scotch_6.0.4/src/Makefile 2014-10-02 17:31:36.000000000 +0200
|
|
||||||
+++ scotch_6.0.4-new/src/Makefile 2015-03-14 20:52:24.735897296 +0100
|
|
||||||
@@ -116,6 +116,8 @@ install : required $(bindir) $(includ
|
|
||||||
-$(CP) -f ../bin/d[agm]*$(EXE) $(bindir)
|
|
||||||
-$(CP) -f ../include/*scotch*.h $(includedir)
|
-$(CP) -f ../include/*scotch*.h $(includedir)
|
||||||
|
-$(CP) -f ../lib/*esmumps*$(LIB) $(libdir)
|
||||||
-$(CP) -f ../lib/*scotch*$(LIB) $(libdir)
|
-$(CP) -f ../lib/*scotch*$(LIB) $(libdir)
|
||||||
+ -$(CP) -f ../include/*esmumps*.h $(includedir)
|
+ -$(CP) -f ../include/*esmumps*.h $(includedir)
|
||||||
+ -$(CP) -f ../lib/*esmumps*$(LIB) $(libdir)
|
+ -$(CP) -f ../lib/*esmumps*$(LIB) $(libdir)
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (scotch_6.0.5.tar.gz) = 0fcf639ab1a09451256444005f1a4a739403159e3ab22c34fbcedc481be387cd4c86be6fb029b4b5816220564f64f662434bf7f1d3921ed18be081ae2a7a9ee2
|
SHA512 (scotch_6.0.6.tar.gz) = a98e0b01bf3d9fca62fb5e33bd8ca938e5994af86f3139d54100e797fc46536b9659e0861cbab7eac261521dbf49c549d7800a7af2d353c6546c9d96ebb16960
|
||||||
|
Loading…
Reference in New Issue
Block a user