Rebase to 2.0.2

This commit is contained in:
Panu Matilainen 2017-08-25 11:36:33 +03:00
parent 9aa9068228
commit e7b8e2c0fa
6 changed files with 11 additions and 70 deletions

1
.gitignore vendored
View File

@ -9,3 +9,4 @@
/scl-utils-20140815.tar.gz /scl-utils-20140815.tar.gz
/scl-utils-2.0.tar.bz2 /scl-utils-2.0.tar.bz2
/scl-utils-2.0.1.tar.bz2 /scl-utils-2.0.1.tar.bz2
/scl-utils-2.0.2.tar.bz2

View File

@ -1,25 +0,0 @@
From 0100e1a89bc7ba3f7e94960437f69294638322a6 Mon Sep 17 00:00:00 2001
From: Lubos Kardos <lkardos@redhat.com>
Date: Tue, 7 Jul 2015 10:25:40 +0200
Subject: [PATCH] Honor CFLAGS passed to cmake resovles: #1239997
---
src/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4cfeef3..d0f96fe 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -4,7 +4,7 @@ SET(MODULE_CMD "/usr/bin/modulecmd" )
SET(CONF_DIR "/etc/scl/conf/" )
CONFIGURE_FILE( config.h.cmake config.h )
-SET( CMAKE_C_FLAGS "-Wall -pedantic --std=gnu99 -D_GNU_SOURCE -g" )
+SET( CMAKE_C_FLAGS "-Wall -pedantic --std=gnu99 -D_GNU_SOURCE -g ${CMAKE_C_FLAGS}" )
INCLUDE_DIRECTORIES ("${PROJECT_BINARY_DIR}/src")
list(APPEND SOURCES scl.c debug.c scllib.c lib_common.c args.c sclmalloc.c fallback.c)
ADD_EXECUTABLE (scl ${SOURCES})
--
1.9.3

View File

@ -1,26 +0,0 @@
From c041733a012ec179950c5113a8875a6d4b8c2867 Mon Sep 17 00:00:00 2001
From: Lubos Kardos <lkardos@redhat.com>
Date: Thu, 27 Aug 2015 13:46:06 +0200
Subject: [PATCH] Fix core dumps with large input on stdin (rhbz:1257274)
---
src/args.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/args.c b/src/args.c
index c524dbc..dda57cd 100644
--- a/src/args.c
+++ b/src/args.c
@@ -139,8 +139,8 @@ static int extract_command_stdin(struct scl_args *args)
len = 0;
while ((r = fread(command+len, 1, BUFSIZ, stdin)) == BUFSIZ) {
- command = xrealloc(command, len+BUFSIZ+1);
len += r;
+ command = xrealloc(command, len+BUFSIZ+1);
}
if (feof(stdin)) {
--
1.9.3

View File

@ -1,11 +0,0 @@
diff -up scl-utils-2.0.1/rpm/macros.scl.repack-jars scl-utils-2.0.1/rpm/macros.scl
--- scl-utils-2.0.1/rpm/macros.scl.repack-jars 2017-03-20 09:16:51.194712064 +0200
+++ scl-utils-2.0.1/rpm/macros.scl 2017-03-20 09:18:25.558540724 +0200
@@ -94,7 +94,6 @@ package or when debugging this package.
/usr/lib/rpm/brp-strip-static-archive %{__strip}
/usr/lib/rpm/brp-scl-python-bytecompile %{__python} %{?_python_bytecompile_errors_terminate_build} %{_scl_root}
/usr/lib/rpm/brp-python-hardlink
- %{!?__jar_repack:/usr/lib/rpm/redhat/brp-java-repack-jars}
%{nil}}
BuildRequires: scl-utils-build
%if "%{?scl}%{!?scl:0}" == "%{pkg_name}"

View File

@ -2,8 +2,8 @@
Name: scl-utils Name: scl-utils
Epoch: 1 Epoch: 1
Version: 2.0.1 Version: 2.0.2
Release: 20%{dist} Release: 1%{dist}
Summary: Utilities for alternative packaging Summary: Utilities for alternative packaging
License: GPLv2+ License: GPLv2+
@ -15,10 +15,7 @@ Buildrequires: cmake
Buildrequires: rpm-devel Buildrequires: rpm-devel
Requires: environment(modules) Requires: environment(modules)
Patch1: 0001-Honor-CFLAGS-passed-to-cmake.patch Patch1: 0003-Scl-utils-layout-patch-from-fedora-famillecollet.com.patch
Patch2: 0002-Fix-core-dumps-with-large-input-on-stdin-rhbz-125727.patch
Patch3: 0003-Scl-utils-layout-patch-from-fedora-famillecollet.com.patch
Patch4: scl-utils-2.0.1-no-repack-jars.patch
%description %description
Run-time utility for alternative packaging. Run-time utility for alternative packaging.
@ -63,8 +60,10 @@ rm -rf %buildroot
%dir %{_sysconfdir}/scl/modulefiles %dir %{_sysconfdir}/scl/modulefiles
%dir %{_sysconfdir}/scl/prefixes %dir %{_sysconfdir}/scl/prefixes
%{_sysconfdir}/scl/conf %{_sysconfdir}/scl/conf
%config %{_sysconfdir}/bash_completion.d/scl-completion.bash %{_sysconfdir}/scl/func_scl.csh
%config %{_sysconfdir}/bash_completion.d/scl
%config %{_sysconfdir}/profile.d/scl-init.sh %config %{_sysconfdir}/profile.d/scl-init.sh
%config %{_sysconfdir}/profile.d/scl-init.csh
%{_bindir}/scl %{_bindir}/scl
%{_bindir}/scl_enabled %{_bindir}/scl_enabled
%{_bindir}/scl_source %{_bindir}/scl_source
@ -81,6 +80,9 @@ rm -rf %buildroot
%{_rpmconfigdir}/brp-scl-python-bytecompile %{_rpmconfigdir}/brp-scl-python-bytecompile
%changelog %changelog
* Fri Aug 25 2017 Panu Matilainen <pmatilai@redhat.com> - 1:2.0.2-1
- Rebase to 2.0.2
* Fri Aug 11 2017 Igor Gnatenko <ignatenko@redhat.com> - 1:2.0.1-20 * Fri Aug 11 2017 Igor Gnatenko <ignatenko@redhat.com> - 1:2.0.1-20
- Rebuilt after RPM update (№ 3) - Rebuilt after RPM update (№ 3)

View File

@ -1 +1 @@
fb9362adb77b7d0bcf219b99169f945b scl-utils-2.0.1.tar.bz2 SHA512 (scl-utils-2.0.2.tar.bz2) = e91643d01fa9f5abb257927004a265c054729fee93a4256773ea3cdb95327ee0c46994035154062f5b5c9388719fd7e08001974e9a210c9f3b540ac488449175