- Honor CFLAGS passed to cmake

- resolves: #1239997
This commit is contained in:
Lubos Kardos 2015-07-07 10:19:35 +02:00
parent 690eefa154
commit 23c2e9a341
2 changed files with 32 additions and 2 deletions

View File

@ -0,0 +1,25 @@
From 0100e1a89bc7ba3f7e94960437f69294638322a6 Mon Sep 17 00:00:00 2001
From: Lubos Kardos <lkardos@redhat.com>
Date: Tue, 7 Jul 2015 10:25:40 +0200
Subject: [PATCH] Honor CFLAGS passed to cmake resovles: #1239997
---
src/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4cfeef3..d0f96fe 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -4,7 +4,7 @@ SET(MODULE_CMD "/usr/bin/modulecmd" )
SET(CONF_DIR "/etc/scl/conf/" )
CONFIGURE_FILE( config.h.cmake config.h )
-SET( CMAKE_C_FLAGS "-Wall -pedantic --std=gnu99 -D_GNU_SOURCE -g" )
+SET( CMAKE_C_FLAGS "-Wall -pedantic --std=gnu99 -D_GNU_SOURCE -g ${CMAKE_C_FLAGS}" )
INCLUDE_DIRECTORIES ("${PROJECT_BINARY_DIR}/src")
list(APPEND SOURCES scl.c debug.c scllib.c lib_common.c args.c sclmalloc.c fallback.c)
ADD_EXECUTABLE (scl ${SOURCES})
--
1.9.3

View File

@ -3,7 +3,7 @@
Name: scl-utils Name: scl-utils
Epoch: 1 Epoch: 1
Version: 2.0.1 Version: 2.0.1
Release: 4%{dist} Release: 5%{dist}
Summary: Utilities for alternative packaging Summary: Utilities for alternative packaging
License: GPLv2+ License: GPLv2+
@ -15,6 +15,8 @@ Buildrequires: cmake
Buildrequires: rpm-devel Buildrequires: rpm-devel
Requires: environment-modules Requires: environment-modules
Patch1: 0001-Honor-CFLAGS-passed-to-cmake.patch
%description %description
Run-time utility for alternative packaging. Run-time utility for alternative packaging.
@ -28,7 +30,7 @@ Requires: redhat-rpm-config
Essential RPM build macros for alternative packaging. Essential RPM build macros for alternative packaging.
%prep %prep
%autosetup %autosetup -p1
%build %build
%cmake %cmake
@ -76,6 +78,9 @@ rm -rf %buildroot
%{_rpmconfigdir}/brp-scl-python-bytecompile %{_rpmconfigdir}/brp-scl-python-bytecompile
%changelog %changelog
* Tue Jul 07 2015 Lubos Kardos <lkardos@redhat.com> - 1:2.0.1-5
- Honor CFLAGS passed to cmake (#1239997)
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2.0.1-4 * Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2.0.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild