parent
690eefa154
commit
23c2e9a341
25
0001-Honor-CFLAGS-passed-to-cmake.patch
Normal file
25
0001-Honor-CFLAGS-passed-to-cmake.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From 0100e1a89bc7ba3f7e94960437f69294638322a6 Mon Sep 17 00:00:00 2001
|
||||
From: Lubos Kardos <lkardos@redhat.com>
|
||||
Date: Tue, 7 Jul 2015 10:25:40 +0200
|
||||
Subject: [PATCH] Honor CFLAGS passed to cmake resovles: #1239997
|
||||
|
||||
---
|
||||
src/CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
|
||||
index 4cfeef3..d0f96fe 100644
|
||||
--- a/src/CMakeLists.txt
|
||||
+++ b/src/CMakeLists.txt
|
||||
@@ -4,7 +4,7 @@ SET(MODULE_CMD "/usr/bin/modulecmd" )
|
||||
SET(CONF_DIR "/etc/scl/conf/" )
|
||||
CONFIGURE_FILE( config.h.cmake config.h )
|
||||
|
||||
-SET( CMAKE_C_FLAGS "-Wall -pedantic --std=gnu99 -D_GNU_SOURCE -g" )
|
||||
+SET( CMAKE_C_FLAGS "-Wall -pedantic --std=gnu99 -D_GNU_SOURCE -g ${CMAKE_C_FLAGS}" )
|
||||
INCLUDE_DIRECTORIES ("${PROJECT_BINARY_DIR}/src")
|
||||
list(APPEND SOURCES scl.c debug.c scllib.c lib_common.c args.c sclmalloc.c fallback.c)
|
||||
ADD_EXECUTABLE (scl ${SOURCES})
|
||||
--
|
||||
1.9.3
|
||||
|
@ -3,7 +3,7 @@
|
||||
Name: scl-utils
|
||||
Epoch: 1
|
||||
Version: 2.0.1
|
||||
Release: 4%{dist}
|
||||
Release: 5%{dist}
|
||||
Summary: Utilities for alternative packaging
|
||||
|
||||
License: GPLv2+
|
||||
@ -15,6 +15,8 @@ Buildrequires: cmake
|
||||
Buildrequires: rpm-devel
|
||||
Requires: environment-modules
|
||||
|
||||
Patch1: 0001-Honor-CFLAGS-passed-to-cmake.patch
|
||||
|
||||
%description
|
||||
Run-time utility for alternative packaging.
|
||||
|
||||
@ -28,7 +30,7 @@ Requires: redhat-rpm-config
|
||||
Essential RPM build macros for alternative packaging.
|
||||
|
||||
%prep
|
||||
%autosetup
|
||||
%autosetup -p1
|
||||
|
||||
%build
|
||||
%cmake
|
||||
@ -76,6 +78,9 @@ rm -rf %buildroot
|
||||
%{_rpmconfigdir}/brp-scl-python-bytecompile
|
||||
|
||||
%changelog
|
||||
* Tue Jul 07 2015 Lubos Kardos <lkardos@redhat.com> - 1:2.0.1-5
|
||||
- Honor CFLAGS passed to cmake (#1239997)
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2.0.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user