- Update to 0.12.0 final
- No longer remove weave from python3 build
This commit is contained in:
parent
5ad567d7ee
commit
e2c5ca9e08
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@ scipy-0.7.2.tar.gz
|
||||
/scipy-0.11.0rc2.tar.gz
|
||||
/scipy-0.11.0.tar.gz
|
||||
/scipy-0.12.0b1.tar.gz
|
||||
/scipy-0.12.0.tar.gz
|
||||
|
@ -1,100 +0,0 @@
|
||||
diff -up scipy-0.11.0/scipy/linalg/flapack.pyf.src.linalg scipy-0.11.0/scipy/linalg/flapack.pyf.src
|
||||
--- scipy-0.11.0/scipy/linalg/flapack.pyf.src.linalg 2012-09-10 15:37:39.000000000 -0600
|
||||
+++ scipy-0.11.0/scipy/linalg/flapack.pyf.src 2013-02-13 21:25:50.684650798 -0700
|
||||
@@ -1470,7 +1470,7 @@ subroutine <prefix2>sbevx(ab,ldab,comput
|
||||
!* If JOBZ = 'V', the N-by-N orthogonal matrix used in the
|
||||
!* reduction to tridiagonal form.
|
||||
!* If JOBZ = 'N', the array Q is not referenced.
|
||||
- integer intent(hide),depend(n) :: ldq=(compute_v?n:1)
|
||||
+ integer intent(hide),depend(n,compute_v) :: ldq=(compute_v?n:1)
|
||||
<ftype2> dimension(ldq,ldq),intent(hide),depend(ldq) :: q
|
||||
|
||||
|
||||
@@ -1495,8 +1495,8 @@ subroutine <prefix2>sbevx(ab,ldab,comput
|
||||
|
||||
<ftype2> dimension(n),intent(out),depend(n) :: w
|
||||
|
||||
- <ftype2> dimension(ldz,mmax),intent(out) :: z
|
||||
- integer intent(hide),depend(n) :: ldz=(compute_v?n:1)
|
||||
+ <ftype2> dimension(ldz,mmax),depend(ldz,mmax),intent(out) :: z
|
||||
+ integer intent(hide),depend(n,compute_v) :: ldz=(compute_v?n:1)
|
||||
|
||||
! We use the mmax parameter to fix the size of z
|
||||
! (only if eigenvalues are requested)
|
||||
@@ -1507,12 +1507,12 @@ subroutine <prefix2>sbevx(ab,ldab,comput
|
||||
! number of eigenvalues in the interval in advance.
|
||||
! As default we use the maximum value
|
||||
! but the user should use an appropriate mmax.
|
||||
- integer intent(in),depend(n) :: mmax=(compute_v?(range==2?(iu-il+1):n):1)
|
||||
+ integer intent(in),depend(n,iu,il,compute_v,range) :: mmax=(compute_v?(range==2?(iu-il+1):n):1)
|
||||
integer intent(out) :: m
|
||||
|
||||
- <ftype2> dimension(7*n),intent(hide) :: work
|
||||
- integer dimension(5*n),intent(hide) :: iwork
|
||||
- integer dimension((compute_v?n:1)),intent(out) :: ifail
|
||||
+ <ftype2> dimension(7*n),depend(n),intent(hide) :: work
|
||||
+ integer dimension(5*n),depend(n),intent(hide) :: iwork
|
||||
+ integer dimension((compute_v?n:1)),depend(n,compute_v),intent(out) :: ifail
|
||||
integer intent(out):: info
|
||||
end subroutine <prefix2>sbevx
|
||||
|
||||
@@ -1590,7 +1590,7 @@ subroutine <prefix2c>hbevx(ab,ldab,compu
|
||||
!* If JOBZ = 'V', the N-by-N orthogonal matrix used in the
|
||||
!* reduction to tridiagonal form.
|
||||
!* If JOBZ = 'N', the array Q is not referenced.
|
||||
- integer intent(hide),depend(n) :: ldq=(compute_v?n:1)
|
||||
+ integer intent(hide),depend(n,compute_v) :: ldq=(compute_v?n:1)
|
||||
<ftype2c> dimension(ldq,ldq),intent(hide),depend(ldq) :: q
|
||||
|
||||
|
||||
@@ -1615,8 +1615,8 @@ subroutine <prefix2c>hbevx(ab,ldab,compu
|
||||
|
||||
<ftype2> dimension(n),intent(out),depend(n) :: w
|
||||
|
||||
- <ftype2c> dimension(ldz,mmax),intent(out) :: z
|
||||
- integer intent(hide),depend(n) :: ldz=(compute_v?n:1)
|
||||
+ <ftype2c> dimension(ldz,mmax),depend(ldz,mmax),intent(out) :: z
|
||||
+ integer intent(hide),depend(n,compute_v) :: ldz=(compute_v?n:1)
|
||||
|
||||
! We use the mmax parameter to fix the size of z
|
||||
! (only if eigenvalues are requested)
|
||||
@@ -1627,13 +1627,13 @@ subroutine <prefix2c>hbevx(ab,ldab,compu
|
||||
! number of eigenvalues in the interval in advance.
|
||||
! As default we use the maximum value
|
||||
! but the user should use an appropriate mmax.
|
||||
- integer intent(in),depend(n) :: mmax=(compute_v?(range==2?(iu-il+1):n):1)
|
||||
+ integer intent(in),depend(n,iu,il,compute_v,range) :: mmax=(compute_v?(range==2?(iu-il+1):n):1)
|
||||
integer intent(out) :: m
|
||||
|
||||
- <ftype2c> dimension(n),intent(hide) :: work
|
||||
- <ftype2> dimension(7*n),intent(hide) :: rwork
|
||||
- integer dimension(5*n),intent(hide) :: iwork
|
||||
- integer dimension((compute_v?n:1)),intent(out) :: ifail
|
||||
+ <ftype2c> dimension(n),depend(n),intent(hide) :: work
|
||||
+ <ftype2> dimension(7*n),depend(n),intent(hide) :: rwork
|
||||
+ integer dimension(5*n),depend(n),intent(hide) :: iwork
|
||||
+ integer dimension((compute_v?n:1)),depend(n,compute_v),intent(out) :: ifail
|
||||
integer intent(out):: info
|
||||
end subroutine <prefix2c>hbevx
|
||||
|
||||
diff -up scipy-0.11.0/scipy/sparse/linalg/eigen/arpack/arpack.pyf.src.linalg scipy-0.11.0/scipy/sparse/linalg/eigen/arpack/arpack.pyf.src
|
||||
--- scipy-0.11.0/scipy/sparse/linalg/eigen/arpack/arpack.pyf.src.linalg 2012-09-10 15:37:41.000000000 -0600
|
||||
+++ scipy-0.11.0/scipy/sparse/linalg/eigen/arpack/arpack.pyf.src 2013-02-13 21:25:50.686650709 -0700
|
||||
@@ -29,7 +29,7 @@ python module _arpack ! in
|
||||
character :: howmny
|
||||
logical dimension(ncv) :: select
|
||||
<_rd> dimension(nev),intent(out),depend(nev) :: d
|
||||
- <_rd> dimension(n,nev),intent(out),depend(nev) :: z
|
||||
+ <_rd> dimension(n,nev),intent(out),depend(n,nev) :: z
|
||||
integer optional,check(shape(z,0)==ldz),depend(z) :: ldz=shape(z,0)
|
||||
<_rd> :: sigma
|
||||
character :: bmat
|
||||
@@ -121,7 +121,7 @@ python module _arpack ! in
|
||||
character :: howmny
|
||||
logical dimension(ncv) :: select
|
||||
<_cd> dimension(nev),depend(nev),intent(out) :: d
|
||||
- <_cd> dimension(n,nev), depend(nev),intent(out) :: z
|
||||
+ <_cd> dimension(n,nev), depend(n,nev),intent(out) :: z
|
||||
integer optional,check(shape(z,0)==ldz),depend(z) :: ldz=shape(z,0)
|
||||
<_cd> :: sigma
|
||||
<_cd> dimension(3 * ncv),depend(ncv) :: workev
|
12
scipy.spec
12
scipy.spec
@ -16,12 +16,12 @@
|
||||
Summary: Scipy: Scientific Tools for Python
|
||||
Name: scipy
|
||||
Version: 0.12.0
|
||||
Release: 0.1.b1%{?dist}
|
||||
Release: 1%{?dist}
|
||||
|
||||
Group: Development/Libraries
|
||||
License: BSD and LGPLv2+
|
||||
Url: http://www.scipy.org
|
||||
Source0: http://downloads.sourceforge.net/scipy/%{name}-%{version}b1.tar.gz
|
||||
Source0: http://downloads.sourceforge.net/scipy/%{name}-%{version}.tar.gz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: numpy, python-devel,f2py
|
||||
@ -68,7 +68,7 @@ leading scientists and engineers.
|
||||
%endif # with _python3
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}b1
|
||||
%setup -q
|
||||
cat > site.cfg << EOF
|
||||
|
||||
[amd]
|
||||
@ -86,8 +86,6 @@ EOF
|
||||
%if 0%{?with_python3}
|
||||
rm -rf %{py3dir}
|
||||
cp -a . %{py3dir}
|
||||
rm -r %{py3dir}/scipy/weave
|
||||
sed -i -e /weave/d %{py3dir}/scipy/setup.py
|
||||
%endif
|
||||
|
||||
%build
|
||||
@ -147,6 +145,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%endif # with_python3
|
||||
|
||||
%changelog
|
||||
* Wed Apr 10 2013 Orion Poplawski <orion@cora.nwra.com> - 0.12.0-1
|
||||
- Update to 0.12.0 final
|
||||
- No longer remove weave from python3 build
|
||||
|
||||
* Sat Feb 16 2013 Orion Poplawski <orion@cora.nwra.com> - 0.12.0-0.1.b1
|
||||
- Update to 0.12.0b1
|
||||
- Drop upstreamed linalg patch
|
||||
|
Loading…
Reference in New Issue
Block a user