parent
fad1b115d2
commit
ddfc0d2225
1
.gitignore
vendored
1
.gitignore
vendored
@ -33,3 +33,4 @@ scipy-0.7.2.tar.gz
|
||||
/scipy-1.5.3.tar.gz
|
||||
/scipy-1.5.4.tar.gz
|
||||
/scipy-1.6.0.tar.gz
|
||||
/scipy-1.6.1.tar.gz
|
||||
|
11
scipy.spec
11
scipy.spec
@ -14,8 +14,8 @@
|
||||
|
||||
Summary: Scientific Tools for Python
|
||||
Name: scipy
|
||||
Version: 1.6.0
|
||||
Release: 3%{?dist}
|
||||
Version: 1.6.1
|
||||
Release: 1%{?dist}
|
||||
|
||||
# BSD -- whole package except:
|
||||
# Boost -- scipy/special/cephes/scipy_iv.c
|
||||
@ -24,9 +24,6 @@ License: BSD and Boost and Public Domain
|
||||
Url: http://www.scipy.org/scipylib/index.html
|
||||
Source0: https://github.com/scipy/scipy/releases/download/v%{version}/scipy-%{version}.tar.gz
|
||||
|
||||
# https://github.com/scipy/scipy/pull/13387
|
||||
Patch0: wavfile.patch
|
||||
|
||||
BuildRequires: fftw-devel, suitesparse-devel
|
||||
BuildRequires: %{blaslib}-devel
|
||||
BuildRequires: gcc-gfortran, swig, gcc-c++
|
||||
@ -177,6 +174,10 @@ popd
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Feb 18 2021 Nikola Forró <nforro@redhat.com> - 1.6.1-1
|
||||
- New upstream release 1.6.1
|
||||
resolves: #1929994
|
||||
|
||||
* Wed Feb 03 2021 Nikola Forró <nforro@redhat.com> - 1.6.0-3
|
||||
- Increase test timeout on s390x
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (scipy-1.6.0.tar.gz) = 995ffaf56b713cdd4bdb98d8525b892e9ad84a511878b43213cb71a67f34d87c111da36cf1e0b044c75c0d5af64bfde4ad0f3e9c5e71cae2dbf053251f37064e
|
||||
SHA512 (scipy-1.6.1.tar.gz) = 778a7bca15bb880a3fd1c3d46ef753920335eca95fe5f2b8512883a2aec1bb8e9d8a8fdbf4fee90e823e31980408a51451cc53d4f10c632cd72faf2856c868c8
|
||||
|
@ -1,36 +0,0 @@
|
||||
commit 09d753f0ae71441906f5cee7a44b2d2b80212082
|
||||
Author: Nikola Forró <nforro@redhat.com>
|
||||
Date: Thu Jan 14 14:34:14 2021 +0100
|
||||
|
||||
ENH: Support big-endian platforms and big-endian WAVs
|
||||
|
||||
PR #12287 added support for reading arbitrary-bit-depth WAVs, but
|
||||
the code doesn't consider big-endian WAVs, and doesn't work as expected
|
||||
on big-endian platforms due to the use of native-byte-order data-types.
|
||||
This change fixes that.
|
||||
|
||||
There is also a simple test case that compares euqivalent RIFX
|
||||
(big-endian) and RIFF (little-endian) files to verify the data read
|
||||
are the same.
|
||||
|
||||
diff --git a/scipy/io/wavfile.py b/scipy/io/wavfile.py
|
||||
index 9b5845d6b..951f8d201 100644
|
||||
--- a/scipy/io/wavfile.py
|
||||
+++ b/scipy/io/wavfile.py
|
||||
@@ -458,10 +458,13 @@ def _read_data_chunk(fid, format_tag, channels, bit_depth, is_big_endian,
|
||||
|
||||
if dtype == 'V1':
|
||||
# Rearrange raw bytes into smallest compatible numpy dtype
|
||||
- dt = numpy.int32 if bytes_per_sample == 3 else numpy.int64
|
||||
- a = numpy.zeros((len(data) // bytes_per_sample, dt().itemsize),
|
||||
+ dt = f'{fmt}i4' if bytes_per_sample == 3 else f'{fmt}i8'
|
||||
+ a = numpy.zeros((len(data) // bytes_per_sample, numpy.dtype(dt).itemsize),
|
||||
dtype='V1')
|
||||
- a[:, -bytes_per_sample:] = data.reshape((-1, bytes_per_sample))
|
||||
+ if is_big_endian:
|
||||
+ a[:, :bytes_per_sample] = data.reshape((-1, bytes_per_sample))
|
||||
+ else:
|
||||
+ a[:, -bytes_per_sample:] = data.reshape((-1, bytes_per_sample))
|
||||
data = a.view(dt).reshape(a.shape[:-1])
|
||||
else:
|
||||
if bytes_per_sample in {1, 2, 4, 8}:
|
Loading…
Reference in New Issue
Block a user