parent
cb4c1a5648
commit
bd4e64917c
1
.gitignore
vendored
1
.gitignore
vendored
@ -38,3 +38,4 @@ scipy-0.7.2.tar.gz
|
||||
/scipy-1.7.0.tar.gz
|
||||
/scipy-1.7.3.tar.gz
|
||||
/scipy-1.8.0.tar.gz
|
||||
/scipy-1.8.1.tar.gz
|
||||
|
19
scipy.spec
19
scipy.spec
@ -24,8 +24,8 @@
|
||||
|
||||
Summary: Scientific Tools for Python
|
||||
Name: scipy
|
||||
Version: 1.8.0
|
||||
Release: 3%{?dist}
|
||||
Version: 1.8.1
|
||||
Release: 1%{?dist}
|
||||
|
||||
# BSD -- whole package except:
|
||||
# Boost -- scipy/special/cephes/scipy_iv.c
|
||||
@ -34,9 +34,6 @@ License: BSD and Boost and Public Domain
|
||||
Url: http://www.scipy.org/scipylib/index.html
|
||||
Source0: https://github.com/scipy/scipy/releases/download/v%{version}/scipy-%{version}.tar.gz
|
||||
|
||||
# https://github.com/scipy/scipy/pull/15306
|
||||
Patch0: skip-build.patch
|
||||
|
||||
BuildRequires: fftw-devel, suitesparse-devel
|
||||
BuildRequires: %{blaslib}-devel
|
||||
BuildRequires: gcc-gfortran, swig, gcc-c++
|
||||
@ -177,7 +174,7 @@ export PYTEST_ADDOPTS="-k 'not TestSchur and \
|
||||
TIMEOUT=1000
|
||||
%endif
|
||||
|
||||
%ifarch aarch64
|
||||
%ifarch aarch64 || ppc64le
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1959353
|
||||
export PYTEST_ADDOPTS="-k 'not TestSchur and not test_solve_discrete_are'"
|
||||
%endif
|
||||
@ -192,18 +189,12 @@ export PYTEST_ADDOPTS="-k 'not TestSchur and not test_sygst'"
|
||||
export PYTEST_ADDOPTS="-k 'not TestSchur and not test_sygst and not test_cython_api'"
|
||||
%endif
|
||||
|
||||
# tests on ppc64le are temporarily disabled as they segfault a lot:
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1959353
|
||||
%ifnarch ppc64le
|
||||
|
||||
pushd %{buildroot}/%{python3_sitearch}
|
||||
%{pytest} --timeout=${TIMEOUT} scipy --numprocesses=auto
|
||||
# Remove test remnants
|
||||
rm -rf gram{A,B}
|
||||
popd
|
||||
|
||||
%endif
|
||||
|
||||
%files -n python3-scipy
|
||||
%doc LICENSE.txt
|
||||
%{python3_sitearch}/scipy/
|
||||
@ -216,6 +207,10 @@ popd
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Jun 09 2022 Nikola Forró <nforro@redhat.com> - 1.8.1-1
|
||||
- New upstream release 1.8.1
|
||||
resolves: #2088437
|
||||
|
||||
* Sat Mar 26 2022 Nikola Forró <nforro@redhat.com> - 1.8.0-3
|
||||
- Skip test_cython_api also on armv7hl
|
||||
|
||||
|
@ -1,23 +0,0 @@
|
||||
From 84658e69c2b5f8767c56eaed5151b66a4c0b1e55 Mon Sep 17 00:00:00 2001
|
||||
From: Ralf Gommers <ralf.gommers@gmail.com>
|
||||
Date: Wed, 29 Dec 2021 22:47:28 +0100
|
||||
Subject: [PATCH] Revert "BLD Respect the --skip-build flag in setup.py"
|
||||
(#15306)
|
||||
|
||||
---
|
||||
setup.py | 2 --
|
||||
1 file changed, 2 deletions(-)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index 002531fcc00..d91916e5894 100755
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -488,8 +488,6 @@ def setup_package():
|
||||
if "--force" in sys.argv:
|
||||
run_build = True
|
||||
sys.argv.remove('--force')
|
||||
- elif "--skip-build" in sys.argv:
|
||||
- run_build = False
|
||||
else:
|
||||
# Raise errors for unsupported commands, improve help output, etc.
|
||||
run_build = check_setuppy_command()
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (scipy-1.8.0.tar.gz) = 674652728ae76479d17189e6974895bb838a8e83b17b9fb91c5f86faebf2a1387e1466555ac5b51d05c293f9b31b9a72e634f5858105ea984ca94bd2f05bbb4c
|
||||
SHA512 (scipy-1.8.1.tar.gz) = f6fc71c209991fe82baa4b10d8ade0deb1057f6f5942a91dfb7ae45f3eb78a4535efa2861badf5e2d37239fa99dbd99de760aa7e4854b95991ade0263004e7ea
|
||||
|
Loading…
Reference in New Issue
Block a user