New upstream release 1.8.0

- resolves: #2035126
This commit is contained in:
Nikola Forró 2022-03-05 16:20:07 +01:00
parent b637c5c738
commit a59f9627e2
5 changed files with 50 additions and 55 deletions

1
.gitignore vendored
View File

@ -37,3 +37,4 @@ scipy-0.7.2.tar.gz
/scipy-1.6.2.tar.gz
/scipy-1.7.0.tar.gz
/scipy-1.7.3.tar.gz
/scipy-1.8.0.tar.gz

View File

@ -1,38 +0,0 @@
From c19bf22ce8d8cc2be8ce7950ffb93429ddc49e78 Mon Sep 17 00:00:00 2001
From: serge-sans-paille <serge.guelton@telecom-bretagne.eu>
Date: Sun, 18 Jul 2021 11:14:29 +0200
Subject: [PATCH] Extra pythran annotation for i686 support
Bug spotted on Fedora, see https://src.fedoraproject.org/rpms/scipy/pull-request/22
The `int[::]` annotation is used to accept non-contiguous views.
---
scipy/optimize/_group_columns.py | 2 ++
scipy/signal/_max_len_seq_inner.py | 1 +
2 files changed, 3 insertions(+)
diff --git a/scipy/optimize/_group_columns.py b/scipy/optimize/_group_columns.py
index d5dd9e1e48a1..8b4fcee34e7b 100644
--- a/scipy/optimize/_group_columns.py
+++ b/scipy/optimize/_group_columns.py
@@ -54,6 +54,8 @@ def group_dense(m, n, A):
#pythran export group_sparse(int, int, intc[], intc[])
#pythran export group_sparse(int, int, int[], int[])
+#pythran export group_sparse(int, int, intc[::], intc[::])
+#pythran export group_sparse(int, int, int[::], int[::])
def group_sparse(m, n, indices, indptr):
groups = -np.ones(n, dtype=np.intp)
current_group = 0
diff --git a/scipy/signal/_max_len_seq_inner.py b/scipy/signal/_max_len_seq_inner.py
index fe57499af329..88d6ef3d7557 100644
--- a/scipy/signal/_max_len_seq_inner.py
+++ b/scipy/signal/_max_len_seq_inner.py
@@ -4,6 +4,7 @@
import numpy as np
#pythran export _max_len_seq_inner(intp[], int8[], int, int, int8[])
+#pythran export _max_len_seq_inner(int[], int8[], int, int, int8[])
# Fast inner loop of max_len_seq.
def _max_len_seq_inner(taps, state, nbits, length, seq):

View File

@ -4,7 +4,12 @@
# Pythran is an optional build dependency.
# When used, it makes some modules faster,
# but it is usually not available soon enough for new major Python versions.
%ifarch i686
# It seems pythran is broken on i686, disable it
%bcond_with pythran
%else
%bcond_without pythran
%endif
# Set to pre-release version suffix if building pre-release, else %%{nil}
%global rcver %{nil}
@ -19,8 +24,8 @@
Summary: Scientific Tools for Python
Name: scipy
Version: 1.7.3
Release: 2%{?dist}
Version: 1.8.0
Release: 1%{?dist}
# BSD -- whole package except:
# Boost -- scipy/special/cephes/scipy_iv.c
@ -29,8 +34,8 @@ License: BSD and Boost and Public Domain
Url: http://www.scipy.org/scipylib/index.html
Source0: https://github.com/scipy/scipy/releases/download/v%{version}/scipy-%{version}.tar.gz
# Fix Pythran modules on 32bit arches, merged upstream
Patch1: https://github.com/scipy/scipy/pull/14427.patch
# https://github.com/scipy/scipy/pull/15306
Patch0: skip-build.patch
BuildRequires: fftw-devel, suitesparse-devel
BuildRequires: %{blaslib}-devel
@ -123,7 +128,12 @@ for PY in %{python3_version}; do
%else
FFLAGS="$RPM_OPT_FLAGS -fPIC" \
%endif
LDFLAGS="%{__global_ldflags}" \
%ifarch x86_64
# workaround for https://bugzilla.redhat.com/show_bug.cgi?id=2068530
LDFLAGS="%{__global_ldflags} -Wl,--no-as-needed -lmvec -Wl,--as-needed" \
%else
LDFLAGS="%{__global_ldflags}" \
%endif
%{_bindir}/python$PY setup.py config_fc \
--fcompiler=gnu95 --noarch \
build
@ -161,16 +171,6 @@ export PYTEST_ADDOPTS="-k 'not TestSchur'"
# skip failing tests on s390x for now
export PYTEST_ADDOPTS="-k 'not TestSchur and \
not (TestNoData and test_nodata) and \
not test_fortranfile_read_mixed_record and \
not test_kde_1d and \
not test_kde_1d_weighted and \
not test_kde_2d and \
not test_kde_2d_weighted and \
not test_gaussian_kde_subclassing and \
not test_gaussian_kde_covariance_caching and \
not test_kde_integer_input and \
not test_pdf_logpdf and \
not test_pdf_logpdf_weighted and \
not test_solve_discrete_are'"
# some tests (namely test_logpdf_overflow) tend to run for a long time on s390x
@ -182,11 +182,16 @@ TIMEOUT=1000
export PYTEST_ADDOPTS="-k 'not TestSchur and not test_solve_discrete_are'"
%endif
%ifarch i686 || x86_64 || armv7hl
%ifarch x86_64 || armv7hl
# skip also failing test_sygst for now
export PYTEST_ADDOPTS="-k 'not TestSchur and not test_sygst'"
%endif
%ifarch i686
# skip also test_cython_api: https://bugzilla.redhat.com/show_bug.cgi?id=2068496
export PYTEST_ADDOPTS="-k 'not TestSchur and not test_sygst and not test_cython_api'"
%endif
# tests on ppc64le are temporarily disabled as they segfault a lot:
# https://bugzilla.redhat.com/show_bug.cgi?id=1959353
%ifnarch ppc64le
@ -211,6 +216,10 @@ popd
%endif
%changelog
* Mon Feb 07 2022 Nikola Forró <nforro@redhat.com> - 1.8.0-1
- New upstream release 1.8.0
resolves: #2035126
* Sat Jan 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild

23
skip-build.patch Normal file
View File

@ -0,0 +1,23 @@
From 84658e69c2b5f8767c56eaed5151b66a4c0b1e55 Mon Sep 17 00:00:00 2001
From: Ralf Gommers <ralf.gommers@gmail.com>
Date: Wed, 29 Dec 2021 22:47:28 +0100
Subject: [PATCH] Revert "BLD Respect the --skip-build flag in setup.py"
(#15306)
---
setup.py | 2 --
1 file changed, 2 deletions(-)
diff --git a/setup.py b/setup.py
index 002531fcc00..d91916e5894 100755
--- a/setup.py
+++ b/setup.py
@@ -488,8 +488,6 @@ def setup_package():
if "--force" in sys.argv:
run_build = True
sys.argv.remove('--force')
- elif "--skip-build" in sys.argv:
- run_build = False
else:
# Raise errors for unsupported commands, improve help output, etc.
run_build = check_setuppy_command()

View File

@ -1 +1 @@
SHA512 (scipy-1.7.3.tar.gz) = 83fe00cf708a13a08d28af7022ec645d8976c177f2fefb56e0a47bfcbec726330b973d1f44364e23c939ae708e239a05904346f515ea1a37e8b70ad160b81cee
SHA512 (scipy-1.8.0.tar.gz) = 674652728ae76479d17189e6974895bb838a8e83b17b9fb91c5f86faebf2a1387e1466555ac5b51d05c293f9b31b9a72e634f5858105ea984ca94bd2f05bbb4c