Update to 1.2.0
This commit is contained in:
parent
b491c27147
commit
98a80e211d
1
.gitignore
vendored
1
.gitignore
vendored
@ -24,3 +24,4 @@ scipy-0.7.2.tar.gz
|
||||
/scipy-0.19.1.tar.xz
|
||||
/scipy-1.0.0.tar.xz
|
||||
/scipy-1.1.0.tar.gz
|
||||
/scipy-1.2.0.tar.gz
|
||||
|
@ -1,5 +1,5 @@
|
||||
diff --git a/scipy/conftest.py b/scipy/conftest.py
|
||||
index b0edcdd..f5c3c0b 100644
|
||||
index e5fac23..1a971e8 100644
|
||||
--- a/scipy/conftest.py
|
||||
+++ b/scipy/conftest.py
|
||||
@@ -3,6 +3,7 @@ from __future__ import division, absolute_import, print_function
|
||||
@ -9,8 +9,8 @@ index b0edcdd..f5c3c0b 100644
|
||||
+import _pytest
|
||||
import warnings
|
||||
|
||||
from scipy._lib._fpumode import get_fpu_mode
|
||||
@@ -33,3 +34,15 @@ def check_fpu_mode(request):
|
||||
from distutils.version import LooseVersion
|
||||
@@ -37,3 +38,15 @@ def check_fpu_mode(request):
|
||||
warnings.warn("FPU mode changed from {0:#x} to {1:#x} during "
|
||||
"the test".format(old_mode, new_mode),
|
||||
category=FPUModeChangeWarning, stacklevel=0)
|
||||
|
11
scipy.spec
11
scipy.spec
@ -6,8 +6,8 @@
|
||||
|
||||
Summary: Scientific Tools for Python
|
||||
Name: scipy
|
||||
Version: 1.1.0
|
||||
Release: 4%{?dist}
|
||||
Version: 1.2.0
|
||||
Release: 1%{?dist}
|
||||
|
||||
# BSD -- whole package except:
|
||||
# Boost -- scipy/special/cephes/scipy_iv.c
|
||||
@ -190,10 +190,14 @@ export k="not test_denormals"
|
||||
|
||||
pushd %{buildroot}/%{python3_sitearch}
|
||||
py.test-3 --timeout=300 -k "$k" scipy
|
||||
# Remove test remnants
|
||||
rm -rf gram{A,B}
|
||||
popd
|
||||
|
||||
pushd %{buildroot}/%{python2_sitearch}
|
||||
py.test-2 --timeout=300 -k "$k" scipy
|
||||
# Remove test remnants
|
||||
rm -f gram{A,B}
|
||||
popd
|
||||
|
||||
|
||||
@ -220,6 +224,9 @@ popd
|
||||
%endif # with doc
|
||||
|
||||
%changelog
|
||||
* Wed Feb 06 2019 Charalampos Stratakis <cstratak@redhat.com> - 1.2.0-1
|
||||
- Update to 1.2.0
|
||||
|
||||
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (scipy-1.1.0.tar.gz) = 72fe32c6c009613cb78202598e5db14f8e630b3218839cfe18d43d40550d94cc5aa100c6f5d41f40e86ae148e9b6a13431bb91b0f9be44b0569ccd7b725fe973
|
||||
SHA512 (scipy-1.2.0.tar.gz) = e5355a79832644a68fd21c21d4033171bf5ffa94ca601165524192ca4b8d7c7437a9ac83e7672bd942f9cec14504e957924ba5583cd02b0c1ca52ee2214c7b25
|
||||
|
Loading…
Reference in New Issue
Block a user