Update to 1.11.3
This commit is contained in:
parent
e098f22b88
commit
78288e18a6
1
.gitignore
vendored
1
.gitignore
vendored
@ -42,3 +42,4 @@ scipy-0.7.2.tar.gz
|
|||||||
/scipy-1.10.0.tar.gz
|
/scipy-1.10.0.tar.gz
|
||||||
/scipy-1.10.1.tar.gz
|
/scipy-1.10.1.tar.gz
|
||||||
/scipy-1.11.1.tar.gz
|
/scipy-1.11.1.tar.gz
|
||||||
|
/scipy-1.11.3.tar.gz
|
||||||
|
@ -1,63 +0,0 @@
|
|||||||
From 3c89445b6439f3ce7bffc4cf11c6407c39faedc5 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Matus Valo <matusvalo@users.noreply.github.com>
|
|
||||||
Date: Thu, 6 Jul 2023 16:55:25 +0200
|
|
||||||
Subject: [PATCH] BLD: copy `cython_optimize.pxd` to build dir (#18810)
|
|
||||||
|
|
||||||
Closes gh-18792
|
|
||||||
|
|
||||||
[skip cirrus] [skip circle]
|
|
||||||
|
|
||||||
---------
|
|
||||||
|
|
||||||
Co-authored-by: Ralf Gommers <ralf.gommers@gmail.com>
|
|
||||||
---
|
|
||||||
scipy/optimize/cython_optimize.pxd | 2 +-
|
|
||||||
scipy/optimize/cython_optimize/meson.build | 1 +
|
|
||||||
scipy/optimize/meson.build | 8 +++++++-
|
|
||||||
3 files changed, 9 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/scipy/optimize/cython_optimize.pxd b/scipy/optimize/cython_optimize.pxd
|
|
||||||
index d5a0bdd758e0..d35f8da68b34 100644
|
|
||||||
--- a/scipy/optimize/cython_optimize.pxd
|
|
||||||
+++ b/scipy/optimize/cython_optimize.pxd
|
|
||||||
@@ -7,5 +7,5 @@
|
|
||||||
# support. Changing it causes an ABI forward-compatibility break
|
|
||||||
# (gh-11793), so we currently leave it as is (no further cimport
|
|
||||||
# statements should be used in this file).
|
|
||||||
-from .cython_optimize._zeros cimport (
|
|
||||||
+from scipy.optimize.cython_optimize._zeros cimport (
|
|
||||||
brentq, brenth, ridder, bisect, zeros_full_output)
|
|
||||||
diff --git a/scipy/optimize/cython_optimize/meson.build b/scipy/optimize/cython_optimize/meson.build
|
|
||||||
index 359ea8418ba3..ee8def39b4d3 100644
|
|
||||||
--- a/scipy/optimize/cython_optimize/meson.build
|
|
||||||
+++ b/scipy/optimize/cython_optimize/meson.build
|
|
||||||
@@ -17,6 +17,7 @@ cy_opt_gen = generator(cython,
|
|
||||||
arguments : cython_args,
|
|
||||||
output : '@BASENAME@.c',
|
|
||||||
depends : [_cython_tree,
|
|
||||||
+ cython_optimize_pxd,
|
|
||||||
_dummy_init_optimize,
|
|
||||||
_dummy_init_cyoptimize])
|
|
||||||
|
|
||||||
diff --git a/scipy/optimize/meson.build b/scipy/optimize/meson.build
|
|
||||||
index 26458b05cd70..4c5ab798316b 100644
|
|
||||||
--- a/scipy/optimize/meson.build
|
|
||||||
+++ b/scipy/optimize/meson.build
|
|
||||||
@@ -206,10 +206,16 @@ endif
|
|
||||||
|
|
||||||
_dummy_init_optimize = fs.copyfile('__init__.py')
|
|
||||||
|
|
||||||
+# Copying this .pxd file is only needed because of a Cython bug, see
|
|
||||||
+# discussion on SciPy PR gh-18810.
|
|
||||||
+cython_optimize_pxd = [
|
|
||||||
+ fs.copyfile('cython_optimize.pxd'),
|
|
||||||
+]
|
|
||||||
+
|
|
||||||
opt_gen = generator(cython,
|
|
||||||
arguments : cython_args,
|
|
||||||
output : '@BASENAME@.c',
|
|
||||||
- depends : [_cython_tree, cython_blas_pxd, _dummy_init_optimize])
|
|
||||||
+ depends : [_cython_tree, cython_blas_pxd, cython_optimize_pxd, _dummy_init_optimize])
|
|
||||||
|
|
||||||
_bglu_dense_c = opt_gen.process('_bglu_dense.pyx')
|
|
||||||
|
|
22
scipy.spec
22
scipy.spec
@ -24,7 +24,7 @@
|
|||||||
|
|
||||||
Summary: Scientific Tools for Python
|
Summary: Scientific Tools for Python
|
||||||
Name: scipy
|
Name: scipy
|
||||||
Version: 1.11.1
|
Version: 1.11.3
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
# BSD -- whole package except:
|
# BSD -- whole package except:
|
||||||
@ -34,9 +34,6 @@ License: BSD and Boost and Public Domain
|
|||||||
Url: http://www.scipy.org/scipylib/index.html
|
Url: http://www.scipy.org/scipylib/index.html
|
||||||
Source0: https://github.com/scipy/scipy/releases/download/v%{version}/scipy-%{version}.tar.gz
|
Source0: https://github.com/scipy/scipy/releases/download/v%{version}/scipy-%{version}.tar.gz
|
||||||
|
|
||||||
# Fix build failure with Cython 3 when scipy is already installed
|
|
||||||
Patch: https://github.com/scipy/scipy/commit/3c89445b6439f3ce7bffc4cf11c6407c39faedc5.patch
|
|
||||||
|
|
||||||
BuildRequires: fftw-devel, suitesparse-devel
|
BuildRequires: fftw-devel, suitesparse-devel
|
||||||
BuildRequires: %{blaslib}-devel
|
BuildRequires: %{blaslib}-devel
|
||||||
BuildRequires: gcc-gfortran, swig, gcc-c++
|
BuildRequires: gcc-gfortran, swig, gcc-c++
|
||||||
@ -118,10 +115,17 @@ library_dirs = %{_libdir}
|
|||||||
EOF
|
EOF
|
||||||
|
|
||||||
# Docs won't build unless the .dat files are specified here
|
# Docs won't build unless the .dat files are specified here
|
||||||
sed -i 's/metadata = dict(/metadata = dict(package_data={"": ["*.dat"]},/' setup.py
|
sed -i 's/metadata = dict(/metadata = dict(package_data={"": ["*.dat"]},/' _setup.py
|
||||||
|
|
||||||
rm $(grep -rl '/\* Generated by Cython') PKG-INFO
|
rm $(grep -rl '/\* Generated by Cython') PKG-INFO
|
||||||
|
|
||||||
|
# numpy no longer contains a copy of distutils
|
||||||
|
for f in $(grep -Frl numpy.distutils); do
|
||||||
|
sed -i.orig 's/numpy\.\(distutils\)/\1/g' $f
|
||||||
|
touch -r $f.orig $f
|
||||||
|
rm $f.orig
|
||||||
|
done
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export SCIPY_USE_PYTHRAN=0%{?with_pythran}
|
export SCIPY_USE_PYTHRAN=0%{?with_pythran}
|
||||||
|
|
||||||
@ -134,7 +138,7 @@ for PY in %{python3_version}; do
|
|||||||
FFLAGS="$RPM_OPT_FLAGS -fPIC" \
|
FFLAGS="$RPM_OPT_FLAGS -fPIC" \
|
||||||
%endif
|
%endif
|
||||||
LDFLAGS="%{__global_ldflags}" \
|
LDFLAGS="%{__global_ldflags}" \
|
||||||
%{_bindir}/python$PY setup.py config_fc \
|
%{_bindir}/python$PY _setup.py config_fc \
|
||||||
--fcompiler=gnu95 --noarch \
|
--fcompiler=gnu95 --noarch \
|
||||||
build
|
build
|
||||||
|
|
||||||
@ -228,7 +232,7 @@ pushd %{buildroot}/%{python3_sitearch}
|
|||||||
%{pytest} --timeout=${TIMEOUT} scipy %{?!rhel:--numprocesses=auto}
|
%{pytest} --timeout=${TIMEOUT} scipy %{?!rhel:--numprocesses=auto}
|
||||||
# Remove test remnants
|
# Remove test remnants
|
||||||
rm -rf gram{A,B}
|
rm -rf gram{A,B}
|
||||||
rm -rf scipy/.pytest_cache
|
rm -rf .pytest_cache
|
||||||
popd
|
popd
|
||||||
|
|
||||||
%files -n python3-scipy
|
%files -n python3-scipy
|
||||||
@ -253,6 +257,10 @@ popd
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 11 2023 Jerry James <loganjerry@gmail.com> - 1.11.3-1
|
||||||
|
- New upstream release 1.11.3
|
||||||
|
resolves: #2211813
|
||||||
|
|
||||||
* Wed Jul 12 2023 psimovec <psimovec@redhat.com> - 1.11.1-1
|
* Wed Jul 12 2023 psimovec <psimovec@redhat.com> - 1.11.1-1
|
||||||
- New upstream release 1.11.1
|
- New upstream release 1.11.1
|
||||||
resolves: #2211813
|
resolves: #2211813
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (scipy-1.11.1.tar.gz) = 049c9061ccbf101e6f93e055f905616bc7775fbc51c3af99d8533aedc828c5e55d525ccd98b7299280ed706f3298975f28127de9b66809dfe198b0cc4fef466b
|
SHA512 (scipy-1.11.3.tar.gz) = 6491c4e479d9f4f02e677396a25ddca947a0dc6c009fc2ec34c658012a6224c0b535f14045bb011fbde9973ea987d184574ed64e6760c31798ec860eb0896fcf
|
||||||
|
Loading…
Reference in New Issue
Block a user