- Update to 0.13.0b1
- Drop patches applied upstream - Fixup changelog and summary
This commit is contained in:
parent
73b75412df
commit
744eba3525
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@ scipy-0.7.2.tar.gz
|
||||
/scipy-0.11.0.tar.gz
|
||||
/scipy-0.12.0b1.tar.gz
|
||||
/scipy-0.12.0.tar.gz
|
||||
/scipy-0.13.0b1.tar.gz
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up scipy-0.12.0/scipy/linalg/flapack.pyf.src.gerqf scipy-0.12.0/scipy/linalg/flapack.pyf.src
|
||||
--- scipy-0.12.0/scipy/linalg/flapack.pyf.src.gerqf 2013-04-06 10:10:35.000000000 -0600
|
||||
+++ scipy-0.12.0/scipy/linalg/flapack.pyf.src 2013-04-15 17:03:37.290059000 -0600
|
||||
@@ -650,7 +650,7 @@ interface
|
||||
<ftype> dimension(m,n),intent(in,out,copy,out=qr,aligned8) :: a
|
||||
<ftype> dimension(MIN(m,n)),intent(out) :: tau
|
||||
|
||||
- integer optional,intent(in),depend(n),check(lwork>=m||lwork==-1) :: lwork=3*m
|
||||
+ integer optional,intent(in),depend(m),check(lwork>=m||lwork==-1) :: lwork=3*m
|
||||
<ftype> dimension(MAX(lwork,1)),intent(out),depend(lwork) :: work
|
||||
integer intent(out) :: info
|
||||
end subroutine <prefix>gerqf
|
34
scipy.spec
34
scipy.spec
@ -5,10 +5,13 @@
|
||||
%filter_setup
|
||||
}
|
||||
|
||||
Summary: Scipy: Scientific Tools for Python
|
||||
# Set to pre-release version suffix if building pre-release, else %{nil}
|
||||
%define rcver b1
|
||||
|
||||
Summary: Scientific Tools for Python
|
||||
Name: scipy
|
||||
Version: 0.12.0
|
||||
Release: 4%{?dist}
|
||||
Version: 0.13.0
|
||||
Release: 0.1.b1%{?dist}
|
||||
|
||||
Group: Development/Libraries
|
||||
# BSD -- whole package except:
|
||||
@ -16,10 +19,7 @@ Group: Development/Libraries
|
||||
# Public Domain -- scipy/odr/__odrpack.c
|
||||
License: BSD and Boost and Public Domain
|
||||
Url: http://www.scipy.org
|
||||
Source0: http://downloads.sourceforge.net/scipy/%{name}-%{version}.tar.gz
|
||||
# Fix definition on gerqf that caused test segfault
|
||||
Patch0: scipy-gerqf.patch
|
||||
Patch1: use-argument-build_dir.patch
|
||||
Source0: http://downloads.sourceforge.net/scipy/%{name}-%{version}%{?rcver}.tar.gz
|
||||
|
||||
BuildRequires: numpy, python-devel,f2py
|
||||
BuildRequires: fftw-devel, blas-devel, lapack-devel, suitesparse-devel
|
||||
@ -47,7 +47,7 @@ leading scientists and engineers.
|
||||
|
||||
%if 0%{?with_python3}
|
||||
%package -n python3-scipy
|
||||
Summary: Scipy: Scientific Tools for Python
|
||||
Summary: Scientific Tools for Python
|
||||
Group: Development/Libraries
|
||||
License: BSD and LGPLv2+
|
||||
Requires: python3-numpy, python3-f2py
|
||||
@ -65,9 +65,7 @@ leading scientists and engineers.
|
||||
%endif # with _python3
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .gerqf
|
||||
%patch1 -p1
|
||||
%setup -q -n %{name}-%{version}%{?rcver}
|
||||
cat > site.cfg << EOF
|
||||
|
||||
[amd]
|
||||
@ -142,16 +140,22 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%endif # with_python3
|
||||
|
||||
%changelog
|
||||
* Thu Aug 29 2013 Orion Poplwski <orion@cora.nwra.com> - 0.13.0-0.1.b1
|
||||
- Update to 0.13.0b1
|
||||
- Drop patches applied upstream
|
||||
- Fixup changelog and summary
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
- Tue Jul 30 2013 Tomas Tomecek <ttomecek@redhat.com> - 0.12.0-4
|
||||
- Fix rpmlint warnings
|
||||
- License update
|
||||
- Add patch to use build_dir argument in build_extension
|
||||
|
||||
* Wed May 15 2013 Orion Poplawski <orion@cora.nwra.com> - 0.12.0-3
|
||||
- Remove old ufsparse references, use suitesparse
|
||||
- Spec cleanup
|
||||
- Tue Jul 30 2013 Tomas Tomecek <ttomecek@redhat.com>:
|
||||
- Fix rpmlint warnings
|
||||
- License update
|
||||
- Add patch to use build_dir argument in build_extension
|
||||
|
||||
* Mon Apr 15 2013 Orion Poplawski <orion@cora.nwra.com> - 0.12.0-2
|
||||
- Add patch to fix segfaul in test of sgeqrf
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
8fb4da324649f655e8557ea92b998786 scipy-0.12.0.tar.gz
|
||||
d51c84f63542fd610c0344af424c563b scipy-0.13.0b1.tar.gz
|
||||
|
@ -1,16 +0,0 @@
|
||||
diff --git a/scipy/weave/build_tools.py b/scipy/weave/build_tools.py
|
||||
index b990f33..57a5a8e 100644
|
||||
--- a/scipy/weave/build_tools.py
|
||||
+++ b/scipy/weave/build_tools.py
|
||||
@@ -228,7 +228,7 @@ def build_extension(module_path,compiler_name = '',build_dir = None,
|
||||
|
||||
# configure temp and build directories
|
||||
temp_dir = configure_temp_dir(temp_dir)
|
||||
- build_dir = configure_build_dir(module_dir)
|
||||
+ build_dir = configure_build_dir(build_dir or module_dir)
|
||||
|
||||
# dag. We keep having to add directories to the path to keep
|
||||
# object files separated from each other. gcc2.x and gcc3.x C++
|
||||
--
|
||||
1.8.1.2
|
||||
|
Loading…
Reference in New Issue
Block a user