- Patch for stsci image function syntax fix.
This commit is contained in:
parent
873f0a8b31
commit
7005ef5ab3
@ -2,7 +2,7 @@
|
|||||||
Summary: Scipy: Scientific Tools for Python
|
Summary: Scipy: Scientific Tools for Python
|
||||||
Name: scipy
|
Name: scipy
|
||||||
Version: 0.7.0
|
Version: 0.7.0
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
|
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
License: BSD and LGPLv2+
|
License: BSD and LGPLv2+
|
||||||
@ -12,6 +12,7 @@ Source0: http://prdownloads.sourceforge.net/scipy/%{name}-%{version}.tar.gz
|
|||||||
# These should be removed as soon as upstream pushes a release with this fixed
|
# These should be removed as soon as upstream pushes a release with this fixed
|
||||||
Source1: stsci_image_setup.py
|
Source1: stsci_image_setup.py
|
||||||
Source2: stsci_convolve_setup.py
|
Source2: stsci_convolve_setup.py
|
||||||
|
Patch0: stsci_image_syntax.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
@ -36,6 +37,7 @@ leading scientists and engineers.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}
|
%setup -q -n %{name}-%{version}
|
||||||
|
%patch0 -p0
|
||||||
cat > site.cfg << EOF
|
cat > site.cfg << EOF
|
||||||
[amd]
|
[amd]
|
||||||
library_dirs = %{_libdir}
|
library_dirs = %{_libdir}
|
||||||
@ -73,6 +75,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Mar 1 2009 Jef Spaleta <jspaleta@fedoraproject.org> - 0.7.0-2
|
||||||
|
- Patch for stsci image function syntax fix.
|
||||||
|
|
||||||
* Thu Feb 26 2009 Jef Spaleta <jspaleta@fedoraproject.org> - 0.7.0-1
|
* Thu Feb 26 2009 Jef Spaleta <jspaleta@fedoraproject.org> - 0.7.0-1
|
||||||
- Update to final 0.7 release
|
- Update to final 0.7 release
|
||||||
|
|
||||||
|
16
stsci_image_syntax.patch
Normal file
16
stsci_image_syntax.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
--- scipy/stsci/image/lib/_image.py 2008-11-24 10:52:40.000000000 +0100
|
||||||
|
+++ scipy/stsci/image/lib/_image.py 2009-02-26 16:43:44.000000000 +0100
|
||||||
|
@@ -1,5 +1,5 @@
|
||||||
|
import numpy as np
|
||||||
|
-import scipy.stsci.convolve
|
||||||
|
+import scipy.stsci.convolve as convolve
|
||||||
|
import scipy.stsci.convolve._correlate as _correlate
|
||||||
|
|
||||||
|
def _translate(a, dx, dy, output=None, mode="nearest", cval=0.0):
|
||||||
|
@@ -55,4 +55,4 @@
|
||||||
|
if output is not None:
|
||||||
|
output._copyFrom(np.rot90(output, -rotation%4))
|
||||||
|
else:
|
||||||
|
- return np.rot90(d, -rotation % 4).astype(a.type())
|
||||||
|
+ return np.rot90(d, -rotation % 4).astype(a.dtype)
|
||||||
|
|
Loading…
Reference in New Issue
Block a user