Update to 0.17.0
- Drop ctypes patch applied upstream
This commit is contained in:
parent
c455ea8dfd
commit
4cadcb8b14
1
.gitignore
vendored
1
.gitignore
vendored
@ -18,3 +18,4 @@ scipy-0.7.2.tar.gz
|
||||
/scipy-0.15.1.tar.gz
|
||||
/scipy-0.16.0.tar.gz
|
||||
/scipy-0.16.1.tar.gz
|
||||
/scipy-0.17.0.tar.gz
|
||||
|
@ -1,26 +0,0 @@
|
||||
commit 1f5ccd5447ed2796bb8e9506cfbfdb4a82cccfc0
|
||||
Author: Ralf Gommers <ralf.gommers@gmail.com>
|
||||
Date: Sat Oct 24 18:17:04 2015 +0200
|
||||
|
||||
TST: fix issue with a ctypes test for integrate on Fedora. Closes gh-5370
|
||||
|
||||
diff --git a/scipy/integrate/tests/test_quadpack.py b/scipy/integrate/tests/test_quadpack.py
|
||||
index c3a417c..f384c77 100644
|
||||
--- a/scipy/integrate/tests/test_quadpack.py
|
||||
+++ b/scipy/integrate/tests/test_quadpack.py
|
||||
@@ -42,7 +42,14 @@ class TestCtypesQuad(TestCase):
|
||||
file = 'libm.dylib'
|
||||
else:
|
||||
file = 'libm.so'
|
||||
- self.lib = ctypes.CDLL(file)
|
||||
+
|
||||
+ try:
|
||||
+ self.lib = ctypes.CDLL(file)
|
||||
+ except OSError:
|
||||
+ # This test doesn't work on some Linux platforms (Fedora for
|
||||
+ # example) that put an ld script in libm.so - see gh-5370
|
||||
+ self.skipTest("Ctypes can't import libm.so")
|
||||
+
|
||||
restype = ctypes.c_double
|
||||
argtypes = (ctypes.c_double,)
|
||||
for name in ['sin', 'cos', 'tan']:
|
15
scipy.spec
15
scipy.spec
@ -10,17 +10,16 @@
|
||||
|
||||
Summary: Scientific Tools for Python
|
||||
Name: scipy
|
||||
Version: 0.16.1
|
||||
Release: 7%{?dist}
|
||||
Version: 0.17.0
|
||||
Release: 1%{?dist}
|
||||
|
||||
Group: Development/Libraries
|
||||
# BSD -- whole package except:
|
||||
# Boost -- scipy/special/cephes/scipy_iv.c
|
||||
# Public Domain -- scipy/odr/__odrpack.c
|
||||
License: BSD and Boost and Public Domain
|
||||
Url: http://www.scipy.org
|
||||
Source0: http://downloads.sourceforge.net/scipy/%{name}-%{version}%{?rcver}.tar.gz
|
||||
Patch0: scipy-0.16.1-ctyptes-test.patch
|
||||
Url: http://www.scipy.org/scipylib/index.html
|
||||
Source0: https://pypi.python.org/packages/source/s/scipy/scipy-%{version}.tar.gz
|
||||
|
||||
BuildRequires: numpy, python2-devel,f2py
|
||||
BuildRequires: fftw-devel, blas-devel, lapack-devel, suitesparse-devel
|
||||
@ -101,8 +100,6 @@ include_dirs = /usr/include/suitesparse
|
||||
umfpack_libs = umfpack
|
||||
EOF
|
||||
|
||||
%patch0 -p1
|
||||
|
||||
|
||||
%build
|
||||
%if 0%{?with_python3}
|
||||
@ -164,6 +161,10 @@ PYTHONPATH=$RPM_BUILD_ROOT%{python2_sitearch} \
|
||||
%endif # with_python3
|
||||
|
||||
%changelog
|
||||
* Mon Feb 15 2016 Orion Poplawski <orion@cora.nwra.com> - 0.17.0-1
|
||||
- Update to 0.17.0
|
||||
- Drop ctypes patch applied upstream
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.16.1-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user