scap-security-guide-0.1.31-1
This commit is contained in:
parent
34ff3c5470
commit
d086af74a5
1
.gitignore
vendored
1
.gitignore
vendored
@ -16,3 +16,4 @@
|
||||
/0.1.29.tar.gz
|
||||
/v0.1.29.tar.gz
|
||||
/v0.1.30.tar.gz
|
||||
/scap-security-guide-0.1.31.tar.gz
|
||||
|
@ -1,42 +0,0 @@
|
||||
From de6aa6fdf977a8bc0022ceff1b219380573c9621 Mon Sep 17 00:00:00 2001
|
||||
From: Jan Lieskovsky <jlieskov@redhat.com>
|
||||
Date: Mon, 27 Jun 2016 15:33:13 +0200
|
||||
Subject: [PATCH] [BugFix] [Infrastructure] Fix parallel make
|
||||
|
||||
As visible e.g. in:
|
||||
https://kojipkgs.fedoraproject.org//work/tasks/1659/14671659/build.log
|
||||
|
||||
attempt to build current SSG master in parallel:
|
||||
+ cd scap-security-guide-0.1.30
|
||||
+ make -j4 dist
|
||||
..
|
||||
|
||||
fails with:
|
||||
..
|
||||
mkdir ../shared/output
|
||||
mkdir ../shared/output
|
||||
xsltproc -o output/guide.xml ../shared/transforms/includelogo.xslt input/guide.xml
|
||||
mkdir: cannot create directory '../shared/output': File exists
|
||||
..
|
||||
|
||||
Fix that (so "make -j4 dist" will work again)
|
||||
---
|
||||
shared/product-make.include | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/shared/product-make.include b/shared/product-make.include
|
||||
index 53fe067..c4c8e2e 100644
|
||||
--- a/shared/product-make.include
|
||||
+++ b/shared/product-make.include
|
||||
@@ -55,7 +55,7 @@ $(OUT)/shorthand.xml: $(OUT)/guide.xml $(IN)/guide.xslt $(guide_xslt_deps)
|
||||
# Create temporary $(SHARED)/$(OUT) folder to hold information like list of contributors or list of
|
||||
# available remediation functions used by all SSG benchmarks
|
||||
$(SHARED)/$(OUT):
|
||||
- mkdir $@
|
||||
+ mkdir -p $@
|
||||
|
||||
# Benchmark metadata prerequisite - derive $(SHARED)/$(OUT)/contributors.xml from the content of Contributors.md
|
||||
$(SHARED)/$(OUT)/contributors.xml: $(SHARED)/$(OUT)
|
||||
--
|
||||
2.4.11
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- scap-security-guide-0.1.30/Makefile.orig 2016-06-27 11:44:37.622873972 +0200
|
||||
+++ scap-security-guide-0.1.30/Makefile 2016-06-27 11:44:54.807223610 +0200
|
||||
@@ -248,7 +248,6 @@ install: dist
|
||||
install -m 0644 Fedora/dist/content/* $(PREFIX)/$(DATADIR)/xml/scap/ssg/content/
|
||||
install -m 0644 Fedora/dist/guide/* $(PREFIX)/$(DOCDIR)/scap-security-guide/guides
|
||||
install -m 0644 RHEL/6/dist/content/* $(PREFIX)/$(DATADIR)/xml/scap/ssg/content/
|
||||
- install -m 0644 shared/remediations/bash/templates/remediation_functions $(PREFIX)/$(DATADIR)/scap-security-guide/
|
||||
install -m 0644 RHEL/6/kickstart/*-ks.cfg $(PREFIX)/$(DATADIR)/scap-security-guide/kickstart
|
||||
install -m 0644 RHEL/7/kickstart/*-ks.cfg $(PREFIX)/$(DATADIR)/scap-security-guide/kickstart
|
||||
install -m 0644 RHEL/6/dist/guide/* $(PREFIX)/$(DOCDIR)/scap-security-guide/guides
|
@ -1,20 +1,11 @@
|
||||
|
||||
# IMPORTANT NOTE: This spec file is solely dedicated to make changes to the
|
||||
# Fedora's scap-security-guide package. If you want to apply changes against
|
||||
# the main RHEL-6 scap-security-guide RPM content, use scap-security-guide.spec
|
||||
# file one level up - in the main scap-security-guide directory (instead of
|
||||
# this one).
|
||||
|
||||
Name: scap-security-guide
|
||||
Version: 0.1.30
|
||||
Release: 2%{?dist}
|
||||
Version: 0.1.31
|
||||
Release: 1%{?dist}
|
||||
Summary: Security guidance and baselines in SCAP formats
|
||||
Group: Applications/System
|
||||
License: Public Domain
|
||||
URL: https://github.com/OpenSCAP/scap-security-guide/
|
||||
Source0: https://github.com/OpenSCAP/scap-security-guide/archive/v%{version}.tar.gz
|
||||
Patch1: scap-security-guide-0.1.30-drop-remediations-functions-library.patch
|
||||
Patch2: 0001-BugFix-Infrastructure-Fix-parallel-make.patch
|
||||
Source0: https://github.com/OpenSCAP/scap-security-guide/releases/download/v0.1.31/scap-security-guide-0.1.31.tar.gz
|
||||
BuildArch: noarch
|
||||
BuildRequires: libxslt, expat, python
|
||||
BuildRequires: python-lxml
|
||||
@ -47,11 +38,7 @@ hardening guidances that have been generated from XCCDF benchmarks
|
||||
present in %{name} package.
|
||||
|
||||
%prep
|
||||
%setup -q -D -n %{name}-%{version}
|
||||
# Drop remediation_functions shell library (not needed starting from 0.1.30)
|
||||
%patch1 -p1 -b .drop_remediation_functions_library
|
||||
# Fix parallel build
|
||||
%patch2 -p1 -b .parallel_build
|
||||
%setup -q
|
||||
|
||||
%build
|
||||
make %{?_smp_mflags} dist
|
||||
@ -59,28 +46,25 @@ make %{?_smp_mflags} dist
|
||||
%install
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
|
||||
# Install DataStream files
|
||||
for target in Firefox JRE
|
||||
do
|
||||
cp -a $target/dist/content/ssg-*-ds.xml %{buildroot}%{_datadir}/xml/scap/ssg/content/
|
||||
done
|
||||
|
||||
# Docs
|
||||
mkdir -p %{buildroot}/%{_docdir}/%{name}/Firefox
|
||||
install -m 0644 README.md %{buildroot}/%{_docdir}/%{name}
|
||||
install -m 0644 LICENSE %{buildroot}/%{_docdir}/%{name}
|
||||
|
||||
%files
|
||||
%{_datadir}/xml/scap
|
||||
%{_datadir}/scap/ssg
|
||||
%{_datadir}/%{name}/kickstart
|
||||
%lang(en) %{_mandir}/en/man8/scap-security-guide.8.*
|
||||
%doc %{_docdir}/%{name}/LICENSE
|
||||
%doc %{_docdir}/%{name}/README.md
|
||||
# compatibility symlink
|
||||
%{_datadir}/xml/scap/ssg/content
|
||||
|
||||
%files doc
|
||||
%doc %{_docdir}/%{name}/guides/*.html
|
||||
%doc %{_docdir}/%{name}/tables/*.{,x}html
|
||||
|
||||
%changelog
|
||||
* Mon Nov 28 2016 Martin Preisler <mpreisle@redhat.com> - 0.1.31-1
|
||||
- update to the latest upstream release
|
||||
- new default location for content /usr/share/scap/ssg
|
||||
- install HTML tables in the doc subpackage
|
||||
|
||||
* Mon Jun 27 2016 Jan iankko Lieskovsky <jlieskov@redhat.com> - 0.1.30-2
|
||||
- Correct currently failing parallel SCAP Security Guide build
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user