Make sblim-sfcb post install scriptlet silent, Fix value.c

This commit is contained in:
vcrhonek 2010-03-22 12:58:09 +00:00
parent f1ee0dc07f
commit 75da8c1824
2 changed files with 35 additions and 5 deletions

View File

@ -0,0 +1,24 @@
diff -up sblim-sfcb-1.3.7/value.c.orig sblim-sfcb-1.3.7/value.c
--- sblim-sfcb-1.3.7/value.c.orig 2010-03-15 16:29:18.072377466 +0100
+++ sblim-sfcb-1.3.7/value.c 2010-03-15 16:30:44.887460552 +0100
@@ -186,11 +186,19 @@ char *sfcb_value2Chars(CMPIType type, CM
case CMPI_filter:
break;
+ case CMPI_chars:
+ if (value->chars) {
+ size = strlen((char *) value->chars);
+ p = malloc(size + 3);
+ sprintf(p, "\"%s\"", (char *) value->chars);
+ return p;
+ }
+ break;
+
case CMPI_string:
case CMPI_numericString:
case CMPI_booleanString:
case CMPI_dateTimeString:
- case CMPI_classNameString:
if (value->string->hdl) {
size = strlen((char *) value->string->hdl);
p = malloc(size + 8);

View File

@ -1,5 +1,5 @@
#
# $Id: sblim-sfcb.spec,v 1.2 2010/03/03 08:23:25 vcrhonek Exp $
# $Id: sblim-sfcb.spec,v 1.3 2010/03/22 12:58:09 vcrhonek Exp $
#
# Package spec for sblim-sfcb
#
@ -8,12 +8,13 @@ Name: sblim-sfcb
Summary: Small Footprint CIM Broker
URL: http://www.sblim.org
Version: 1.3.7
Release: 1%{?dist}
Release: 2%{?dist}
Group: Applications/System
License: EPL
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}
Source0: http://downloads.sourceforge.net/sblim/%{name}-%{version}.tar.bz2
patch0: %{name}-disable_auto_service_start.patch
Patch0: %{name}-disable_auto_service_start.patch
Patch1: sblim-sfcb-1.3.7-value.c.patch
Provides: cim-server
Requires: cim-schema
BuildRequires: libcurl-devel
@ -40,7 +41,8 @@ Programming Interface (CMPI).
%prep
%setup -q -T -b 0 -n %{name}-%{version}
%patch0 -p1
%patch0 -p1 -b .autostart
%patch1 -p1 -b .valuec
%build
%configure --enable-debug --enable-ssl --enable-pam --enable-ipv6 CFLAGS="$CFLAGS -D_GNU_SOURCE"
@ -80,7 +82,7 @@ cat _pkg_list
rm -rf $RPM_BUILD_ROOT
%post
%{_datadir}/sfcb/genSslCert.sh %{_sysconfdir}/sfcb
%{_datadir}/sfcb/genSslCert.sh %{_sysconfdir}/sfcb &>/dev/null || :
/sbin/ldconfig
%{_bindir}/sfcbrepos -f -c /usr/share/mof/cim-current
/sbin/chkconfig --add sblim-sfcb
@ -107,6 +109,10 @@ fi
#%doc COPYING README
%changelog
* Mon Mar 22 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.3.7-2
- Make sblim-sfcb post install scriptlet silent
- Fix value.c
* Wed Mar 3 2010 <vcrhonek@redhat.com> - 1.3.7-1
- Update to sblim-sfcb-1.3.7
- Fix dist tag in Release field