Update to sblim-sfcb-1.3.8, Fix unmatched calls of closeLogging() and

startLogging()
This commit is contained in:
vcrhonek 2010-06-23 10:31:02 +00:00
parent a219604aa8
commit 71ed928e59
5 changed files with 32 additions and 32 deletions

View File

@ -1 +1,2 @@
sblim-sfcb-1.3.7.tar.bz2
sblim-sfcb-1.3.8.tar.bz2

View File

@ -0,0 +1,19 @@
diff -up sblim-sfcb-1.3.7/cimcClientSfcbLocal.c.orig sblim-sfcb-1.3.7/cimcClientSfcbLocal.c
--- sblim-sfcb-1.3.7/cimcClientSfcbLocal.c.orig 2010-05-11 09:08:17.709465965 +0200
+++ sblim-sfcb-1.3.7/cimcClientSfcbLocal.c 2010-05-11 09:11:10.133456342 +0200
@@ -209,7 +209,6 @@ static CMPIStatus releaseClient(Client *
if (cl->connection) CMRelease(cl->connection);
free(cl);
- closeLogging();
return rc;
}
@@ -1618,6 +1617,7 @@ int localConnect(ClientEnv* ce, CMPIStat
static void* release(ClientEnv* ce)
{
void *lib=ce->hdl;
+ closeLogging();
CONNECT_LOCK();
if (localConnectCount > 0) localConnectCount -= 1;
if (localConnectCount == 0) {

View File

@ -1,24 +0,0 @@
diff -up sblim-sfcb-1.3.7/value.c.orig sblim-sfcb-1.3.7/value.c
--- sblim-sfcb-1.3.7/value.c.orig 2010-03-15 16:29:18.072377466 +0100
+++ sblim-sfcb-1.3.7/value.c 2010-03-15 16:30:44.887460552 +0100
@@ -186,11 +186,19 @@ char *sfcb_value2Chars(CMPIType type, CM
case CMPI_filter:
break;
+ case CMPI_chars:
+ if (value->chars) {
+ size = strlen((char *) value->chars);
+ p = malloc(size + 3);
+ sprintf(p, "\"%s\"", (char *) value->chars);
+ return p;
+ }
+ break;
+
case CMPI_string:
case CMPI_numericString:
case CMPI_booleanString:
case CMPI_dateTimeString:
- case CMPI_classNameString:
if (value->string->hdl) {
size = strlen((char *) value->string->hdl);
p = malloc(size + 8);

View File

@ -1,5 +1,5 @@
#
# $Id: sblim-sfcb.spec,v 1.4 2010/04/22 12:04:57 vcrhonek Exp $
# $Id: sblim-sfcb.spec,v 1.5 2010/06/23 10:31:02 vcrhonek Exp $
#
# Package spec for sblim-sfcb
#
@ -7,15 +7,15 @@
Name: sblim-sfcb
Summary: Small Footprint CIM Broker
URL: http://www.sblim.org
Version: 1.3.7
Release: 3%{?dist}
Version: 1.3.8
Release: 1%{?dist}
Group: Applications/System
License: EPL
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}
Source0: http://downloads.sourceforge.net/sblim/%{name}-%{version}.tar.bz2
Patch0: %{name}-disable_auto_service_start.patch
Patch1: sblim-sfcb-1.3.7-value.c.patch
Patch2: sblim-sfcb-1.3.7-initscript.patch
Patch1: sblim-sfcb-1.3.7-initscript.patch
Patch2: sblim-sfcb-1.3.7-close_logging.patch
Provides: cim-server
Requires: cim-schema
BuildRequires: libcurl-devel
@ -43,8 +43,8 @@ Programming Interface (CMPI).
%prep
%setup -q -T -b 0 -n %{name}-%{version}
%patch0 -p1 -b .autostart
%patch1 -p1 -b .valuec
%patch2 -p1 -b .initscript
%patch1 -p1 -b .initscript
%patch2 -p1 -b .close_logging
%build
%configure --enable-debug --enable-ssl --enable-pam --enable-ipv6 CFLAGS="$CFLAGS -D_GNU_SOURCE"
@ -111,6 +111,10 @@ fi
#%doc COPYING README
%changelog
* Wed Jun 23 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.3.8-1
- Update to sblim-sfcb-1.3.8
- Fix unmatched calls of closeLogging() and startLogging()
* Thu Apr 22 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.3.7-3
- Fix initscript

View File

@ -1 +1 @@
94e1df8a2a8dca49adee3f61c4058129 sblim-sfcb-1.3.7.tar.bz2
c19c1361447d4402beb3ef8c6e6c5682 sblim-sfcb-1.3.8.tar.bz2