import sblim-cmpi-base-1.6.4-20.el9
This commit is contained in:
commit
3cd9498a55
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/sblim-cmpi-base-1.6.4.tar.bz2
|
1
.sblim-cmpi-base.metadata
Normal file
1
.sblim-cmpi-base.metadata
Normal file
@ -0,0 +1 @@
|
||||
ef690b7b875bb7c063f9b86fa529b03bc057ab0e SOURCES/sblim-cmpi-base-1.6.4.tar.bz2
|
25
SOURCES/sblim-cmpi-base-1.6.0-methods-enable.patch
Normal file
25
SOURCES/sblim-cmpi-base-1.6.0-methods-enable.patch
Normal file
@ -0,0 +1,25 @@
|
||||
--- mof/Linux_BaseIndication.registration 2005-06-07 15:12:43.000000000 +0200
|
||||
+++ mof/Linux_BaseIndication.registration 2009-03-09 14:08:47.187964574 +0100
|
||||
@@ -1,14 +1,14 @@
|
||||
# Classname Namespace ProviderName ProviderModule ProviderTypes ...
|
||||
-Linux_Processor root/cimv2 OSBase_ProcessorProvider cmpiOSBase_ProcessorProvider instance
|
||||
-Linux_UnixProcess root/cimv2 OSBase_UnixProcessProvider cmpiOSBase_UnixProcessProvider instance
|
||||
-Linux_ComputerSystem root/cimv2 OSBase_ComputerSystemProvider cmpiOSBase_ComputerSystemProvider instance
|
||||
-Linux_OperatingSystem root/cimv2 OSBase_OperatingSystemProvider cmpiOSBase_OperatingSystemProvider instance
|
||||
-Linux_OperatingSystemStatisticalData root/cimv2 OSBase_OperatingSystemStatisticalDataProvider cmpiOSBase_OperatingSystemStatisticalDataProvider instance
|
||||
-Linux_BaseBoard root/cimv2 OSBase_BaseBoardProvider cmpiOSBase_BaseBoardProvider instance
|
||||
+Linux_Processor root/cimv2 OSBase_ProcessorProvider cmpiOSBase_ProcessorProvider instance method
|
||||
+Linux_UnixProcess root/cimv2 OSBase_UnixProcessProvider cmpiOSBase_UnixProcessProvider instance method
|
||||
+Linux_ComputerSystem root/cimv2 OSBase_ComputerSystemProvider cmpiOSBase_ComputerSystemProvider instance method
|
||||
+Linux_OperatingSystem root/cimv2 OSBase_OperatingSystemProvider cmpiOSBase_OperatingSystemProvider instance method
|
||||
+Linux_OperatingSystemStatisticalData root/cimv2 OSBase_OperatingSystemStatisticalDataProvider cmpiOSBase_OperatingSystemStatisticalDataProvider instance method
|
||||
+Linux_BaseBoard root/cimv2 OSBase_BaseBoardProvider cmpiOSBase_BaseBoardProvider instance method
|
||||
Linux_RunningOS root/cimv2 OSBase_RunningOSProvider cmpiOSBase_RunningOSProvider instance association
|
||||
Linux_OSProcess root/cimv2 OSBase_OSProcessProvider cmpiOSBase_OSProcessProvider instance association
|
||||
Linux_OperatingSystemStatistics root/cimv2 OSBase_OperatingSystemStatisticsProvider cmpiOSBase_OperatingSystemStatisticsProvider instance association
|
||||
Linux_CSProcessor root/cimv2 OSBase_CSProcessorProvider cmpiOSBase_CSProcessorProvider instance association
|
||||
Linux_CSBaseBoard root/cimv2 OSBase_CSBaseBoardProvider cmpiOSBase_CSBaseBoardProvider instance association
|
||||
Linux_OperatingSystemIndication root/cimv2 OSBase_OperatingSystemProvider cmpiOSBase_OperatingSystemProvider indication
|
||||
-CIM_InstModification root/cimv2 OSBase_OperatingSystemProvider cmpiOSBase_OperatingSystemProvider indication
|
||||
+CIM_InstModification root/cimv2 OSBase_OperatingSystemProvider cmpiOSBase_OperatingSystemProvider indication method
|
||||
|
14
SOURCES/sblim-cmpi-base-1.6.0-missing-fclose.patch
Normal file
14
SOURCES/sblim-cmpi-base-1.6.0-missing-fclose.patch
Normal file
@ -0,0 +1,14 @@
|
||||
Index: OSBase_OperatingSystemStatisticalData.c
|
||||
===================================================================
|
||||
--- OSBase_OperatingSystemStatisticalData.c.orig
|
||||
+++ OSBase_OperatingSystemStatisticalData.c
|
||||
@@ -155,6 +155,7 @@ int get_cpu_page_data_24(struct os_stati
|
||||
if ((f = fopen(DATA_FILE,"r")) != NULL) {
|
||||
read_count = fread(buf,sizeof(char),sizeof(buf)-1,f);
|
||||
buf[read_count] = '\0';
|
||||
+ fclose(f);
|
||||
|
||||
/* read cpu data
|
||||
*
|
||||
|
||||
|
11
SOURCES/sblim-cmpi-base-1.6.1-double-fclose.patch
Normal file
11
SOURCES/sblim-cmpi-base-1.6.1-double-fclose.patch
Normal file
@ -0,0 +1,11 @@
|
||||
diff -up sblim-cmpi-base-1.6.1/OSBase_OperatingSystemStatisticalData.c.orig sblim-cmpi-base-1.6.1/OSBase_OperatingSystemStatisticalData.c
|
||||
--- sblim-cmpi-base-1.6.1/OSBase_OperatingSystemStatisticalData.c.orig 2012-05-10 13:19:42.628416721 +0200
|
||||
+++ sblim-cmpi-base-1.6.1/OSBase_OperatingSystemStatisticalData.c 2012-05-10 13:20:38.331706857 +0200
|
||||
@@ -250,7 +250,6 @@ int get_cpu_queue_data_26(struct os_stat
|
||||
} else {
|
||||
_OSBASE_TRACE(1,("get_cpu_queue_data_26(): could not find cpu info"));
|
||||
}
|
||||
- fclose(f);
|
||||
} else {
|
||||
_OSBASE_TRACE(1,("get_cpu_queue_data_26(): could not open %s: %s",DATA_FILE,strerror(errno)));
|
||||
}
|
12
SOURCES/sblim-cmpi-base-1.6.2-docdir.patch
Normal file
12
SOURCES/sblim-cmpi-base-1.6.2-docdir.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up sblim-cmpi-base-1.6.4/Makefile.am.orig sblim-cmpi-base-1.6.4/Makefile.am
|
||||
--- sblim-cmpi-base-1.6.4/Makefile.am.orig 2014-10-23 16:54:13.000000000 +0200
|
||||
+++ sblim-cmpi-base-1.6.4/Makefile.am 2018-08-22 10:59:51.497500435 +0200
|
||||
@@ -23,7 +23,7 @@ sblimincdir = $(includedir)/sblim
|
||||
EXTRA_DIST=
|
||||
|
||||
# docdir defines where the documentation goes
|
||||
-docdir=$(datadir)/doc/$(PACKAGE)-$(VERSION)
|
||||
+docdir=$(datadir)/doc/$(PACKAGE)
|
||||
|
||||
#
|
||||
# Automake instructions for documentation
|
12
SOURCES/sblim-cmpi-base-1.6.2-pegasus-interop.patch
Normal file
12
SOURCES/sblim-cmpi-base-1.6.2-pegasus-interop.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up sblim-cmpi-base-1.6.2/provider-register.sh.orig sblim-cmpi-base-1.6.2/provider-register.sh
|
||||
--- sblim-cmpi-base-1.6.2/provider-register.sh.orig 2013-08-07 18:02:52.438321970 +0200
|
||||
+++ sblim-cmpi-base-1.6.2/provider-register.sh 2013-08-07 18:04:06.087746426 +0200
|
||||
@@ -216,7 +216,7 @@ pegasus_install()
|
||||
then
|
||||
chatter Registering providers with $state cimserver
|
||||
$CIMMOF -uc -I $mofpath -n $namespace $mymofs &&
|
||||
- $CIMMOF -uc -n root/PG_Interop $_REGFILENAME
|
||||
+ $CIMMOF -uc -n root/interop $_REGFILENAME
|
||||
else
|
||||
echo "Failed to build pegasus registration MOF." >&2
|
||||
return 1
|
12
SOURCES/sblim-cmpi-base-1.6.4-dont-install-license.patch
Normal file
12
SOURCES/sblim-cmpi-base-1.6.4-dont-install-license.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up sblim-cmpi-base-1.6.4/Makefile.am.orig sblim-cmpi-base-1.6.4/Makefile.am
|
||||
--- sblim-cmpi-base-1.6.4/Makefile.am.orig 2018-08-22 13:21:00.740031951 +0200
|
||||
+++ sblim-cmpi-base-1.6.4/Makefile.am 2018-08-22 13:21:51.421079223 +0200
|
||||
@@ -28,7 +28,7 @@ docdir=$(datadir)/doc/$(PACKAGE)
|
||||
#
|
||||
# Automake instructions for documentation
|
||||
#
|
||||
-doc_DATA=README AUTHORS COPYING
|
||||
+doc_DATA=README AUTHORS
|
||||
|
||||
# ADD EXTRA DOC FILES IF PRESENT
|
||||
doc_DATA+=README.INDICATION README.tog-pegasus DEBUG
|
67
SOURCES/sblim-cmpi-base-1.6.4-fix-get-os-install-date.patch
Normal file
67
SOURCES/sblim-cmpi-base-1.6.4-fix-get-os-install-date.patch
Normal file
@ -0,0 +1,67 @@
|
||||
diff -up sblim-cmpi-base-1.6.4/OSBase_OperatingSystem.c.orig sblim-cmpi-base-1.6.4/OSBase_OperatingSystem.c
|
||||
--- sblim-cmpi-base-1.6.4/OSBase_OperatingSystem.c.orig 2014-10-23 16:54:13.000000000 +0200
|
||||
+++ sblim-cmpi-base-1.6.4/OSBase_OperatingSystem.c 2020-01-21 15:11:49.420942584 +0100
|
||||
@@ -143,11 +143,11 @@ void _init_os_distro() {
|
||||
|
||||
_OSBASE_TRACE(4,("--- _init_os_distro() called : init"));
|
||||
|
||||
- rc = runcommand( "find /etc/ -maxdepth 1 -type f -name *release 2>/dev/null" , NULL , &hdout , NULL );
|
||||
+ rc = runcommand( "find /etc/ /usr/lib/ -maxdepth 1 -type f -name *release 2>/dev/null" , NULL , &hdout , NULL );
|
||||
if( rc == 0 && *hdout != NULL) {
|
||||
while (hdout[j] && hdout[j][0]) {
|
||||
- if (strstr(hdout[j],"lsb-release") && hdout[j+1] && hdout[j+1][0]) {
|
||||
- /* found lsb-release but there are other (preferred) release files */
|
||||
+ if ((strstr(hdout[j],"lsb-release") || strstr(hdout[j],"os-release")) && hdout[j+1] && hdout[j+1][0]) {
|
||||
+ /* found lsb-release/os-release but there are other (preferred) release files */
|
||||
j++;
|
||||
continue;
|
||||
}
|
||||
@@ -242,35 +242,28 @@ unsigned long long get_os_totalSwapSize(
|
||||
|
||||
|
||||
char * get_os_installdate() {
|
||||
- struct tm date;
|
||||
+ struct tm * datep;
|
||||
char ** hdout = NULL;
|
||||
- char * dstr = NULL;
|
||||
char * str = NULL;
|
||||
- char * ptr = NULL;
|
||||
- int rc = 0;
|
||||
+ int rc = -1;
|
||||
|
||||
_OSBASE_TRACE(4,("--- get_os_installdate() called"));
|
||||
|
||||
- if( CIM_OS_DISTRO && strstr( CIM_OS_DISTRO, "Red Hat" ) ) {
|
||||
- /* we guess it is Red Hat */
|
||||
- rc = runcommand( "rpm -qi redhat-release | grep Install" , NULL , &hdout , NULL );
|
||||
- if(rc!=0) {
|
||||
- /* we guess it is Fedora */
|
||||
- rc = runcommand( "rpm -qi fedora-release | grep Install" , NULL , &hdout , NULL );
|
||||
+ if( CIM_OS_DISTRO ) {
|
||||
+ if( strstr( CIM_OS_DISTRO, "Red Hat" ) ) {
|
||||
+ /* we guess it is Red Hat */
|
||||
+ rc = runcommand( "rpm -q --qf '%{INSTALLTIME}' redhat-release" , NULL , &hdout , NULL );
|
||||
+ }
|
||||
+ else if( strstr( CIM_OS_DISTRO, "Fedora" ) ) {
|
||||
+ /* we guess it is Fedora */
|
||||
+ rc = runcommand( "rpm -q --qf '%{INSTALLTIME}' fedora-release-common" , NULL , &hdout , NULL );
|
||||
}
|
||||
if( rc == 0 ) {
|
||||
- str = strstr( hdout[0], ": ");
|
||||
- str+=2;
|
||||
- for( ptr = str ; (*ptr)!=' ' ; ptr++ ) {
|
||||
- if( *(ptr+1)==' ' ) { ptr ++; }
|
||||
- }
|
||||
- dstr = (char *) malloc( (strlen(str)-strlen(ptr)+1));
|
||||
- strncpy( dstr , str, strlen(str)-strlen(ptr)-1);
|
||||
- strptime(dstr, "%A %d %B %Y %H:%M:%S %p %Z", &date);
|
||||
+ time_t t = (time_t) atoi(*hdout);
|
||||
+ datep = gmtime(&t);
|
||||
str = (char*)malloc(26);
|
||||
- strftime(str,26,"%Y%m%d%H%M%S.000000",&date);
|
||||
+ strftime(str,26,"%Y%m%d%H%M%S.000000",datep);
|
||||
_cat_timezone(str, get_os_timezone());
|
||||
- if(dstr) free(dstr);
|
||||
}
|
||||
freeresultbuf(hdout);
|
||||
}
|
@ -0,0 +1,63 @@
|
||||
diff -up sblim-cmpi-base-1.6.4/OSBase_OperatingSystem.c.orig sblim-cmpi-base-1.6.4/OSBase_OperatingSystem.c
|
||||
--- sblim-cmpi-base-1.6.4/OSBase_OperatingSystem.c.orig 2020-02-04 13:55:31.565801631 +0100
|
||||
+++ sblim-cmpi-base-1.6.4/OSBase_OperatingSystem.c 2020-02-04 13:58:39.514189758 +0100
|
||||
@@ -88,13 +88,21 @@ int get_operatingsystem_data( struct cim
|
||||
bytes_read = fread(buf, 1, sizeof(buf)-1, fhd);
|
||||
buf[bytes_read] = 0; /* safeguard end of buffer */
|
||||
ptr = strstr(buf,"MemTotal");
|
||||
- sscanf(ptr, "%*s %lld", &((*sptr)->totalPhysMem));
|
||||
+ if( ptr != NULL ) {
|
||||
+ sscanf(ptr, "%*s %lld", &((*sptr)->totalPhysMem));
|
||||
+ }
|
||||
ptr = strstr(buf,"MemFree");
|
||||
- sscanf(ptr, "%*s %lld", &((*sptr)->freePhysMem));
|
||||
+ if( ptr != NULL ) {
|
||||
+ sscanf(ptr, "%*s %lld", &((*sptr)->freePhysMem));
|
||||
+ }
|
||||
ptr = strstr(buf,"SwapTotal");
|
||||
- sscanf(ptr, "%*s %lld", &((*sptr)->totalSwapMem));
|
||||
+ if( ptr != NULL ) {
|
||||
+ sscanf(ptr, "%*s %lld", &((*sptr)->totalSwapMem));
|
||||
+ }
|
||||
ptr = strstr(buf,"SwapFree");
|
||||
- sscanf(ptr, "%*s %lld", &((*sptr)->freeSwapMem));
|
||||
+ if( ptr != NULL ) {
|
||||
+ sscanf(ptr, "%*s %lld", &((*sptr)->freeSwapMem));
|
||||
+ }
|
||||
fclose(fhd);
|
||||
}
|
||||
/* TotalVirtualMemorySize */
|
||||
diff -up sblim-cmpi-base-1.6.4/OSBase_OperatingSystemStatisticalData.c.orig sblim-cmpi-base-1.6.4/OSBase_OperatingSystemStatisticalData.c
|
||||
--- sblim-cmpi-base-1.6.4/OSBase_OperatingSystemStatisticalData.c.orig 2020-02-04 13:55:31.557801615 +0100
|
||||
+++ sblim-cmpi-base-1.6.4/OSBase_OperatingSystemStatisticalData.c 2020-02-04 14:09:01.613474453 +0100
|
||||
@@ -109,13 +109,15 @@ int get_queue_info_24(struct os_statisti
|
||||
if ((f = fopen("/proc/loadavg","r")) != NULL) {
|
||||
fgets(buf,127,f);
|
||||
strptr = strstr(buf,"/");
|
||||
- *strptr = '\0';
|
||||
- while (*strptr != ' ') {
|
||||
- strptr--;
|
||||
+ if (strptr != NULL) {
|
||||
+ *strptr = '\0';
|
||||
+ while (*strptr != ' ') {
|
||||
+ strptr--;
|
||||
+ }
|
||||
+ stats->run_queue_length = atoll(strptr);
|
||||
+ res = 1;
|
||||
}
|
||||
- stats->run_queue_length = atoll(strptr);
|
||||
fclose(f);
|
||||
- res = 1;
|
||||
} else {
|
||||
_OSBASE_TRACE(1,("get_queue_info: could not open /proc/loadavg: %s",strerror(errno)));
|
||||
}
|
||||
@@ -173,7 +175,8 @@ int get_cpu_page_data_24(struct os_stati
|
||||
*
|
||||
* page <in> <out>
|
||||
*/
|
||||
- if (sscanf(strptr,"page %lld %lld",&pages_in, &pages_out) == 2) {
|
||||
+ if (strptr != NULL &&
|
||||
+ sscanf(strptr,"page %lld %lld",&pages_in, &pages_out) == 2) {
|
||||
stats->pages_in = pages_in;
|
||||
stats->pages_out = pages_out;
|
||||
res = 1;
|
86
SOURCES/sblim-cmpi-base-1.6.4-list-lib-dependencies.patch
Normal file
86
SOURCES/sblim-cmpi-base-1.6.4-list-lib-dependencies.patch
Normal file
@ -0,0 +1,86 @@
|
||||
diff -up sblim-cmpi-base-1.6.4/Makefile.am.orig sblim-cmpi-base-1.6.4/Makefile.am
|
||||
--- sblim-cmpi-base-1.6.4/Makefile.am.orig 2018-08-22 11:36:52.150165932 +0200
|
||||
+++ sblim-cmpi-base-1.6.4/Makefile.am 2018-08-22 11:42:27.735431424 +0200
|
||||
@@ -61,6 +61,7 @@ libcmpiOSBase_ComputerSystemProvider_la_
|
||||
OSBase_ComputerSystem.c
|
||||
libcmpiOSBase_ComputerSystemProvider_la_LIBADD = -lcmpiOSBase_Common
|
||||
libcmpiOSBase_ComputerSystemProvider_la_LDFLAGS = -avoid-version
|
||||
+libcmpiOSBase_ComputerSystemProvider_la_DEPENDENCIES = libcmpiOSBase_Common.la
|
||||
|
||||
# Operating System
|
||||
libcmpiOSBase_OperatingSystemProvider_la_SOURCES = \
|
||||
@@ -72,6 +73,8 @@ libcmpiOSBase_OperatingSystemProvider_la
|
||||
-ldmiinfo @LINDHELP@
|
||||
# This gcc/ld specific flag is ugly - need to check in configure
|
||||
libcmpiOSBase_OperatingSystemProvider_la_LDFLAGS = -avoid-version
|
||||
+libcmpiOSBase_OperatingSystemProvider_la_DEPENDENCIES = libcmpiOSBase_Common.la \
|
||||
+ libdmiinfo.la
|
||||
|
||||
# Operating System Statistical Data
|
||||
libcmpiOSBase_OperatingSystemStatisticalDataProvider_la_SOURCES = \
|
||||
@@ -80,6 +83,7 @@ libcmpiOSBase_OperatingSystemStatistical
|
||||
OSBase_OperatingSystemStatisticalData.c
|
||||
libcmpiOSBase_OperatingSystemStatisticalDataProvider_la_LIBADD = -lcmpiOSBase_Common
|
||||
libcmpiOSBase_OperatingSystemStatisticalDataProvider_la_LDFLAGS = -avoid-version
|
||||
+libcmpiOSBase_OperatingSystemStatisticalDataProvider_la_DEPENDENCIES = libcmpiOSBase_Common.la
|
||||
|
||||
# Unix Process
|
||||
libcmpiOSBase_UnixProcessProvider_la_SOURCES = \
|
||||
@@ -88,6 +92,7 @@ libcmpiOSBase_UnixProcessProvider_la_SOU
|
||||
OSBase_UnixProcess.c
|
||||
libcmpiOSBase_UnixProcessProvider_la_LIBADD = -lcmpiOSBase_Common
|
||||
libcmpiOSBase_UnixProcessProvider_la_LDFLAGS = -avoid-version
|
||||
+libcmpiOSBase_UnixProcessProvider_la_DEPENDENCIES = libcmpiOSBase_Common.la
|
||||
|
||||
# Processor
|
||||
libcmpiOSBase_ProcessorProvider_la_SOURCES = \
|
||||
@@ -96,6 +101,7 @@ libcmpiOSBase_ProcessorProvider_la_SOURC
|
||||
OSBase_Processor.c
|
||||
libcmpiOSBase_ProcessorProvider_la_LIBADD = -lcmpiOSBase_Common -lpthread
|
||||
libcmpiOSBase_ProcessorProvider_la_LDFLAGS = -avoid-version
|
||||
+libcmpiOSBase_ProcessorProvider_la_DEPENDENCIES = libcmpiOSBase_Common.la
|
||||
|
||||
# Base Board
|
||||
libcmpiOSBase_BaseBoardProvider_la_SOURCES = \
|
||||
@@ -104,26 +110,33 @@ libcmpiOSBase_BaseBoardProvider_la_SOURC
|
||||
OSBase_BaseBoard.c
|
||||
libcmpiOSBase_BaseBoardProvider_la_LIBADD = -lcmpiOSBase_Common -ldmiinfo
|
||||
libcmpiOSBase_BaseBoardProvider_la_LDFLAGS = -avoid-version
|
||||
+libcmpiOSBase_BaseBoardProvider_la_DEPENDENCIES = libcmpiOSBase_Common.la \
|
||||
+ libdmiinfo.la
|
||||
|
||||
libcmpiOSBase_RunningOSProvider_la_SOURCES = cmpiOSBase_RunningOSProvider.c
|
||||
libcmpiOSBase_RunningOSProvider_la_LIBADD = -lcmpiOSBase_Common
|
||||
libcmpiOSBase_RunningOSProvider_la_LDFLAGS = -avoid-version
|
||||
+libcmpiOSBase_RunningOSProvider_la_DEPENDENCIES = libcmpiOSBase_Common.la
|
||||
|
||||
libcmpiOSBase_OSProcessProvider_la_SOURCES = cmpiOSBase_OSProcessProvider.c
|
||||
libcmpiOSBase_OSProcessProvider_la_LIBADD = -lcmpiOSBase_Common
|
||||
libcmpiOSBase_OSProcessProvider_la_LDFLAGS = -avoid-version
|
||||
+libcmpiOSBase_OSProcessProvider_la_DEPENDENCIES = libcmpiOSBase_Common.la
|
||||
|
||||
libcmpiOSBase_OperatingSystemStatisticsProvider_la_SOURCES = cmpiOSBase_OperatingSystemStatisticsProvider.c
|
||||
libcmpiOSBase_OperatingSystemStatisticsProvider_la_LIBADD = -lcmpiOSBase_Common
|
||||
libcmpiOSBase_OperatingSystemStatisticsProvider_la_LDFLAGS = -avoid-version
|
||||
+libcmpiOSBase_OperatingSystemStatisticsProvider_la_DEPENDENCIES = libcmpiOSBase_Common.la
|
||||
|
||||
libcmpiOSBase_CSProcessorProvider_la_SOURCES = cmpiOSBase_CSProcessorProvider.c
|
||||
libcmpiOSBase_CSProcessorProvider_la_LIBADD = -lcmpiOSBase_Common
|
||||
libcmpiOSBase_CSProcessorProvider_la_LDFLAGS = -avoid-version
|
||||
+libcmpiOSBase_CSProcessorProvider_la_DEPENDENCIES = libcmpiOSBase_Common.la
|
||||
|
||||
libcmpiOSBase_CSBaseBoardProvider_la_SOURCES = cmpiOSBase_CSBaseBoardProvider.c
|
||||
libcmpiOSBase_CSBaseBoardProvider_la_LIBADD = -lcmpiOSBase_Common
|
||||
libcmpiOSBase_CSBaseBoardProvider_la_LDFLAGS = -avoid-version
|
||||
+libcmpiOSBase_CSBaseBoardProvider_la_DEPENDENCIES = libcmpiOSBase_Common.la
|
||||
|
||||
|
||||
# OSBase support utility libraries
|
||||
@@ -139,6 +152,7 @@ libdmiinfo_la_SOURCES=dmiinfo.c dmiinfo.
|
||||
noinst_PROGRAMS = dmitest
|
||||
dmitest_SOURCES = dmitest.c
|
||||
dmitest_LDADD = -ldmiinfo
|
||||
+dmitest_DEPENDENCIES = libdmiinfo.la
|
||||
|
||||
# Installable Header Files
|
||||
sbliminc_HEADERS = OSBase_Common.h cmpiOSBase_Common.h \
|
42
SOURCES/sblim-cmpi-base-1.6.4-prov-reg-sfcb-systemd.patch
Normal file
42
SOURCES/sblim-cmpi-base-1.6.4-prov-reg-sfcb-systemd.patch
Normal file
@ -0,0 +1,42 @@
|
||||
diff -up sblim-cmpi-base-1.6.4/provider-register.sh.orig sblim-cmpi-base-1.6.4/provider-register.sh
|
||||
--- sblim-cmpi-base-1.6.4/provider-register.sh.orig 2015-02-19 13:39:18.057255372 +0100
|
||||
+++ sblim-cmpi-base-1.6.4/provider-register.sh 2015-02-19 13:40:32.471535246 +0100
|
||||
@@ -351,20 +351,8 @@ sfcb_rebuild()
|
||||
if ps -C sfcbd > /dev/null 2>&1
|
||||
then
|
||||
# sfcb is running -- need to restart
|
||||
- for INITSCRIPT in /etc/init.d/sfcb /usr/local/etc/init.d/sfcb none
|
||||
- do
|
||||
- if test -x $INITSCRIPT
|
||||
- then
|
||||
- break;
|
||||
- fi
|
||||
- done
|
||||
chatter "Shutting down sfcb."
|
||||
- if test $INITSCRIPT = none
|
||||
- then
|
||||
- killall sfcbd
|
||||
- else
|
||||
- $INITSCRIPT stop
|
||||
- fi
|
||||
+ systemctl stop sblim-sfcb
|
||||
t=0
|
||||
while ps -C sfcbd > /dev/null 2>&1
|
||||
do
|
||||
@@ -385,14 +373,8 @@ sfcb_rebuild()
|
||||
return 1
|
||||
fi
|
||||
|
||||
- if test $INITSCRIPT = none
|
||||
- then
|
||||
- echo "No init script found - you need to start sfcbd manually." >&2
|
||||
- return 1
|
||||
- else
|
||||
- chatter "Restarting sfcb."
|
||||
- $INITSCRIPT start
|
||||
- fi
|
||||
+ chatter "Restarting sfcb."
|
||||
+ systemctl start sblim-sfcb
|
||||
else
|
||||
# Not running - rebuild repository
|
||||
chatter "Rebuilding repository."
|
306
SPECS/sblim-cmpi-base.spec
Normal file
306
SPECS/sblim-cmpi-base.spec
Normal file
@ -0,0 +1,306 @@
|
||||
Name: sblim-cmpi-base
|
||||
Version: 1.6.4
|
||||
Release: 20%{?dist}
|
||||
Summary: SBLIM CMPI Base Providers
|
||||
|
||||
License: EPL-1.0
|
||||
URL: https://sourceforge.net/projects/sblim/
|
||||
Source0: http://downloads.sourceforge.net/sblim/%{name}-%{version}.tar.bz2
|
||||
Patch0: sblim-cmpi-base-1.6.0-missing-fclose.patch
|
||||
Patch1: sblim-cmpi-base-1.6.0-methods-enable.patch
|
||||
Patch2: sblim-cmpi-base-1.6.1-double-fclose.patch
|
||||
# Patch3: removes version from docdir
|
||||
Patch3: sblim-cmpi-base-1.6.2-docdir.patch
|
||||
# Patch4: use Pegasus root/interop instead of root/PG_Interop
|
||||
Patch4: sblim-cmpi-base-1.6.2-pegasus-interop.patch
|
||||
# Patch5: call systemctl in provider registration
|
||||
Patch5: sblim-cmpi-base-1.6.4-prov-reg-sfcb-systemd.patch
|
||||
# Patch6: explicitly list library dependencies in Makefile.am, rhbz#1606302
|
||||
Patch6: sblim-cmpi-base-1.6.4-list-lib-dependencies.patch
|
||||
# Patch7: don't install COPYING with license, included through %%license
|
||||
Patch7: sblim-cmpi-base-1.6.4-dont-install-license.patch
|
||||
# Patch8: fixes getting of InstallDate property, improves it to work
|
||||
# on non en_US locales and updates support for Fedora
|
||||
Patch8: sblim-cmpi-base-1.6.4-fix-get-os-install-date.patch
|
||||
# Patch9: fixes possible null pointer dereferences after strstr calls
|
||||
Patch9: sblim-cmpi-base-1.6.4-fix-possible-null-dereference.patch
|
||||
Requires: cim-server sblim-indication_helper
|
||||
BuildRequires: make
|
||||
BuildRequires: perl-generators
|
||||
BuildRequires: sblim-cmpi-devel sblim-indication_helper-devel
|
||||
BuildRequires: autoconf automake libtool pkgconfig
|
||||
|
||||
|
||||
%description
|
||||
SBLIM (Standards Based Linux Instrumentation for Manageability)
|
||||
CMPI (Common Manageability Programming Interface) Base Providers
|
||||
for System-Related CIM (Common Information Model) classes.
|
||||
|
||||
%package devel
|
||||
Summary: SBLIM CMPI Base Providers Development Header Files
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
SBLIM (Standards Based Linux Instrumentation for Manageability)
|
||||
CMPI (Common Manageability Programming Interface) Base Provider
|
||||
development header files and link libraries.
|
||||
|
||||
%package test
|
||||
Summary: SBLIM CMPI Base Providers Test Cases
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Requires: sblim-testsuite
|
||||
|
||||
%description test
|
||||
SBLIM (Standards Based Linux Instrumentation for Manageability)
|
||||
CMPI (Common Manageability Programming Interface) Base Provider
|
||||
Testcase Files for the SBLIM Testsuite.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
autoreconf --install --force
|
||||
%patch0 -p0 -b .missing-fclose
|
||||
%patch1 -p0 -b .methods-enable
|
||||
%patch2 -p1 -b .double-fclose
|
||||
%patch3 -p1 -b .docdir
|
||||
%patch4 -p1 -b .pegasus-interop
|
||||
%patch5 -p1 -b .prov-reg-sfcb-systemd
|
||||
%patch6 -p1 -b .list-lib-dependencies
|
||||
%patch7 -p1 -b .dont-install-license
|
||||
%patch8 -p1 -b .fix-get-os-install-date
|
||||
%patch9 -p1 -b .fix-possible-null-dereference.patch
|
||||
|
||||
%build
|
||||
%configure TESTSUITEDIR=%{_datadir}/sblim-testsuite --disable-static
|
||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||
make
|
||||
|
||||
%install
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
cp -fp *OSBase_UnixProcess.h $RPM_BUILD_ROOT/%{_includedir}/sblim
|
||||
chmod 644 $RPM_BUILD_ROOT/%{_includedir}/sblim/*OSBase_UnixProcess.h
|
||||
# remove unused libtool files
|
||||
rm -f $RPM_BUILD_ROOT/%{_libdir}/*a
|
||||
rm -f $RPM_BUILD_ROOT/%{_libdir}/cmpi/*a
|
||||
|
||||
%files
|
||||
%license COPYING
|
||||
%doc AUTHORS DEBUG README README.INDICATION README.TEST README.tog-pegasus
|
||||
%{_datadir}/%{name}
|
||||
%{_libdir}/*.so.*
|
||||
%{_libdir}/cmpi/*.so*
|
||||
|
||||
%files devel
|
||||
%{_includedir}/*
|
||||
%{_libdir}/*.so
|
||||
|
||||
%files test
|
||||
%dir %{_datadir}/sblim-testsuite/cim
|
||||
%dir %{_datadir}/sblim-testsuite/system
|
||||
%dir %{_datadir}/sblim-testsuite/system/linux
|
||||
%{_datadir}/sblim-testsuite/test-cmpi-base.sh
|
||||
%{_datadir}/sblim-testsuite/cim/*.cim
|
||||
%{_datadir}/sblim-testsuite/system/linux/*.system
|
||||
%{_datadir}/sblim-testsuite/system/linux/*.sh
|
||||
%{_datadir}/sblim-testsuite/system/linux/*.pl
|
||||
|
||||
%global SCHEMA %{_datadir}/%{name}/Linux_Base.mof %{_datadir}/%{name}/Linux_BaseIndication.mof
|
||||
|
||||
%global REGISTRATION %{_datadir}/%{name}/Linux_BaseIndication.registration
|
||||
|
||||
%pre
|
||||
%sblim_pre
|
||||
|
||||
%post
|
||||
%sblim_post
|
||||
|
||||
%preun
|
||||
%sblim_preun
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%changelog
|
||||
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 1.6.4-20
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 1.6.4-19
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.4-18
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.4-17
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Tue Feb 04 2020 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.6.4-16
|
||||
- Fix possible null pointer dereferences after strstr calls
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.4-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Wed Jan 22 2020 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.6.4-14
|
||||
- Fix getting of InstallDate property, improve it to work on non en_US locales
|
||||
and update support for recent Fedora distributions
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.4-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Tue May 14 2019 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.6.4-12
|
||||
- Fix URL
|
||||
|
||||
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.4-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Wed Aug 22 2018 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.6.4-10
|
||||
- Fix docdir patch (patch Makefile.am, not Makefile.in)
|
||||
- Use correct short name for Eclipse Public License 1.0
|
||||
- Use %%license
|
||||
- Add explicit dependencies for libraries in Makefile.am (fixes FTBFS)
|
||||
Resolves: #1606302
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.4-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.4-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.4-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.4-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.4-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.4-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Thu Feb 26 2015 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.6.4-2
|
||||
- Update provider registration script to use systemctl to stop/start sfcb
|
||||
- Use new macros for %%pre/%%post/%%preun from sblim-cmpi-devel
|
||||
|
||||
* Wed Oct 29 2014 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.6.4-1
|
||||
- Update to sblim-cmpi-base-1.6.4
|
||||
|
||||
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.2-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.2-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Tue Feb 18 2014 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.6.2-8
|
||||
- Support aarch64
|
||||
Resolves: #926474
|
||||
|
||||
* Wed Aug 07 2013 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.6.2-7
|
||||
- Use Pegasus root/interop instead of root/PG_Interop
|
||||
- Fix unversioned docdir change
|
||||
Resolves: #994073
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.2-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Thu Jul 18 2013 Petr Pisar <ppisar@redhat.com> - 1.6.2-5
|
||||
- Perl 5.18 rebuild
|
||||
|
||||
* Mon Jun 17 2013 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.6.2-4
|
||||
- Fix wrong UserModeTime and KernelModeTime
|
||||
- Fix bogus date in %%changelog
|
||||
|
||||
* Thu Jun 06 2013 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.6.2-3
|
||||
- Fix incorrect max cpu frequency
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Wed Dec 05 2012 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.6.2-1
|
||||
- Update to sblim-cmpi-base-1.6.2
|
||||
|
||||
* Tue Sep 04 2012 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.6.1-8
|
||||
- Fix issues found by fedora-review utility in the spec file
|
||||
|
||||
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.1-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Thu May 10 2012 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.6.1-6
|
||||
- Fix double fclose() call (patch by Roman Rakus <rrakus@redhat.com>)
|
||||
Resolves: #820315
|
||||
|
||||
* Wed Feb 15 2012 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.6.1-5
|
||||
- Enable indications and method providers
|
||||
|
||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Wed Apr 27 2011 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.6.1-3
|
||||
- Fix/enhance mofs registration for various CIMOMs (patch by Masatake Yamato)
|
||||
Resolves: #695626
|
||||
|
||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Mon Feb 7 2011 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.6.1-1
|
||||
- Update to sblim-cmpi-base-1.6.1
|
||||
|
||||
* Mon Dec 13 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.6.0-2
|
||||
- Fix license, mofs registration for various CIMOMs, sblim-sfcb init script
|
||||
path in provider-register.sh, rpmlint warnings
|
||||
|
||||
* Wed Oct 6 2010 Praveen K Paladugu <praveen_paladugu@dell.com> - 1.6.0-1
|
||||
- Updated to 1.6.0
|
||||
- removed the CIMOM dependencies
|
||||
- following the upstream packaging obsolete, sblim-cmpi-base-test pkg.
|
||||
- Added the patches from upstream packaging
|
||||
- fix to restart tog-pegasus properly
|
||||
|
||||
* Thu Aug 27 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.5.9-1
|
||||
- Update to 1.5.9
|
||||
|
||||
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.7-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.7-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Tue Nov 4 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.5.7-2
|
||||
- Fix %%files (to be able build -devel dependent packages)
|
||||
- Remove rpath from libraries
|
||||
- Spec file cleanup, rpmlint check
|
||||
|
||||
* Fri Oct 24 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.5.7-1
|
||||
- Update to 1.5.7
|
||||
Resolves: #468325
|
||||
|
||||
* Wed Jul 2 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.5.5-2
|
||||
- Fix testsuite dependency
|
||||
|
||||
* Tue Jul 1 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.5.5-1
|
||||
- Update to 1.5.5
|
||||
- Spec file revision
|
||||
|
||||
* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.5.4-8
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
* Tue Dec 05 2006 Mark Hamzy <hamzy@us.ibm.com> - 1.5.4-7
|
||||
- Ignore failures when running provider-register.sh. cimserver may be down
|
||||
|
||||
* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 1.5.4-6
|
||||
- rebuilt for unwind info generation, broken in gcc-4.1.1-21
|
||||
|
||||
* Thu Nov 10 2005 <mihajlov@de.ibm.com> - 1.5.4-3
|
||||
- suppress error output in post scriptlets
|
||||
|
||||
* Wed Oct 26 2005 <mihajlov@de.ibm.com> - 1.5.4-2
|
||||
- went back to original provider dir location as FC5 pegasus 2.5.1 support
|
||||
/usr/lib[64]/cmpi
|
||||
|
||||
* Wed Oct 12 2005 <mihajlov@de.ibm.com> - 1.5.4-1
|
||||
- new spec file specifically for Fedora/RedHat
|
||||
|
||||
* Wed Jul 20 2005 Mark Hamzy <hamzy@us.ibm.com> - 1.5.3-1
|
||||
- initial support
|
Loading…
Reference in New Issue
Block a user