import sbd-1.5.0-2.el9.1
This commit is contained in:
commit
e4dd777f2f
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/sbd-d7f447d689da52897e190114c448d1129f3c5f72.tar.gz
|
1
.sbd.metadata
Normal file
1
.sbd.metadata
Normal file
@ -0,0 +1 @@
|
||||
7506baf3940101bc1472036cb6d5e05d7f0cb92c SOURCES/sbd-d7f447d689da52897e190114c448d1129f3c5f72.tar.gz
|
@ -0,0 +1,41 @@
|
||||
From 956f3558d4b619fb19eaa040614dfaf9a226d514 Mon Sep 17 00:00:00 2001
|
||||
From: Klaus Wenninger <klaus.wenninger@aon.at>
|
||||
Date: Mon, 28 Jun 2021 17:37:44 +0200
|
||||
Subject: [PATCH] Build: Fix: correctly derive package version from git
|
||||
|
||||
---
|
||||
Makefile.am | 4 ++--
|
||||
sbd.spec | 2 +-
|
||||
2 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index e614754..5d53c4c 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -73,8 +73,8 @@ spec:
|
||||
sed -i 's/global\ build_counter.*/global\ build_counter\ $(COUNT)/' $(distdir)/$(PACKAGE).spec; \
|
||||
echo $(COUNT) > $(BUILD_COUNTER); \
|
||||
fi
|
||||
- if [ -n $(COMMIT_COUNTER) ]; then \
|
||||
- sed -i 's/global\ commit_counter.*/global\ commit_counter\ $(COMMIT_COUNTER)-1/' $(distdir)/$(PACKAGE).spec; \
|
||||
+ if [ -n "$(COMMIT_COUNTER)" ]; then \
|
||||
+ sed -i 's/global\ commit_counter.*/global\ commit_counter\ $(COMMIT_COUNTER)/' $(distdir)/$(PACKAGE).spec; \
|
||||
fi
|
||||
|
||||
srpm: export spec
|
||||
diff --git a/sbd.spec b/sbd.spec
|
||||
index 776e48b..0498db1 100644
|
||||
--- a/sbd.spec
|
||||
+++ b/sbd.spec
|
||||
@@ -20,7 +20,7 @@
|
||||
%global modified %(echo %{longcommit}-|cut -f2 -d-)
|
||||
%global github_owner Clusterlabs
|
||||
%global commit_counter 0
|
||||
-%global build_counter 1
|
||||
+%global build_counter 0
|
||||
%global buildnum %(expr %{commit_counter} + %{build_counter})
|
||||
|
||||
%ifarch s390x s390
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -0,0 +1,43 @@
|
||||
From 8438c244cc2066fbe9c598a6392e8935cf017d97 Mon Sep 17 00:00:00 2001
|
||||
From: "Gao,Yan" <ygao@suse.com>
|
||||
Date: Fri, 25 Jun 2021 15:02:14 +0200
|
||||
Subject: [PATCH] Refactor: sbd-inquisitor: functionize striping leading spaces
|
||||
of an option value
|
||||
|
||||
---
|
||||
src/sbd-inquisitor.c | 11 +++++++++--
|
||||
1 file changed, 9 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/sbd-inquisitor.c b/src/sbd-inquisitor.c
|
||||
index 4fec2fd..53ddfa3 100644
|
||||
--- a/src/sbd-inquisitor.c
|
||||
+++ b/src/sbd-inquisitor.c
|
||||
@@ -40,9 +40,8 @@ bool sync_resource_startup = false;
|
||||
int parse_device_line(const char *line);
|
||||
|
||||
static const char *
|
||||
-get_env_option(const char *option)
|
||||
+sanitize_option_value(const char *value)
|
||||
{
|
||||
- const char *value = getenv(option);
|
||||
size_t max = 0;
|
||||
size_t lpc = 0;
|
||||
|
||||
@@ -61,6 +60,14 @@ get_env_option(const char *option)
|
||||
return (strlen(value + lpc) > 0 ? (value + lpc) : NULL);
|
||||
}
|
||||
|
||||
+static const char *
|
||||
+get_env_option(const char *option)
|
||||
+{
|
||||
+ const char *value = getenv(option);
|
||||
+
|
||||
+ return sanitize_option_value(value);
|
||||
+}
|
||||
+
|
||||
static int
|
||||
recruit_servant(const char *devname, pid_t pid)
|
||||
{
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -0,0 +1,29 @@
|
||||
From c1bb2a4d8c8ec66c72da3ec080f23b1f858a66af Mon Sep 17 00:00:00 2001
|
||||
From: "Gao,Yan" <ygao@suse.com>
|
||||
Date: Mon, 28 Jun 2021 13:35:56 +0200
|
||||
Subject: [PATCH] Log: sbd-inquisitor: tell the actual watchdog device
|
||||
specified with `-w`
|
||||
|
||||
---
|
||||
src/sbd-inquisitor.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/sbd-inquisitor.c b/src/sbd-inquisitor.c
|
||||
index 53ddfa3..2cf09ac 100644
|
||||
--- a/src/sbd-inquisitor.c
|
||||
+++ b/src/sbd-inquisitor.c
|
||||
@@ -1042,10 +1042,10 @@ int main(int argc, char **argv, char **envp)
|
||||
W_count++;
|
||||
break;
|
||||
case 'w':
|
||||
- cl_log(LOG_NOTICE, "Using watchdog device '%s'", watchdogdev);
|
||||
free(watchdogdev);
|
||||
watchdogdev = strdup(optarg);
|
||||
watchdogdev_is_default = false;
|
||||
+ cl_log(LOG_NOTICE, "Using watchdog device '%s'", watchdogdev);
|
||||
break;
|
||||
case 'd':
|
||||
#if SUPPORT_SHARED_DISK
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -0,0 +1,146 @@
|
||||
From 1c72cf23561deeb69b04891f3fc4d0613f73fbb0 Mon Sep 17 00:00:00 2001
|
||||
From: "Gao,Yan" <ygao@suse.com>
|
||||
Date: Fri, 25 Jun 2021 15:21:38 +0200
|
||||
Subject: [PATCH] Fix: sbd-inquisitor: tolerate and strip any leading spaces of
|
||||
command line option values
|
||||
|
||||
Somehow an user's own monitoring agent doesn't well parse an SBD_DEVICE
|
||||
setting with spaces between the device names:
|
||||
|
||||
SBD_DEVICE="/dev/<a>; /dev/<b>; /dev/<c>"
|
||||
|
||||
And eventually it calls an sbd command:
|
||||
|
||||
`sbd list -d " /dev/<b>"`
|
||||
|
||||
-- A space is prefixed to the device name which is quoted.
|
||||
|
||||
Of course it could be easily fixed in the setting or their agent. But
|
||||
OTOH, sbd'd better tolerate and strip any leading spaces of command line
|
||||
option values.
|
||||
---
|
||||
src/sbd-inquisitor.c | 41 +++++++++++++++++++++++++----------------
|
||||
1 file changed, 25 insertions(+), 16 deletions(-)
|
||||
|
||||
diff --git a/src/sbd-inquisitor.c b/src/sbd-inquisitor.c
|
||||
index 2cf09ac..944a353 100644
|
||||
--- a/src/sbd-inquisitor.c
|
||||
+++ b/src/sbd-inquisitor.c
|
||||
@@ -999,6 +999,15 @@ int main(int argc, char **argv, char **envp)
|
||||
}
|
||||
|
||||
while ((c = getopt(argc, argv, "czC:DPRTWZhvw:d:n:p:1:2:3:4:5:t:I:F:S:s:r:")) != -1) {
|
||||
+ /* Call it before checking optarg for NULL to make coverity happy */
|
||||
+ const char *sanitized_optarg = sanitize_option_value(optarg);
|
||||
+
|
||||
+ if (optarg && sanitized_optarg == NULL) {
|
||||
+ fprintf(stderr, "Invalid value \"%s\" for option -%c\n", optarg, c);
|
||||
+ exit_status = -2;
|
||||
+ goto out;
|
||||
+ }
|
||||
+
|
||||
switch (c) {
|
||||
case 'D':
|
||||
break;
|
||||
@@ -1011,11 +1020,11 @@ int main(int argc, char **argv, char **envp)
|
||||
cl_log(LOG_INFO, "Realtime mode deactivated.");
|
||||
break;
|
||||
case 'S':
|
||||
- start_mode = atoi(optarg);
|
||||
+ start_mode = atoi(sanitized_optarg);
|
||||
cl_log(LOG_INFO, "Start mode set to: %d", (int)start_mode);
|
||||
break;
|
||||
case 's':
|
||||
- timeout_startup = atoi(optarg);
|
||||
+ timeout_startup = atoi(sanitized_optarg);
|
||||
cl_log(LOG_INFO, "Start timeout set to: %d", (int)timeout_startup);
|
||||
break;
|
||||
case 'v':
|
||||
@@ -1043,13 +1052,13 @@ int main(int argc, char **argv, char **envp)
|
||||
break;
|
||||
case 'w':
|
||||
free(watchdogdev);
|
||||
- watchdogdev = strdup(optarg);
|
||||
+ watchdogdev = strdup(sanitized_optarg);
|
||||
watchdogdev_is_default = false;
|
||||
cl_log(LOG_NOTICE, "Using watchdog device '%s'", watchdogdev);
|
||||
break;
|
||||
case 'd':
|
||||
#if SUPPORT_SHARED_DISK
|
||||
- if (recruit_servant(optarg, 0) != 0) {
|
||||
+ if (recruit_servant(sanitized_optarg, 0) != 0) {
|
||||
fprintf(stderr, "Invalid device: %s\n", optarg);
|
||||
exit_status = -1;
|
||||
goto out;
|
||||
@@ -1070,48 +1079,48 @@ int main(int argc, char **argv, char **envp)
|
||||
disk_priority = 0;
|
||||
break;
|
||||
case 'n':
|
||||
- local_uname = strdup(optarg);
|
||||
+ local_uname = strdup(sanitized_optarg);
|
||||
cl_log(LOG_INFO, "Overriding local hostname to %s", local_uname);
|
||||
break;
|
||||
case 'p':
|
||||
- pidfile = strdup(optarg);
|
||||
+ pidfile = strdup(sanitized_optarg);
|
||||
cl_log(LOG_INFO, "pidfile set to %s", pidfile);
|
||||
break;
|
||||
case 'C':
|
||||
- timeout_watchdog_crashdump = atoi(optarg);
|
||||
+ timeout_watchdog_crashdump = atoi(sanitized_optarg);
|
||||
cl_log(LOG_INFO, "Setting crashdump watchdog timeout to %d",
|
||||
(int)timeout_watchdog_crashdump);
|
||||
break;
|
||||
case '1':
|
||||
- timeout_watchdog = atoi(optarg);
|
||||
+ timeout_watchdog = atoi(sanitized_optarg);
|
||||
break;
|
||||
case '2':
|
||||
- timeout_allocate = atoi(optarg);
|
||||
+ timeout_allocate = atoi(sanitized_optarg);
|
||||
break;
|
||||
case '3':
|
||||
- timeout_loop = atoi(optarg);
|
||||
+ timeout_loop = atoi(sanitized_optarg);
|
||||
break;
|
||||
case '4':
|
||||
- timeout_msgwait = atoi(optarg);
|
||||
+ timeout_msgwait = atoi(sanitized_optarg);
|
||||
break;
|
||||
case '5':
|
||||
- timeout_watchdog_warn = atoi(optarg);
|
||||
+ timeout_watchdog_warn = atoi(sanitized_optarg);
|
||||
do_calculate_timeout_watchdog_warn = false;
|
||||
cl_log(LOG_INFO, "Setting latency warning to %d",
|
||||
(int)timeout_watchdog_warn);
|
||||
break;
|
||||
case 't':
|
||||
- servant_restart_interval = atoi(optarg);
|
||||
+ servant_restart_interval = atoi(sanitized_optarg);
|
||||
cl_log(LOG_INFO, "Setting servant restart interval to %d",
|
||||
(int)servant_restart_interval);
|
||||
break;
|
||||
case 'I':
|
||||
- timeout_io = atoi(optarg);
|
||||
+ timeout_io = atoi(sanitized_optarg);
|
||||
cl_log(LOG_INFO, "Setting IO timeout to %d",
|
||||
(int)timeout_io);
|
||||
break;
|
||||
case 'F':
|
||||
- servant_restart_count = atoi(optarg);
|
||||
+ servant_restart_count = atoi(sanitized_optarg);
|
||||
cl_log(LOG_INFO, "Servant restart count set to %d",
|
||||
(int)servant_restart_count);
|
||||
break;
|
||||
@@ -1119,7 +1128,7 @@ int main(int argc, char **argv, char **envp)
|
||||
if (timeout_action) {
|
||||
free(timeout_action);
|
||||
}
|
||||
- timeout_action = strdup(optarg);
|
||||
+ timeout_action = strdup(sanitized_optarg);
|
||||
break;
|
||||
case 'h':
|
||||
usage();
|
||||
--
|
||||
1.8.3.1
|
||||
|
290
SPECS/sbd.spec
Normal file
290
SPECS/sbd.spec
Normal file
@ -0,0 +1,290 @@
|
||||
#
|
||||
# spec file for package sbd
|
||||
#
|
||||
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
|
||||
# Copyright (c) 2013 Lars Marowsky-Bree
|
||||
#
|
||||
# All modifications and additions to the file contributed by third parties
|
||||
# remain the property of their copyright owners, unless otherwise agreed
|
||||
# upon. The license for this file, and modifications and additions to the
|
||||
# file, is the same license as for the pristine package itself (unless the
|
||||
# license for the pristine package is not an Open Source License, in which
|
||||
# case the license is the MIT License). An "Open Source License" is a
|
||||
# license that conforms to the Open Source Definition (Version 1.9)
|
||||
# published by the Open Source Initiative.
|
||||
|
||||
# Please submit bugfixes or comments via http://bugs.opensuse.org/
|
||||
#
|
||||
%global longcommit d7f447d689da52897e190114c448d1129f3c5f72
|
||||
%global shortcommit %(echo %{longcommit}|cut -c1-8)
|
||||
%global modified %(echo %{longcommit}-|cut -f2 -d-)
|
||||
%global github_owner Clusterlabs
|
||||
%global buildnum 2
|
||||
|
||||
%ifarch s390x s390
|
||||
# minimum timeout on LPAR diag288 watchdog is 15s
|
||||
%global watchdog_timeout_default 15
|
||||
%else
|
||||
%global watchdog_timeout_default 5
|
||||
%endif
|
||||
|
||||
# Be careful with sync_resource_startup_default
|
||||
# being enabled. This configuration has
|
||||
# to be in sync with configuration in pacemaker
|
||||
# where it is called sbd_sync - assure by e.g.
|
||||
# mutual rpm dependencies.
|
||||
%bcond_without sync_resource_startup_default
|
||||
# Syncing enabled per default will lead to
|
||||
# syncing enabled on upgrade without adaption
|
||||
# of the config.
|
||||
# Setting can still be overruled via sysconfig.
|
||||
# The setting in the config-template packaged
|
||||
# will follow the default if below is is left
|
||||
# empty. But it is possible to have the setting
|
||||
# in the config-template deviate from the default
|
||||
# by setting below to an explicit 'yes' or 'no'.
|
||||
%global sync_resource_startup_sysconfig ""
|
||||
|
||||
Name: sbd
|
||||
Summary: Storage-based death
|
||||
License: GPLv2+
|
||||
Version: 1.5.0
|
||||
Release: %{buildnum}%{?dist}.1
|
||||
Url: https://github.com/%{github_owner}/%{name}
|
||||
Source0: https://github.com/%{github_owner}/%{name}/archive/%{longcommit}/%{name}-%{longcommit}.tar.gz
|
||||
Patch0: 0001-Build-Fix-correctly-derive-package-version-from-git.patch
|
||||
Patch1: 0002-Refactor-sbd-inquisitor-functionize-striping-leading.patch
|
||||
Patch2: 0003-Log-sbd-inquisitor-tell-the-actual-watchdog-device-s.patch
|
||||
Patch3: 0004-Fix-sbd-inquisitor-tolerate-and-strip-any-leading-sp.patch
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: glib2-devel
|
||||
BuildRequires: libaio-devel
|
||||
BuildRequires: corosync-devel
|
||||
BuildRequires: pacemaker-libs-devel
|
||||
BuildRequires: libtool
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: make
|
||||
BuildRequires: systemd
|
||||
Conflicts: fence-agents-sbd < 4.5.0
|
||||
Conflicts: pacemaker-libs < 2.1.0-5
|
||||
|
||||
%if 0%{?rhel}
|
||||
ExclusiveArch: i686 x86_64 s390x aarch64 ppc64le
|
||||
%endif
|
||||
|
||||
%if %{defined systemd_requires}
|
||||
%systemd_requires
|
||||
%endif
|
||||
|
||||
%description
|
||||
|
||||
This package contains the storage-based death functionality.
|
||||
|
||||
Available rpmbuild rebuild options:
|
||||
--with(out) : sync_resource_startup_default
|
||||
|
||||
%package tests
|
||||
Summary: Storage-based death environment for regression tests
|
||||
License: GPLv2+
|
||||
|
||||
%description tests
|
||||
This package provides an environment + testscripts for
|
||||
regression-testing sbd.
|
||||
|
||||
###########################################################
|
||||
|
||||
%prep
|
||||
%autosetup -n %{name}-%{longcommit} -p1
|
||||
|
||||
###########################################################
|
||||
|
||||
%build
|
||||
./autogen.sh
|
||||
export CFLAGS="$RPM_OPT_FLAGS -Wall -Werror"
|
||||
%configure --with-watchdog-timeout-default=%{watchdog_timeout_default} \
|
||||
--with-sync-resource-startup-default=%{?with_sync_resource_startup_default:yes}%{!?with_sync_resource_startup_default:no} \
|
||||
--with-sync-resource-startup-sysconfig=%{sync_resource_startup_sysconfig}
|
||||
make %{?_smp_mflags}
|
||||
|
||||
###########################################################
|
||||
|
||||
%install
|
||||
|
||||
make DESTDIR=$RPM_BUILD_ROOT LIBDIR=%{_libdir} install
|
||||
rm -rf ${RPM_BUILD_ROOT}%{_libdir}/stonith
|
||||
|
||||
install -D -m 0755 tests/regressions.sh $RPM_BUILD_ROOT/usr/share/sbd/regressions.sh
|
||||
%if %{defined _unitdir}
|
||||
install -D -m 0644 src/sbd.service $RPM_BUILD_ROOT/%{_unitdir}/sbd.service
|
||||
install -D -m 0644 src/sbd_remote.service $RPM_BUILD_ROOT/%{_unitdir}/sbd_remote.service
|
||||
%endif
|
||||
|
||||
mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig
|
||||
install -m 644 src/sbd.sysconfig ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/sbd
|
||||
|
||||
# Don't package static libs
|
||||
find %{buildroot} -name '*.a' -type f -print0 | xargs -0 rm -f
|
||||
find %{buildroot} -name '*.la' -type f -print0 | xargs -0 rm -f
|
||||
|
||||
###########################################################
|
||||
|
||||
%if %{defined _unitdir}
|
||||
%post
|
||||
%systemd_post sbd.service
|
||||
%systemd_post sbd_remote.service
|
||||
if [ $1 -ne 1 ] ; then
|
||||
if systemctl --quiet is-enabled sbd.service 2>/dev/null
|
||||
then
|
||||
systemctl --quiet reenable sbd.service 2>/dev/null || :
|
||||
fi
|
||||
if systemctl --quiet is-enabled sbd_remote.service 2>/dev/null
|
||||
then
|
||||
systemctl --quiet reenable sbd_remote.service 2>/dev/null || :
|
||||
fi
|
||||
fi
|
||||
|
||||
%preun
|
||||
%systemd_preun sbd.service
|
||||
%systemd_preun sbd_remote.service
|
||||
|
||||
%postun
|
||||
%systemd_postun sbd.service
|
||||
%systemd_postun sbd_remote.service
|
||||
%endif
|
||||
|
||||
%files
|
||||
###########################################################
|
||||
%defattr(-,root,root)
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/sbd
|
||||
%{_sbindir}/sbd
|
||||
%{_datadir}/sbd
|
||||
%{_datadir}/pkgconfig/sbd.pc
|
||||
%exclude %{_datadir}/sbd/regressions.sh
|
||||
%doc %{_mandir}/man8/sbd*
|
||||
%if %{defined _unitdir}
|
||||
%{_unitdir}/sbd.service
|
||||
%{_unitdir}/sbd_remote.service
|
||||
%endif
|
||||
%doc COPYING
|
||||
|
||||
%files tests
|
||||
###########################################################
|
||||
%defattr(-,root,root)
|
||||
%dir %{_datadir}/sbd
|
||||
%{_datadir}/sbd/regressions.sh
|
||||
%{_libdir}/libsbdtestbed*
|
||||
|
||||
%changelog
|
||||
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 1.5.0-2.1
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Fri Jul 9 2021 Klaus Wenninger <kwenning@redhat.com> - 1.5.0-2
|
||||
- properly conflict with pacemaker not providing sync-default we need
|
||||
Resolves: rhbz#1979961
|
||||
Resolves: rhbz#1979573
|
||||
|
||||
* Tue Jul 6 2021 Klaus Wenninger <kwenning@redhat.com> - 1.5.0-1
|
||||
- sync with fedora sbd-1.5.0-1
|
||||
Resolves: rhbz#1979961
|
||||
Resolves: rhbz#1979573
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 1.4.2-3.2
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.2-3.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Mon Dec 7 2020 Klaus Wenninger <kwenning@redhat.com> - 1.4.2-3
|
||||
- this time really remove dist.depcheck from gating
|
||||
|
||||
* Mon Dec 7 2020 Klaus Wenninger <kwenning@redhat.com> - 1.4.2-2
|
||||
- remove deprecated dist.depcheck from gating
|
||||
- add tier0 to push_stable to have rawhide gated as well
|
||||
|
||||
* Mon Dec 7 2020 Klaus Wenninger <kwenning@redhat.com> - 1.4.2-1
|
||||
- Rebase to upstream v1.4.2
|
||||
- Conflict with pacemaker that doesn't have pacemakerd-api
|
||||
- Set default to not do startup/shutdown-syncing via pacemakerd-api
|
||||
but enable in template-config
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.1-7.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Thu May 14 2020 Klaus Wenninger <kwenning@redhat.com> - 1.4.1-7
|
||||
- Rebuild against libqb2.0 (f33-build-side-23348)
|
||||
|
||||
* Wed Mar 11 2020 Klaus Wenninger <kwenning@redhat.com> - 1.4.1-6
|
||||
- Rebuild because tagging the build failed
|
||||
|
||||
* Thu Mar 5 2020 Klaus Wenninger <kwenning@redhat.com> - 1.4.1-5
|
||||
- Rebase to upstream v1.4.1
|
||||
- Make coverity happy with parameter passing in regressions.sh
|
||||
- Add auto generated environment section to man-page
|
||||
- Overhaul setting scheduler policy/priority
|
||||
- Enable Fedora CI Gating
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri Feb 1 2019 Klaus Wenninger <kwenning@redhat.com> - 1.4.0-1
|
||||
- Rebase to upstream v1.4.0
|
||||
- Fail earlier on invalid servants (solves GCC9 build issue as well)
|
||||
|
||||
* Wed Nov 21 2018 Klaus Wenninger <kwenning@redhat.com> - 1.3.1-1.git4927571
|
||||
- Rebased to commit 4927571f8e9b00db8242654b1329dfbd71dcfe99
|
||||
- Removed disabling of shared-disk-support
|
||||
Resolves rhbz#1606301
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-4.3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Sun Mar 18 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1.2.1-4.2
|
||||
- Update Python 2 dependency declarations to new packaging standards
|
||||
(See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-4.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Tue Jan 30 2018 Merlin Mathesius <mmathesi@redhat.com> - 1.2.1-4
|
||||
- Patch to use correct C inline function semantics to fix FTBFS (BZ#1424417)
|
||||
Cleanup spec file conditionals
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-3.4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-3.3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-3.2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-3.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Tue Jan 19 2016 Jan Pokorný <jpokorny+rpm-sbd@redhat.com> - 1.2.1-3
|
||||
- Rebuilt for libpe_status soname bump arising from Pacemaker 1.1.14
|
||||
|
||||
* Thu Jul 02 2015 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.2.1-2
|
||||
- Add dist-tag (RHBZ #1237187).
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-1.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Thu Oct 30 2014 <andrew@beekhof.net> - 1.2.1-1
|
||||
- Correctly enable /proc/pid validation for sbd_lock_running()
|
||||
- Improved integration with the el7 environment
|
||||
|
||||
* Fri Aug 29 2014 <andrew@beekhof.net> - 1.2.1-0.2.8f912945.git
|
||||
- Remove some additional SUSE-isms
|
||||
|
||||
* Fri Aug 29 2014 <andrew@beekhof.net> - 1.2.1-0.1.8f912945.git
|
||||
- Prepare for package review
|
||||
Resolves: rhbz#1134245
|
Loading…
Reference in New Issue
Block a user