* Wed Nov 21 2018 Klaus Wenninger <kwenning@redhat.com> - 1.3.1-1

- Rebased to commit 4927571f8e9b00db8242654b1329dfbd71dcfe99
- removed disabling of shared-disk-support
  Resolves rhbz#1606301

Signed-off-by: Jan Pokorný <jpokorny@redhat.com>
This commit is contained in:
Klaus Wenninger 2018-11-21 16:07:32 +01:00 committed by Jan Pokorný
parent 3dfddc2e00
commit 7311e1ebed
No known key found for this signature in database
GPG Key ID: 61BBB23A9E8F8DE2
8 changed files with 21 additions and 152 deletions

6
.gitignore vendored
View File

@ -1,5 +1 @@
/sbd-8f91294574f0d4b51cd73b1d12ae0f8b30418a28.tar.gz
/sbd-872e82f39db02eab3527ecfa392b1a930dd1964b.tar.gz
/sbd-50b123355ea46a640a8a5177443d73d7e7c8fa2c.tar.gz
/sbd-7c8871796d5e2ede32430a15558e7dff47bbece8.tar.gz
/sbd-1ee3503cbc52b73876b6aae5471d3b6f7c092bf5.tar.gz
/sbd-*.tar.gz

View File

@ -1,28 +0,0 @@
commit 617e138b4c3786208238a43ef2ff6e9543535161
Author: Andrew Beekhof <andrew@beekhof.net>
Date: Fri Oct 24 11:13:14 2014 +1100
Correctly turn on just sbd's debug logging
diff --git a/src/sbd-inquisitor.c b/src/sbd-inquisitor.c
index 61ee8be..6f7d3e4 100644
--- a/src/sbd-inquisitor.c
+++ b/src/sbd-inquisitor.c
@@ -805,14 +805,15 @@ int main(int argc, char **argv, char **envp)
case 'v':
debug++;
if(debug == 1) {
- qb_log_filter_ctl(QB_LOG_SYSLOG, QB_LOG_FILTER_ADD, QB_LOG_FILTER_FILE, "sbd-*", LOG_DEBUG);
- qb_log_filter_ctl(QB_LOG_STDERR, QB_LOG_FILTER_ADD, QB_LOG_FILTER_FILE, "sbd-*", LOG_DEBUG);
+ qb_log_filter_ctl(QB_LOG_SYSLOG, QB_LOG_FILTER_ADD, QB_LOG_FILTER_FILE, "sbd-common.c,sbd-inquisitor.c,sbd-md.c,sbd-pacemaker.c", LOG_DEBUG);
+ qb_log_filter_ctl(QB_LOG_STDERR, QB_LOG_FILTER_ADD, QB_LOG_FILTER_FILE, "sbd-common.c,sbd-inquisitor.c,sbd-md.c,sbd-pacemaker.c", LOG_DEBUG);
cl_log(LOG_INFO, "Verbose mode enabled.");
} else if(debug == 2) {
/* Go nuts, turn on pacemaker's logging too */
qb_log_filter_ctl(QB_LOG_SYSLOG, QB_LOG_FILTER_ADD, QB_LOG_FILTER_FILE, "*", LOG_DEBUG);
qb_log_filter_ctl(QB_LOG_STDERR, QB_LOG_FILTER_ADD, QB_LOG_FILTER_FILE, "*", LOG_DEBUG);
+ cl_log(LOG_INFO, "Verbose library mode enabled.");
}
break;
case 'T':

View File

@ -1,17 +0,0 @@
diff --git a/src/sbd.sysconfig b/src/sbd.sysconfig
index 9ac2d15..f5b0b8c 100644
--- a/src/sbd.sysconfig
+++ b/src/sbd.sysconfig
@@ -1,12 +1,3 @@
-## Type: string
-## Default: ""
-#
-# SBD_DEVICE specifies the devices to use for exchanging sbd messages
-# and to monitor. If specifying more than one path, use ";" as
-# separator.
-#
-#SBD_DEVICE=""
-
## Type: yesno
## Default: yes
#

View File

@ -1,45 +0,0 @@
commit bfc01977f7413977c51f15f61fef801d2bf9c5f9
Author: Andrew Beekhof <andrew@beekhof.net>
Date: Fri Oct 24 12:03:41 2014 +1100
Repair startup when no disks are present
diff --git a/src/sbd-pacemaker.c b/src/sbd-pacemaker.c
index f62d728..7296ad2 100644
--- a/src/sbd-pacemaker.c
+++ b/src/sbd-pacemaker.c
@@ -104,7 +104,8 @@ static int check_ais = 0;
cl_log(lvl, fmt, ##args); \
last_state = state; \
} \
- } while(0)
+ healthy = state; \
+ } while(0)
static cib_t *cib = NULL;
static xmlNode *current_cib = NULL;
@@ -300,7 +301,6 @@ compute_status(pe_working_set_t * data_set)
if (data_set->dc_node == NULL) {
LOGONCE(pcmk_health_transient, LOG_INFO, "We don't have a DC right now.");
- healthy = 2;
goto out;
}
@@ -325,13 +325,13 @@ compute_status(pe_working_set_t * data_set)
LOGONCE(pcmk_health_online, LOG_INFO, "Node state: online");
ever_had_quorum = TRUE;
- } else if(ever_had_quorum == FALSE) {
- LOGONCE(pcmk_health_transient, LOG_INFO, "We do not have quorum yet");
-
} else if(servant_count > 0) {
LOGONCE(pcmk_health_noquorum, LOG_WARNING, "Quorum lost");
goto out;
+ } else if(ever_had_quorum == FALSE) {
+ LOGONCE(pcmk_health_online, LOG_INFO, "We do not have quorum yet");
+
} else {
/* We lost quorum, and there are no disks present
* Setting healthy > 2 here will result in us self-fencing

View File

@ -1,28 +0,0 @@
commit d172f2bb9e6e530039df3a001b9ce3eb76dc4a75
Author: Andrew Beekhof <andrew@beekhof.net>
Date: Mon Oct 27 10:28:51 2014 +1100
Correctly enable /proc/pid validation in sbd_lock_running()
diff --git a/configure.ac b/configure.ac
index ec7fced..540fd57 100644
--- a/configure.ac
+++ b/configure.ac
@@ -78,9 +78,17 @@ DISK=0
if test "x${enable_shared_disk}" != xno ; then
DISK=1
fi
+
AC_DEFINE_UNQUOTED(SUPPORT_SHARED_DISK, $DISK, Turn on functionality that requires shared disk)
AM_CONDITIONAL(SUPPORT_SHARED_DISK, test "$DISK" = "1")
+if
+ test -e /proc/$$
+then
+ echo "/proc/{pid} is supported"
+ AC_DEFINE_UNQUOTED(HAVE_PROC_PID, 1, Define to 1 if /proc/{pid} is supported.)
+fi
+
dnl **********************************************************************
dnl Check for various argv[] replacing functions on various OSs
dnl

View File

@ -1,12 +0,0 @@
diff -ru ../sbd-1ee3503cbc52b73876b6aae5471d3b6f7c092bf5.unpatched/src/sbd-inquisitor.c ./src/sbd-inquisitor.c
--- ../sbd-1ee3503cbc52b73876b6aae5471d3b6f7c092bf5.unpatched/src/sbd-inquisitor.c 2018-01-30 08:37:52.297629808 -0600
+++ ./src/sbd-inquisitor.c 2018-01-30 08:38:37.062571258 -0600
@@ -167,7 +167,7 @@
}
}
-inline void cleanup_servant_by_pid(pid_t pid)
+static inline void cleanup_servant_by_pid(pid_t pid)
{
struct servants_list_item* s;

View File

@ -15,18 +15,16 @@
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%global commit 1ee3503cbc52b73876b6aae5471d3b6f7c092bf5
%global commit 4927571f8e9b00db8242654b1329dfbd71dcfe99
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%global github_owner beekhof
%global buildnum 4
%global github_owner clusterlabs
Name: sbd
Summary: Storage-based death
License: GPLv2+
Group: System Environment/Daemons
Version: 1.2.1
#Release: 0.%{buildnum}.%{shortcommit}.git%{?dist}
Release: %{buildnum}%{?dist}.3
Version: 1.3.1
Release: 1%{?shortcommit:.git%{shortcommit}}%{?dist}
Url: https://github.com/%{github_owner}/%{name}
Source0: https://github.com/%{github_owner}/%{name}/archive/%{commit}/%{name}-%{commit}.tar.gz
BuildRequires: autoconf
@ -34,21 +32,17 @@ BuildRequires: automake
BuildRequires: libuuid-devel
BuildRequires: glib2-devel
BuildRequires: libaio-devel
BuildRequires: corosync-devel
BuildRequires: corosynclib-devel
BuildRequires: pacemaker-libs-devel
BuildRequires: libtool
BuildRequires: libuuid-devel
BuildRequires: libxml2-devel
BuildRequires: pkgconfig
BuildRequires: python2-devel
Patch1: sbd-no-storage-option.patch
Patch2: sbd-local-debug.patch
Patch3: sbd-pcmk-health.patch
Patch4: sbd-proc-pid.patch
Patch5: sbd-static-inline.patch
BuildRequires: make
BuildRequires: systemd
%if 0%{?rhel} && 0%{?rhel} <= 7
ExclusiveArch: i686 x86_64 s390x
%if 0%{?rhel}
ExclusiveArch: i686 x86_64 s390x aarch64 ppc64le
%endif
%if %{defined systemd_requires}
@ -58,7 +52,6 @@ ExclusiveArch: i686 x86_64 s390x
%description
This package contains the storage-based death functionality.
Currently it is limited to watchdog integration.
###########################################################
@ -82,6 +75,7 @@ rm -rf ${RPM_BUILD_ROOT}%{_libdir}/stonith
%if %{defined _unitdir}
install -D -m 0644 src/sbd.service $RPM_BUILD_ROOT/%{_unitdir}/sbd.service
install -D -m 0644 src/sbd_remote.service $RPM_BUILD_ROOT/%{_unitdir}/sbd_remote.service
%endif
mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig
@ -92,12 +86,15 @@ install -m 644 src/sbd.sysconfig ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/sbd
%if %{defined _unitdir}
%post
%systemd_post sbd.service
%systemd_post sbd_remote.service
%preun
%systemd_preun sbd.service
%systemd_preun sbd_remote.service
%postun
%systemd_postun sbd.service
%systemd_postun sbd_remote.service
%endif
%files
@ -108,10 +105,16 @@ install -m 644 src/sbd.sysconfig ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/sbd
%doc %{_mandir}/man8/sbd*
%if %{defined _unitdir}
%{_unitdir}/sbd.service
%{_unitdir}/sbd_remote.service
%endif
%doc COPYING
%changelog
* Wed Nov 21 2018 Klaus Wenninger <kwenning@redhat.com> - 1.3.1-1.git4927571
- Rebased to commit 4927571f8e9b00db8242654b1329dfbd71dcfe99
- removed disabling of shared-disk-support
Resolves rhbz#1606301
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-4.3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

View File

@ -1 +1 @@
75557ea36d72fb6e23a0029aa7bcbd87 sbd-1ee3503cbc52b73876b6aae5471d3b6f7c092bf5.tar.gz
SHA512 (sbd-4927571f8e9b00db8242654b1329dfbd71dcfe99.tar.gz) = 9279f002310ebb375129860b86a4fba34f432585cc4594f14925192e8de36d2d4ba6df606d88af71fffe07d659dd40fb5d0f7f0f0568b27f016919f3b60ee901