2.0
This commit is contained in:
parent
e2d93a1e09
commit
26d724f434
@ -1,44 +0,0 @@
|
|||||||
From 909a9bdf7ab143e1f0baaf9736baebd3cd79aacf Mon Sep 17 00:00:00 2001
|
|
||||||
From: Marius Bakke <marius@gnu.org>
|
|
||||||
Date: Tue, 22 Dec 2020 11:04:26 +0000
|
|
||||||
Subject: sbc_primitives: Fix build on non-x86.
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
Don't call __builtin_cpu_init unless targeting i386 or x86_64.
|
|
||||||
Otherwise we get an error at link time:
|
|
||||||
|
|
||||||
CC sbc/sbc_primitives.lo
|
|
||||||
sbc/sbc_primitives.c: In function ‘sbc_init_primitives_x86’:
|
|
||||||
sbc/sbc_primitives.c:596:2: warning: implicit declaration of function ‘__builtin_cpu_init’; did you mean ‘__builtin_irint’? [-Wimplicit-function-declaration]
|
|
||||||
[...]
|
|
||||||
CCLD src/sbcdec
|
|
||||||
ld: sbc/.libs/libsbc-private.a(sbc_primitives.o): in function `sbc_init_primitives':
|
|
||||||
sbc_primitives.c:(.text+0x3a30): undefined reference to `__builtin_cpu_init'
|
|
||||||
---
|
|
||||||
sbc/sbc_primitives.c | 2 ++
|
|
||||||
1 file changed, 2 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/sbc/sbc_primitives.c b/sbc/sbc_primitives.c
|
|
||||||
index 97a75be..09c214a 100644
|
|
||||||
--- a/sbc/sbc_primitives.c
|
|
||||||
+++ b/sbc/sbc_primitives.c
|
|
||||||
@@ -593,6 +593,7 @@ static int sbc_calc_scalefactors_j(
|
|
||||||
|
|
||||||
static void sbc_init_primitives_x86(struct sbc_encoder_state *state)
|
|
||||||
{
|
|
||||||
+#if defined(__x86_64__) || defined(__i386__)
|
|
||||||
__builtin_cpu_init();
|
|
||||||
|
|
||||||
#ifdef SBC_BUILD_WITH_MMX_SUPPORT
|
|
||||||
@@ -604,6 +605,7 @@ static void sbc_init_primitives_x86(struct sbc_encoder_state *state)
|
|
||||||
if (__builtin_cpu_supports("sse4.2"))
|
|
||||||
sbc_init_primitives_sse(state);
|
|
||||||
#endif
|
|
||||||
+#endif
|
|
||||||
}
|
|
||||||
|
|
||||||
/*
|
|
||||||
--
|
|
||||||
cgit 1.2.3-1.el7
|
|
8
sbc.spec
8
sbc.spec
@ -1,12 +1,11 @@
|
|||||||
Name: sbc
|
Name: sbc
|
||||||
Version: 1.5
|
Version: 2.0
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Sub Band Codec used by bluetooth A2DP
|
Summary: Sub Band Codec used by bluetooth A2DP
|
||||||
|
|
||||||
License: GPLv2 and LGPLv2+
|
License: GPLv2 and LGPLv2+
|
||||||
URL: http://www.bluez.org
|
URL: http://www.bluez.org
|
||||||
Source0: http://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.xz
|
Source0: http://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.xz
|
||||||
Patch1: sbc-fix-non-x86.patch
|
|
||||||
|
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -66,6 +65,9 @@ find %{buildroot} -type f -name "*.la" -delete
|
|||||||
%{_libdir}/libsbc.so
|
%{_libdir}/libsbc.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 11 2022 Peter Robinson <pbrobinson@fedoraproject.org> - 2.0-1
|
||||||
|
- Update to 2.0
|
||||||
|
|
||||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.5-4
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.5-4
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (sbc-1.5.tar.xz) = 0243586188acede595317f2afbfdb41be5850d2a6133c374edbe5cbcf59a2a0fd4570d0b8f2d13ce9637ce48b2f1910c3e4ab1c0354dbf273ee67b09db8c4915
|
SHA512 (sbc-2.0.tar.xz) = 600e86aa492ca1af512ec8e568a08fe526cf2f6eb7306bb0fbdd9a844d03a2a5dedb5f986725aa2c66fe3fe43a7ba45d111e9666eb8912ff3e3a36b948adbc61
|
||||||
|
Loading…
Reference in New Issue
Block a user