New upstream version 0.18
Remove function fingerprinting New kernel taint flags Normalization tweaks More secure core stacktraces from core hook
This commit is contained in:
parent
2609450308
commit
ede4ce2a68
1
.gitignore
vendored
1
.gitignore
vendored
@ -12,3 +12,4 @@
|
|||||||
/satyr-0.14.tar.xz
|
/satyr-0.14.tar.xz
|
||||||
/satyr-0.15.tar.xz
|
/satyr-0.15.tar.xz
|
||||||
/satyr-0.16.tar.xz
|
/satyr-0.16.tar.xz
|
||||||
|
/satyr-0.18.tar.xz
|
||||||
|
27
satyr.spec
27
satyr.spec
@ -18,14 +18,15 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: satyr
|
Name: satyr
|
||||||
Version: 0.16
|
Version: 0.18
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Tools to create anonymous, machine-friendly problem reports
|
Summary: Tools to create anonymous, machine-friendly problem reports
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: https://github.com/abrt/satyr
|
URL: https://github.com/abrt/satyr
|
||||||
Source0: https://fedorahosted.org/released/abrt/satyr-%{version}.tar.xz
|
Source0: https://fedorahosted.org/released/abrt/satyr-%{version}.tar.xz
|
||||||
BuildRequires: %{python2_devel}
|
BuildRequires: %{python2_devel}
|
||||||
|
BuildRequires: python3-devel
|
||||||
BuildRequires: %{libdw_devel}
|
BuildRequires: %{libdw_devel}
|
||||||
BuildRequires: %{libelf_devel}
|
BuildRequires: %{libelf_devel}
|
||||||
BuildRequires: binutils-devel
|
BuildRequires: binutils-devel
|
||||||
@ -38,8 +39,6 @@ BuildRequires: gcc-c++
|
|||||||
BuildRequires: python-sphinx
|
BuildRequires: python-sphinx
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
Patch1: test-fail-gcc5-x86_64.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Satyr is a library that can be used to create and process microreports.
|
Satyr is a library that can be used to create and process microreports.
|
||||||
Microreports consist of structured data suitable to be analyzed in a fully
|
Microreports consist of structured data suitable to be analyzed in a fully
|
||||||
@ -65,9 +64,16 @@ Requires: %{name}%{?_isa} = %{version}-%{release}
|
|||||||
%description python
|
%description python
|
||||||
Python bindings for %{name}.
|
Python bindings for %{name}.
|
||||||
|
|
||||||
|
%package python3
|
||||||
|
Summary: Python 3 bindings for %{name}
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description python3
|
||||||
|
Python 3 bindings for %{name}.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
@ -114,7 +120,18 @@ make check || {
|
|||||||
%{_mandir}/man3/satyr-python.3*
|
%{_mandir}/man3/satyr-python.3*
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%files python3
|
||||||
|
%dir %{python3_sitearch}/%{name}
|
||||||
|
%{python3_sitearch}/%{name}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 09 2015 Martin Milata <mmilata@redhat.com> - 0.18-1
|
||||||
|
- New upstream version
|
||||||
|
- Remove function fingerprinting
|
||||||
|
- New kernel taint flags
|
||||||
|
- Normalization tweaks
|
||||||
|
- More secure core stacktraces from core hook
|
||||||
|
|
||||||
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 0.16-3
|
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 0.16-3
|
||||||
- Rebuilt for GCC 5 C++11 ABI change
|
- Rebuilt for GCC 5 C++11 ABI change
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
cf8783759f9e209835afca9085e2bd1b satyr-0.16.tar.xz
|
7a5b1538385dd31e146de771d5c894ae satyr-0.18.tar.xz
|
||||||
|
@ -1,104 +0,0 @@
|
|||||||
diff -ur satyr-0.16/tests/ruby_stacktrace.at satyr-0.16.1.gd339.dirty/tests/ruby_stacktrace.at
|
|
||||||
--- satyr-0.16/tests/ruby_stacktrace.at 2015-02-18 14:04:56.000000000 +0100
|
|
||||||
+++ satyr-0.16.1.gd339.dirty/tests/ruby_stacktrace.at 2015-02-20 14:47:11.000000000 +0100
|
|
||||||
@@ -261,6 +261,7 @@
|
|
||||||
|
|
||||||
AT_TESTFUN([sr_ruby_stacktrace_from_json],
|
|
||||||
[[
|
|
||||||
+#include "stacktrace.h"
|
|
||||||
#include "ruby/stacktrace.h"
|
|
||||||
#include "ruby/frame.h"
|
|
||||||
#include "utils.h"
|
|
||||||
@@ -268,13 +269,14 @@
|
|
||||||
#include <assert.h>
|
|
||||||
#include <stdlib.h>
|
|
||||||
#include <stdio.h>
|
|
||||||
+#include <string.h>
|
|
||||||
|
|
||||||
void
|
|
||||||
check(char *filename)
|
|
||||||
{
|
|
||||||
char *error_message = NULL;
|
|
||||||
- const char *file_contents = sr_file_to_string(filename, &error_message);
|
|
||||||
- const char *input = file_contents;
|
|
||||||
+ char *file_contents = sr_file_to_string(filename, &error_message);
|
|
||||||
+ char *input = file_contents;
|
|
||||||
struct sr_location location;
|
|
||||||
sr_location_init(&location);
|
|
||||||
|
|
||||||
diff -ur satyr-0.16/tests/testsuite satyr-0.16.1.gd339.dirty/tests/testsuite
|
|
||||||
--- satyr-0.16/tests/testsuite 2015-02-19 12:23:19.000000000 +0100
|
|
||||||
+++ satyr-0.16.1.gd339.dirty/tests/testsuite 2015-02-20 14:48:52.000000000 +0100
|
|
||||||
@@ -1041,7 +1041,7 @@
|
|
||||||
# List of tests.
|
|
||||||
if $at_list_p; then
|
|
||||||
cat <<_ATEOF || at_write_fail=1
|
|
||||||
-satyr 0.16 test suite test groups:
|
|
||||||
+satyr 0.16.1.gd339.dirty test suite test groups:
|
|
||||||
|
|
||||||
NUM: FILE-NAME:LINE TEST-GROUP-NAME
|
|
||||||
KEYWORDS
|
|
||||||
@@ -1082,7 +1082,7 @@
|
|
||||||
exit $at_write_fail
|
|
||||||
fi
|
|
||||||
if $at_version_p; then
|
|
||||||
- $as_echo "$as_me (satyr 0.16)" &&
|
|
||||||
+ $as_echo "$as_me (satyr 0.16.1.gd339.dirty)" &&
|
|
||||||
cat <<\_ATEOF || at_write_fail=1
|
|
||||||
|
|
||||||
Copyright (C) 2012 Free Software Foundation, Inc.
|
|
||||||
@@ -1330,13 +1330,13 @@
|
|
||||||
exec 5>>"$at_suite_log"
|
|
||||||
|
|
||||||
# Banners and logs.
|
|
||||||
-$as_echo "## ---------------------- ##
|
|
||||||
-## satyr 0.16 test suite. ##
|
|
||||||
-## ---------------------- ##"
|
|
||||||
-{
|
|
||||||
- $as_echo "## ---------------------- ##
|
|
||||||
-## satyr 0.16 test suite. ##
|
|
||||||
-## ---------------------- ##"
|
|
||||||
+$as_echo "## ------------------------------------ ##
|
|
||||||
+## satyr 0.16.1.gd339.dirty test suite. ##
|
|
||||||
+## ------------------------------------ ##"
|
|
||||||
+{
|
|
||||||
+ $as_echo "## ------------------------------------ ##
|
|
||||||
+## satyr 0.16.1.gd339.dirty test suite. ##
|
|
||||||
+## ------------------------------------ ##"
|
|
||||||
echo
|
|
||||||
|
|
||||||
$as_echo "$as_me: command line was:"
|
|
||||||
@@ -2179,7 +2179,7 @@
|
|
||||||
$as_echo "Please send $at_msg and all information you think might help:
|
|
||||||
|
|
||||||
To: <crash-catcher@fedorahosted.org>
|
|
||||||
- Subject: [satyr 0.16] $as_me: $at_fail_list${at_fail_list:+ failed${at_xpass_list:+, }}$at_xpass_list${at_xpass_list:+ passed unexpectedly}
|
|
||||||
+ Subject: [satyr 0.16.1.gd339.dirty] $as_me: $at_fail_list${at_fail_list:+ failed${at_xpass_list:+, }}$at_xpass_list${at_xpass_list:+ passed unexpectedly}
|
|
||||||
|
|
||||||
You may investigate any problem if you feel able to do so, in which
|
|
||||||
case the test suite provides a good starting point. Its output may
|
|
||||||
@@ -10995,6 +10995,7 @@
|
|
||||||
|
|
||||||
cat >sr_ruby_stacktrace_from_json.c <<'_ATEOF'
|
|
||||||
|
|
||||||
+#include "stacktrace.h"
|
|
||||||
#include "ruby/stacktrace.h"
|
|
||||||
#include "ruby/frame.h"
|
|
||||||
#include "utils.h"
|
|
||||||
@@ -11002,13 +11003,14 @@
|
|
||||||
#include <assert.h>
|
|
||||||
#include <stdlib.h>
|
|
||||||
#include <stdio.h>
|
|
||||||
+#include <string.h>
|
|
||||||
|
|
||||||
void
|
|
||||||
check(char *filename)
|
|
||||||
{
|
|
||||||
char *error_message = NULL;
|
|
||||||
- const char *file_contents = sr_file_to_string(filename, &error_message);
|
|
||||||
- const char *input = file_contents;
|
|
||||||
+ char *file_contents = sr_file_to_string(filename, &error_message);
|
|
||||||
+ char *input = file_contents;
|
|
||||||
struct sr_location location;
|
|
||||||
sr_location_init(&location);
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user