Fixes
- actualize list of normalized functions (#1509086) - elfutils: Add missing stubs from earlier commit Signed-off-by: Matej Habrnal <mhabrnal@redhat.com>
This commit is contained in:
parent
6f11dbbdb5
commit
b9f124993b
30
0001-normalization-actualize-list-of-functions.patch
Normal file
30
0001-normalization-actualize-list-of-functions.patch
Normal file
@ -0,0 +1,30 @@
|
||||
From 6383faff4959c751f71f107901897ff654e82615 Mon Sep 17 00:00:00 2001
|
||||
From: Matej Habrnal <mhabrnal@redhat.com>
|
||||
Date: Fri, 3 Nov 2017 14:38:13 +0100
|
||||
Subject: [PATCH] normalization: actualize list of functions
|
||||
|
||||
Related to #1509086
|
||||
|
||||
Signed-off-by: Matej Habrnal <mhabrnal@redhat.com>
|
||||
---
|
||||
lib/normalize.c | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/normalize.c b/lib/normalize.c
|
||||
index 9d7574e..4e9ebb5 100644
|
||||
--- a/lib/normalize.c
|
||||
+++ b/lib/normalize.c
|
||||
@@ -145,7 +145,9 @@ is_removable_glib(const char *function_name,
|
||||
call_match(function_name, source_file, "g_print", "libglib", NULL) ||
|
||||
call_match(function_name, source_file, "invalid_closure_notify", "gsignal.c", "libgobject", NULL) ||
|
||||
call_match(function_name, source_file, "smc_tree_abort", "gslice.c", "libglib", NULL) ||
|
||||
- call_match(function_name, source_file, "g_thread_abort", "libglib", NULL);
|
||||
+ call_match(function_name, source_file, "g_thread_abort", "libglib", NULL) ||
|
||||
+ call_match(function_name, source_file, "_g_log_abort", "gmessages.c", "libglib", NULL) ||
|
||||
+ call_match(function_name, source_file, "g_log_default_handler", "gmessages.c", "libglib", NULL);
|
||||
}
|
||||
|
||||
static bool
|
||||
--
|
||||
2.13.6
|
||||
|
46
0003-elfutils-Add-missing-stubs-from-earlier-commit.patch
Normal file
46
0003-elfutils-Add-missing-stubs-from-earlier-commit.patch
Normal file
@ -0,0 +1,46 @@
|
||||
From c932a8e85f8306c03618628b1cc8fcfd39d820b0 Mon Sep 17 00:00:00 2001
|
||||
From: Wes Lindauer <wesley.lindauer@gmail.com>
|
||||
Date: Mon, 14 Aug 2017 16:31:03 -0400
|
||||
Subject: [PATCH] elfutils: Add missing stubs from earlier commit
|
||||
|
||||
Commit f749d97f060e3c287eb700636790d61337b73eae added new functions
|
||||
*_core_hook_prepare and *_core_hook_generate to replace a single
|
||||
function *_core_hook. The *_core_hook was already stubbed out when
|
||||
WITH_LIBDWFL or PTRACE_SEIZE was not defined, but the new commit did not
|
||||
add matching stubs for the new functions that replaced it.
|
||||
---
|
||||
lib/core_unwind.c | 18 ++++++++++++++++++
|
||||
1 file changed, 18 insertions(+)
|
||||
|
||||
diff --git a/lib/core_unwind.c b/lib/core_unwind.c
|
||||
index e6dfc1c..1145df3 100644
|
||||
--- a/lib/core_unwind.c
|
||||
+++ b/lib/core_unwind.c
|
||||
@@ -57,6 +57,24 @@ sr_parse_coredump(const char *coredump_filename,
|
||||
|
||||
#if (!defined WITH_LIBDWFL || !defined PTRACE_SEIZE)
|
||||
|
||||
+struct sr_core_stracetrace_unwind_state *
|
||||
+sr_core_stacktrace_from_core_hook_prepare(pid_t thread_id, char **error_message)
|
||||
+{
|
||||
+ *error_message = sr_asprintf("satyr is built without live process unwind support");
|
||||
+ return NULL;
|
||||
+}
|
||||
+
|
||||
+struct sr_core_stacktrace *
|
||||
+sr_core_stacktrace_from_core_hook_generate(pid_t thread_id,
|
||||
+ const char *executable_filename,
|
||||
+ int signum,
|
||||
+ struct sr_core_stracetrace_unwind_state *state,
|
||||
+ char **error_message)
|
||||
+{
|
||||
+ *error_message = sr_asprintf("satyr is built without live process unwind support");
|
||||
+ return NULL;
|
||||
+}
|
||||
+
|
||||
struct sr_core_stacktrace *
|
||||
sr_core_stacktrace_from_core_hook(pid_t thread_id,
|
||||
const char *executable_filename,
|
||||
--
|
||||
2.13.6
|
||||
|
14
satyr.spec
14
satyr.spec
@ -7,7 +7,7 @@
|
||||
%define enable_python_manpage 1
|
||||
%endif
|
||||
|
||||
%if 0%{?fedora}
|
||||
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||
%define with_python3 1
|
||||
%else
|
||||
# EL doesn't have Python 3
|
||||
@ -26,7 +26,7 @@
|
||||
|
||||
Name: satyr
|
||||
Version: 0.24
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Tools to create anonymous, machine-friendly problem reports
|
||||
Group: System Environment/Libraries
|
||||
License: GPLv2+
|
||||
@ -50,6 +50,12 @@ BuildRequires: gdb
|
||||
BuildRequires: python-sphinx
|
||||
%endif
|
||||
|
||||
Patch0001: 0001-normalization-actualize-list-of-functions.patch
|
||||
#Patch0002: 0002-testsuite-add-testcase-for-ARM-kernel-oops-bz.patch
|
||||
Patch0003: 0003-elfutils-Add-missing-stubs-from-earlier-commit.patch
|
||||
#Patch0004: 0004-makefile-add-make-release-subcommands.patch
|
||||
#Patch0005: 0005-allow-to-build-python3-for-rhel8.patch
|
||||
|
||||
%description
|
||||
Satyr is a library that can be used to create and process microreports.
|
||||
Microreports consist of structured data suitable to be analyzed in a fully
|
||||
@ -156,6 +162,10 @@ make check || {
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Dec 04 2017 Matej Habrnal <mhabrnal@redhat.com> 0.24-2
|
||||
- actualize list of normalized functions (#1509086)
|
||||
- elfutils: Add missing stubs from earlier commit
|
||||
|
||||
* Wed Nov 1 2017 Julius Milan <jmilan@redhat.com> 0.24-1
|
||||
- New upstream version
|
||||
- Allow to report unpackaged problems
|
||||
|
Loading…
Reference in New Issue
Block a user