New upstream version
Do not export internal function symbols.
This commit is contained in:
parent
3ea927177f
commit
520ebef48b
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@
|
|||||||
/satyr-0.3.tar.xz
|
/satyr-0.3.tar.xz
|
||||||
/satyr-0.4.tar.xz
|
/satyr-0.4.tar.xz
|
||||||
/satyr-0.5.tar.xz
|
/satyr-0.5.tar.xz
|
||||||
|
/satyr-0.6.tar.xz
|
||||||
|
@ -1,36 +0,0 @@
|
|||||||
From db15f83d09faf472a02b28ac97770c84769d8004 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Martin Milata <mmilata@redhat.com>
|
|
||||||
Date: Thu, 25 Jul 2013 16:56:07 +0200
|
|
||||||
Subject: [SATYR PATCH] Always build GDB-output-based unwinder
|
|
||||||
|
|
||||||
Previously it was built only when a native unwinding library was
|
|
||||||
present, which does not make any sense.
|
|
||||||
|
|
||||||
Signed-off-by: Martin Milata <mmilata@redhat.com>
|
|
||||||
Signed-off-by: Jakub Filak <jfilak@redhat.com>
|
|
||||||
---
|
|
||||||
lib/core_unwind.c | 4 +---
|
|
||||||
1 file changed, 1 insertion(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/lib/core_unwind.c b/lib/core_unwind.c
|
|
||||||
index f15a0f9..f8ec516 100644
|
|
||||||
--- a/lib/core_unwind.c
|
|
||||||
+++ b/lib/core_unwind.c
|
|
||||||
@@ -49,7 +49,7 @@ sr_parse_coredump(const char *coredump_filename,
|
|
||||||
return NULL;
|
|
||||||
}
|
|
||||||
|
|
||||||
-#else /* !defined WITH_LIBDWFL && !defined WITH_LIBUNWIND */
|
|
||||||
+#endif /* !defined WITH_LIBDWFL && !defined WITH_LIBUNWIND */
|
|
||||||
|
|
||||||
/* FIXME: is there another way to pass the executable name to the find_elf
|
|
||||||
* callback? */
|
|
||||||
@@ -444,5 +444,3 @@ sr_core_stacktrace_from_gdb(const char *gdb_output, const char *core_file,
|
|
||||||
sr_gdb_stacktrace_free(gdb_stacktrace);
|
|
||||||
return core_stacktrace;
|
|
||||||
}
|
|
||||||
-
|
|
||||||
-#endif /* !defined WITH_LIBDWFL && !defined WITH_LIBUNWIND */
|
|
||||||
--
|
|
||||||
1.8.3.1
|
|
||||||
|
|
10
satyr.spec
10
satyr.spec
@ -1,14 +1,13 @@
|
|||||||
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
||||||
|
|
||||||
Name: satyr
|
Name: satyr
|
||||||
Version: 0.5
|
Version: 0.6
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Tools to create anonymous, machine-friendly problem reports
|
Summary: Tools to create anonymous, machine-friendly problem reports
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: https://github.com/abrt/satyr
|
URL: https://github.com/abrt/satyr
|
||||||
Source0: https://fedorahosted.org/released/abrt/satyr-%{version}.tar.xz
|
Source0: https://fedorahosted.org/released/abrt/satyr-%{version}.tar.xz
|
||||||
Patch0: satyr-0.5-always_build_gdb_output_based_unwinder.patch
|
|
||||||
BuildRequires: python2-devel
|
BuildRequires: python2-devel
|
||||||
BuildRequires: elfutils-devel, elfutils-libelf-devel, binutils-devel
|
BuildRequires: elfutils-devel, elfutils-libelf-devel, binutils-devel
|
||||||
BuildRequires: rpm-devel
|
BuildRequires: rpm-devel
|
||||||
@ -40,7 +39,6 @@ Python bindings for %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-static
|
%configure --disable-static
|
||||||
@ -74,6 +72,10 @@ make check
|
|||||||
%{python_sitearch}/%{name}/*
|
%{python_sitearch}/%{name}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 29 2013 Martin Milata <mmilata@redhat.com> 0.6-1
|
||||||
|
- New upstream version
|
||||||
|
- Do not export internal function symbols.
|
||||||
|
|
||||||
* Thu Jul 25 2013 Martin Milata <mmilata@redhat.com> 0.5-2
|
* Thu Jul 25 2013 Martin Milata <mmilata@redhat.com> 0.5-2
|
||||||
- Remove libunwind dependency altogether, always use GDB for unwinding.
|
- Remove libunwind dependency altogether, always use GDB for unwinding.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user