forwardport changes from f18
This commit is contained in:
parent
e95c8df161
commit
17309f21cd
29
0002-wdmd-use-mode-775-for-run-dir.patch
Normal file
29
0002-wdmd-use-mode-775-for-run-dir.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
From c7e288e4609bb84167a2ccb56ac66567c71be557 Mon Sep 17 00:00:00 2001
|
||||||
|
From: David Teigland <teigland@redhat.com>
|
||||||
|
Date: Tue, 6 Nov 2012 15:36:16 -0600
|
||||||
|
Subject: [PATCH 2/3] wdmd: use mode 775 for run dir
|
||||||
|
|
||||||
|
init script already creates it as 775,
|
||||||
|
so this isn't a big problem.
|
||||||
|
|
||||||
|
Signed-off-by: David Teigland <teigland@redhat.com>
|
||||||
|
---
|
||||||
|
wdmd/main.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/wdmd/main.c b/wdmd/main.c
|
||||||
|
index 482ab29..646a0ac 100644
|
||||||
|
--- a/wdmd/main.c
|
||||||
|
+++ b/wdmd/main.c
|
||||||
|
@@ -1185,7 +1185,7 @@ static int lockfile(void)
|
||||||
|
int fd, rv;
|
||||||
|
|
||||||
|
old_umask = umask(0022);
|
||||||
|
- rv = mkdir(WDMD_RUN_DIR, 0777);
|
||||||
|
+ rv = mkdir(WDMD_RUN_DIR, 0775);
|
||||||
|
if (rv < 0 && errno != EEXIST) {
|
||||||
|
umask(old_umask);
|
||||||
|
return rv;
|
||||||
|
--
|
||||||
|
1.7.10.1.362.g242cab3
|
||||||
|
|
26
0003-systemd-add-wdmd-dependency-for-sanlock.patch
Normal file
26
0003-systemd-add-wdmd-dependency-for-sanlock.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
From 917c64327acb0ae53ce605dc6b47a4a0f4983827 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Federico Simoncelli <fsimonce@redhat.com>
|
||||||
|
Date: Tue, 13 Nov 2012 10:59:09 -0600
|
||||||
|
Subject: [PATCH 3/3] systemd: add wdmd dependency for sanlock
|
||||||
|
|
||||||
|
Signed-off-by: Federico Simoncelli <fsimonce@redhat.com>
|
||||||
|
---
|
||||||
|
init.d/sanlock.service | 3 ++-
|
||||||
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/init.d/sanlock.service b/init.d/sanlock.service
|
||||||
|
index f026fe0..64d9ced 100644
|
||||||
|
--- a/init.d/sanlock.service
|
||||||
|
+++ b/init.d/sanlock.service
|
||||||
|
@@ -1,6 +1,7 @@
|
||||||
|
[Unit]
|
||||||
|
Description=Shared Storage Lease Manager
|
||||||
|
-After=syslog.target wdmd.service
|
||||||
|
+After=syslog.target
|
||||||
|
+Wants=wdmd.service
|
||||||
|
|
||||||
|
[Service]
|
||||||
|
Type=forking
|
||||||
|
--
|
||||||
|
1.7.10.1.362.g242cab3
|
||||||
|
|
18
sanlock.spec
18
sanlock.spec
@ -1,6 +1,6 @@
|
|||||||
Name: sanlock
|
Name: sanlock
|
||||||
Version: 2.6
|
Version: 2.6
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
Summary: A shared disk lock manager
|
Summary: A shared disk lock manager
|
||||||
|
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -11,13 +11,18 @@ BuildRequires: libblkid-devel libaio-devel python python-devel
|
|||||||
%if 0%{?fedora} >= 16 || 0%{?rhel} >= 7
|
%if 0%{?fedora} >= 16 || 0%{?rhel} >= 7
|
||||||
BuildRequires: systemd-units
|
BuildRequires: systemd-units
|
||||||
%endif
|
%endif
|
||||||
|
%if 0%{?rhel} >= 6
|
||||||
|
ExclusiveArch: x86_64
|
||||||
|
%endif
|
||||||
Requires: %{name}-lib = %{version}-%{release}
|
Requires: %{name}-lib = %{version}-%{release}
|
||||||
Requires(pre): /usr/sbin/groupadd
|
Requires(pre): /usr/sbin/groupadd
|
||||||
Requires(pre): /usr/sbin/useradd
|
Requires(pre): /usr/sbin/useradd
|
||||||
Source0: https://fedorahosted.org/releases/s/a/sanlock/%{name}-%{version}.tar.gz
|
Source0: https://fedorahosted.org/releases/s/a/sanlock/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
Patch0: 0001-fix-systemd-service-files.patch
|
Patch0: 0001-fix-systemd-service-files.patch
|
||||||
Patch1: 0002-wdmd-make-the-watchdog-device-configurable.patch
|
Patch1: 0002-wdmd-use-mode-775-for-run-dir.patch
|
||||||
|
Patch2: 0003-systemd-add-wdmd-dependency-for-sanlock.patch
|
||||||
|
Patch3: 0004-wdmd-make-the-watchdog-device-configurable.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
sanlock uses disk paxos to manage leases on shared storage.
|
sanlock uses disk paxos to manage leases on shared storage.
|
||||||
@ -27,7 +32,9 @@ access to the shared disks.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .0001-fix-systemd-service-files
|
%patch0 -p1 -b .0001-fix-systemd-service-files
|
||||||
%patch1 -p1 -b .0002-wdmd-make-the-watchdog-device-configurable
|
%patch1 -p1 -b .0002-wdmd-use-mode-775-for-run-dir
|
||||||
|
%patch2 -p1 -b .0003-systemd-add-wdmd-dependency-for-sanlock
|
||||||
|
%patch3 -p1 -b .0004-wdmd-make-the-watchdog-device-configurable
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# upstream does not require configure
|
# upstream does not require configure
|
||||||
@ -256,9 +263,12 @@ if [ $1 -ge 1 ] ; then
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Wed Jan 2 2013 Federico Simoncelli <fsimonce@redhat.com> 2.6-4
|
* Wed Jan 2 2013 Federico Simoncelli <fsimonce@redhat.com> 2.6-5
|
||||||
- wdmd: make the watchdog device configurable
|
- wdmd: make the watchdog device configurable
|
||||||
|
|
||||||
|
* Tue Nov 13 2012 David Teigland <teigland@redhat.com> - 2.6-4
|
||||||
|
- systemd: add wdmd dependency for sanlock
|
||||||
|
|
||||||
* Mon Nov 05 2012 David Teigland <teigland@redhat.com> - 2.6-3
|
* Mon Nov 05 2012 David Teigland <teigland@redhat.com> - 2.6-3
|
||||||
- fix systemd service files and install them on rhel7
|
- fix systemd service files and install them on rhel7
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user